指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 抄底逃顶 
TIM截图20180926102922.png

TIM截图20180926102929.png

[lywrap=通达信主图指标公式][lycode=tdx,true]VAR1:=((((HHV((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),4)<0) AND ((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2)>REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),1))) AND (REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),1)<REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),2))) AND (REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),2)<REF((((EMA(DCLOSE,12)-EMA(DCLOSE,26))-(EMA((EMA(DCLOSE,12)-EMA(DCLOSE,26)),9)))*2),3)));
DRAWTEXT(VAR1,L*0.98,'★短买'),COLORYELLOW;
LY:=10;
BL:=40;
CJQS:=XMA(CLOSE,LY);
JBQS:=XMA(CLOSE,BL);
N:=REF(JBQS,BL/2+1-CURRBARSCOUNT)/REF(JBQS,BL/2+2-CURRBARSCOUNT);
M:=REF(CJQS,LY/2+1-CURRBARSCOUNT)/REF(CJQS,LY/2+2-CURRBARSCOUNT);
JB上轨:IF(CURRBARSCOUNT>BL/2,JBQS*1.1,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*1.1);
JB下轨:IF(CURRBARSCOUNT>BL/2,JBQS*0.9,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*0.9);
CJ上轨:IF(CURRBARSCOUNT>LY/2,CJQS*1.05,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*1.05);
CJ下轨:IF(CURRBARSCOUNT>LY/2,CJQS*0.95,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*0.95);
DRAWTEXT(O<=CJ下轨,(L * 0.98),'抢'),COLORYELLOW;
DRAWTEXT(CROSS(H,CJ上轨),(H * 1.01),'砸'),COLORYELLOW;
DRAWTEXT(CROSS(ZIG(3,13),REF(ZIG(3,13),1)),LOW*1.001,'★底'),COLORGREEN;
DRAWTEXT(CROSS(REF(ZIG(3,13),1),ZIG(3,13)),HIGH*1,'★逃顶'), COLORRED;[/lycode][lycode=tdx2,true]VAR1赋值:((((4日内(((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)-((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)的9日指数移动平均))*2)的最高值<0) AND ((((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)-((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)的9日指数移动平均))*2)>1日前的(((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)-((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)的9日指数移动平均))*2))) AND (1日前的(((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)-((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)的9日指数移动平均))*2)<2日前的(((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)-((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)的9日指数移动平均))*2))) AND (2日前的(((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)-((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)的9日指数移动平均))*2)<3日前的(((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)-((不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均)的9日指数移动平均))*2)))
当满足条件VAR1时,在最低价*0.98位置书写文字,画黄色
LY赋值:10
BL赋值:40
CJQS赋值:收盘价的LY日偏移移动平均
JBQS赋值:收盘价的BL日偏移移动平均
N赋值:BL/2+1-到最后交易的周期日前的JBQS/BL/2+2-到最后交易的周期日前的JBQS
M赋值:LY/2+1-到最后交易的周期日前的CJQS/LY/2+2-到最后交易的周期日前的CJQS
输出JB上轨:如果到最后交易的周期>BL/2,返回JBQS*1.1,否则返回BL/2+1-到最后交易的周期日前的JBQS*N的BL/2+1-到最后交易的周期乘幂*1.1
输出JB下轨:如果到最后交易的周期>BL/2,返回JBQS*0.9,否则返回BL/2+1-到最后交易的周期日前的JBQS*N的BL/2+1-到最后交易的周期乘幂*0.9
输出CJ上轨:如果到最后交易的周期>LY/2,返回CJQS*1.05,否则返回LY/2+1-到最后交易的周期日前的CJQS*M的LY/2+1-到最后交易的周期乘幂*1.05
输出CJ下轨:如果到最后交易的周期>LY/2,返回CJQS*0.95,否则返回LY/2+1-到最后交易的周期日前的CJQS*M的LY/2+1-到最后交易的周期乘幂*0.95
当满足条件开盘价<=CJ下轨时,在(最低价*0.98)位置书写文字,画黄色
当满足条件最高价上穿CJ上轨时,在(最高价*1.01)位置书写文字,画黄色
当满足条件收盘价13%的之字转向上穿1日前的收盘价13%的之字转向时,在最低价*1.001位置书写文字,画绿色
当满足条件1日前的收盘价13%的之字转向上穿收盘价13%的之字转向时,在最高价*1位置书写文字, 画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1XFZozi86Z6I9HX9rVi6qxA

看了该指标的人还看了:
叶公跟庄指标    股海神偷指标    降龙贰式指标
均线进多头指标    主力主升指标    画线指标指标

使用道具 举报

回复