指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 操盘控盘 
TIM截图20180926102507.png

TIM截图20180926102522.png

[lywrap=通达信副图指标公式][lycode=tdx,true]Z_1:=C-REF(C,1);
空:=EMA(EMA(Z_1,6),6)/EMA(EMA(ABS(Z_1),6),6)*20,LINETHICK0,COLOR00FF00;
多:=(空*2-FORCAST(空,9)),LINETHICK0,COLORFF59FF;
{警报}
J1:=IF(多<=空,多,DRAWNULL);
J2:=IF(多<=空,多,REF(J1,1));
J3:=IF(多<=空,多,REF(J2,1));
J4:=IF(多<=空,多,REF(J3,1));
J5:=IF(多<=空,多,REF(J4,1));
J6:=IF(多<=空,多,REF(J5,1));
J7:=IF(多<=空,多,REF(J6,1));
J8:=IF(多<=空,多,REF(J7,1));
J9:=IF(多<=空,多,REF(J8,1));
J10:=IF(多<=空,多,REF(J9,1));
J11:=IF(多<=空,多,REF(J10,1));
J12:=IF(多<=空,多,REF(J11,1));
J13:=IF(多<=空,多,REF(J12,1));
J14:=IF(多<=空,多,REF(J13,1));
J15:=IF(多<=空,多,REF(J14,1));
JJ_1:=IF(多<=空,多,REF(J15,1));
JJ1:=IF(多>空,空,DRAWNULL);
JJ2:=IF(多>空,空,REF(JJ1,1));
JJ3:=IF(多>空,空,REF(JJ2,1));
JJ4:=IF(多>空,空,REF(JJ3,1));
JJ5:=IF(多>空,空,REF(JJ4,1));
JJ6:=IF(多>空,空,REF(JJ5,1));
JJ7:=IF(多>空,空,REF(JJ6,1));
JJ8:=IF(多>空,空,REF(JJ7,1));
JJ9:=IF(多>空,空,REF(JJ8,1));
JJ10:=IF(多>空,空,REF(JJ9,1));
JJ11:=IF(多>空,空,REF(JJ10,1));
JJ12:=IF(多>空,空,REF(JJ11,1));
JJ13:=IF(多>空,空,REF(JJ12,1));
JJ14:=IF(多>空,空,REF(JJ13,1));
JJ15:=IF(多>空,空,REF(JJ14,1));
JJ_2:=IF(多>空,空,REF(JJ15,1));
K1:=IF(多>空,1,IF(多<空,-1,0));
KJ1:=IF(K1!=0,K1,DRAWNULL);
KJ2:=IF(K1!=0,K1,REF(KJ1,1));
KJ3:=IF(K1!=0,K1,REF(KJ2,1));
KJ4:=IF(K1!=0,K1,REF(KJ3,1));
KJ5:=IF(K1!=0,K1,REF(KJ4,1));
KJ6:=IF(K1!=0,K1,REF(KJ5,1));
KJ7:=IF(K1!=0,K1,REF(KJ6,1));
KJ8:=IF(K1!=0,K1,REF(KJ7,1));
KJ9:=IF(K1!=0,K1,REF(KJ8,1));
KJ10:=IF(K1!=0,K1,REF(KJ9,1));
KJ11:=IF(K1!=0,K1,REF(KJ10,1));
KJ12:=IF(K1!=0,K1,REF(KJ11,1));
KJ13:=IF(K1!=0,K1,REF(KJ12,1));
KJ14:=IF(K1!=0,K1,REF(KJ13,1));
KJ15:=IF(K1!=0,K1,REF(KJ14,1));
K2:=IF(K1!=0,K1,REF(KJ15,1));
警报:IF(K2>0,JJ_1,JJ_2),COLOR00B4FF;
{-----------------【图解模板】---------------------}
DRAWBAND(空,RGB(0,158,0),多,RGB(180,0,0));
RSV:=(C-LLV(L,3))/(HHV(H,3)-LLV(L,3))*100;
K:=SMA(RSV,2,1);          D:=SMA(K,2,1);          J:=3*K-2*D;
引力:SMA(J,2,1)-SMA(J,3,1),COLORSTICK;
{画各线}
空头:空,COLOR00FF00;
多头:多,COLORFF59FF;
{近台比}
JT_B1:=(O+L+H+C*3)/6;
WMAA:=(5*JT_B1+4*REF(JT_B1,1)+3*REF(JT_B1,2)+2*REF(JT_B1,3)+1*REF(JT_B1,4))/(5+4+3+2+1);
JT_B2:=REVERSE(JT_B1)+2*WMAA;
JT_B3:=3*JT_B2-2*SMA(JT_B2,2,1);
JTB4:=IF(BARSLAST(C>JT_B3),JT_B3,DRAWNULL);
JT_B4:=IF(BARSLAST(C>JT_B3),JT_B3,REF(JTB4,1));
JTB5:=IF(BARSLAST(C<=JT_B3),JT_B3,DRAWNULL);
JT_B5:=IF(BARSLAST(C<=JT_B3),JT_B3,REF(JTB5,1));
JT_B6:=IF(C<=JT_B3,JT_B4,JT_B5);
近台比:(C-JT_B6)/JT_B6*100,NODRAW,COLORYELLOW;[/lycode][lycode=tdx2,true]Z_1赋值:收盘价-1日前的收盘价
空赋值:Z_1的6日指数移动平均的6日指数移动平均/Z_1的绝对值的6日指数移动平均的6日指数移动平均*20,线宽为0,COLOR00FF00
多赋值:(空*2-空的9日线性回归预测值),线宽为0,COLORFF59FF
J1赋值:如果多<=空,返回多,否则返回无效数
J2赋值:如果多<=空,返回多,否则返回1日前的J1
J3赋值:如果多<=空,返回多,否则返回1日前的J2
J4赋值:如果多<=空,返回多,否则返回1日前的J3
J5赋值:如果多<=空,返回多,否则返回1日前的J4
J6赋值:如果多<=空,返回多,否则返回1日前的J5
J7赋值:如果多<=空,返回多,否则返回1日前的J6
J8赋值:如果多<=空,返回多,否则返回1日前的J7
J9赋值:如果多<=空,返回多,否则返回1日前的J8
J10赋值:如果多<=空,返回多,否则返回1日前的J9
J11赋值:如果多<=空,返回多,否则返回1日前的J10
J12赋值:如果多<=空,返回多,否则返回1日前的J11
J13赋值:如果多<=空,返回多,否则返回1日前的J12
J14赋值:如果多<=空,返回多,否则返回1日前的J13
J15赋值:如果多<=空,返回多,否则返回1日前的J14
JJ_1赋值:如果多<=空,返回多,否则返回1日前的J15
JJ1赋值:如果多>空,返回空,否则返回无效数
JJ2赋值:如果多>空,返回空,否则返回1日前的JJ1
JJ3赋值:如果多>空,返回空,否则返回1日前的JJ2
JJ4赋值:如果多>空,返回空,否则返回1日前的JJ3
JJ5赋值:如果多>空,返回空,否则返回1日前的JJ4
JJ6赋值:如果多>空,返回空,否则返回1日前的JJ5
JJ7赋值:如果多>空,返回空,否则返回1日前的JJ6
JJ8赋值:如果多>空,返回空,否则返回1日前的JJ7
JJ9赋值:如果多>空,返回空,否则返回1日前的JJ8
JJ10赋值:如果多>空,返回空,否则返回1日前的JJ9
JJ11赋值:如果多>空,返回空,否则返回1日前的JJ10
JJ12赋值:如果多>空,返回空,否则返回1日前的JJ11
JJ13赋值:如果多>空,返回空,否则返回1日前的JJ12
JJ14赋值:如果多>空,返回空,否则返回1日前的JJ13
JJ15赋值:如果多>空,返回空,否则返回1日前的JJ14
JJ_2赋值:如果多>空,返回空,否则返回1日前的JJ15
K1赋值:如果多>空,返回1,否则返回如果多<空,返回-1,否则返回0
KJ1赋值:如果K1不等于0,返回K1,否则返回无效数
KJ2赋值:如果K1不等于0,返回K1,否则返回1日前的KJ1
KJ3赋值:如果K1不等于0,返回K1,否则返回1日前的KJ2
KJ4赋值:如果K1不等于0,返回K1,否则返回1日前的KJ3
KJ5赋值:如果K1不等于0,返回K1,否则返回1日前的KJ4
KJ6赋值:如果K1不等于0,返回K1,否则返回1日前的KJ5
KJ7赋值:如果K1不等于0,返回K1,否则返回1日前的KJ6
KJ8赋值:如果K1不等于0,返回K1,否则返回1日前的KJ7
KJ9赋值:如果K1不等于0,返回K1,否则返回1日前的KJ8
KJ10赋值:如果K1不等于0,返回K1,否则返回1日前的KJ9
KJ11赋值:如果K1不等于0,返回K1,否则返回1日前的KJ10
KJ12赋值:如果K1不等于0,返回K1,否则返回1日前的KJ11
KJ13赋值:如果K1不等于0,返回K1,否则返回1日前的KJ12
KJ14赋值:如果K1不等于0,返回K1,否则返回1日前的KJ13
KJ15赋值:如果K1不等于0,返回K1,否则返回1日前的KJ14
K2赋值:如果K1不等于0,返回K1,否则返回1日前的KJ15
输出警报:如果K2>0,返回JJ_1,否则返回JJ_2,COLOR00B4FF
画带状线
RSV赋值:(收盘价-3日内最低价的最低值)/(3日内最高价的最高值-3日内最低价的最低值)*100
K赋值:RSV的2日[1日权重]移动平均
D赋值:K的2日[1日权重]移动平均
J赋值:3*K-2*D
输出引力:J的2日[1日权重]移动平均-J的3日[1日权重]移动平均,COLORSTICK
输出空头:空,COLOR00FF00
输出多头:多,COLORFF59FF
JT_B1赋值:(开盘价+最低价+最高价+收盘价*3)/6
WMAA赋值:(5*JT_B1+4*1日前的JT_B1+3*2日前的JT_B1+2*3日前的JT_B1+1*4日前的JT_B1)/(5+4+3+2+1)
JT_B2赋值:JT_B1的相反数+2*WMAA
JT_B3赋值:3*JT_B2-2*JT_B2的2日[1日权重]移动平均
JTB4赋值:如果上次收盘价>JT_B3距今天数,返回JT_B3,否则返回无效数
JT_B4赋值:如果上次收盘价>JT_B3距今天数,返回JT_B3,否则返回1日前的JTB4
JTB5赋值:如果上次收盘价<=JT_B3距今天数,返回JT_B3,否则返回无效数
JT_B5赋值:如果上次收盘价<=JT_B3距今天数,返回JT_B3,否则返回1日前的JTB5
JT_B6赋值:如果收盘价<=JT_B3,返回JT_B4,否则返回JT_B5
输出近台比:(收盘价-JT_B6)/JT_B6*100,NODRAW,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1FysIoxkIJ-8OdggJLWBIWA

看了该指标的人还看了:
绝佳买点指标    堪称一绝指标    盈富宝典指标
买卖精品指标    顶底管家指标    波段指标

使用道具 举报

回复