指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 操盘控盘 背离 
TIM截图20180925113228.png

TIM截图20180925113238.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,0),COLORRED;
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORYELLOW;
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORMAGENTA;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR008800;
A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
中线:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORMAGENTA,LINETHICK2;
操作线:=中线-(EMA(C,3)-中线),COLOR00FFFF,LINETHICK2;
PM:MA(C,5),COLORRED ,LINETHICK2;
IF(PM> REF(PM,1),PM,DRAWNULL),COLORLIGRAY ,LINETHICK2;
IF(PM=REF(PM,1),PM,DRAWNULL),COLORLIGRAY ;
IF(PM<REF(PM,1),PM,DRAWNULL), COLORFF9900,LINETHICK2;
S:=(PM> 操作线);
DD:=中线<REF(中线,1);
IF(DD,中线,DRAWNULL),COLORLIGREEN ,LINETHICK2;
IF(S,中线,DRAWNULL),COLORLIGREEN ,POINTDOT,LINETHICK4;
DRAWICON(CROSS(中线,操作线),中线-0.4,11);
A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));
B1:=REF(C,A1+1)> C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");
DRAWTEXT(B1> 0,L-0.02,'*M底'),COLOR00FFFF;
A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));
B2:=REF(C,A2+1)> C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");
DRAWTEXT(B2,L-0.10,'*K底'),COLORFF00FF;
A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));
B3:=REF(C,A3+1)> C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");
DRAWTEXT(B3> 0,L-0.18,'*R底'),COLOR0000FF;
C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)> "MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");
DRAWTEXT(D1> 0,H+0.30,'*M顶'),COLOR00FF00;
C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)> "KDJ.K" AND CROSS("KDJ.D","KDJ.K");
DRAWTEXT(D2> 0,H+0.25,'*K顶'),COLORFFFFCC;
C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)> "RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");
DRAWTEXT(D3> 0,H+0.13,'*R顶'),COLORFF9900;
V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
V2:=(1-7/100)*(DMA(CLOSE,V1));
决策:REFDATE(V2,DATE),,LINETHICK2,COLORLIGRAY;
DRAWTEXT(ISLASTBAR,决策,'*决策线'),COLORWHITE;
{以下含未来函数,不影响以上参数,不喜欢可删除}
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLORRED;
DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLORRED;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLORLIBLUE;
DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.12,0,'财务分折:')COLORMAGENTA;
DRAWTEXT_FIX(1,0.07,0.06,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX  (1,0.05,0.12,0,'现金流:'),COLOR00CCCC;
DRAWNUMBER_FIX(1,0.086,0.12,0,CONST(FINANCE(25)/1000000000)),COLOR00CCCC;
DRAWTEXT_FIX  (1,0.125,0.12,0,'应收款:'),COLOR00CCCC;
DRAWNUMBER_FIX(1,0.159,0.12,0,CONST(FINANCE(22)/100000000)),COLOR00CCCC;
DRAWTEXT_FIX  (1,0.193,0.12,0,'存货:'),COLOR00CCCC;
DRAWNUMBER_FIX(1,0.218,0.12,0,CONST(FINANCE(27)/100000000)),COLOR00CCCC;
DRAWTEXT_FIX(1,0.253,0.12,0,'流动比率:'),COLOR00CCCC;{流动比率值>1.5<2.5较为合理,低于1说明偿债能力欠佳。}
DRAWNUMBER_FIX(1,0.299,0.12,0,CONST(FINANCE(11)/FINANCE(15))),COLOR00CCCC;
DRAWTEXT_FIX(1,0.336,0.12,0,'速动比率:'),COLOR00CCCC;
DRAWNUMBER_FIX(1,0.383,0.12,0,CONST(FINANCE(11)-FINANCE(27)/FINANCE(15))),COLOR00CCCC;
DRAWTEXT_FIX  (1,0.47,0.12,0,'套牢盘%:'),COLOR00CCCC;
DRAWNUMBER_FIX(1,0.507,0.12,0,CONST(100-WINNER(CLOSE)*100)),COLOR00CCCC;[/lycode][lycode=tdx2,true]VAR1赋值:收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价
VAR2赋值:1日前的VAR1 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR3赋值:1日前的VAR2 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR4赋值:1日前的VAR3 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR5赋值:1日前的VAR4 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR6赋值:1日前的VAR5 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR7赋值:1日前的VAR6 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR8赋值:1日前的VAR7 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR9赋值:1日前的VAR8 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARA赋值:1日前的VAR9 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VARB赋值:1日前的VARA AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARC赋值:1日前的VARB AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
当满足条件VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC时,在收盘价和1日前的收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
VARD赋值:收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价
VARE赋值:1日前的VARD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARF赋值:1日前的VARE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR10赋值:1日前的VARF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR11赋值:1日前的VAR10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR12赋值:1日前的VAR11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR13赋值:1日前的VAR12 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR14赋值:1日前的VAR13 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR15赋值:1日前的VAR14 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR16赋值:1日前的VAR15 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR17赋值:1日前的VAR16 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR18赋值:1日前的VAR17 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
当满足条件VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18时,在收盘价和1日前的收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画黄色
VAR19赋值:1日前的VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18 AND VAR1
当满足条件VAR19时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画洋红色
VAR1A赋值:1日前的VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC AND VARD
当满足条件VAR1A时,在1日前的收盘价和2日前的收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR008800
A赋值:收盘价的17日简单移动平均+收盘价的17日简单移动平均-1日前的收盘价的17日简单移动平均的绝对值
B赋值:收盘价的17日简单移动平均+收盘价的17日简单移动平均-1日前的收盘价的17日简单移动平均
输出中线:如果收盘价的17日简单移动平均<B,返回B,否则返回收盘价的17日简单移动平均,画洋红色,线宽为2
操作线赋值:中线-(收盘价的3日指数移动平均-中线),COLOR00FFFF,线宽为2
输出PM:收盘价的5日简单移动平均,画红色 ,线宽为2
如果PM>1日前的PM,返回PM,否则返回无效数,画淡灰色 ,线宽为2
如果PM=1日前的PM,返回PM,否则返回无效数,画淡灰色
如果PM<1日前的PM,返回PM,否则返回无效数, COLORFF9900,线宽为2
S赋值:(PM> 操作线)
DD赋值:中线<1日前的中线
如果DD,返回中线,否则返回无效数,画淡绿色 ,线宽为2
如果S,返回中线,否则返回无效数,画淡绿色 ,POINTDOT,线宽为4
当满足条件中线上穿操作线时,在中线-0.4位置画11号图标
A1赋值:上次1日前的"平滑异同平均的DIF"上穿"平滑异同平均的DEA"距今天数
B1赋值:A1+1日前的收盘价> 收盘价 AND A1+1日前的"平滑异同平均的DIF"<"平滑异同平均的DIF" AND "平滑异同平均的DIF"上穿"平滑异同平均的DEA"
当满足条件B1>0时,在最低价-0.02位置书写文字,COLOR00FFFF
A2赋值:上次1日前的"KDJ的K"上穿"KDJ的D"距今天数
B2赋值:A2+1日前的收盘价> 收盘价 AND A2+1日前的"KDJ的K"<"KDJ的K" AND "KDJ的K"上穿"KDJ的D"
当满足条件B2时,在最低价-0.10位置书写文字,COLORFF00FF
A3赋值:上次1日前的"RSI的RSI1"上穿"RSI的RSI2"距今天数
B3赋值:A3+1日前的收盘价> 收盘价 AND A3+1日前的"RSI的RSI1"<"RSI的RSI1" AND "RSI的RSI1"上穿"RSI的RSI2"
当满足条件B3>0时,在最低价-0.18位置书写文字,COLOR0000FF
C1赋值:上次1日前的"平滑异同平均的DEA"上穿"平滑异同平均的DIF"距今天数
D1赋值:C1+1日前的收盘价<收盘价 AND C1+1日前的"平滑异同平均的DIF"> "平滑异同平均的DIF" AND "平滑异同平均的DEA"上穿"平滑异同平均的DIF"
当满足条件D1>0时,在最高价+0.30位置书写文字,COLOR00FF00
C2赋值:上次1日前的"KDJ的D"上穿"KDJ的K"距今天数
D2赋值:C2+1日前的收盘价<收盘价 AND C2+1日前的"KDJ的K"> "KDJ的K" AND "KDJ的D"上穿"KDJ的K"
当满足条件D2>0时,在最高价+0.25位置书写文字,COLORFFFFCC
C3赋值:上次1日前的"RSI的RSI2"上穿"RSI的RSI1"距今天数
D3赋值:C3+1日前的收盘价<收盘价 AND C3+1日前的"RSI的RSI1"> "RSI的RSI1" AND "RSI的RSI2"上穿"RSI的RSI1"
当满足条件D3>0时,在最高价+0.13位置书写文字,COLORFF9900
V1赋值:以0.9为权重(((最高价+最低价)+(收盘价*2))/4.15)的动态移动平均
V2赋值:(1-7/100)*(以V1为权重收盘价的动态移动平均)
输出决策:日期日V2,,线宽为2,画淡灰色
当满足条件是否最后一个周期时,在决策位置书写文字,画白色
当满足条件1时,在横轴0.00纵轴0位置书写文字画红色
当满足条件1时,在横轴0.07纵轴0位置书写文字画红色
当满足条件1时,在横轴0.14纵轴0位置书写文字画淡蓝色
当满足条件1时,在横轴0.21纵轴0位置书写文字COLOR00FFFF
当满足条件1时,在横轴0.00纵轴0.12位置书写文字画洋红色
当满足条件1时,在横轴0.07纵轴0.06位置书写文字COLOR0000FF
当满足条件1时,在横轴0.05纵轴0.12位置书写文字,COLOR00CCCC
当满足条件1时,在横轴0.086纵轴0.12位置书写数字,COLOR00CCCC
当满足条件1时,在横轴0.125纵轴0.12位置书写文字,COLOR00CCCC
当满足条件1时,在横轴0.159纵轴0.12位置书写数字,COLOR00CCCC
当满足条件1时,在横轴0.193纵轴0.12位置书写文字,COLOR00CCCC
当满足条件1时,在横轴0.218纵轴0.12位置书写数字,COLOR00CCCC
当满足条件1时,在横轴0.253纵轴0.12位置书写文字,COLOR00CCCC
当满足条件1时,在横轴0.299纵轴0.12位置书写数字,COLOR00CCCC
当满足条件1时,在横轴0.336纵轴0.12位置书写文字,COLOR00CCCC
当满足条件1时,在横轴0.383纵轴0.12位置书写数字,COLOR00CCCC
当满足条件1时,在横轴0.47纵轴0.12位置书写文字,COLOR00CCCC
当满足条件1时,在横轴0.507纵轴0.12位置书写数字,COLOR00CCCC[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1i3TYtgNmgc9GRF8yVBL7gg

看了该指标的人还看了:
绝佳买点指标    堪称一绝指标    盈富宝典指标
买卖精品指标    顶底管家指标    波段指标

使用道具 举报

回复