指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 画线 操盘控盘 压力支撑 K线形态 
TIM截图20180925112943.png

TIM截图20180925112952.png

[lywrap=通达信主图指标公式][lycode=tdx,true]N:=3;
M:=5;
N1:10;
N2:=20;
N3:=34;
JJH:=H;
JJL:=L;
AA2:=REF(JJH,N)=HHV(JJH,2*N+1);
AA3:=FILTER(AA2,N);
AA4:=BACKSET(AA3,N+1);
AA5:=FILTER(AA4,N);
AA7:=REF(JJL,N)=LLV(JJL,2*N+1);
AA8:=FILTER(AA7,N);
AA9:=BACKSET(AA8,N+1);
AA10:=FILTER(AA9,N);
AA11:=REF(H,BARSLAST(AA5));
AA12:=REF(L,BARSLAST(AA10));
AA13:=BARSLAST(AA5)<BARSLAST(AA10) AND NOT(AA5) ;
AA14:=BARSLAST(AA5)>BARSLAST(AA10) AND NOT(AA10);
AA15:=BARSLAST(AA5);
AA16:=CONST(AA15);
AA17:=REF(AA11,AA15+1);
AA18:=CONST(AA17);
AA19:=BARSLAST(H=AA18);
AA20:=CONST(AA19);
AA21:=BARSLAST(AA10);
AA22:=CONST(AA21);
AA23:=REF(AA12,AA21+1);
AA24:=CONST(AA23);
AA25:=BARSLAST(L=AA24);
AA26:=CONST(AA25);
RR:=BARSLAST(H=CONST(AA11));

BB2:=REF(JJH,M)=HHV(JJH,2*M+1);
BB3:=FILTER(BB2,M);
BB4:=BACKSET(BB3,M+1);
BB5:=FILTER(BB4,M);
BB7:=REF(JJL,M)=LLV(JJL,2*M+1);
BB8:=FILTER(BB7,M);
BB9:=BACKSET(BB8,M+1);
BB10:=FILTER(BB9,M);
BB11:=REF(H,BARSLAST(BB5));
BB12:=REF(L,BARSLAST(BB10));
BB13:=BARSLAST(BB5)<BARSLAST(BB10) AND NOT(BB5) ;
BB14:=BARSLAST(BB5)>BARSLAST(BB10) AND NOT(BB10);
BB15:=BARSLAST(BB5);
BB16:=CONST(BB15);
BB17:=REF(BB11,BB15+1);
BB18:=CONST(BB17);
BB19:=BARSLAST(H=BB18);
BB20:=CONST(BB19);
BB21:=BARSLAST(BB10);
BB22:=CONST(BB21);
BB23:=REF(BB12,BB21+1);
BB24:=CONST(BB23);
BB25:=BARSLAST(L=BB24);
BB26:=CONST(BB25);

PP:=MIN(AA26,BB15);
QQ:=FILTER(V>0,CURRBARSCOUNT-CONST(PP)-1);
STICKLINE(QQ,CONST(BB11),CONST(AA23),8,0),COLOR646400;

CC2:=REF(JJH,N1)=HHV(JJH,2*N1+1);
CC3:=FILTER(CC2,N1);
CC4:=BACKSET(CC3,N1+1);
CC5:=FILTER(CC4,N1);
CC7:=REF(JJL,N1)=LLV(JJL,2*N1+1);
CC8:=FILTER(CC7,N1);
CC9:=BACKSET(CC8,N1+1);
CC10:=FILTER(CC9,N1);
CC11:=REF(H,BARSLAST(CC5));
CC12:=REF(L,BARSLAST(CC10));
CC13:=BARSLAST(CC5)<BARSLAST(CC10) AND NOT(CC5) ;
CC14:=BARSLAST(CC5)>BARSLAST(CC10) AND NOT(CC10);
CC15:=BARSLAST(CC5);
CC16:=CONST(CC15);
CC17:=REF(CC11,CC15+1);
CC18:=CONST(CC17);
CC19:=BARSLAST(H=CC18);
CC20:=CONST(CC19);
CC21:=BARSLAST(CC10);
CC22:=CONST(CC21);
CC23:=REF(CC12,CC21+1);
CC24:=CONST(CC23);
CC25:=BARSLAST(L=CC24);
CC26:=CONST(CC25);

DD2:=REF(JJH,N2)=HHV(JJH,2*N2+1);
DD3:=FILTER(DD2,N2);
DD4:=BACKSET(DD3,N2+1);
DD5:=FILTER(DD4,N2);
DD7:=REF(JJL,N2)=LLV(JJL,2*N2+1);
DD8:=FILTER(DD7,N2);
DD9:=BACKSET(DD8,N2+1);
DD10:=FILTER(DD9,N2);
DD11:=REF(H,BARSLAST(DD5));
DD12:=REF(L,BARSLAST(DD10));
DD13:=BARSLAST(DD5)<BARSLAST(DD10) AND NOT(DD5) ;
DD14:=BARSLAST(DD5)>BARSLAST(DD10) AND NOT(DD10);
DD15:=BARSLAST(DD5);
DD16:=CONST(DD15);
DD17:=REF(DD11,DD15+1);
DD18:=CONST(DD17);
DD19:=BARSLAST(H=DD18);
DD20:=CONST(DD19);
DD21:=BARSLAST(DD10);
DD22:=CONST(DD21);
DD23:=REF(DD12,DD21+1);
DD24:=CONST(DD23);
DD25:=BARSLAST(L=DD24);
DD26:=CONST(DD25);

EE2:=REF(JJH,N3)=HHV(JJH,2*N3+1);
EE3:=FILTER(EE2,N3);
EE4:=BACKSET(EE3,N3+1);
EE5:=FILTER(EE4,N3);
EE7:=REF(JJL,N3)=LLV(JJL,2*N3+1);
EE8:=FILTER(EE7,N3);
EE9:=BACKSET(EE8,N3+1);
EE10:=FILTER(EE9,N3);
EE11:=REF(H,BARSLAST(EE5));
EE12:=REF(L,BARSLAST(EE10));
EE13:=BARSLAST(EE5)<BARSLAST(EE10) AND NOT(EE5) ;
EE14:=BARSLAST(EE5)>BARSLAST(EE10) AND NOT(EE10);
EE15:=BARSLAST(EE5);
EE16:=CONST(EE15);
EE17:=REF(EE11,EE15+1);
EE18:=CONST(EE17);
EE19:=BARSLAST(H=EE18);
EE20:=CONST(EE19);
EE21:=BARSLAST(EE10);
EE22:=CONST(EE21);
EE23:=REF(EE12,EE21+1);
EE24:=CONST(EE23);
EE25:=BARSLAST(L=EE24);
EE26:=CONST(EE25);

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
压力:DRAWLINE(CURRBARSCOUNT=CONST(RR)+1,AA11,CURRBARSCOUNT=1,AA11,1),COLORYELLOW;
DRAWLINE(CURRBARSCOUNT=AA20+1,H,IF(CONST(AA11)>=CONST(AA17),CURRBARSCOUNT=AA20+1,CURRBARSCOUNT=AA16+1),H,1),COLORLIRED;
DRAWLINE(CURRBARSCOUNT=AA26+1,L,CURRBARSCOUNT=AA22+1,L,1),COLORRED;
DRAWLINE(CURRBARSCOUNT=BB20+1,H,IF(CONST(BB11)>=CONST(BB17),CURRBARSCOUNT=BB20+1,CURRBARSCOUNT=BB16+1),H,1),COLORBBFFFF;
DRAWLINE(CURRBARSCOUNT=BB26+1,L,CURRBARSCOUNT=BB22+1,L,1),COLORYELLOW;
DRAWLINE(CURRBARSCOUNT=CC20+1,H,IF(CONST(CC11)>=CONST(CC17),CURRBARSCOUNT=CC20+1,CURRBARSCOUNT=CC16+1),H,1),COLORFF00BB;
DRAWLINE(CURRBARSCOUNT=CC26+1,L,CURRBARSCOUNT=CC22+1,L,1),COLORMAGENTA;
DRAWLINE(CURRBARSCOUNT=DD20+1,H,IF(CONST(DD11)>=CONST(DD17),CURRBARSCOUNT=DD20+1,CURRBARSCOUNT=DD16+1),H,1),COLORC5AC72;
DRAWLINE(CURRBARSCOUNT=DD26+1,L,CURRBARSCOUNT=DD22+1,L,1),COLOREEAC72;
DRAWLINE(CURRBARSCOUNT=EE20+1,H,IF(CONST(EE11)>=CONST(EE17),CURRBARSCOUNT=EE20+1,CURRBARSCOUNT=EE16+1),H,1),COLORABD0BC;
DRAWLINE(CURRBARSCOUNT=EE26+1,L,CURRBARSCOUNT=EE22+1,L,1),COLORABD066;

{涨跌停K线}
{涨跌停次数K线}
涨停:=(C-REF(C,1))*100/REF(C,1)>9.7;
跌停:=(C-REF(C,1))*100/REF(C,1)<-9.5;
TESTSKIP(PERIOD>5);
STICKLINE((C-REF(C,1))*100/REF(C,1)>9.7,O,C,2,0),COLORRED;
STICKLINE((C-REF(C,1))*100/REF(C,1)<-9.5,O,C,2,0),COLORGREEN;
NUMBER:=COUNT(涨停,BARSSINCE(涨停)+1),COLORYELLOW;
DRAWNUMBER(涨停,H*1.04,NUMBER),COLORWHITE;
NUMBER1:=COUNT(跌停,BARSSINCE(跌停)+1),COLORYELLOW;
DRAWNUMBER(跌停,H*1.04,NUMBER1),COLORGREEN;[/lycode][lycode=tdx2,true]N赋值:3
M赋值:5
输出N1:10
N2赋值:20
N3赋值:34
JJH赋值:最高价
JJL赋值:最低价
AA2赋值:N日前的JJH=2*N+1日内JJH的最高值
AA3赋值:AA2的N日过滤
AA4赋值:若AA3则将最近N+1周期置为1
AA5赋值:AA4的N日过滤
AA7赋值:N日前的JJL=2*N+1日内JJL的最低值
AA8赋值:AA7的N日过滤
AA9赋值:若AA8则将最近N+1周期置为1
AA10赋值:AA9的N日过滤
AA11赋值:上次AA5距今天数日前的最高价
AA12赋值:上次AA10距今天数日前的最低价
AA13赋值:上次AA5距今天数<上次AA10距今天数 AND 取反
AA14赋值:上次AA5距今天数>上次AA10距今天数 AND 取反
AA15赋值:上次AA5距今天数
AA16赋值:AA15的最后一日取值设为常数
AA17赋值:AA15+1日前的AA11
AA18赋值:AA17的最后一日取值设为常数
AA19赋值:上次最高价=AA18距今天数
AA20赋值:AA19的最后一日取值设为常数
AA21赋值:上次AA10距今天数
AA22赋值:AA21的最后一日取值设为常数
AA23赋值:AA21+1日前的AA12
AA24赋值:AA23的最后一日取值设为常数
AA25赋值:上次最低价=AA24距今天数
AA26赋值:AA25的最后一日取值设为常数
RR赋值:上次最高价=AA11的最后一日取值设为常数距今天数
BB2赋值:M日前的JJH=2*M+1日内JJH的最高值
BB3赋值:BB2的M日过滤
BB4赋值:若BB3则将最近M+1周期置为1
BB5赋值:BB4的M日过滤
BB7赋值:M日前的JJL=2*M+1日内JJL的最低值
BB8赋值:BB7的M日过滤
BB9赋值:若BB8则将最近M+1周期置为1
BB10赋值:BB9的M日过滤
BB11赋值:上次BB5距今天数日前的最高价
BB12赋值:上次BB10距今天数日前的最低价
BB13赋值:上次BB5距今天数<上次BB10距今天数 AND 取反
BB14赋值:上次BB5距今天数>上次BB10距今天数 AND 取反
BB15赋值:上次BB5距今天数
BB16赋值:BB15的最后一日取值设为常数
BB17赋值:BB15+1日前的BB11
BB18赋值:BB17的最后一日取值设为常数
BB19赋值:上次最高价=BB18距今天数
BB20赋值:BB19的最后一日取值设为常数
BB21赋值:上次BB10距今天数
BB22赋值:BB21的最后一日取值设为常数
BB23赋值:BB21+1日前的BB12
BB24赋值:BB23的最后一日取值设为常数
BB25赋值:上次最低价=BB24距今天数
BB26赋值:BB25的最后一日取值设为常数
PP赋值:AA26和BB15的较小值
QQ赋值:成交量(手)>0的到最后交易的周期-PP的最后一日取值设为常数-1日过滤
当满足条件QQ时,在BB11的最后一日取值设为常数和AA23的最后一日取值设为常数位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLOR646400
CC2赋值:N1日前的JJH=2*N1+1日内JJH的最高值
CC3赋值:CC2的N1日过滤
CC4赋值:若CC3则将最近N1+1周期置为1
CC5赋值:CC4的N1日过滤
CC7赋值:N1日前的JJL=2*N1+1日内JJL的最低值
CC8赋值:CC7的N1日过滤
CC9赋值:若CC8则将最近N1+1周期置为1
CC10赋值:CC9的N1日过滤
CC11赋值:上次CC5距今天数日前的最高价
CC12赋值:上次CC10距今天数日前的最低价
CC13赋值:上次CC5距今天数<上次CC10距今天数 AND 取反
CC14赋值:上次CC5距今天数>上次CC10距今天数 AND 取反
CC15赋值:上次CC5距今天数
CC16赋值:CC15的最后一日取值设为常数
CC17赋值:CC15+1日前的CC11
CC18赋值:CC17的最后一日取值设为常数
CC19赋值:上次最高价=CC18距今天数
CC20赋值:CC19的最后一日取值设为常数
CC21赋值:上次CC10距今天数
CC22赋值:CC21的最后一日取值设为常数
CC23赋值:CC21+1日前的CC12
CC24赋值:CC23的最后一日取值设为常数
CC25赋值:上次最低价=CC24距今天数
CC26赋值:CC25的最后一日取值设为常数
DD2赋值:N2日前的JJH=2*N2+1日内JJH的最高值
DD3赋值:DD2的N2日过滤
DD4赋值:若DD3则将最近N2+1周期置为1
DD5赋值:DD4的N2日过滤
DD7赋值:N2日前的JJL=2*N2+1日内JJL的最低值
DD8赋值:DD7的N2日过滤
DD9赋值:若DD8则将最近N2+1周期置为1
DD10赋值:DD9的N2日过滤
DD11赋值:上次DD5距今天数日前的最高价
DD12赋值:上次DD10距今天数日前的最低价
DD13赋值:上次DD5距今天数<上次DD10距今天数 AND 取反
DD14赋值:上次DD5距今天数>上次DD10距今天数 AND 取反
DD15赋值:上次DD5距今天数
DD16赋值:DD15的最后一日取值设为常数
DD17赋值:DD15+1日前的DD11
DD18赋值:DD17的最后一日取值设为常数
DD19赋值:上次最高价=DD18距今天数
DD20赋值:DD19的最后一日取值设为常数
DD21赋值:上次DD10距今天数
DD22赋值:DD21的最后一日取值设为常数
DD23赋值:DD21+1日前的DD12
DD24赋值:DD23的最后一日取值设为常数
DD25赋值:上次最低价=DD24距今天数
DD26赋值:DD25的最后一日取值设为常数
EE2赋值:N3日前的JJH=2*N3+1日内JJH的最高值
EE3赋值:EE2的N3日过滤
EE4赋值:若EE3则将最近N3+1周期置为1
EE5赋值:EE4的N3日过滤
EE7赋值:N3日前的JJL=2*N3+1日内JJL的最低值
EE8赋值:EE7的N3日过滤
EE9赋值:若EE8则将最近N3+1周期置为1
EE10赋值:EE9的N3日过滤
EE11赋值:上次EE5距今天数日前的最高价
EE12赋值:上次EE10距今天数日前的最低价
EE13赋值:上次EE5距今天数<上次EE10距今天数 AND 取反
EE14赋值:上次EE5距今天数>上次EE10距今天数 AND 取反
EE15赋值:上次EE5距今天数
EE16赋值:EE15的最后一日取值设为常数
EE17赋值:EE15+1日前的EE11
EE18赋值:EE17的最后一日取值设为常数
EE19赋值:上次最高价=EE18距今天数
EE20赋值:EE19的最后一日取值设为常数
EE21赋值:上次EE10距今天数
EE22赋值:EE21的最后一日取值设为常数
EE23赋值:EE21+1日前的EE12
EE24赋值:EE23的最后一日取值设为常数
EE25赋值:上次最低价=EE24距今天数
EE26赋值:EE25的最后一日取值设为常数
K线
输出压力:当满足条件到最后交易的周期=RR的最后一日取值设为常数+1时,在AA11位置画直线起点,当满足条件到最后交易的周期=1时,在AA11位置画直线终点,1表示是否延长.,画黄色
当满足条件到最后交易的周期=AA20+1时,在最高价位置画直线起点,当满足条件如果AA11的最后一日取值设为常数>=AA17的最后一日取值设为常数,返回到最后交易的周期=AA20+1,否则返回到最后交易的周期=AA16+1时,在最高价位置画直线终点,1表示是否延长.,画淡红色
当满足条件到最后交易的周期=AA26+1时,在最低价位置画直线起点,当满足条件到最后交易的周期=AA22+1时,在最低价位置画直线终点,1表示是否延长.,画红色
当满足条件到最后交易的周期=BB20+1时,在最高价位置画直线起点,当满足条件如果BB11的最后一日取值设为常数>=BB17的最后一日取值设为常数,返回到最后交易的周期=BB20+1,否则返回到最后交易的周期=BB16+1时,在最高价位置画直线终点,1表示是否延长.,COLORBBFFFF
当满足条件到最后交易的周期=BB26+1时,在最低价位置画直线起点,当满足条件到最后交易的周期=BB22+1时,在最低价位置画直线终点,1表示是否延长.,画黄色
当满足条件到最后交易的周期=CC20+1时,在最高价位置画直线起点,当满足条件如果CC11的最后一日取值设为常数>=CC17的最后一日取值设为常数,返回到最后交易的周期=CC20+1,否则返回到最后交易的周期=CC16+1时,在最高价位置画直线终点,1表示是否延长.,COLORFF00BB
当满足条件到最后交易的周期=CC26+1时,在最低价位置画直线起点,当满足条件到最后交易的周期=CC22+1时,在最低价位置画直线终点,1表示是否延长.,画洋红色
当满足条件到最后交易的周期=DD20+1时,在最高价位置画直线起点,当满足条件如果DD11的最后一日取值设为常数>=DD17的最后一日取值设为常数,返回到最后交易的周期=DD20+1,否则返回到最后交易的周期=DD16+1时,在最高价位置画直线终点,1表示是否延长.,COLORC5AC72
当满足条件到最后交易的周期=DD26+1时,在最低价位置画直线起点,当满足条件到最后交易的周期=DD22+1时,在最低价位置画直线终点,1表示是否延长.,COLOREEAC72
当满足条件到最后交易的周期=EE20+1时,在最高价位置画直线起点,当满足条件如果EE11的最后一日取值设为常数>=EE17的最后一日取值设为常数,返回到最后交易的周期=EE20+1,否则返回到最后交易的周期=EE16+1时,在最高价位置画直线终点,1表示是否延长.,COLORABD0BC
当满足条件到最后交易的周期=EE26+1时,在最低价位置画直线起点,当满足条件到最后交易的周期=EE22+1时,在最低价位置画直线终点,1表示是否延长.,COLORABD066
涨停赋值:(收盘价-1日前的收盘价)*100/1日前的收盘价>9.7
跌停赋值:(收盘价-1日前的收盘价)*100/1日前的收盘价<-9.5
如果不满足条件周期类型>5,公式返回
当满足条件(收盘价-1日前的收盘价)*100/1日前的收盘价>9.7时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
当满足条件(收盘价-1日前的收盘价)*100/1日前的收盘价<-9.5时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色
NUMBER赋值:统计首次涨停距今天数+1日中满足涨停的天数,画黄色
当满足条件涨停时,在最高价*1.04位置书写数字,画白色
NUMBER1赋值:统计首次跌停距今天数+1日中满足跌停的天数,画黄色
当满足条件跌停时,在最高价*1.04位置书写数字,画绿色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1fy_qVdakrxPw9gg27nd6Dg

看了该指标的人还看了:
叶公跟庄指标    股海神偷指标    降龙贰式指标
均线进多头指标    主力主升指标    画线指标指标

使用道具 举报

回复