请选择 进入手机版|继续访问电脑版

堪称一绝指标 通达信 副图 波段 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-10-29 08:00:04 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
堪称一绝指标 通达信 副图 波段 短线 买卖点 炒股叉第10564张

堪称一绝指标 通达信 副图 波段 短线 买卖点 炒股叉第10565张

[lywrap=通达信副图指标公式][lycode=tdx,true]Q_1:=C-REF(C,1);
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
Z1:=L=LLV(L,BARSLAST(Q_3)+1);
Z2:=LLV(L,BARSLAST(Q_3)+1);
Z3:=H=HHV(H,BARSLAST(Q_4)+1);
Z4:=HHV(H,BARSLAST(Q_4)+1);
Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0);
Y1:=H=HHV(H,BARSLAST(Q_4)+1);
Y2:=HHV(H,BARSLAST(Q_4)+1);
Y3:=L=LLV(L,BARSLAST(Q_3)+1);
Y4:=LLV(L,BARSLAST(Q_3)+1);
Q_B:=DRAWLINE(Y1,Y2,Y3,Y4,0);
X1:=LLV(Q_2,2)=LLV(Q_2,7) ;
X2:=COUNT(Q_2<0,2);
X3:=CROSS(Q_2,MA(Q_2,2));
X4:=REF(Q_B,1)<REF(Q_B,2);
X5:=Q_A>REF(Q_B,1);
买进:=(X1 AND X2 AND X3) AND X4 AND X5;
TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);
堪称一绝:IF(REF(TJ,1)=0 AND TJ>=1,80,10),STICK,COLORRED;
持币:IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,0,10),STICK,COLORGREEN;

地狱底:0,COLORGRAY;
地狱线:10,COLORGRAY;
地平线:20,COLORLIMAGENTA;
天际线:80,COLORGRAY;
RSV:=(((CLOSE - LLV(LOW,33)) / (HHV(HIGH,33) - LLV(LOW,33))) * 100);
神仙:SMA(RSV,7,1),COLORWHITE;
魔鬼:SMA(SMA(RSV,7,1),3,1),COLORYELLOW;
轨迹:SMA(SMA(SMA(RSV,6,1),5,1),3,1),COLORMAGENTA;
财神到:IF(CROSS(神仙,20),20,0),POINTDOT;
DRAWICON((CROSS(神仙,20)),5,1);[/lycode][lycode=tdx2,true]Q_1赋值:收盘价-1日前的收盘价
Q_2赋值:100*Q_1的6日指数移动平均的6日指数移动平均/Q_1的绝对值的6日指数移动平均的6日指数移动平均
Q_3赋值:收盘价的19日指数移动平均上穿收盘价的7日指数移动平均
Q_4赋值:收盘价的7日指数移动平均上穿收盘价的19日指数移动平均
Z1赋值:最低价=上次Q_3距今天数+1日内最低价的最低值
Z2赋值:上次Q_3距今天数+1日内最低价的最低值
Z3赋值:最高价=上次Q_4距今天数+1日内最高价的最高值
Z4赋值:上次Q_4距今天数+1日内最高价的最高值
Q_A赋值:当满足条件Z1时,在Z2位置画直线起点,当满足条件Z3时,在Z4位置画直线终点,0表示是否延长.
Y1赋值:最高价=上次Q_4距今天数+1日内最高价的最高值
Y2赋值:上次Q_4距今天数+1日内最高价的最高值
Y3赋值:最低价=上次Q_3距今天数+1日内最低价的最低值
Y4赋值:上次Q_3距今天数+1日内最低价的最低值
Q_B赋值:当满足条件Y1时,在Y2位置画直线起点,当满足条件Y3时,在Y4位置画直线终点,0表示是否延长.
X1赋值:2日内Q_2的最低值=7日内Q_2的最低值
X2赋值:统计2日中满足Q_2<0的天数
X3赋值:Q_2上穿Q_2的2日简单移动平均
X4赋值:1日前的Q_B<2日前的Q_B
X5赋值:Q_A>1日前的Q_B
买进赋值:(X1 AND X2 AND X3) AND X4 AND X5
TJ赋值:如果Q_B<1日前的Q_BANDQ_B=Q_A,返回1,否则返回0
输出堪称一绝:如果1日前的TJ=0ANDTJ>=1,返回80,否则返回10,STICK,画红色
输出持币:如果Q_B<1日前的Q_BANDQ_B=Q_A,返回0,否则返回10,STICK,画绿色
输出地狱底:0,画深灰色
输出地狱线:10,画深灰色
输出地平线:20,画淡洋红色
输出天际线:80,画深灰色
RSV赋值:(((收盘价 - 33日内最低价的最低值) / (33日内最高价的最高值 - 33日内最低价的最低值)) * 100)
输出神仙:RSV的7日[1日权重]移动平均,画白色
输出魔鬼:RSV的7日[1日权重]移动平均的3日[1日权重]移动平均,画黄色
输出轨迹:RSV的6日[1日权重]移动平均的5日[1日权重]移动平均的3日[1日权重]移动平均,画洋红色
输出财神到:如果神仙上穿20,返回20,否则返回0,POINTDOT
当满足条件(神仙上穿20)时,在5位置画1号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1VW8VLasS3EKJ3RG6Y8kc0Q

看了该指标的人还看了:
无极神枪指标    机构洗盘优化指标
操盘利器CCI指标    60日价值中枢指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表