请选择 进入手机版|继续访问电脑版

五彩周J指标 通达信 主图 KDJ指标 波段 短线 买卖点 金叉

[复制链接]

admin  管理员

发表于 2018-10-26 08:00:47 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: KDJ指标 波段 短线 买卖点 金叉 
说明:
为了能将周KDJ的J线走势的各种形态(下跌到0轴以下、在0轴以下拐头向上、突破0轴向上、进入风险区及下跌等)的讯号及时提供给使用者,及时采取相应的不同的操盘策略,特将周J的各种走势形态用五彩K线方式编辑显示在主图中,同时标示出日、周、月KDJ的金叉与死叉。可以让使用者一目了然地看清楚K线走势的同时也清晰地显示了周KDJ的状态。

五彩周J指标 通达信 主图 KDJ指标 波段 短线 买卖点 金叉 炒股叉第10509张

五彩周J指标 通达信 主图 KDJ指标 波段 短线 买卖点 金叉 炒股叉第10510张

[lywrap=通达信主图指标公式][lycode=tdx,true]ZJ:=MA("KDJ.J#WEEK"(9,3,3) ,5);
AAA:=ZJ<0 AND ZJ<REF(ZJ,1);
BB:=ZJ<0 AND ZJ>=REF(ZJ,1);
DD:=ZJ>=0 AND ZJ>=REF(ZJ,1);
EE:= ZJ>85;
FF:=ZJ<REF(ZJ,1) AND ZJ>0;
STICKLINE(AAA,C,O,3,0),COLOR2737FF;
STICKLINE(AAA,H,L,0,0),COLOR2737FF;
STICKLINE(AAA,C,O,1.9,0),COLOR226CFF;
STICKLINE(AAA,C,O,1.0,0),COLOR3EA6FF;
STICKLINE(AAA,C,O,0.2,0),COLOR17FFF6;
STICKLINE(BB,C,O,3,0),COLOR990099;
STICKLINE(BB,H,L,0,0),COLORFF00FF;
STICKLINE(BB,C,O,1.9,0),COLORBB00CC;
STICKLINE(BB,C,O,1.0,0),COLORDD00DD;
STICKLINE(BB,C,O,0.2,0),COLORFF88FF;
STICKLINE(DD,C,O,3,0),COLOR000099;
STICKLINE(DD,H,L,0,0),COLOR0000FF;
STICKLINE(DD,C,O,1.9,0),COLOR0000CC;
STICKLINE(DD,C,O,1.0,0),COLOR0000DD;
STICKLINE(DD,C,O,0.2,0),COLOR7788FF;
STICKLINE(EE,C,O,3,0),COLOR00AAAA;
STICKLINE(EE,H,L,0,0),COLOR00FFFF;
STICKLINE(EE,C,O,1.9,0),COLOR00CCCC;
STICKLINE(EE,C,O,1.0,0),COLOR00DDDD;
STICKLINE(EE,C,O,0.2,0),COLOR00FFFF;
STICKLINE(FF,C,O,3,0),COLOR888800;
STICKLINE(FF,H,L,0,0),COLORFFFF00;
STICKLINE(FF,C,O,1.9,0),COLORCCCC00;
STICKLINE(FF,C,O,1.0,0),COLORDDDD00;
STICKLINE(FF,C,O,0.2,0),COLORFFFF00;
YK:=MA("KDJ.K#MONTH"(9,3,3),20),LINETHICK0;
YD:=MA("KDJ.D#MONTH"(9,3,3),20),LINETHICK0;
YJ:=MA("KDJ.J#MONTH"(9,3,3),20);
ZK:=MA("KDJ.K#WEEK"(9,3,3) ,5),LINETHICK0;
ZD:=MA("KDJ.D#WEEK"(9,3,3) ,5),LINETHICK0;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),LINETHICK0;
D:=SMA(K,3,1),LINETHICK0;
J:=3*K-2*D,LINETHICK0;
RJC:DRAWICON(CROSS(K,D),L*0.98,1);
DRAWTEXT(RJC,L*0.98,'日金叉'),COLOR0000FF;
RSC:DRAWICON(CROSS(D,K),H*1.03,2),;
DRAWTEXT(RSC,H*1.03,'日死叉'),COLORFFFFFF;
ZJC: DRAWICON (CROSS(ZK,ZD), L*0.98,1);
DRAWTEXT(ZJC,L*0.98,'周金叉'),COLORFF00FF;
ZSC: DRAWICON (CROSS(ZD,ZK), H*1.03,2),;
DRAWTEXT(ZSC,H*1.03,'周死叉'),COLOR00FFFF;
YJC: DRAWICON (CROSS(YK,YD), L*0.98,1);
DRAWTEXT(YJC,L*0.98,'月金叉'),COLORFF0000;
YSC: DRAWICON (CROSS(YD,YK), H*1.03,2);
DRAWTEXT(YSC,H*1.03,'月死叉'),COLORADEAEA;
MA10:MA(C,10),COLORRED,LINETHICK1;
IF(MA10<REF(MA10,1),MA10,DRAWNULL),COLORFFFF00,LINETHICK1;
MA20:MA(C,20),COLORFF00FF,LINETHICK1;
IF(MA20<REF(MA20,1),MA20,DRAWNULL),COLORFFFFFF,LINETHICK1;
MA55:MA(C,55),COLORFF0000,LINETHICK1;
IF(MA55<REF(MA55,1),MA55,DRAWNULL),COLOR00FFFF,LINETHICK1;
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
NN:=120;
HH:=HHV(V*TT,NN);
LL:=LLV(V,NN);
最高:=CONST(HH);
最低:=CONST(LL);
最高2:=CONST(HHV(H,NN));
最低2:=CONST(LLV(L,NN));
PP:=IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,20)),0.9,IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,50)),0.7,0.6)),NODRAW;
RCC1:=最高2*0.9-(最高2-最低2)*PP;
最低3:=MIN(RCC1,最低2);
AA:=最低3;
STICKLINE(AAA,AA-0.000*AA,AA-0.040*AA,2.5,0),COLOR3EA6FF;
STICKLINE(BB,AA-0.000*AA,AA-0.040*AA,2.5,0),COLORFF00FF;
STICKLINE(DD,AA-0.000*AA,AA-0.040*AA,2.5,0),COLOR0000FF;
STICKLINE(EE,AA-0.000*AA,AA-0.040*AA,2.5,1),COLOR00FFFF;
STICKLINE(FF,AA-0.000*AA,AA-0.040*AA,2.5,1),COLORFFFF00;
DRAWTEXT_FIX(1,0.2,0.86,0,'★★ 橘红色--周J<0--底部警示★★粉色--周J拐头--买入★★红色--周J向上--加仓★★黄色--周J>85--风险提示★★青色--周J下跌--持币★★'),COLOR00FFFF;[/lycode][lycode=tdx2,true]ZJ赋值:"KDJ的J[取周线数据]"(9,3,3)的5日简单移动平均
AAA赋值:ZJ<0 AND ZJ<1日前的ZJ
BB赋值:ZJ<0 AND ZJ>=1日前的ZJ
DD赋值:ZJ>=0 AND ZJ>=1日前的ZJ
EE赋值: ZJ>85
FF赋值:ZJ<1日前的ZJ AND ZJ>0
当满足条件AAA时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR2737FF
当满足条件AAA时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR2737FF
当满足条件AAA时,在收盘价和开盘价位置之间画柱状线,宽度为1.9,0不为0则画空心柱.,COLOR226CFF
当满足条件AAA时,在收盘价和开盘价位置之间画柱状线,宽度为1.0,0不为0则画空心柱.,COLOR3EA6FF
当满足条件AAA时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR17FFF6
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR990099
当满足条件BB时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF00FF
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为1.9,0不为0则画空心柱.,COLORBB00CC
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为1.0,0不为0则画空心柱.,COLORDD00DD
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLORFF88FF
当满足条件DD时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000099
当满足条件DD时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000FF
当满足条件DD时,在收盘价和开盘价位置之间画柱状线,宽度为1.9,0不为0则画空心柱.,COLOR0000CC
当满足条件DD时,在收盘价和开盘价位置之间画柱状线,宽度为1.0,0不为0则画空心柱.,COLOR0000DD
当满足条件DD时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR7788FF
当满足条件EE时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00AAAA
当满足条件EE时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00FFFF
当满足条件EE时,在收盘价和开盘价位置之间画柱状线,宽度为1.9,0不为0则画空心柱.,COLOR00CCCC
当满足条件EE时,在收盘价和开盘价位置之间画柱状线,宽度为1.0,0不为0则画空心柱.,COLOR00DDDD
当满足条件EE时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR00FFFF
当满足条件FF时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR888800
当满足条件FF时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFFF00
当满足条件FF时,在收盘价和开盘价位置之间画柱状线,宽度为1.9,0不为0则画空心柱.,COLORCCCC00
当满足条件FF时,在收盘价和开盘价位置之间画柱状线,宽度为1.0,0不为0则画空心柱.,COLORDDDD00
当满足条件FF时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLORFFFF00
YK赋值:"KDJ的K[取月线数据]"(9,3,3)的20日简单移动平均,线宽为0
YD赋值:"KDJ的D[取月线数据]"(9,3,3)的20日简单移动平均,线宽为0
YJ赋值:"KDJ的J[取月线数据]"(9,3,3)的20日简单移动平均
ZK赋值:"KDJ的K[取周线数据]"(9,3,3)的5日简单移动平均,线宽为0
ZD赋值:"KDJ的D[取周线数据]"(9,3,3)的5日简单移动平均,线宽为0
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均,线宽为0
D赋值:K的3日[1日权重]移动平均,线宽为0
J赋值:3*K-2*D,线宽为0
输出RJC:当满足条件K上穿D时,在最低价*0.98位置画1号图标
当满足条件RJC时,在最低价*0.98位置书写文字,COLOR0000FF
输出RSC:当满足条件D上穿K时,在最高价*1.03位置画2号图标,
当满足条件RSC时,在最高价*1.03位置书写文字,COLORFFFFFF
输出ZJC: 当满足条件ZK上穿ZD时,在最低价*0.98位置画1号图标
当满足条件ZJC时,在最低价*0.98位置书写文字,COLORFF00FF
输出ZSC: 当满足条件ZD上穿ZK时,在最高价*1.03位置画2号图标,
当满足条件ZSC时,在最高价*1.03位置书写文字,COLOR00FFFF
输出YJC: 当满足条件YK上穿YD时,在最低价*0.98位置画1号图标
当满足条件YJC时,在最低价*0.98位置书写文字,COLORFF0000
输出YSC: 当满足条件YD上穿YK时,在最高价*1.03位置画2号图标
当满足条件YSC时,在最高价*1.03位置书写文字,COLORADEAEA
输出MA10:收盘价的10日简单移动平均,画红色,线宽为1
如果MA10<1日前的MA10,返回MA10,否则返回无效数,COLORFFFF00,线宽为1
输出MA20:收盘价的20日简单移动平均,COLORFF00FF,线宽为1
如果MA20<1日前的MA20,返回MA20,否则返回无效数,COLORFFFFFF,线宽为1
输出MA55:收盘价的55日简单移动平均,COLORFF0000,线宽为1
如果MA55<1日前的MA55,返回MA55,否则返回无效数,COLOR00FFFF,线宽为1
TT赋值:如果是否最后一个周期,返回240/当前离开盘分钟数,否则返回1
NN赋值:120
HH赋值:NN日内成交量(手)*TT的最高值
LL赋值:NN日内成交量(手)的最低值
最高赋值:HH的最后一日取值设为常数
最低赋值:LL的最后一日取值设为常数
最高2赋值:NN日内最高价的最高值的最后一日取值设为常数
最低2赋值:NN日内最低价的最低值的最后一日取值设为常数
PP赋值:如果(最高2*0.9-(最高2-最低2)*0.5)>20日内最低价的最低值的最后一日取值设为常数,返回0.9,否则返回如果(最高2*0.9-(最高2-最低2)*0.5)>50日内最低价的最低值的最后一日取值设为常数,返回0.7,否则返回0.6,NODRAW
RCC1赋值:最高2*0.9-(最高2-最低2)*PP
最低3赋值:RCC1和最低2的较小值
AA赋值:最低3
当满足条件AAA时,在AA-0.000*AA和AA-0.040*AA位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR3EA6FF
当满足条件BB时,在AA-0.000*AA和AA-0.040*AA位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLORFF00FF
当满足条件DD时,在AA-0.000*AA和AA-0.040*AA位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR0000FF
当满足条件EE时,在AA-0.000*AA和AA-0.040*AA位置之间画柱状线,宽度为2.5,1不为0则画空心柱.,COLOR00FFFF
当满足条件FF时,在AA-0.000*AA和AA-0.040*AA位置之间画柱状线,宽度为2.5,1不为0则画空心柱.,COLORFFFF00
当满足条件1时,在横轴0.2纵轴0.86位置书写文字,COLOR00FFFF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1jXphVykzhhbZCoJvd7OEFA

看了该指标的人还看了:
必胜客指标    买卖提示指标
抓妖雄鹰指标    一年四倍指标 改编自飞狐主图

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表