指标公式
软件: 通达信 
公式类型: 主图 副图 选股 
二级分类: 波段 无未来函数 短线 买卖点 趋势 
TIM截图20180918102034.png

TIM截图20180918102046.png

[lywrap=通达信主图指标公式][lycode=tdx,true]DRAWBAND(MA(CLOSE,5),RGB(200,80,80),MA(CLOSE,10),RGB(0,0,115));
MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);
VAR1:=(CLOSE+HIGH+LOW)/3;
VAR2:=EMA(VAR1,10);
VAR3:=REF(VAR2,1);
STICKLINE((VAR2>VAR3),CLOSE,OPEN,2.8,0),COLOR000088;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,2.6,0),COLOR000099;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,2.4,0),COLOR0000AA;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,2.2,0),COLOR0000BB;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,2.0,0),COLOR0000CC;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,1.8,0),COLOR0000DD;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,1.5,0),COLOR0000EE;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,1,0),COLOR0000FF;
STICKLINE((VAR2>VAR3),LOW,HIGH,0.0,0),COLOR0000FF;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,2.8,0),COLOR888800;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,2.6,0),COLOR999900;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,2.4,0),COLORAAAA00;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,2,2),COLORBBBB00;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,2.0,0),COLORCCCC00;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,1.8,0),COLORDDDD00;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,1.5,0),COLOREEEE00;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,1,0),COLORFFFF00;
STICKLINE((VAR3>VAR2),LOW,HIGH,0.0,0),COLORFFFF00;
STICKLINE((OPEN>CLOSE),CLOSE,OPEN,0,0),COLORFFFF00;
STICKLINE((OPEN<CLOSE),CLOSE,OPEN,0,0),COLORRED;
C4:=CROSS(VAR2,VAR3);
C5:=CROSS(VAR3,VAR2);
DRAWICON(C4,LOW-0.3,11);
买进价:=((C-REF(MA(C,6),1))/6+MA(C,6))*1.004;
买进条件:=CROSS(C,买进价) AND 买进价>REF(买进价,1);
STICKLINE(买进条件,O,C,0.5,0),COLORFF0080;
加码价:=((C-REF(MA(C,21),1))/21+MA(C,21))*1.004;
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);
STICKLINE(加码条件,O,C,1.5,0),COLORFF0080;
短线强势区:=CROSS("KDJ".J,80) AND "MACD.DIF">"MACD.DEA" AND MA(C,5)>MA(C,30);
DRAWTEXT("KDJ.J"-REF("KDJ.J",1)>30  AND C/REF(C,1)>1.043 AND "MACD.MACD">0 AND "MACD.DEA">0,L*0.98,'*爆'),COLORYELLOW;[/lycode][lycode=tdx2,true]画带状线
输出MA5:收盘价的5日简单移动平均
输出MA10:收盘价的10日简单移动平均
输出MA20:收盘价的20日简单移动平均
VAR1赋值:(收盘价+最高价+最低价)/3
VAR2赋值:VAR1的10日指数移动平均
VAR3赋值:1日前的VAR2
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR000088
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为2.6,0不为0则画空心柱.,COLOR000099
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为2.4,0不为0则画空心柱.,COLOR0000AA
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR0000BB
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为2.0,0不为0则画空心柱.,COLOR0000CC
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR0000DD
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000EE
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000FF
当满足条件(VAR2>VAR3)时,在最低价和最高价位置之间画柱状线,宽度为0.0,0不为0则画空心柱.,COLOR0000FF
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR888800
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为2.6,0不为0则画空心柱.,COLOR999900
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为2.4,0不为0则画空心柱.,COLORAAAA00
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为2,2不为0则画空心柱.,COLORBBBB00
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为2.0,0不为0则画空心柱.,COLORCCCC00
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLORDDDD00
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOREEEE00
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFFFF00
当满足条件(VAR3>VAR2)时,在最低价和最高价位置之间画柱状线,宽度为0.0,0不为0则画空心柱.,COLORFFFF00
当满足条件(收阴线)时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFFF00
当满足条件(收阳线)时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
C4赋值:VAR2上穿VAR3
C5赋值:VAR3上穿VAR2
当满足条件C4时,在最低价-0.3位置画11号图标
买进价赋值:((收盘价-1日前的收盘价的6日简单移动平均)/6+收盘价的6日简单移动平均)*1.004
买进条件赋值:收盘价上穿买进价 AND 买进价>1日前的买进价
当满足条件买进条件时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFF0080
加码价赋值:((收盘价-1日前的收盘价的21日简单移动平均)/21+收盘价的21日简单移动平均)*1.004
加码条件赋值:收盘价上穿加码价 AND 加码价>1日前的加码价
当满足条件加码条件时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFF0080
短线强势区赋值:"KDJ".J上穿80 AND "平滑异同平均的DIF">"平滑异同平均的DEA" AND 收盘价的5日简单移动平均>收盘价的30日简单移动平均
当满足条件"KDJ的J"-1日前的"KDJ的J">30ANDC/1日前的收盘价>1.043AND"平滑异同平均的MACD">0AND"平滑异同平均的DEA">0时,在最低价*0.98位置书写文字,画黄色[/lycode][/lywrap]

[lywrap=通达信副图选股预警指标公式][lycode=tdx,true]云端爆点:"KDJ.J"-REF("KDJ.J",1)>30  AND C/REF(C,1)>1.043 AND "MACD.MACD">0 AND "MACD.DEA">0;[/lycode][lycode=tdx2,true]输出云端爆点:"KDJ的J"-1日前的"KDJ的J">30  AND 收盘价/1日前的收盘价>1.043 AND "平滑异同平均的MACD">0 AND "平滑异同平均的DEA">0[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1-6rYmdRHaXciLpknNM1Qfw

看了该指标的人还看了:
横扫天下指标    周线测底指标    波段密码指标
青龙白虎指标    高抛低吸指标    龙行凤影指标,很漂亮

使用道具 举报

回复