请选择 进入手机版|继续访问电脑版

短线王+短线无敌+底部吸筹 通达信 主图 副图 波段 无未来函数 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-10-21 08:00:19 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 副图 
二级分类: 波段 无未来函数 短线 买卖点 
当同时出现买入信号后,第二天以上一天收盘价以下价位买进,在未来一周内绝对有5%-10%收益,希望大家能受益。

1、公式源码1为主图源码,公式源码
2、3为两个附图源码,使用时缺一不可!

短线王+短线无敌+底部吸筹 通达信 主图 副图 波段 无未来函数 短线 买卖点 炒股叉第10389张

短线王+短线无敌+底部吸筹 通达信 主图 副图 波段 无未来函数 短线 买卖点 炒股叉第10390张

短线无敌
[lywrap=通达信主图指标公式][lycode=tdx,true]JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
离场:=IF(红色持股,JRL,DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
今离场价:REF(离场,1)COLOR0000FF,NODRAW;
青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
进:=IF(青色观望,JRH,DRAWNULL);
明进场价:=进,COLOR33AACC,NODRAW;
今进场价:REF(明进场价,1),COLORFF0000,NODRAW;
短买:VAR19,COLOR33AACC,NODRAW;
品红离场:VAR1A,COLORFF99FF,NODRAW;
急速超跌:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW;
辰星线:(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLOR0000FF;
牵牛线:MA(CLOSE,26),COLORFF00FF;
等待:=IF(MA3>辰星线,辰星线,MA3);
IF(等待>REF(等待,1),等待,DRAWNULL),LINETHICK2,COLOR00FFFF;
IF(辰星线>REF(辰星线,1),辰星线,DRAWNULL),LINETHICK2,COLOR0000FF;
IF(辰星线<REF(辰星线,1),辰星线,DRAWNULL),COLOR00FF00;
IF(牵牛线>REF(牵牛线,1),牵牛线,DRAWNULL),LINETHICK1,COLORFF00FF;
IF(牵牛线<REF(牵牛线,1),牵牛线,DRAWNULL),COLOR669933;
STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088;
STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800;
STICKLINE(青色观望,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(青色观望,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(青色观望,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(短买,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(短买,O,O+CO/3,2,0),COLOR338888;
STICKLINE(短买,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(短买,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(短买,O,O+CO/3,0,0),COLOR33EEEE;
DRAWTEXT(短买,REF(CLOSE,1)-0.2,'B'),COLORRED;
STICKLINE(品红离场,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(品红离场,O,O+CO/3,2,0),COLOR880088;
STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE;
DRAWTEXT(品红离场,REF(CLOSE,1)+0.5,'S'),COLORGREEN;[/lycode][lycode=tdx2,true]JRH赋值:2日内收盘价的最高值
JRL赋值:2日内收盘价的最低值
MA3赋值:收盘价的3日简单移动平均
YTSL赋值:(3*收盘价+最低价+开盘价+最高价)/6
VAR1赋值:(收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价)
VAR2赋值:(1日前的VAR1 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR3赋值:(1日前的VAR2 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR4赋值:(1日前的VAR3 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR5赋值:(1日前的VAR4 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR6赋值:(1日前的VAR5 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR7赋值:(1日前的VAR6 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR8赋值:(1日前的VAR7 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR9赋值:(1日前的VAR8 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARA赋值:(1日前的VAR9 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VARB赋值:(1日前的VARA AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARC赋值:(1日前的VARB AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VARD赋值:(收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价)
VARE赋值:(1日前的VARD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VARF赋值:(1日前的VARE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR10赋值:(1日前的VARF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR11赋值:(1日前的VAR10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR12赋值:(1日前的VAR11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR13赋值:(1日前的VAR12 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR14赋值:(1日前的VAR13 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR15赋值:(1日前的VAR14 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR16赋值:(1日前的VAR15 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR17赋值:(1日前的VAR16 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VAR18赋值:(1日前的VAR17 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VAR19赋值:((1日前的VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18) AND VAR1)
VAR1A赋值:((1日前的VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC) AND VARD)
输出红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW
离场赋值:如果红色持股,返回JRL,否则返回无效数
明离场价赋值:离场,COLORFF99FF,NODRAW
输出今离场价:1日前的离场COLOR0000FF,NODRAW
输出青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW
进赋值:如果青色观望,返回JRH,否则返回无效数
明进场价赋值:进,COLOR33AACC,NODRAW
输出今进场价:1日前的明进场价,COLORFF0000,NODRAW
输出短买:VAR19,COLOR33AACC,NODRAW
输出品红离场:VAR1A,COLORFF99FF,NODRAW
输出急速超跌:(收盘价-收盘价的34日简单移动平均)/收盘价的34日简单移动平均*100<-14,COLORFFFFFF,NODRAW
输出辰星线:(20*YTSL+19*1日前的YTSL+18*2日前的YTSL+17*3日前的YTSL+16*4日前的YTSL+15*5日前的YTSL+14*6日前的YTSL+13*7日前的YTSL+12*8日前的YTSL+11*9日前的YTSL+10*10日前的YTSL+9*11日前的YTSL+8*12日前的YTSL+7*13日前的YTSL+6*14日前的YTSL+5*15日前的YTSL+4*16日前的YTSL+3*17日前的YTSL+2*18日前的YTSL+20日前的YTSL)/211,COLOR0000FF
输出牵牛线:收盘价的26日简单移动平均,COLORFF00FF
等待赋值:如果MA3>辰星线,返回辰星线,否则返回MA3
如果等待>1日前的等待,返回等待,否则返回无效数,线宽为2,COLOR00FFFF
如果辰星线>1日前的辰星线,返回辰星线,否则返回无效数,线宽为2,COLOR0000FF
如果辰星线<1日前的辰星线,返回辰星线,否则返回无效数,COLOR00FF00
如果牵牛线>1日前的牵牛线,返回牵牛线,否则返回无效数,线宽为1,COLORFF00FF
如果牵牛线<1日前的牵牛线,返回牵牛线,否则返回无效数,COLOR669933
当满足条件ISLASTBARAND(红色持股ORREF(红色持股,1)=1)时,在今离场价和今离场价位置之间画柱状线,宽度为30,1不为0则画空心柱.,COLOR0000FF
当满足条件ISLASTBARAND(青色观望ORREF(青色观望,1)=1)时,在今进场价和今进场价位置之间画柱状线,宽度为30,1不为0则画空心柱.,COLOR00FF00
当满足条件收盘价>=开盘价时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000CC
当满足条件收阴线时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR999900
当满足条件1时,在收盘价和开盘价位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLOR858500
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLOR0000E5
当满足条件红色持股时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR000055
当满足条件红色持股时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR000088
当满足条件红色持股时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000AA
当满足条件红色持股时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000CC
当满足条件红色持股时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR0000EE
当满足条件青色观望时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR555500
当满足条件青色观望时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR888800
当满足条件青色观望时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORAAAA00
当满足条件青色观望时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORCCCC00
当满足条件青色观望时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOREEEE00
CO赋值:(收盘价-开盘价)
当满足条件急速超跌时,在开盘价和收盘价-CO/2位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR555555
当满足条件急速超跌时,在开盘价和收盘价-CO/2位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR888888
当满足条件急速超跌时,在开盘价和收盘价-CO/2位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORAAAAAA
当满足条件急速超跌时,在开盘价和收盘价-CO/2位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORCCCCCC
当满足条件急速超跌时,在开盘价和收盘价-CO/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOREEEEEE
当满足条件短买时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR335555
当满足条件短买时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR338888
当满足条件短买时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR33AAAA
当满足条件短买时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR33CCCC
当满足条件短买时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR33EEEE
当满足条件短买时,在1日前的收盘价-0.2位置书写文字,画红色
当满足条件品红离场时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR550055
当满足条件品红离场时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR880088
当满足条件品红离场时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORAA00AA
当满足条件品红离场时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORCC00CC
当满足条件品红离场时,在开盘价和开盘价+CO/3位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOREE00EE
当满足条件品红离场时,在1日前的收盘价+0.5位置书写文字,画绿色[/lycode][/lywrap]

底部吸筹
[lywrap=通达信副图公式][lycode=tdx,true]VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100;
VAR4:=EMA(IF(CLOSE*1.3,VAR3*10,VAR3/10),3);
VAR5:=LLV(LOW,30);
VAR6:=HHV(VAR4,30);
VAR7:=IF(MA(CLOSE,58),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=IF(VAR8>100,100,VAR8);
STICKLINE(VAR9>-150,0,VAR9,0.1,0),  COLORFF00FF;
吸筹指标:(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100,COLOR00FF00;
STICKLINE(CROSS(吸筹指标,-24),100,0,1,0),  COLORFFFFFF;
先知: (CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100, COLORFF00FF;
放量拉升:IF(CROSS(吸筹指标,-24),1,0), COLORFFFFFF;
获利:STICKLINE(REF("KDJ.J",1)<0 AND "KDJ.J">0,60,0,1,0),COLOR0000FF;
VARK1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARK2:=REVERSE(VARK1);
VARK3:=SMA(VARK1,3,1);
波段王:SMA(VARK3,3,1),  COLORRED,LINETHICK2;
波段鬼:SMA(波段王,2.5,1),COLORYELLOW,LINETHICK2;
趋势线: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),COLORFF6666,LINETHICK2;
RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:SMA(RSV9,3,1);
DK1:K1-REF(K1,1),COLORSTICK;
出手就赢:IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,1))>9,50,0), STICK,COLORYELLOW;DRAWICON(出手就赢>0,50 ,1);
STICKLINE( CROSS(趋势线,10),0,73,3,0), COLOR3366FF;
DRAWTEXT(IF(CROSS(趋势线,10),100,0),68,'底'),COLORWHITE ;
DRAWTEXT(IF(CROSS(10,趋势线),1,0), 10,'钱'),COLOR33FFCC;
DRAWTEXT(REF("KDJ.J",1)<0 AND "KDJ.J">0,50,'买'),COLORRED ;
DRAWTEXT(CROSS(吸筹指标,-24),80,'底'),COLORWHITE ;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
短期底部:=LLV(OPEN,30);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
AA10:=MA(CLOSE,10);
AA12:=MA(CLOSE,12);
BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);
MA13:=MA(CLOSE,13);
VARB:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VARC:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VARD:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VARE:=(((VARB + (2 * VARC)) + (3 * VARD)) / 6);
VARF:=MA(VARE,3);
STICKLINE((CROSS(J,0) AND (VARF <= (0 - 7))),0,88,2,0),COLORBLUE;
DRAWICON((CROSS(J,0) AND (VARF <= (0 - 7))),88,9);
VARO2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
VARO3:=SMA(SMA(VARO2,3,1),3,1);
VARO4:=EMA(VARO3,5);
VARO5:=LLV(LOW,26);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
STICKLINE(CROSS(VARO4,10) AND VARO4>10,25,0,1,0),COLORYELLOW;
建仓区: IF((VARO7<10),0,20),LINETHICK3 ,COLORRED;[/lycode][lycode=tdx2,true]VAR2赋值:1日前的最低价
VAR3赋值:最低价-VAR2的绝对值的3日[1日权重]移动平均/最低价-VAR2和0的较大值的3日[1日权重]移动平均*100
VAR4赋值:如果收盘价*1.3,返回VAR3*10,否则返回VAR3/10的3日指数移动平均
VAR5赋值:30日内最低价的最低值
VAR6赋值:30日内VAR4的最高值
VAR7赋值:如果收盘价的58日简单移动平均,返回1,否则返回0
VAR8赋值:如果最低价<=VAR5,返回(VAR4+VAR6*2)/2,否则返回0的3日指数移动平均/618*VAR7
VAR9赋值:如果VAR8>100,返回100,否则返回VAR8
当满足条件VAR9>-150时,在0和VAR9位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,  COLORFF00FF
输出吸筹指标:(收盘价-收盘价的40日简单移动平均)/收盘价的40日简单移动平均*100,COLOR00FF00
当满足条件吸筹指标上穿-24时,在100和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,  COLORFFFFFF
输出先知: (收盘价-收盘价的5日简单移动平均)/收盘价的5日简单移动平均*100, COLORFF00FF
输出放量拉升:如果吸筹指标上穿-24,返回1,否则返回0, COLORFFFFFF
输出获利:当满足条件1日前的"KDJ的J"<0AND"KDJ的J">0时,在60和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000FF
VARK1赋值:(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100
VARK2赋值:VARK1的相反数
VARK3赋值:VARK1的3日[1日权重]移动平均
输出波段王:VARK3的3日[1日权重]移动平均,  画红色,线宽为2
输出波段鬼:波段王的2.5日[1日权重]移动平均,画黄色,线宽为2
输出趋势线: 3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均,COLORFF6666,线宽为2
RSV9赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
输出K1:RSV9的3日[1日权重]移动平均
输出DK1:K1-1日前的K1,COLORSTICK
输出出手就赢:如果DK1>7ANDREF(DK1,1)<0AND(DK1-1日前的DK1)>9,返回50,否则返回0, STICK,画黄色
当满足条件出手就赢>0时,在50位置画1号图标
当满足条件趋势线上穿10时,在0和73位置之间画柱状线,宽度为3,0不为0则画空心柱., COLOR3366FF
当满足条件如果趋势线上穿10,返回100,否则返回0时,在68位置书写文字,画白色
当满足条件如果10上穿趋势线,返回1,否则返回0时,在10位置书写文字,COLOR33FFCC
当满足条件1日前的"KDJ的J"<0AND"KDJ的J">0时,在50位置书写文字,画红色
当满足条件吸筹指标上穿-24时,在80位置书写文字,画白色
RSV赋值:(((收盘价 - 9日内最低价的最低值) / (9日内最高价的最高值 - 9日内最低价的最低值)) * 100)
短期底部赋值:30日内开盘价的最低值
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:((3 * K) - (2 * D))
AA10赋值:收盘价的10日简单移动平均
AA12赋值:收盘价的12日简单移动平均
BB10赋值:(((AA10-1日前的AA10)的反正切 * 3.1416) * 10)
BB12赋值:(((AA12-1日前的AA12)的反正切 * 3.1416) * 10)
MA13赋值:收盘价的13日简单移动平均
VARB赋值:(((收盘价 - 收盘价的6日简单移动平均) / 收盘价的6日简单移动平均) * 100)
VARC赋值:(((收盘价 - 收盘价的12日简单移动平均) / 收盘价的12日简单移动平均) * 100)
VARD赋值:(((收盘价 - 收盘价的24日简单移动平均) / 收盘价的24日简单移动平均) * 100)
VARE赋值:(((VARB + (2 * VARC)) + (3 * VARD)) / 6)
VARF赋值:VARE的3日简单移动平均
当满足条件(J上穿0AND(VARF<=(0-7)))时,在0和88位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
当满足条件(J上穿0AND(VARF<=(0-7)))时,在88位置画9号图标
VARO2赋值:(收盘价-26日内最低价的最低值)/(26日内最高价的最高值-26日内最低价的最低值)*100
VARO3赋值:VARO2的3日[1日权重]移动平均的3日[1日权重]移动平均
VARO4赋值:VARO3的5日指数移动平均
VARO5赋值:26日内最低价的最低值
VARO6赋值:34日内最高价的最高值
VARO7赋值:(收盘价-VARO5)/(VARO6-VARO5)*4的4日指数移动平均*25
当满足条件VARO4上穿10ANDVARO4>10时,在25和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
输出建仓区: 如果(VARO7<10),返回0,否则返回20,线宽为3 ,画红色[/lycode][/lywrap]

短线王
[lywrap=通达信副图指标公式][lycode=tdx,true]V1:=MA(C,3)=HHV(MA(C,3),7);
V2:=MA(C,3)>MA(C,5);
V3:=MA(V,5)>MA(V,10)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
LC20:=REF(CLOSE,1);
RSI20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100;
STICKLINE(CROSS(RSI20,11)*1,-10,20,2,0),COLORYELLOW;
VAR3A:=3;
VAR2A:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
加仓:IF(FILTER(YXF=1,5),20,-10),STICK,COLORLIBLUE,LINETHICK3;
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV
(L,55))*100,5,1);
FY:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
QS:(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2)),LINETHICK2,COLORRED;[/lycode][lycode=tdx2,true]V1赋值:收盘价的3日简单移动平均=7日内收盘价的3日简单移动平均的最高值
V2赋值:收盘价的3日简单移动平均>收盘价的5日简单移动平均
V3赋值:成交量(手)的5日简单移动平均>成交量(手)的10日简单移动平均*1.01
V4赋值:统计2日中满足收盘价的1日简单移动平均>1日前的收盘价的天数=2
LC20赋值:1日前的收盘价
RSI20赋值:收盘价-LC20和0的较大值的4.1日[1日权重]移动平均/收盘价-LC20的绝对值的4.1日[1日权重]移动平均*100
当满足条件RSI20上穿11*1时,在-10和20位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
VAR3A赋值:3
VAR2A赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
MTM赋值:收盘价-1日前的收盘价
DX赋值:100*MTM的6日指数移动平均的6日指数移动平均/MTM的绝对值的6日指数移动平均的6日指数移动平均
YXF赋值:如果2日内DX的最低值=7日内DX的最低值ANDCOUNT(DX<0,2)ANDCROSS(DX,DX的2日简单移动平均),返回1,否则返回0
输出加仓:如果YXF=1的5日过滤,返回20,否则返回-10,STICK,画淡蓝色,线宽为3
A51赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均
FY赋值:A51的5日指数移动平均
A54赋值:((收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值))*100
输出QS:(3*A54的6日[1日权重]移动平均-2*A54的5日[1日权重]移动平均的5日[1日权重]移动平均的2日简单移动平均),线宽为2,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1ojDZS8HHNyXbE2rXSDKJ3A

看了该指标的人还看了:
抄底王指标    牛逼买入指标
做足波段指标    均衡加仓买线指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表