请选择 进入手机版|继续访问电脑版

求助。这两个指标我合并了。怎么显示不全

[复制链接]

s657794113  注册会员

发表于 2018-9-13 17:10:07 | 查看全部

本帖最后由 s657794113 于 2018-9-13 17:31 编辑

{分时主图}
攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN;
攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN),COLOR0000FF,LINETHICK0;
攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),COLOR00FF00,LINETHICK0;
攻击流量:=攻击量A+攻击量B,COLORSTICK;
攻击比:=攻击流量/SUM(V,FROMOPEN)*100,COLORRED,LINETHICK1;
资金攻击度:=IF(攻击比>=0,(攻击比+50),100-ABS((攻击比-50)));
资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),STICK,COLORRED;
资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),STICK,COLOR00FF00;
资金出入:=资金流入+资金流出,COLORSTICK;
资金比:=资金出入/SUM(V,FROMOPEN)*100,COLOR00FFFF,LINETHICK1;
资金流量比:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2));
DRAWTEXT_FIX(1,0.250,0.88,0,STRCAT(STRCAT('【资金流量比】',CON2STR(资金流量比,2)),'%买')),COLORCYAN;
DRAWTEXT_FIX(1,0.000,0.88,0,STRCAT(STRCAT('【资金攻击度】',CON2STR(资金攻击度,2)),' %买')),COLORCYAN;

XG:HHV(H,480),DOTLINE,COLORRED;
STICKLINE(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.99,C,8,0),COLORGREEN;
DRAWTEXT(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.99,'突破'),COLORYELLOW;
RQ:=DATETODAY(DATE)-DATETODAY(REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT))+1;
JY:=BARSLAST((RQ-REF(RQ,1))!=WEEKDAY-REF(WEEKDAY,1) OR TOTALBARSCOUNT-CURRBARSCOUNT=0)+1;
MA1:=REF(C,JY);
MA2:=REF(MA1,JY);
MA3:=REF(MA2,JY);
MA4:=REF(MA3,JY);
MA5:=REF(MA4,JY);
MA6:=REF(MA5,JY);
MA7:=REF(MA6,JY);
MA8:=REF(MA7,JY);
MA9:=REF(MA8,JY);
CK:REFDATE((C+MA1+MA2+MA3+MA4+MA5+MA6+MA7+MA8+MA9)/10,DATE),COLORAC59FF,CIRCLEDOT;
DRAWTEXT(ISLASTBAR,CK,' 参考线'),COLOR0000FF;

DIF:=(EMA(CLOSE,12)-EMA(CLOSE,26))+DYNAINFO(3);
DEA:=EMA(DIF,9);
MACD1:=10*(DIF-DEA);
MACD2:=EMA(MACD1,2);
STICKLINE(MACD1>=MACD2 AND MACD1>=0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR0000B4;
STICKLINE(MACD1<MACD2 AND MACD1>0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR00B400;
STICKLINE(MACD1>=MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR5151A2;
STICKLINE(MACD1<MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR88743A;


XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
主力:=EXPMA(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);
底:=1;1.02,NODRAW;高:=1.03;
DRAWTEXT(CROSS(主力,1.02),C*0.999,'-拉升'),COLORCYAN;
DRAWICON(CROSS(主力,1.04),C,24);
DRAWTEXT(CROSS(主力,1.04),C*0.999,'-冲涨停'),COLORLIMAGENTA;

A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交额:=V*C/100,NODRAW;
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
A9:=IF((ISLASTBAR),((100*A4)/A6),0);
A10:=IF((ISLASTBAR),((100*A5)/A6),0);
机构买盘:=(A2),LINETHICK2;
机构卖盘:=(A3),LINETHICK2;
散户买盘:=(A4);
散户卖盘:=(A5);
DRAWTEXT_FIX(1,0.000,1-0.05,0,STRCAT(STRCAT('【机构买盘】',CON2STR(机构买盘,2)),'万')),COLORRED;
DRAWTEXT_FIX(1,0.250,1-0.05,0,STRCAT(STRCAT('【机构卖盘】',CON2STR(机构卖盘,2)),'万')),COLOR00FF00;
DRAWTEXT_FIX(1,0.500,1-0.05,0,STRCAT(STRCAT('【散户买盘】',CON2STR(散户买盘,2)),'万')),COLORRED;
DRAWTEXT_FIX(1,0.745,1-0.05,0,STRCAT(STRCAT('【散户卖盘】',CON2STR(散户卖盘,2)),'万')),COLOR00FF00;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:=L1+P1*7/8,COLORGREEN;
支撑:=L1+P1*0.5/8,COLORMAGENTA;
DRAWTEXT(LONGCROSS(支撑,C,2),C,'买'),COLORYELLOW;
DRAWTEXT(LONGCROSS(C,阻力,2),C,'卖'),COLORGREEN;

量价:=(VOL/CLOSE)/3;
B2:=SUM((IF(((量价>0.20) AND (CLOSE>(REF(CLOSE,1)))),量价,0)),0);
B3:=SUM((IF(((量价>0.20) AND (CLOSE<(REF(CLOSE,1)))),量价,0)),0);
B6:=B2+B3;DD1:=1;比:=B2/B3;


AAA1:=STRCAT(STRCAT('机构买入',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('机构卖出',CON2STR((100*A3)/A6,0)),'%');
AAA0:=STRCAT(STRCAT('机构总买入',CON2STR((100*(A2-A3))/A6,0)),'%');
AAA3:=STRCAT(STRCAT('散户买入',CON2STR((100*A4)/A6,0)),'%');
AAA4:=STRCAT(STRCAT('散户卖出',CON2STR((100*A5)/A6,0)),'%');
AAA5:=STRCAT(STRCAT('散户总买入',CON2STR((100*(A4-A5))/A6,0)),'%');
DRAWTEXT_FIX(DD1=1,0,0.55,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0,0.60,0,AAA2),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0,0.65,0,AAA3),COLORRED;
DRAWTEXT_FIX(DD1=1,0,0.70,0,AAA4),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0,0.75,0,AAA0),LINETHICK5,COLORCYAN;
DRAWTEXT_FIX(DD1=1,0,0.80,0,AAA5),LINETHICK5,COLORCYAN;

虎:=(EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100;
DRAWICON(CROSS(EXPMA(虎,120)-0.0004,EXPMA(虎,200)),C,13);
Q:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))),1.05,0.95);
Q2:=IF(Q=0,MA(C,BARSCOUNT(C)),(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))));
DRAWICON(CROSS((C/Q2),1.03),C,1);

MZ0:=(BARSLAST(((HOUR=9) AND (MINUTE=31)))+1);
上穿分时:IF(((SETCODE<2) AND (CONST(MZ0)<241)),CONST(IF((TIME<1000),HHV(CLOSE,0),SUM((IF((TIME=1000),1,0)*HHV(CLOSE,0)),0))),DRAWNULL),LINETHICK3,COLORMAGENTA;
底支:IF(((SETCODE<2) AND (CONST(MZ0)<241)),CONST(IF((TIME<1000),HHV(CLOSE,0),SUM((IF((TIME=1000),1,0)*LLV(CLOSE,0)),0))),DRAWNULL),LINETHICK2,COLORLIRED;
STICKLINE(TIME=931 OR TIME=1000,上穿分时,底支,1,0),COLORYELLOW;
分时上突:=CROSS(C,上穿分时);
上突:=C<上穿分时 AND 上穿分时>底支;
DRAWICON(分时上突,C*0.99,25);
股价支撑线:=MA(CLOSE,20),COLORRED;
底价线:股价支撑线-2*STD(CLOSE,20),COLORMAGENTA,LINETHICK3;
DRAWTEXT_FIX(1,0.000,0.00,0,STRCAT(STRCAT('【今日强势有效突破股】',CON2STR(上穿分时,2)),'元买入稳赚')),COLORYELLOW;
DRAWTEXT_FIX(1,0.500,0.00,0,STRCAT(STRCAT('【底部得到有效支撑】',CON2STR(底支,2)),'可以参考')),COLORYELLOW;

{原分时福图}A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交额:=V*C/100,NODRAW;{万元}
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
A9:=IF((ISLASTBAR),((100*A4)/A6),0);
A10:=IF((ISLASTBAR),((100*A5)/A6),0);
增减仓%:A1;
机构买盘:(A2),LINETHICK6,COLORRED;
机构卖盘:(A3),LINETHICK6,COLORFFFF55;
机构进出:机构买盘-机构卖盘,NODRAW;
散户买盘:(A4),COLOR5555FF;{细红线}
散户卖盘:(A5),COLOR55FF55;{细绿线}
强势:((100*A2)/A6>50);
STICKLINE(强势,机构买盘*1.02,机构买盘*1.1,1,0),COLORYELLOW;
拉升:((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;
STICKLINE(拉升,机构买盘*1.1,机构买盘*1.2,1,0),COLORFF00FF;
DRAWTEXT(ISLASTBAR=1,机构买盘*0.95,'●机构买盘'),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR=1,机构卖盘*0.95,'○机构卖盘'),LINETHICK2,COLORFFFF55;
DRAWTEXT(机构进出>0 AND REF(机构进出,1)<=0,机构买盘*1.02,'●机买'),COLORRED;
DRAWTEXT(机构进出<0 AND REF(机构进出,1)>=0,机构买盘*0.98,'○机卖'),COLORFFFF55;

      {合并改了幅图}
AA1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交额1:=V*C/100,NODRAW;{万元}
AA2:=SUM((IF(((成交额1/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额1,0)),0);
AA3:=SUM((IF(((成交额1/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额1,0)),0);
AA4:=SUM((IF(((成交额1/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额1,0)),0);
AA5:=SUM((IF(((成交额1/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额1,0)),0);
AA6:=((AA2+AA3)+AA4)+AA5;
AA7:=IF((ISLASTBAR),((100*AA2)/AA6),0);
AA8:=IF((ISLASTBAR),((100*AA3)/AA6),0);
AA9:=IF((ISLASTBAR),((100*AA4)/AA6),0);
AA10:=IF((ISLASTBAR),((100*AA5)/AA6),0);
增减仓%:AA1;
机构买盘1:(AA2),LINETHICK6,NODRAW;
机构卖盘1:(AA3),LINETHICK6,NODRAW;
机构进出1:机构买盘1-机构卖盘1,NODRAW;
散户买盘1:(AA4),NODRAW;{细红线}
散户卖盘1:(AA5),NODRAW;{细绿线}
强势:((100*AA2)/AA6>50);
STICKLINE(强势,机构买盘1*1.02,机构买盘1*1.1,1,0),COLORYELLOW;
拉升:((100*AA2)/AA6-(100*AA3)/AA6)>18 AND (100*AA2)/AA6-(100*AA5)/AA6>18;
STICKLINE(拉升,机构买盘1*1.1,机构买盘1*1.2,1,0),COLORFF00FF;
DRAWTEXT(ISLASTBAR=1,机构买盘1*0.95,'●机构买盘'),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR=1,机构卖盘1*0.95,'○机构卖盘'),LINETHICK2,COLORFFFF55;
DRAWTEXT(机构进出1>0 AND REF(机构进出1,1)<=0,机构买盘1*1.02,'●机买'),COLORRED;
DRAWTEXT(机构进出1<0 AND REF(机构进出1,1)>=0,机构买盘1*0.98,'○机卖'),COLORFFFF55;




   合并后原来的主图显示不出来了,求助





举报 使用道具

回复

精彩评论3

admin  管理员

发表于 2018-9-14 09:59:29 | 显示全部楼层

等高手解答。。。  

举报 使用道具

回复

 楼主| s657794113  注册会员

发表于 2018-9-15 09:17:47 | 显示全部楼层

搞定了。。好了

举报 使用道具

回复

admin  管理员

发表于 2018-11-8 10:15:55 | 显示全部楼层

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表