请选择 进入手机版|继续访问电脑版

加仓减仓指标 强势狙击 通达信 主图 选股 波段 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-10-12 08:00:03 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 选股 
二级分类: 波段 短线 买卖点 
加仓减仓指标 强势狙击 通达信 主图 选股 波段 短线 买卖点 炒股叉第10211张

加仓减仓指标 强势狙击 通达信 主图 选股 波段 短线 买卖点 炒股叉第10212张

[lywrap=通达信主图指标公式][lycode=tdx,true]MA05:MA(C,5)LINETHICK3,COLOR00CCFF;
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
五日乖离率:=(C-MA05)/MA05*100;
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORRED;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK3,COLORGREEN;
三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;
VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);
DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;
买入:=FILTER(MR,10);
DRAWTEXT(减仓,HIGH*1.02,'←风险'),COLORCYAN;
DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;
DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;
DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;
VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;
压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;[/lycode][lycode=tdx2,true]输出MA05:收盘价的5日简单移动平均线宽为3,COLOR00CCFF
MA10赋值:收盘价的10日简单移动平均
MA20赋值:收盘价的20日简单移动平均
MA30赋值:收盘价的30日简单移动平均
五日乖离率赋值:(收盘价-MA05)/MA05*100
BB05赋值:(MA05/1日前的MA05-1)*100的反正切*180/3.1416
速度5赋值:(MA05-1日前的MA05)/1日前的MA05的3日指数移动平均*100的3日[1日权重]移动平均
加速度5赋值:(速度5-1日前的速度5)的3日指数移动平均,NODRAW
如果BB05>30ANDMA05>1日前的MA05,返回MA05,否则返回无效数,线宽为3,画红色
BB10赋值:(MA10/1日前的MA10-1)*100的反正切*180/3.1416
如果BB05<0ANDMA05<1日前的MA05,返回MA05,否则返回无效数,线宽为3,画绿色
三拾日乖离率赋值:(收盘价-MA30)/MA30*100,NODRAW
VAR1赋值:(MA20-MA30)>1日前的(MA20-MA30) AND MA20>1日前的MA20 AND MA30>1日前的MA30
VAR2赋值:(MA30-MA20)<1日前的(MA30-MA20) AND MA20<1日前的MA20 AND MA30<1日前的MA30
BB30赋值:(MA30/1日前的MA30-1)*100的反正切*180/3.1416
强势狙击赋值:BB30>30ANDBB10>45ANDCROSS(BB05,60)的10日过滤
加仓赋值:统计5日中满足BB05上穿30的天数>=1ANDMA05>1日前的MA05AND三拾日乖离率>1日前的三拾日乖离率ANDMA10>1日前的MA10AND加速度5>1日前的加速度5AND速度5>1日前的速度5的10日过滤
清仓赋值:统计5日中满足30上穿BB05的天数>=1AND(收盘价>MA30ORO>MA30)ANDMA05<1日前的MA05AND三拾日乖离率<1日前的三拾日乖离率ANDMA10<1日前的MA10的10日过滤
当满足条件加仓时,在最低价*0.98位置书写文字,画红色
JC赋值:0上穿五日乖离率 AND 三拾日乖离率<1日前的三拾日乖离率 AND MA10>1日前的MA10
减仓赋值:JC的10日过滤
MR赋值:统计3日中满足五日乖离率上穿0的天数>=1 AND 三拾日乖离率>1日前的三拾日乖离率 AND MA05>1日前的MA05 AND (收盘价/1日前的收盘价-1)*100>5 AND 1日前的收盘价<MA30
买入赋值:MR的10日过滤
当满足条件减仓时,在最高价*1.02位置书写文字,画青色
当满足条件买入时,在最低价*0.98位置书写文字,画黄色
当满足条件清仓时,在最高价*1.02位置书写文字,画绿色
当满足条件强势狙击时,在最低价*0.98位置书写文字,画黄色
VAR21赋值:最高价-成交额(元)/成交量(手)/100的绝对值和成交额(元)/成交量(手)/100-最低价的绝对值的较大值
VAR3赋值:(开盘价+收盘价)/2-成交额(元)/成交量(手)/100的绝对值
MV赋值:(VAR21+VAR3)/成交额(元)*成交量(手)*100*50
输出压力:1日前的30日内收盘价的最高值的2日简单移动平均,COLOR9DFFFF
输出支撑:1日前的30日内收盘价的最低值的2日简单移动平均,COLORABFF46[/lycode][/lywrap]

[lywrap=通达信选股公式指标][lycode=tdx,true]MA05:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
强势狙击:FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);[/lycode][lycode=tdx2,true]MA05赋值:收盘价的5日简单移动平均
MA10赋值:收盘价的10日简单移动平均
MA30赋值:收盘价的30日简单移动平均
BB05赋值:(MA05/1日前的MA05-1)*100的反正切*180/3.1416
BB10赋值:(MA10/1日前的MA10-1)*100的反正切*180/3.1416
BB30赋值:(MA30/1日前的MA30-1)*100的反正切*180/3.1416
输出强势狙击:BB30>30ANDBB10>45ANDCROSS(BB05,60)的10日过滤[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1V34y44b50VLCCOZ7AOxXtQ

看了该指标的人还看了:
短线买点指标 极品    抓妖雄鹰指标
最佳综合顶底指标    主力潜伏吃货指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表