请选择 进入手机版|继续访问电脑版

次日必涨指标 通达信 副图 波段 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-10-12 08:00:03 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
次日必涨指标 通达信 副图 波段 短线 买卖点 炒股叉第10207张

次日必涨指标 通达信 副图 波段 短线 买卖点 炒股叉第10208张

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VARA:=BARSCOUNT(CLOSE);
VARB:=VAR8<20 AND VAR9<23 AND VARA>35;
VARC:=VARB AND COUNT(VARB,1)=1;
VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VARE:=EMA(VARD,5);
VARF:=TROUGHBARS(3,6,1)<4 AND CROSS(VARD,VARE);
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR1A:=EMA(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);
VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR1E:=EMA(VAR1D*0.97,3);
VAR1F:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));
VAR21:=CROSS(VAR1E,LOW);
选股买点:VAR10,COLORYELLOW;
组合买:(VAR11+VAR13+VAR15+VAR17),COLORRED;
组合卖:(VAR12+VAR14+VAR16+VAR18),COLORGREEN;
黑马线:IF(VAR1B>0.1,VAR1C,0)*1;
黑马信号介入点:选股买点 AND VARF AND VARC AND VAR21 AND VAR4<0 AND VAR5<2 AND VAR6=0,COLORFFFF99;
DRAWTEXT(VAR13,0.6,'●'),COLORRED;
DRAWICON(组合买,组合买,1);
DRAWICON(组合卖,组合卖,9);
DRAWTEXT(黑马信号介入点>0,4.5,'●我的黑马介入点'),COLORRED;
DRAWICON(选股买点>0,4.2,1);
DRAWTEXT(选股买点 AND VARF AND VARC,2.8,' 30%下单莫错过!'),COLORMAGENTA;
DRAWTEXT(VAR18,3,'空仓'),COLORGREEN;
DRAWTEXT(VAR20<-110 AND 选股买点>0,2,'选股买点'),COLORYELLOW;
DRAWTEXT(VAR17,1.3,'发现黑马'),COLORFF6600;
DRAWTEXT(选股买点 AND VAR20<-100 AND VARF AND VARC>0,4.1,'★组合5分钟线选股思路获利5%以上'),COLORRED;[/lycode][lycode=tdx2,true]VAR3赋值:240日内最高价的最低值
VAR4赋值:100*(收盘价-VAR3)/VAR3
VAR5赋值:(收盘价-528日内最低价的最低值)/(528日内最高价的最高值-528日内最低价的最低值)*100
VAR6赋值:(收盘价-530日内收盘价的最低值)/(530日内收盘价的最高值-530日内收盘价的最低值)*100
VAR8赋值:收盘价-1日前的收盘价和0的较大值的34日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的7日[1日权重]移动平均*100
VAR9赋值:收盘价-1日前的收盘价和0的较大值的13日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的13日[1日权重]移动平均*100
VARA赋值:收盘价的有效数据周期数
VARB赋值:VAR8<20 AND VAR9<23 AND VARA>35
VARC赋值:VARB AND 统计1日中满足VARB的天数=1
VARD赋值:收盘价的21日指数移动平均-收盘价的8日指数移动平均
VARE赋值:VARD的5日指数移动平均
VARF赋值:收盘价6%之字转向的前1个波谷位置<4 AND VARD上穿VARE
VAR10赋值:如果收盘价16%之字转向的前1个波谷位置=0ANDHIGH>最低价+0.04,返回4,否则返回0
VAR11赋值:收盘价6%的之字转向>1日前的收盘价6%的之字转向 AND 1日前的收盘价6%的之字转向<=2日前的收盘价6%的之字转向 AND 2日前的收盘价6%的之字转向<=3日前的收盘价6%的之字转向
VAR12赋值:收盘价6%的之字转向<1日前的收盘价6%的之字转向 AND 1日前的收盘价6%的之字转向>=2日前的收盘价6%的之字转向 AND 2日前的收盘价6%的之字转向>=3日前的收盘价6%的之字转向
VAR13赋值:收盘价22%的之字转向>1日前的收盘价22%的之字转向 AND 1日前的收盘价22%的之字转向<=2日前的收盘价22%的之字转向 AND 2日前的收盘价22%的之字转向<=3日前的收盘价22%的之字转向
VAR14赋值:收盘价22%的之字转向<1日前的收盘价22%的之字转向 AND 1日前的收盘价22%的之字转向>=2日前的收盘价22%的之字转向 AND 2日前的收盘价22%的之字转向>=3日前的收盘价22%的之字转向
VAR15赋值:收盘价51%的之字转向>1日前的收盘价51%的之字转向 AND 1日前的收盘价51%的之字转向<=2日前的收盘价51%的之字转向 AND 2日前的收盘价51%的之字转向<=3日前的收盘价51%的之字转向
VAR16赋值:收盘价51%的之字转向<1日前的收盘价51%的之字转向 AND 1日前的收盘价51%的之字转向>=2日前的收盘价51%的之字转向 AND 2日前的收盘价51%的之字转向>=3日前的收盘价51%的之字转向
VAR17赋值:收盘价72%的之字转向>1日前的收盘价72%的之字转向 AND 1日前的收盘价72%的之字转向<=2日前的收盘价72%的之字转向 AND 2日前的收盘价72%的之字转向<=3日前的收盘价72%的之字转向
VAR18赋值:收盘价72%的之字转向<1日前的收盘价72%的之字转向 AND 1日前的收盘价72%的之字转向>=2日前的收盘价72%的之字转向 AND 2日前的收盘价72%的之字转向>=3日前的收盘价72%的之字转向
VAR19赋值:收盘价的2日指数移动平均-收盘价的150日指数移动平均
VAR1A赋值:VAR19的100日指数移动平均
VAR1B赋值:2*(VAR19-VAR1A)
VAR1C赋值:VAR1B的3乘幂*0.1+VAR1B的1乘幂
VAR1D赋值:最低价*最高价*开盘价*收盘价的开方的开方
VAR1E赋值:VAR1D*0.97的3日指数移动平均
VAR1F赋值:(最高价+最低价+收盘价)/3
VAR20赋值:(VAR1F-VAR1F的14日简单移动平均)/(0.015*VAR1F的14日平均绝对偏差)
VAR21赋值:VAR1E上穿最低价
输出选股买点:VAR10,画黄色
输出组合买:(VAR11+VAR13+VAR15+VAR17),画红色
输出组合卖:(VAR12+VAR14+VAR16+VAR18),画绿色
输出黑马线:如果VAR1B>0.1,返回VAR1C,否则返回0*1
输出黑马信号介入点:选股买点 AND VARF AND VARC AND VAR21 AND VAR4<0 AND VAR5<2 AND VAR6=0,COLORFFFF99
当满足条件VAR13时,在0.6位置书写文字,画红色
当满足条件组合买时,在组合买位置画1号图标
当满足条件组合卖时,在组合卖位置画9号图标
当满足条件黑马信号介入点>0时,在4.5位置书写文字,画红色
当满足条件选股买点>0时,在4.2位置画1号图标
当满足条件选股买点ANDVARFANDVARC时,在2.8位置书写文字,画洋红色
当满足条件VAR18时,在3位置书写文字,画绿色
当满足条件VAR20<-110AND选股买点>0时,在2位置书写文字,画黄色
当满足条件VAR17时,在1.3位置书写文字,COLORFF6600
当满足条件选股买点ANDVAR20<-100ANDVARFANDVARC>0时,在4.1位置书写文字,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/10BsdcvJqvLtY3_JdY-l_jw

看了该指标的人还看了:
牛气冲天指标    狂龙探底指标
一清二楚指标    无极神枪指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表