请选择 进入手机版|继续访问电脑版

成交量指标 通达信 副图 无未来函数 操盘控盘 成交量

[复制链接]

admin  管理员

发表于 3 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 无未来函数 操盘控盘 成交量 
成交量指标 通达信 副图 无未来函数 操盘控盘 成交量 炒股叉第10201张

成交量指标 通达信 副图 无未来函数 操盘控盘 成交量 炒股叉第10202张

[lywrap=通达信副图指标公式][lycode=tdx,true]虚拟成交:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虚拟成交,0,-1,-1),COLORC0C0C0;
量高:HHV(V,120)*0.382,COLORCYAN,DOTLINE;
量比:V/REF(V,1),NODRAW,COLOR0000FF;

STICKLINE(IF(V>REF(HHV(V,239),1),0.99,1)<1,V,0,-1,1),COLORDD00DD;
STICKLINE(IF(V>REF(HHV(V,239),1),0.99,1)<1 AND O>C,V,0,-1,0),COLORDD00DD;
STICKLINE(IF(V<REF(LLV(V,119),1),0.99,1)<1,V,0,-1,0),COLOR00DD00;
STICKLINE(IF(V<REF(LLV(V,239),1),0.99,1)<1,V,0,-1,0),COLORDD0000;
STICKLINE(V/REF(V,1)>2 ,0,V/2,2,0),COLORDDDDDD;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA),STICK;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(DIF>=DEA,0,VOL,3,-1),COLORRED;
STICKLINE(DIF<=DEA,0,VOL,3,-1),COLORGREEN;
STICKLINE(J>D,VOL/2,VOL,3,-1),COLORRED;
STICKLINE(J<D,VOL/2,VOL,3,-1),COLORGREEN;
{STICKLINE(((MACD<=0) AND (MACD > REF(MACD,1))),0,VOL/8,2,0),COLORMAGENTA;
STICKLINE((MACD>=0) AND MACD>REF(MACD,1),0,VOL/8,2,0),COLORRED;}
0.COLORLIBLUE;
MAC5:=SUM(C*V,5)/SUM(V,5);
红色持股:=C>MAC5  AND MACD>REF(MACD,1)AND DIF>=REF(DIF,1) AND J>REF(J,1) AND DIF>DEA AND J>D,COLOR0000CC;
STICKLINE(红色持股,0,VOL/4,2.8,0),COLORYELLOW;
STICKLINE(红色持股,0,VOL/4,1.5,0),COLOR11BBBB;
STICKLINE(红色持股,0,VOL/4,0.8,0),COLOR11DDDD;
STICKLINE(红色持股,0,VOL/4,0.1,0),COLOR11FFFF;[/lycode][lycode=tdx2,true]虚拟成交赋值:如果到最后交易的周期=1ANDPERIOD=5,返回成交量(手)*240/当前离开盘分钟数,否则返回无效数
当满足条件到最后交易的周期=1ANDPERIOD=5时,在虚拟成交和0位置之间画柱状线,宽度为-1,-1不为0则画空心柱.,COLORC0C0C0
输出量高:120日内成交量(手)的最高值*0.382,画青色,DOTLINE
输出量比:成交量(手)/1日前的成交量(手),NODRAW,COLOR0000FF
当满足条件如果成交量(手)>1日前的239日内成交量(手)的最高值,返回0.99,否则返回1<1时,在成交量(手)和0位置之间画柱状线,宽度为-1,1不为0则画空心柱.,COLORDD00DD
当满足条件如果成交量(手)>1日前的239日内成交量(手)的最高值,返回0.99,否则返回1<1ANDO>收盘价时,在成交量(手)和0位置之间画柱状线,宽度为-1,0不为0则画空心柱.,COLORDD00DD
当满足条件如果成交量(手)<1日前的119日内成交量(手)的最低值,返回0.99,否则返回1<1时,在成交量(手)和0位置之间画柱状线,宽度为-1,0不为0则画空心柱.,COLOR00DD00
当满足条件如果成交量(手)<1日前的239日内成交量(手)的最低值,返回0.99,否则返回1<1时,在成交量(手)和0位置之间画柱状线,宽度为-1,0不为0则画空心柱.,COLORDD0000
当满足条件成交量(手)/1日前的成交量(手)>2时,在0和成交量(手)/2位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORDDDDDD
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
MACD赋值:2*(DIF-DEA),STICK
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
当满足条件DIF>=DEA时,在0和成交量(手)位置之间画柱状线,宽度为3,-1不为0则画空心柱.,画红色
当满足条件DIF<=DEA时,在0和成交量(手)位置之间画柱状线,宽度为3,-1不为0则画空心柱.,画绿色
当满足条件J>D时,在成交量(手)/2和成交量(手)位置之间画柱状线,宽度为3,-1不为0则画空心柱.,画红色
当满足条件J<D时,在成交量(手)/2和成交量(手)位置之间画柱状线,宽度为3,-1不为0则画空心柱.,画绿色
0.画淡蓝色
MAC5赋值:收盘价*成交量(手)的5日累和/成交量(手)的5日累和
红色持股赋值:收盘价>MAC5  AND MACD>1日前的MACDAND DIF>=1日前的DIF AND J>1日前的J AND DIF>DEA AND J>D,COLOR0000CC
当满足条件红色持股时,在0和成交量(手)/4位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,画黄色
当满足条件红色持股时,在0和成交量(手)/4位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR11BBBB
当满足条件红色持股时,在0和成交量(手)/4位置之间画柱状线,宽度为0.8,0不为0则画空心柱.,COLOR11DDDD
当满足条件红色持股时,在0和成交量(手)/4位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR11FFFF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1ANjajklyADrZ7Oom8zo-fQ

看了该指标的人还看了:
趋势买卖控盘指标    超短线指标
线性回归线指标    金钱摸鬼指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表