请选择 进入手机版|继续访问电脑版

高价金钻指标寻龙诀 通达信 副图 波段 短线 买卖点

[复制链接]

admin  管理员

发表于 3 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
高价金钻指标寻龙诀 通达信 副图 波段 短线 买卖点 炒股叉第10199张

高价金钻指标寻龙诀 通达信 副图 波段 短线 买卖点 炒股叉第10200张

[lywrap=通达信副图指标公式][lycode=tdx,true]X1:=C<=REF(C,1) AND C<=O;
X2:=C<=REF(C,1) AND C>=O;
X3:=X1>0 OR X2>0;
XT0:=BARSLAST(X3);
X4:=MAX(REF(C,XT0),REF(O,XT0));
X5:=REF(V,XT0);
YT:=XT0>0 AND C>X4 AND V>X4*1.1;YS:=IF(YT>0 AND REF(YT,1)=0,10,0);
XA1:=(CLOSE/REF(CLOSE,1)>1.098 OR C/O>1.098) AND V<HHV(V,21);
X0:=NOT(NAMELIKE('S') OR NAMELIKE('*S')) AND VOL>1;
XA2:=BARSLAST(XA1);
XA31:=(L>=REF(L,XA2) AND (L-REF(L,XA2))<=0.03);
XA32:=(L>=REF(C,XA2)*0.99 AND (L-REF(C,XA2))<=0.03) ;
XA33:=(0>=REF(C,XA2)*0.99 AND (0-REF(C,XA2))<=0.03);
XA3:=XA31 OR XA32 OR XA33;
龙吟:YS>0 AND C>O AND C>REF(C,1) AND XA3 AND (XA2<21 OR COUNT(REF(XA2,1),21)>=1) AND X0,COLORYELLOW;
YB:=(C-REF(C,1))*100/REF(C,1)>=9.9 AND L=H;
XA4:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
XA5:=MA(XA4,5);
XA6:=PLOYLINE(CROSS(XA4,XA5),XA5);
XA7:=PLOYLINE(CROSS(XA5,XA4),XA4);
XA8:=COUNT(CROSS(XA4,XA5),XA6<REF(XA6,5) AND XA7>REF(XA7,5));
XA9:=CROSS(EMA(C,3),EMA(C,21));
XA10:=CROSS(MA(C,3),MA(C,21));
XA11:=((MAX(C,O)-MIN(C,O))/MIN(C,O))*100;
XA12:=(CLOSE/REF(CLOSE,1)<=0.96 OR CLOSE/OPEN<=0.96) AND (V/HHV(V,20)<=0.618 OR VOL/REF(VOL,1)<=0.5 OR VOL<HHV(VOL,5));
XA13:=(CLOSE/REF(CLOSE,1)>=1.04 OR CLOSE/OPEN>=1.04) AND (V/HHV(V,20)<=0.618 OR VOL/REF(VOL,1)<=0.5 OR VOL<HHV(VOL,5))
AND C>REF(C,1) AND HIGH>LOW;
XA14:=O>REF(C,1) AND C>REF(C,1) AND H>(H,1);
XA15:=(REF(C<REF(C,1) AND V/REF(V,1)<0.67,2) OR REF(XA12,2) OR REF(XA13,2)) AND REF(XA11<3,1) AND REF(V,1)<REF(V,2) AND XA14;
XA16:=O>REF(CLOSE,1) AND CLOSE>OPEN AND CLOSE>REF(O,1);
XA17:=(REF(XA12,1) AND XA16 AND XA13) OR XA15;
XA18:=(CROSS(C,MA(C,5)) AND CROSS(C,MA(C,13)) AND CROSS(C,MA(C,21)) OR CROSS(C,MA(C,34)))
AND MA(C,5)>REF(MA(C,5),1);
XA19:=MA(C,5)>REF(MA(C,5),1) AND MA(C,5)>MA(C,10) AND MA(C,10)>=MA(C,20);
XA20:=XA18 AND 龙吟 AND NOT(YB) AND (XA8 OR XA10 OR XA9 OR CROSS(C,MA(C,20)));
XA21:=龙吟 AND (V/REF(V,1)>1.5 OR REF(V,1)/REF(V,2)<0.67) AND (XA8 OR XA10 OR XA9 OR CROSS(C,MA(C,20))) AND NOT(O/REF(C,1)>1.06)
AND NOT(YB) AND X0,COLORMAGENTA;
XA22:=C>O AND C>REF(C,1) {AND V>REF(V,1)} AND XA17 AND (COUNT(龙吟,8)=1 OR XA18) AND NOT(YB)
AND (XA8 OR XA10 OR XA9 OR CROSS(C,MA(C,20))) AND X0,COLORGREEN;
龙跃:(XA20 OR XA21 OR XA22),COLORCYAN;

PX:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
妖龙刺:REF(龙吟,1) AND C>O AND O>REF(C,1) AND CROSS(C,PX),COLORMAGENTA;
DRAWICON(妖龙刺,0.4,9),COLORMAGENTA;[/lycode][lycode=tdx2,true]X1赋值:收盘价<=1日前的收盘价 AND 收盘价<=开盘价
X2赋值:收盘价<=1日前的收盘价 AND 收盘价>=开盘价
X3赋值:X1>0 OR X2>0
XT0赋值:上次X3距今天数
X4赋值:XT0日前的收盘价和XT0日前的开盘价的较大值
X5赋值:XT0日前的成交量(手)
YT赋值:XT0>0 AND 收盘价>X4 AND 成交量(手)>X4*1.1
YS赋值:如果YT>0ANDREF(YT,1)=0,返回10,否则返回0
XA1赋值:(收盘价/1日前的收盘价>1.098 OR 收盘价/开盘价>1.098) AND 成交量(手)<21日内成交量(手)的最高值
X0赋值:取反 AND 成交量(手)>1
XA2赋值:上次XA1距今天数
XA31赋值:(最低价>=XA2日前的最低价 AND (最低价-XA2日前的最低价)<=0.03)
XA32赋值:(最低价>=XA2日前的收盘价*0.99 AND (最低价-XA2日前的收盘价)<=0.03)
XA33赋值:(0>=XA2日前的收盘价*0.99 AND (0-XA2日前的收盘价)<=0.03)
XA3赋值:XA31 OR XA32 OR XA33
输出龙吟:YS>0 AND 收阳线AND 收盘价>1日前的收盘价 AND XA3 AND (XA2<21 OR 统计21日中满足1日前的XA2的天数>=1) AND X0,画黄色
YB赋值:(收盘价-1日前的收盘价)*100/1日前的收盘价>=9.9 AND 最低价=最高价
XA4赋值:((收盘价的5日简单移动平均/1日前的收盘价的5日简单移动平均-1)*100的反正切*180/3.14115926)
XA5赋值:XA4的5日简单移动平均
XA6赋值:当满足条件XA4上穿XA5时以XA5位置为顶点画折线连接
XA7赋值:当满足条件XA5上穿XA4时以XA4位置为顶点画折线连接
XA8赋值:统计XA6<5日前的XA6ANDXA7>5日前的XA7日中满足XA4上穿XA5的天数
XA9赋值:收盘价的3日指数移动平均上穿收盘价的21日指数移动平均
XA10赋值:收盘价的3日简单移动平均上穿收盘价的21日简单移动平均
XA11赋值:((收盘价和开盘价的较大值-收盘价和开盘价的较小值)/收盘价和开盘价的较小值)*100
XA12赋值:(收盘价/1日前的收盘价<=0.96 OR 收盘价/开盘价<=0.96) AND (成交量(手)/20日内成交量(手)的最高值<=0.618 OR 成交量(手)/1日前的成交量(手)<=0.5 OR 成交量(手)<5日内成交量(手)的最高值)
XA13赋值:(收盘价/1日前的收盘价>=1.04 OR 收盘价/开盘价>=1.04) AND (成交量(手)/20日内成交量(手)的最高值<=0.618 OR 成交量(手)/1日前的成交量(手)<=0.5 OR 成交量(手)<5日内成交量(手)的最高值)AND 收盘价>1日前的收盘价 AND 最高价>最低价
XA14赋值:开盘价>1日前的收盘价 AND 收盘价>1日前的收盘价 AND 最高价>(最高价,1)
XA15赋值:(2日前的收盘价<1日前的收盘价ANDV/1日前的成交量(手)<0.67 OR 2日前的XA12 OR 2日前的XA13) AND 1日前的XA11<3 AND 1日前的成交量(手)<2日前的成交量(手) AND XA14
XA16赋值:开盘价>1日前的收盘价 AND 收阳线ANDSE 收盘价>1日前的开盘价
XA17赋值:(1日前的XA12 AND XA16 AND XA13) OR XA15
XA18赋值:(收盘价上穿收盘价的5日简单移动平均 AND 收盘价上穿收盘价的13日简单移动平均 AND 收盘价上穿收盘价的21日简单移动平均 OR 收盘价上穿收盘价的34日简单移动平均)AND 收盘价的5日简单移动平均>1日前的收盘价的5日简单移动平均
XA19赋值:收盘价的5日简单移动平均>1日前的收盘价的5日简单移动平均 AND 收盘价的5日简单移动平均>收盘价的10日简单移动平均 AND 收盘价的10日简单移动平均>=收盘价的20日简单移动平均
XA20赋值:XA18 AND 龙吟 AND 取反 AND (XA8 OR XA10 OR XA9 OR 收盘价上穿收盘价的20日简单移动平均)
XA21赋值:龙吟 AND (成交量(手)/1日前的成交量(手)>1.5 OR 1日前的成交量(手)/2日前的成交量(手)<0.67) AND (XA8 OR XA10 OR XA9 OR 收盘价上穿收盘价的20日简单移动平均) AND 取反AND 取反 AND X0,画洋红色
XA22赋值:收阳线AND 收盘价>1日前的收盘价  AND XA17 AND (统计8日中满足龙吟的天数=1 OR XA18) AND 取反AND (XA8 OR XA10 OR XA9 OR 收盘价上穿收盘价的20日简单移动平均) AND X0,画绿色
输出龙跃:(XA20 OR XA21 OR XA22),画青色
PX赋值:(收盘价的3日简单移动平均+收盘价的6日简单移动平均+收盘价的12日简单移动平均+收盘价的24日简单移动平均)/4
输出妖龙刺:1日前的龙吟 AND 收阳线AND 开盘价>1日前的收盘价 AND 收盘价上穿PX,画洋红色
当满足条件妖龙刺时,在0.4位置画9号图标,画洋红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1zx-8QhaLh4eF9hNffr7kPw

看了该指标的人还看了:
多周期MACD支撑压力画线指标    超短线指标
低进高出指标    买卖提示指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表