请选择 进入手机版|继续访问电脑版

缠论108课公式最终版本 通达信 主图 缠论 波段 短线 买卖点 画线 操盘控盘

[复制链接]

admin  管理员

发表于 4 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 缠论 波段 短线 买卖点 画线 操盘控盘 
缠论108课公式最终版本 通达信 主图 缠论 波段 短线 买卖点 画线 操盘控盘 炒股叉第10181张

缠论108课公式最终版本 通达信 主图 缠论 波段 短线 买卖点 画线 操盘控盘 炒股叉第10182张

[lywrap=通达信主图指标公式][lycode=tdx,true]N:=(1,100,8);
KK:=(0,2,0);
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAAB:=(3*C+H+L+O)/6;
VVAR1:=(8*AAAB+7*REF(AAAB,1)+6*REF(AAAB,2)+5*REF(AAAB,3)+4*REF(AAAB,4)+3*REF(AAAB,5)+2*REF(AAAB,6)+REF(AAAB,8))/36;
VVAR6:=(LLV(VVAR1,2)+LLV(VVAR1,4)+LLV(VVAR1,6))/3;
短线:IF(KK=0, VVAR1, DRAWNULL),COLORWHITE;
中线:IF(KK=0,VVAR6, DRAWNULL),COLORYELLOW;
DRAWBAND(短线,RGB(200,10,10),中线,RGB(10,200,10));
DRAWKLINE(H,O,L,C);
下跌:IF(KK=0 AND VVAR1=VVAR6,VVAR6, DRAWNULL),COLORGREEN;
中:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
上轨:IF(KK=1,中+3*STD(中,10),DRAWNULL),COLOR000088,LINETHICK1;
IF(KK=1,2*MA(上轨,12)-MA(C,21),DRAWNULL),COLOR666666;
N1:=(1,100,10);
N2:=(1,100,10);
DISP:=(1,3,2);
K:=IF(PERIOD=5,1,{日}
IF(PERIOD=6,1,{周}
IF(PERIOD=7,1,{月}
IF(PERIOD=8,1,{多分钟}
IF(PERIOD=9,1,{多日}
IF(PERIOD=10,1,{季}
IF(PERIOD=11,2,{年}
IF(PERIOD=4,1,{60F}
IF(PERIOD=3,1,{30F}
IF(PERIOD=2,1,{15F}
IF(PERIOD=1,1{5F},1{1F})))))))))))/10;
P1:=PEAK(1,K*N1,1);
P2:=PEAK(1,K*N1,2);
WP1:=PEAKBARS(1,K*N1,1);
WP2:=PEAKBARS(1,K*N1,2);
T1:=TROUGH(2,K*N2,1);
T2:=TROUGH(2,K*N2,2);
WT1:=TROUGHBARS(2,K*N2,1);
WT2:=TROUGHBARS(2,K*N2,2);
TJ1:=P1>T1 AND P2>T2 ;
ZD:=MAX(T1,T2);
ZG:=MIN(P1,P2);
LL:=MIN(T1,T2);
HH:=MAX(P1,P2);
TJ2:=FILTER(ZG>ZD,2);
TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));
TJ4:=TJ1&&TJ2&&NOT(TJ3);
TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1))&&ZD<REF(ZD,REF(BARSLAST(TJ4),1));
TJ8:=TJ4&&NOT(TJ5 OR TJ6 OR TJ7);
ZSD:=IF(TJ8,ZD,DRAWNULL);
ZSG:=IF(TJ8,ZG,DRAWNULL);
ZSH:=IF(TJ8,HH,DRAWNULL);
ZSL:=IF(TJ8,LL,DRAWNULL);
STICKLINE(TJ8,ZSH,ZSL,0,-1),COLORMAGENTA;
STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),COLORMAGENTA;
DRAWTEXT(DISP=2,ZSH,'中枢'),COLORWHITE;
中枢高:PLOYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CIRCLEDOT,COLORLIRED;
中枢低:PLOYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CIRCLEDOT,COLORLIGREEN;
中枢最高:PLOYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,COLORRED;
中枢最低:PLOYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,COLORGREEN;
趋势高:PLOYLINE(DISP=3,ZIG(1,K*N1)),COLORLIBLUE;
趋势低:PLOYLINE(DISP=3,ZIG(2,K*N2)),COLORLIBLUE;
局部低点预选A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);
局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);
局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);
局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);
局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);
局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);
缺口判断:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));
距前高天:=BARSLAST(局部高点预选C=1);
距前低天:=BARSLAST(局部低点预选C=-1);
小值周期:=LOWRANGE(L);
大值周期:=TOPRANGE(H);
低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);
低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);
预判:=IF((距前低天<4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);
判断:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 预判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期
>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);
高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);
高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判断,距前低天)=1),1,0);
高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);
预判A:=IF((距前高天<4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);
判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 预判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);
低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-
1),-1,0);
低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);
距前高天A:=BARSLAST(高保留=1);
距前低天A:=BARSLAST(低保留=-1);
预判X:=IF((距前低天A<4 AND HHV(缺口判断,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);
判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 预判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);
高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);
高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判断,距前低天A)=1),1,0);
高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);
预判XA:=IF((距前高天A<4 AND HHV(缺口判断,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);
判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 预判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);
低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);
低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);
低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);
距前高天YA:=BARSLAST(高保留X=1);
距前低天YA:=BARSLAST(低保留X=-1);
预判YX:=IF((距前低天YA<4 AND HHV(缺口判断,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);
判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 预判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND
大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);
高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);
高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR
HHV(缺口判断,距前低天YA)=1),1,0);
高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);
预判YXA:=IF((距前高天YA<4 AND HHV(缺口判断,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);
判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 预判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1)
AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);
低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-
1,0);
低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判断,距前高天YA)=-1 OR
判断YXA=-1),-1,0);
低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);
AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));
极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);
局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)) CIRCLEDOT COLORYELLOW;
STICKLINE(C>REF(C,1)*1.099,C,O,2.7,0)COLORRED,LINETHICK2;
STICKLINE(C<REF(C,1)*0.901,C,O,2.7,0)COLORGREEN,LINETHICK2;
DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0),COLORRED;
DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0),COLORGREEN;
DD1:=BARSLAST(ABS(极点保留)!=1);
DRAWICON(极点保留=1,局部极点,2);
DRAWICON(极点保留=-1,局部极点,1);
{MA5:MA(CLOSE,5),COLORMAGENTA,LINETHICK1;
判:IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORCYAN,LINETHICK1;};
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1,O,C,1,0),COLORYELLOW;
TY:=C;{收盘价}
A1:=REF(TY,10)=HHV(TY,2*10+1);{10日前收盘价等于21天内最高价}
VB1:=FILTER(A1,10);{当出现A1条件时,过滤10天后连续出现的信号}
C1:=BACKSET(VB1,10+1);{将当前位置到11天前的位置设为1}
HD:=FILTER(C1,10);{将当前位置到10天后的位置设为1}
A2:=REF(TY,10)=LLV(TY,2*10+1);{10天前的收盘价等于21天内最低价}
VB2:=FILTER(A2,10); {过滤10天内连续出现的信号}
C2:=BACKSET(VB2,10+1);{将当前位置到11天前的位置设为1}
LD:=FILTER(C2,10);{当出现C2后,10天后的数据不予记录}
A:=REF(C,BARSLAST(HD));{设值上次高点位置}
B:=REF(C,BARSLAST(LD));{设值上次低点位置}
T11:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD);{上升波段回调不创新低没新高}
T21:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);{下降波段反弹不创新高没新低}
波峰:IF(T11,A,A),COLORFF00FF,POINTDOT;{符合T1条件,高位线为紫色点状线}
STICKLINE(T11,A,A,9,0),COLORFF00FF;{高位画横线}
波谷:IF(T21,B,B),COLOR80FF00,POINTDOT;{符合T2条件,高位线为绿色点状线}
STICKLINE(T21,B,B,9,0),COLOR80FF00;{低位画横线};[/lycode][lycode=tdx2,true]N赋值:(1,100,8)
KK赋值:(0,2,0)
赋值: (最高价 + 最低价 + 收盘价)/3
CCI1赋值:(TYP-TYP的6日简单移动平均)/(0.015*TYP的6日平均绝对偏差)
CCI2赋值:(TYP-TYP的10日简单移动平均)/(0.015*TYP的10日平均绝对偏差)
CCI3赋值:(TYP-TYP的20日简单移动平均)/(0.015*TYP的20日平均绝对偏差)
CCI4赋值:(TYP-TYP的30日简单移动平均)/(0.015*TYP的30日平均绝对偏差)
CCI5赋值:(TYP-TYP的60日简单移动平均)/(0.015*TYP的60日平均绝对偏差)
CCI赋值:CCI1+CCI2+CCI3+CCI4+CCI5
AAAB赋值:(3*收盘价+最高价+最低价+开盘价)/6
VVAR1赋值:(8*AAAB+7*1日前的AAAB+6*2日前的AAAB+5*3日前的AAAB+4*4日前的AAAB+3*5日前的AAAB+2*6日前的AAAB+8日前的AAAB)/36
VVAR6赋值:(2日内VVAR1的最低值+4日内VVAR1的最低值+6日内VVAR1的最低值)/3
输出短线:如果KK=0,返回VVAR1,否则返回无效数,画白色
输出中线:如果KK=0,返回VVAR6,否则返回无效数,画黄色
画带状线
K线
输出下跌:如果KK=0ANDVVAR1=VVAR6,返回VVAR6,否则返回无效数,画绿色
中赋值:(收盘价的3日简单移动平均+收盘价的6日简单移动平均+收盘价的12日简单移动平均+收盘价的24日简单移动平均)/4
输出上轨:如果KK=1,返回中+3*中的10日估算标准差,否则返回无效数,COLOR000088,线宽为1
如果KK=1,返回2*上轨的12日简单移动平均-收盘价的21日简单移动平均,否则返回无效数,COLOR666666
N1赋值:(1,100,10)
N2赋值:(1,100,10)
DISP赋值:(1,3,2)
K赋值:如果周期类型=5,返回1,否则返回如果周期类型=6,返回1,否则返回如果周期类型=7,返回1,否则返回如果周期类型=8,返回1,否则返回如果周期类型=9,返回1,否则返回如果周期类型=10,返回1,否则返回如果周期类型=11,返回2,否则返回如果周期类型=4,返回1,否则返回如果周期类型=3,返回1,否则返回如果周期类型=2,返回1,否则返回如果周期类型=1,返回1,否则返回1/10
P1赋值:最高价K*N1%之字转向的前1个波峰值
P2赋值:最高价K*N1%之字转向的前2个波峰值
WP1赋值:最高价K*N1%之字转向的前1个波峰位置
WP2赋值:最高价K*N1%之字转向的前2个波峰位置
T1赋值:最低价K*N2%之字转向的前1个波谷值
T2赋值:最低价K*N2%之字转向的前2个波谷值
WT1赋值:最低价K*N2%之字转向的前1个波谷位置
WT2赋值:最低价K*N2%之字转向的前2个波谷位置
TJ1赋值:P1>T1 AND P2>T2
ZD赋值:T1和T2的较大值
ZG赋值:P1和P2的较小值
LL赋值:T1和T2的较小值
HH赋值:P1和P2的较大值
TJ2赋值:ZG>ZD的2日过滤
TJ3赋值:ZG=上次TJ2距今天数日前的ZG OR ZD=上次TJ2距今天数日前的ZD
TJ4赋值:TJ1并且TJ2并且取反
TJ5赋值:ZD位于1日前的上次TJ4距今天数日前的ZD和1日前的上次TJ4距今天数日前的ZG之间
TJ6赋值:ZG位于1日前的上次TJ4距今天数日前的ZD和1日前的上次TJ4距今天数日前的ZG之间
TJ7赋值:ZG>1日前的上次TJ4距今天数日前的ZG并且ZD<1日前的上次TJ4距今天数日前的ZD
TJ8赋值:TJ4并且取反
ZSD赋值:如果TJ8,返回ZD,否则返回无效数
ZSG赋值:如果TJ8,返回ZG,否则返回无效数
ZSH赋值:如果TJ8,返回HH,否则返回无效数
ZSL赋值:如果TJ8,返回LL,否则返回无效数
当满足条件TJ8时,在ZSH和ZSL位置之间画柱状线,宽度为0,-1不为0则画空心柱.,画洋红色
当满足条件TJ8时,在ZSD和ZSG位置之间画柱状线,宽度为如果DISP=1,返回3,否则返回0,1不为0则画空心柱.,画洋红色
当满足条件DISP=2时,在ZSH位置书写文字,画白色
输出中枢高:当满足条件DISP=2时以上次TJ8距今天数日前的ZSD位置为顶点画折线连接,CIRCLEDOT,画淡红色
输出中枢低:当满足条件DISP=2时以上次TJ8距今天数日前的ZSG位置为顶点画折线连接,CIRCLEDOT,画淡绿色
输出中枢最高:当满足条件DISP=2时以上次TJ8距今天数日前的ZSH位置为顶点画折线连接,POINTDOT,画红色
输出中枢最低:当满足条件DISP=2时以上次TJ8距今天数日前的ZSL位置为顶点画折线连接,POINTDOT,画绿色
输出趋势高:当满足条件DISP=3时以最高价K*N1%的之字转向位置为顶点画折线连接,画淡蓝色
输出趋势低:当满足条件DISP=3时以最低价K*N2%的之字转向位置为顶点画折线连接,画淡蓝色
局部低点预选A赋值:若5日内最低价的最低值<1日前的4日内最低价的最低值则将最近4周期置为1
局部低点预选B赋值:若局部低点预选A=0ANDREF(局部低点预选A,1)=1则将最近2周期置为1
局部低点预选C赋值:如果局部低点预选B=1ANDREF(局部低点预选B,1)=0,返回-1,否则返回0
局部高点预选A赋值:若5日内最高价的最高值>1日前的4日内最高价的最高值则将最近4周期置为1
局部高点预选B赋值:若局部高点预选A=0ANDREF(局部高点预选A,1)=1则将最近2周期置为1
局部高点预选C赋值:如果局部高点预选B=1ANDREF(局部高点预选B,1)=0,返回1,否则返回0
缺口判断赋值:如果最低价>1日前的最高价,返回1,否则返回如果最高价<1日前的最低价,返回-1,否则返回0
距前高天赋值:上次局部高点预选C=1距今天数
距前低天赋值:上次局部低点预选C=-1距今天数
小值周期赋值:当前值是近最低价周期的最小值
大值周期赋值:当前值是近最高价周期的最大值
低保留AA赋值:如果局部低点预选C=-1ANDREF(距前高天,1)>1日前的距前低天ANDLLV(最低价,距前高天+1)<1日前的距前高天+1日内最低价的最低值,返回-1,否则返回0
低保留AB赋值:如果局部低点预选C=-1ANDREF(距前高天,1)<=1日前的距前低天AND(距前高天>=4ORLLV(缺口判断,距前高天)=-1ORLLV(最低价,距前低天+2)<1日前的距前低天+1日内最低价的最低值),返回-1,否则返回0
低保留S赋值:如果(低保留AA=-1OR低保留AB=-1)ANDL<距前高天+1日前的最高价,返回-1,否则返回0
预判赋值:如果(距前低天<4ANDHHV(缺口判断,距前低天)不等于1)ORREF(低保留S,距前低天)=0,返回1,否则返回0
判断赋值:如果局部高点预选C=1ANDREF(距前低天,1)<=1日前的距前高天AND预判=1AND大值周期>距前低天+1日前的小值周期AND大值周期>距前低天日前的小值周期AND大值周期>距前溉涨暗拇笾抵芷?返回天),否则返回1
高保留A赋值:如果局部高点预选C=1ANDREF(距前低天,1)>1日前的距前高天ANDHHV(最高价,距前低天+1)>1日前的距前低天+1日内最高价的最高值,返回1,否则返回0
高保留B赋值:如果局部高点预选C=1ANDREF(距前低天,1)<=1日前的距前高天ANDREF(低保留S,距前低天)=-1AND(距前低天>=4ORHHV(缺口判断,距前低天)=1),返回1,否则返回0
高保留赋值:如果(高保留A=1OR高保留B=1OR判断=1)ANDH>距前低天+1日前的最低价,返回1,否则返回0
预判A赋值:如果(距前高天<4ANDHHV(缺口判断,距前高天)不等于1)ORREF(高保留,距前高天)=0,返回1,否则返回0
判断A赋值:如果局部低点预选C=-1ANDREF(距前高天,1)<=1日前的距前低天AND预判A=1AND小值周期>距前高天+1日前的大值周期AND小值周期>距前高天日前的大值周期AND小值周期>距侨涨暗男≈抵芷?返回低天),否则返回-1
低保留A赋值:如果局部低点预选C=-1ANDREF(距前高天,1)>1日前的距前低天ANDLLV(最低价,距前高天+1)<1日前的距前高天+1日内最低价的最低值,返回-1,否则返回0
低保留B赋值:如果局部低点预选C=-1ANDREF(距前高天,1)<=1日前的距前低天AND(距前高天>=4ORLLV(缺口判断,距前高天)=-1OR判断A=-1),返回-1,否则返回0
低保留赋值:如果(低保留A=-1OR低保留B=-1)ANDL<距前高天+1日前的最高价,返回-1,否则返回0
距前高天A赋值:上次高保留=1距今天数
距前低天A赋值:上次低保留=-1距今天数
预判X赋值:如果(距前低天A<4ANDHHV(缺口判断,距前低天A)不等于1)ORREF(低保留,距前低天A)=0,返回1,否则返回0
判断X赋值:如果局部高点预选C=1ANDREF(距前低天A,1)<=1日前的距前高天AAND预判X=1AND大值周期>距前低天A+1日前的小值周期AND大值周期>距前低天A日前的小值周期AND大值周期>?日前的大值周期,返回嗲案咛霢),否则返回1
高保留XA赋值:如果局部高点预选C=1ANDREF(距前低天A,1)>1日前的距前高天AANDHHV(最高价,距前低天A+1)>1日前的距前低天A+1日内最高价的最高值,返回1,否则返回0
高保留XB赋值:如果局部高点预选C=1ANDREF(距前低天A,1)<=1日前的距前高天AANDREF(低保留,距前低天A)=-1AND(距前低天A>=4ORHHV(缺口判断,距前低天A)=1),返回1,否则返回0
高保留X赋值:如果(高保留XA=1OR高保留XB=1OR判断X=1)ANDH>距前低天A+1日前的最低价,返回1,否则返回0
预判XA赋值:如果(距前高天A<4ANDHHV(缺口判断,距前高天A)不等于1)ORREF(高保留XA,距前高天A)=0,返回1,否则返回0
判断XA赋值:如果局部低点预选C=-1ANDREF(距前高天A,1)<=1日前的距前低天AAND预判XA=1AND小值周期>距前高天A+1日前的大值周期AND小值周期>距前高天A日前的大值周期AND小值周期>?日前的小值周?返回,距前低天A),否则返回-1
低保留XA赋值:如果局部低点预选C=-1ANDREF(距前高天A,1)>1日前的距前低天AANDLLV(最低价,距前高天A+1)<1日前的距前高天A+1日内最低价的最低值,返回-1,否则返回0
低保留XB赋值:如果局部低点预选C=-1ANDREF(距前高天A,1)<=1日前的距前低天AAND(距前高天A>=4ORLLV(缺口判断,距前高天A)=-1OR判断XA=-1),返回-1,否则返回0
低保留X赋值:如果(低保留XA=-1OR低保留XB=-1)ANDL<距前高天A+1日前的最高价,返回-1,否则返回0
距前高天YA赋值:上次高保留X=1距今天数
距前低天YA赋值:上次低保留X=-1距今天数
预判YX赋值:如果(距前低天YA<4ANDHHV(缺口判断,距前低天YA)不等于1)ORREF(低保留X,距前低天YA)=0,返回1,否则返回0
判断YX赋值:如果局部高点预选C=1ANDREF(距前低天YA,1)<=1日前的距前高天YAAND预判YX=1AND大值周期>距前低天YA+1日前的小值周期AND大值周期>距前低天YA日前的小值周期AND大值周期>?日前的大值,返回芷?距前高天YA),否则返回1
高保留YXA赋值:如果局部高点预选C=1ANDREF(距前低天YA,1)>1日前的距前高天YAANDHHV(最高价,距前低天YA+1)>1日前的距前低天YA+1日内最高价的最高值,返回1,否则返回0
高保留YXB赋值:如果局部高点预选C=1ANDREF(距前低天YA,1)<=1日前的距前高天YAANDREF(低保留X,距前低天YA)=-1AND(距前低天YA>=4ORHHV(缺口判断,距前低天YA)=1),返回1,否则返回0
高保留YX赋值:如果(高保留YXA=1OR高保留YXB=1OR判断YX=1)ANDH>距前低天YA+1日前的最低价,返回1,否则返回0
预判YXA赋值:如果(距前高天YA<4ANDHHV(缺口判断,距前高天YA)不等于1)ORREF(高保留YXA,距前高天YA)=0,返回1,否则返回0
判断YXA赋值:如果局部低点预选C=-1ANDREF(距前高天YA,1)<=1日前的距前低天YAAND预判YXA=1AND小值周期>距前高天YA+1日前的大值周期AND小值周期>距前高天YA日前的大值周期AND小值周期>?日前的小,返回抵芷?距前低天YA),否则返回-1
低保留YXA赋值:如果局部低点预选C=-1ANDREF(距前高天YA,1)>1日前的距前低天YAANDLLV(最低价,距前高天YA+1)<1日前的距前高天YA+1日内最低价的最低值,返回-1,否则返回0
低保留YXB赋值:如果局部低点预选C=-1ANDREF(距前高天YA,1)<=1日前的距前低天YAAND(距前高天YA>=4ORLLV(缺口判断,距前高天YA)=-1OR判断YXA=-1),返回-1,否则返回0
低保留YX赋值:如果(低保留YXA=-1OR低保留YXB=-1)ANDL<距前高天YA+1日前的最高价,返回-1,否则返回0
AAAD赋值:如果高保留YX=1AND低保留YX=-1ANDH>1日前的距前高天YA+2日前的最高价,返回1,否则返回如果高保留YX=1AND低保留YX=-1ANDL<1日前的距前低天YA+2日前的最低价,返回-1,否则返回0
极点保留赋值:如果AAAD=0,返回高保留YX+低保留YX,否则返回AAAD
输出局部极点:如果极点保留=-1,返回最低价,否则返回如果极点保留=1,返回最高价,否则返回无效数 CIRCLEDOT 画黄色
当满足条件收盘价>1日前的收盘价*1.099时,在收盘价和开盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.画红色,线宽为2
当满足条件收盘价<1日前的收盘价*0.901时,在收盘价和开盘价位置之间画柱状线,宽度为2.7,0不为0则画空心柱.画绿色,线宽为2
当满足条件极点保留=-1时,在局部极点位置画直线起点,当满足条件极点保留=1时,在局部极点位置画直线终点,0表示是否延长.,画红色
当满足条件极点保留=1时,在局部极点位置画直线起点,当满足条件极点保留=-1时,在局部极点位置画直线终点,0表示是否延长.,画绿色
DD1赋值:上次极点保留的绝对值不等于1距今天数
当满足条件极点保留=1时,在局部极点位置画2号图标
当满足条件极点保留=-1时,在局部极点位置画1号图标

V2赋值:如果到最后交易的周期=1,返回成交量(手)*240/当前离开盘分钟数/1日前的成交量(手)-1,否则返回成交量(手)/1日前的成交量(手)-1
当满足条件V2>=1时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
TY赋值:收盘价
A1赋值:10日前的TY=2*10+1日内TY的最高值
VB1赋值:A1的10日过滤
C1赋值:若VB1则将最近10+1周期置为1
HD赋值:C1的10日过滤
A2赋值:10日前的TY=2*10+1日内TY的最低值
VB2赋值:A2的10日过滤
C2赋值:若VB2则将最近10+1周期置为1
LD赋值:C2的10日过滤
A赋值:上次HD距今天数日前的收盘价
B赋值:上次LD距今天数日前的收盘价
T11赋值:上次HD距今天数<上次LD距今天数 AND 取反
T21赋值:上次HD距今天数>上次LD距今天数 AND 取反
输出波峰:如果T11,返回A,否则返回A,COLORFF00FF,POINTDOT
当满足条件T11时,在A和A位置之间画柱状线,宽度为9,0不为0则画空心柱.,COLORFF00FF
输出波谷:如果T21,返回B,否则返回B,COLOR80FF00,POINTDOT
当满足条件T21时,在B和B位置之间画柱状线,宽度为9,0不为0则画空心柱.,COLOR80FF00[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1kKyyNQtZKee51uWu0-rQuA

看了该指标的人还看了:
牛气冲天指标    波段抄底指标
拾金图指标    绝对超底指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表