请选择 进入手机版|继续访问电脑版

财富地图指标 通达信 副图 波段 无未来函数 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-10-10 08:00:34 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
财富地图指标 通达信 副图 波段 无未来函数 短线 买卖点 炒股叉第10173张

财富地图指标 通达信 副图 波段 无未来函数 短线 买卖点 炒股叉第10174张

[lywrap=通达信副图指标公式][lycode=tdx,true]STICKLINE(C>0,0,100,15,0),COLOR7C221C;
P:50;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,2,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
AA:=IF(VAR9>100,VAR9-100,0);
BB:=HHV(HIGH,34);
CC:=EMA((VAR6-VAR8)/(BB-VAR8)*100,13);
气温:EMA(0.64*REF(CC,1)+0.333*CC,4);
DRAWBAND(气温,RGB(255,0,0),50,RGB(0,150,255));
DRAWTEXT(CROSS(气温,20),气温,'春↑'),COLORGREEN;
DRAWTEXT(CROSS(气温,40),气温,'夏↑'),COLORRED;
DRAWTEXT(CROSS(气温,70),气温,'秋↓'),COLORYELLOW;
DRAWTEXT(CROSS(70,气温),气温,'冬↓'),COLORWHITE;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
WEN:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
J1:=SMA(RSV1,3,1);J2:=SMA(J1,3,1);
W1:=SMA(RSV2,3,1);W2:=SMA(W1,3,1);
强弱界线:49,POINTDOT,LINETHICK3,COLOR9966CC;
见顶信号:100,COLORCCFF00;
出点准备: IF(CROSS(J2,J1) AND J2>85,70,100),LINETHICK2,COLOR00FF00;
趋势线: WEN,LINETHICK2;
买点准备:IF(趋势线<=10,30,0),LINETHICK2,COLORYELLOW;
G1:W1,LINETHICK2,COLORWHITE;
G2:W2,LINETHICK2,COLORCYAN;
STICKLINE(趋势线>88,100,趋势线,3,1),COLORGREEN;
STICKLINE(趋势线<=10,0,趋势线,3,1),COLORYELLOW;
STICKLINE(COUNT(趋势线<REF(趋势线,1) AND 趋势线<10,2)=2 ,0,20,3,0),COLORRED;
STICKLINE(CROSS(J2,J1) AND J2>85,100,80,3,0),COLORGREEN;
DRAWICON(CROSS(趋势线,49),趋势线,1);
DRAWICON(FILTER(CROSS(G2,G1) AND G2>81,10),G2*1.05,2);
DRAWTEXT(CROSS(趋势线,49),47,'转强'),COLORRED;
DRAWTEXT(CROSS(49,趋势线),52,'转弱'),COLORGREEN;[/lycode][lycode=tdx2,true]当满足条件收盘价>0时,在0和100位置之间画柱状线,宽度为15,0不为0则画空心柱.,COLOR7C221C
输出P:50
VAR1赋值:9日内最高价的最高值-9日内最低价的最低值
VAR2赋值:9日内最高价的最高值-收盘价
VAR3赋值:收盘价-9日内最低价的最低值
VAR4赋值:VAR2/VAR1*100-70
VAR5赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*100
VAR6赋值:(2*收盘价+最高价+最低价)/4
VAR7赋值:VAR3/VAR1*100的2日[1日权重]移动平均
VAR8赋值:34日内最低价的最低值
VAR9赋值:VAR7的3日[1日权重]移动平均-VAR4的9日[1日权重]移动平均
AA赋值:如果VAR9>100,返回VAR9-100,否则返回0
BB赋值:34日内最高价的最高值
CC赋值:(VAR6-VAR8)/(BB-VAR8)*100的13日指数移动平均
输出气温:0.64*1日前的CC+0.333*CC的4日指数移动平均
画带状线
当满足条件气温上穿20时,在气温位置书写文字,画绿色
当满足条件气温上穿40时,在气温位置书写文字,画红色
当满足条件气温上穿70时,在气温位置书写文字,画黄色
当满足条件70上穿气温时,在气温位置书写文字,画白色
RSV1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
RSV2赋值:(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100
WEN赋值:3*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
J1赋值:RSV1的3日[1日权重]移动平均
J2赋值:J1的3日[1日权重]移动平均
W1赋值:RSV2的3日[1日权重]移动平均
W2赋值:W1的3日[1日权重]移动平均
输出强弱界线:49,POINTDOT,线宽为3,COLOR9966CC
输出见顶信号:100,COLORCCFF00
输出出点准备: 如果J2上穿J1ANDJ2>85,返回70,否则返回100,线宽为2,COLOR00FF00
输出趋势线: WEN,线宽为2
输出买点准备:如果趋势线<=10,返回30,否则返回0,线宽为2,画黄色
输出G1:W1,线宽为2,画白色
输出G2:W2,线宽为2,画青色
当满足条件趋势线>88时,在100和趋势线位置之间画柱状线,宽度为3,1不为0则画空心柱.,画绿色
当满足条件趋势线<=10时,在0和趋势线位置之间画柱状线,宽度为3,1不为0则画空心柱.,画黄色
当满足条件统计2日中满足趋势线<1日前的趋势线AND趋势线<10的天数=2时,在0和20位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
当满足条件J2上穿J1ANDJ2>85时,在100和80位置之间画柱状线,宽度为3,0不为0则画空心柱.,画绿色
当满足条件趋势线上穿49时,在趋势线位置画1号图标
当满足条件G2上穿G1ANDG2>81的10日过滤时,在G2*1.05位置画2号图标
当满足条件趋势线上穿49时,在47位置书写文字,画红色
当满足条件49上穿趋势线时,在52位置书写文字,画绿色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1N67FBQVrwQ5yPQFgkblFgA

看了该指标的人还看了:
上攻启动指标    高抛低吸指标
OBV能量顶底指标    持股待涨指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表