请选择 进入手机版|继续访问电脑版

分时攻击力度指标 通达信 分时副图 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 5 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 分时副图 
二级分类: 买卖点 操盘控盘 
看力度捕捉涨停板
分时攻击力度指标 通达信 分时副图 买卖点 操盘控盘 炒股叉第10159张

分时攻击力度指标 通达信 分时副图 买卖点 操盘控盘 炒股叉第10160张

[lywrap=通达信分时副图指标公式][lycode=tdx,true]昨收:=DYNAINFO(3);
HH:=DYNAINFO(5);
LL:=DYNAINFO(6);
FK:=MAX(HH-昨收,昨收-LL)*0.1;
ZS:=昨收-FK*3.2;
Q1:=昨收-FK*3.22;
Q2:=昨收-1*FK*3.22;
Q3:=昨收-5*FK*3.2;
TJ:=FILTER(C,239)>0,NODRAW;
TJJ:=SUM(TJ,0),NODRAW;
TJA:=CONST(TJJ),NODRAW;
流通盘:CAPITAL*100/100000000,NODRAW;
资金流入:=SUM(IF(C>REF(C,1),V,0),FROMOPEN),STICK,COLORRED;
资金流出:=-SUM(IF(C<REF(C,1),V,0),FROMOPEN),STICK,COLOR00FF00;
资金出入:=资金流入+资金流出,COLORSTICK;
NN:=2400;
HD:=HHV(资金出入,NN);
LD:=LLV(资金出入,NN);
最高:=CONST(HD),NODRAW;
最低:=CONST(LD),NODRAW;
HLMAX:=最高;
HLMIN:=最低;
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
中间价轴:=(50-HLMN3)*HLMN2/HLMN4+HLMN1;
轴差:=最高-最低;
DRAWBAND(资金出入,RGB(150,0,150),0,RGB(0,100,0));
资金流量:资金出入,COLORFFFFFF,LINETHICK1;
资金比:资金出入/SUM(V,FROMOPEN)*100,COLOR00FFFF,LINETHICK1;
资金流量比:=IF(资金比>=0,(资金比+100)/2,100-ABS((资金比-100)/2));
攻击量:=((HSL*0.50+REF(HSL,1)*0.33)+(REF(HSL,2)*0.17))*SUM(C,FROMOPEN)/FROMOPEN;
攻击量A:=SUM(IF(C>REF(C,1),攻击量*V,0),FROMOPEN),COLOR0000FF,LINETHICK0;
攻击量B:=-SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),COLOR00FF00,LINETHICK0;
攻击流量:攻击量A+攻击量B,COLORSTICK;
NOTEXT攻击线:攻击流量,COLORYELLOW,LINETHICK1;
攻击比:攻击流量/SUM(V,FROMOPEN)*100,COLORRED,LINETHICK1;
资金攻击度:=IF(攻击比>=0,(攻击比+50),100-ABS((攻击比-50)));
{STICKLINE(资金流量A>0,资金流量A,0,1,0),COLOR0000FF;
STICKLINE(资金流量B<0,资金流量B,0,1,0),COLORFF0000;}
DRAWRECTREL(110,10,400,90,RGB(0,75,200));
DRAWRECTREL(110,10,250,90,RGB(0,250,50));
DRAWRECTREL(110,10,100+CONST(资金流量比*300/100),90,RGB(200,50,0));
DRAWTEXT_FIX(1,0.000,0.00,0,STRCAT(STRCAT('【资金流量比】',CON2STR(资金流量比,2)),'%买')),COLORYELLOW;
DRAWRECTREL(610,10,900,90,RGB(0,75,200));
DRAWRECTREL(610,10,750,90,RGB(0,250,50));
DRAWRECTREL(610,10,600+CONST(资金攻击度*300/100),90,RGB(175,50,0));
DRAWTEXT_FIX(1,0.500,0.00,0,STRCAT(STRCAT('【资金攻击度】',CON2STR(资金攻击度,2)),' %买')),COLORYELLOW;
量:=VOL,VOLSTICK;
五日量:=MA(量,5),COLORWHITE;
TT:=BARSCOUNT(C);{取得有效收盘价}
均价黄:=SUM(C*V,TT)/SUM(V,TT);{分时均线的取值}
量两步:=MA(V,5)>REF(MA(V,5),1) AND REF(MA(V,5),1)>REF(MA(V,5),2);
价两步:= C>=REF(C,1) AND REF(C,1)>REF(C,2);
价上岗量破5:=C>均价黄 AND V>MA(V,5);
量起爆:=V>=REF(V,1)*1;
价创新高:=C>=HHV(C,0);
量创新高:=V>=HHV(V,0);
对昨日涨幅:=(C/DYNAINFO(3)-1)*100<=1.50;{涨幅控制2个点以内}
每日一点:=量两步 AND 价两步 AND 价上岗量破5 AND 量起爆 AND 价创新高  AND 量创新高 AND 对昨日涨幅;
{计算收益、已爆分钟}
VV:=BARSSINCE(每日一点)+1;
首次起爆价:=REF(C,VV-1),NODRAW;
起爆收益:(DYNAINFO(7)-首次起爆价)/首次起爆价*100,NODRAW;
起爆时间:=REF(TIME/10000,VV),NODRAW;
已爆分钟:=VV-1,NODRAW;
{画出底线和红球}
首次起爆量:=REF(VOL,VV-1);
DRAWICON(已爆分钟>=2,最低,8);{出现8,至少已经确认2分钟了};
MMA30:=EMA(CLOSE,30);
强弱界定:=IF(PERIOD=0 ,EMA(CLOSE,900),DRAWNULL);
分时均价线:=SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK2;
BGTYU:=IF(DATE<=1150530,1,0);
GHYJKU:=BETWEEN((DCLOSE*BGTYU)/(SUM(AMOUNT,BARSCOUNT((DCLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BGTYU)))),1.05,0.95);
VBNH:=IF(GHYJKU=0,MA((DCLOSE*BGTYU),BARSCOUNT((DCLOSE*BGTYU))),(SUM(AMOUNT,BARSCOUNT((DCLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BGTYU)))));
二十☆:=EXPMA((DCLOSE/VBNH),20),COLORRED,LINETHICK1;
六十★:=EXPMA((DCLOSE/VBNH),60),COLORLIGREEN,LINETHICK1;
FAA:=BARSLAST(TIME=100000);
FCC:=REF(HHV(C,0),FAA+1);
FVV:=REF(HHV(V,0),FAA+1);
ZF:=FCC/DYNAINFO(3)<1.05;
XG1:=CROSS(C,FCC) AND V>FVV AND ZF,COLORWHITE;
FAA1:=BARSLAST(TIME=110000);
FCC1:=REF(HHV(C,0),FAA1+1);
FVV1:=REF(HHV(V,0),FAA1+1);
ZF1:=FCC1/DYNAINFO(3)<1.05;
XG2:=CROSS(C,FCC1)  AND V>FVV1 AND ZF1,COLORYELLOW;
突破:=XG1 OR XG2,COLORRED;
VT:=BARSSINCE(突破)+1;
首次突破价:=REF(C,VT-1),NODRAW;
突破收益:(DYNAINFO(7)-首次突破价)/首次突破价*100,NODRAW;
拉升量:=IF(C>REF(C,1),VOL,0);
昨拉升最高值:=CONST(FINDHIGH(拉升量,FROMOPEN,240,1)),LINETHICK1,COLORMAGENTA;
今拉升最高值:=CONST(REF(HHV(拉升量,FROMOPEN),0)),COLORYELLOW,NODRAW;
攻击力度:=今拉升最高值/昨拉升最高值,NODRAW;
STICKLINE(FILTER(CROSS(拉升量,昨拉升最高值),30),最低+轴差*0.80,最低,1,0),COLORCYAN;
STICKLINE(每日一点,最低+轴差*0.65,最低,1,0),COLORMAGENTA;
STICKLINE(突破,最低+轴差*0.50,最低,1,0),COLORWHITE;
STICKLINE(CROSS(EXPMA((DCLOSE/VBNH),60),EXPMA((DCLOSE/VBNH),120)),最低+轴差*0.35,最低,1,0),COLORYELLOW;
STICKLINE(FILTER(BARSLAST(C<MIN(MMA30,强弱界定))<=20 AND CROSS(C,MAX(MMA30,强弱界定)),30),最低,最低+轴差*0.2,1,0),COLORGREEN;
DRAWICON(FILTER(CROSS(拉升量,昨拉升最高值),30),最低+轴差*0.80,1);
DRAWICON(每日一点,最低+轴差*0.65,1);
DRAWICON(突破,最低+轴差*0.50,17);
DRAWICON(FILTER(BARSLAST(C<MIN(MMA30,强弱界定))<=20 AND CROSS(C,MAX(MMA30,强弱界定)),30),最低+轴差*0.2,9);
DRAWTEXT(FILTER(CROSS(拉升量,昨拉升最高值),30),最低+轴差*0.80,'☆攻击'),COLORCYAN;
DRAWTEXT(每日一点,最低+轴差*0.65,'∠起爆'),COLORGREEN;
DRAWNUMBER(每日一点,最低+轴差*0.55,首次起爆价),COLORGREEN;
{DRAWTEXT(CURRBARSCOUNT=160,HHV(V,60)*0.9,'20线上行+日价K线突破+日K线量起爆更好+估换手小于10%时更稳定'),COLORGREEN;};
DRAWTEXT(突破,最低+轴差*0.50,'分时突破'),COLORWHITE;
DRAWNUMBER(突破,最低+轴差*0.40,首次突破价),COLORWHITE;
DRAWTEXT(CROSS(EXPMA((DCLOSE/VBNH),60),EXPMA((DCLOSE/VBNH),120)),最低+轴差*0.35,'★迹'),COLORYELLOW;
{DRAWICON(CROSS(EXPMA((DCLOSE/VBNH),20),1.01),MAX(资金流量,攻击流量),18);}
DRAWTEXT(FILTER(BARSLAST(C<MIN(MMA30,强弱界定))<=20 AND CROSS(C,MAX(MMA30,强弱界定)),30),最低+轴差*0.2,'关注'),COLORRED;[/lycode][lycode=tdx2,true]昨收赋值:前收盘价
HH赋值:最高价
LL赋值:最低价
FK赋值:HH-昨收和昨收-LL的较大值*0.1
ZS赋值:昨收-FK*3.2
Q1赋值:昨收-FK*3.22
Q2赋值:昨收-1*FK*3.22
Q3赋值:昨收-5*FK*3.2
TJ赋值:收盘价的239日过滤>0,NODRAW
TJJ赋值:TJ的历史累和,NODRAW
TJA赋值:TJJ的最后一日取值设为常数,NODRAW
输出流通盘:当前流通股本(手)*100/100000000,NODRAW
资金流入赋值:如果收盘价>1日前的收盘价,返回成交量(手),否则返回0的当前离开盘分钟数日累和,STICK,画红色
资金流出赋值:-如果收盘价<1日前的收盘价,返回成交量(手),否则返回0的当前离开盘分钟数日累和,STICK,COLOR00FF00
资金出入赋值:资金流入+资金流出,COLORSTICK
NN赋值:2400
HD赋值:NN日内资金出入的最高值
LD赋值:NN日内资金出入的最低值
最高赋值:HD的最后一日取值设为常数,NODRAW
最低赋值:LD的最后一日取值设为常数,NODRAW
HLMAX赋值:最高
HLMIN赋值:最低
HLMN1赋值:(HLMAX+HLMIN)/2
HLMN2赋值:HLMAX-HLMIN
HLMN3赋值:(100-0)/2*1.3
HLMN4赋值:(100-0)/1*1.3
中间价轴赋值:(50-HLMN3)*HLMN2/HLMN4+HLMN1
轴差赋值:最高-最低
画带状线
输出资金流量:资金出入,COLORFFFFFF,线宽为1
输出资金比:资金出入/成交量(手)的当前离开盘分钟数日累和*100,COLOR00FFFF,线宽为1
资金流量比赋值:如果资金比>=0,返回(资金比+100)/2,否则返回100-(资金比-100)/2的绝对值
攻击量赋值:((换手线*0.50+1日前的换手线*0.33)+(2日前的换手线*0.17))*收盘价的当前离开盘分钟数日累和/当前离开盘分钟数
攻击量A赋值:如果收盘价>1日前的收盘价,返回攻击量*成交量(手),否则返回0的当前离开盘分钟数日累和,COLOR0000FF,线宽为0
攻击量B赋值:-如果收盘价<1日前的收盘价,返回攻击量*成交量(手),否则返回0的当前离开盘分钟数日累和,COLOR00FF00,线宽为0
输出攻击流量:攻击量A+攻击量B,COLORSTICK
输出NOTEXT攻击线:攻击流量,画黄色,线宽为1
输出攻击比:攻击流量/成交量(手)的当前离开盘分钟数日累和*100,画红色,线宽为1
资金攻击度赋值:如果攻击比>=0,返回(攻击比+50),否则返回100-(攻击比-50)的绝对值
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
当满足条件1时,在横轴0.000纵轴0.00位置书写文字,画黄色
相对位置上画矩形
相对位置上画矩形
相对位置上画矩形
当满足条件1时,在横轴0.500纵轴0.00位置书写文字,画黄色
量赋值:成交量(手),VOLSTICK
五日量赋值:量的5日简单移动平均,画白色
TT赋值:收盘价的有效数据周期数
均价黄赋值:收盘价*成交量(手)的TT日累和/成交量(手)的TT日累和
量两步赋值:成交量(手)的5日简单移动平均>1日前的成交量(手)的5日简单移动平均 AND 1日前的成交量(手)的5日简单移动平均>2日前的成交量(手)的5日简单移动平均
价两步赋值: 收盘价>=1日前的收盘价 AND 1日前的收盘价>2日前的收盘价
价上岗量破5赋值:收盘价>均价黄 AND 成交量(手)>成交量(手)的5日简单移动平均
量起爆赋值:成交量(手)>=1日前的成交量(手)*1
价创新高赋值:收盘价>=0日内收盘价的最高值
量创新高赋值:成交量(手)>=0日内成交量(手)的最高值
对昨日涨幅赋值:(收盘价/前收盘价-1)*100<=1.50
每日一点赋值:量两步 AND 价两步 AND 价上岗量破5 AND 量起爆 AND 价创新高  AND 量创新高 AND 对昨日涨幅
VV赋值:首次每日一点距今天数+1
首次起爆价赋值:VV-1日前的收盘价,NODRAW
输出起爆收益:(现价-首次起爆价)/首次起爆价*100,NODRAW
起爆时间赋值:VV日前的时间(时分)/10000,NODRAW
已爆分钟赋值:VV-1,NODRAW
首次起爆量赋值:VV-1日前的成交量(手)
当满足条件已爆分钟>=2时,在最低位置画8号图标

MMA30赋值:收盘价的30日指数移动平均
强弱界定赋值:如果周期类型=0,返回收盘价的900日指数移动平均,否则返回无效数
分时均价线赋值:收盘价*成交量(手)的240日累和/成交量(手)的240日累和,画黄色,线宽为2
BGTYU赋值:如果日期<=1150530,返回1,否则返回0
GHYJKU赋值:(不定周期收盘价*BGTYU)/(成交额(元)的(不定周期收盘价*BGTYU)的有效数据周期数日累和/成交量(手)*100的(不定周期收盘价*BGTYU)的有效数据周期数日累和)位于1.05和0.95之间
VBNH赋值:如果GHYJKU=0,返回(不定周期收盘价*BGTYU)的(不定周期收盘价*BGTYU)的有效数据周期数日简单移动平均,否则返回(成交额(元)的(不定周期收盘价*BGTYU)的有效数据周期数日累和/成交量(手)*100的(不定周期收盘价*BGTYU)的有效数据周期数日累和)
二十☆赋值:(不定周期收盘价/VBNH)的20日指数移动平均,画红色,线宽为1
六十★赋值:(不定周期收盘价/VBNH)的60日指数移动平均,画淡绿色,线宽为1
FAA赋值:上次时间(时分)=100000距今天数
FCC赋值:FAA+1日前的0日内收盘价的最高值
FVV赋值:FAA+1日前的0日内成交量(手)的最高值
ZF赋值:FCC/前收盘价<1.05
XG1赋值:收盘价上穿FCC AND 成交量(手)>FVV AND ZF,画白色
FAA1赋值:上次时间(时分)=110000距今天数
FCC1赋值:FAA1+1日前的0日内收盘价的最高值
FVV1赋值:FAA1+1日前的0日内成交量(手)的最高值
ZF1赋值:FCC1/前收盘价<1.05
XG2赋值:收盘价上穿FCC1  AND 成交量(手)>FVV1 AND ZF1,画黄色
突破赋值:XG1 OR XG2,画红色
VT赋值:首次突破距今天数+1
首次突破价赋值:VT-1日前的收盘价,NODRAW
输出突破收益:(现价-首次突破价)/首次突破价*100,NODRAW
拉升量赋值:如果收盘价>1日前的收盘价,返回成交量(手),否则返回0
昨拉升最高值赋值:拉升量在当前离开盘分钟数日前的240天内第1个最高价的最后一日取值设为常数,线宽为1,画洋红色
今拉升最高值赋值:0日前的当前离开盘分钟数日内拉升量的最高值的最后一日取值设为常数,画黄色,NODRAW
攻击力度赋值:今拉升最高值/昨拉升最高值,NODRAW
当满足条件拉升量上穿昨拉升最高值的30日过滤时,在最低+轴差*0.80和最低位置之间画柱状线,宽度为1,0不为0则画空心柱.,画青色
当满足条件每日一点时,在最低+轴差*0.65和最低位置之间画柱状线,宽度为1,0不为0则画空心柱.,画洋红色
当满足条件突破时,在最低+轴差*0.50和最低位置之间画柱状线,宽度为1,0不为0则画空心柱.,画白色
当满足条件(不定周期收盘价/VBNH)的60日指数移动平均上穿(不定周期收盘价/VBNH)的120日指数移动平均时,在最低+轴差*0.35和最低位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
当满足条件上次收盘价<MMA30和强弱界定的较小值距今天数<=20ANDCROSS(收盘价,MMA30和强弱界定的较大值)的30日过滤时,在最低和最低+轴差*0.2位置之间画柱状线,宽度为1,0不为0则画空心柱.,画绿色
当满足条件拉升量上穿昨拉升最高值的30日过滤时,在最低+轴差*0.80位置画1号图标
当满足条件每日一点时,在最低+轴差*0.65位置画1号图标
当满足条件突破时,在最低+轴差*0.50位置画17号图标
当满足条件上次收盘价<MMA30和强弱界定的较小值距今天数<=20ANDCROSS(收盘价,MMA30和强弱界定的较大值)的30日过滤时,在最低+轴差*0.2位置画9号图标
当满足条件拉升量上穿昨拉升最高值的30日过滤时,在最低+轴差*0.80位置书写文字,画青色
当满足条件每日一点时,在最低+轴差*0.65位置书写文字,画绿色
当满足条件每日一点时,在最低+轴差*0.55位置书写数字,画绿色

当满足条件突破时,在最低+轴差*0.50位置书写文字,画白色
当满足条件突破时,在最低+轴差*0.40位置书写数字,画白色
当满足条件(不定周期收盘价/VBNH)的60日指数移动平均上穿(不定周期收盘价/VBNH)的120日指数移动平均时,在最低+轴差*0.35位置书写文字,画黄色
当满足条件上次收盘价<MMA30和强弱界定的较小值距今天数<=20ANDCROSS(收盘价,MMA30和强弱界定的较大值)的30日过滤时,在最低+轴差*0.2位置书写文字,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1X-5jfoSkT4oO6iTgXto_0A

看了该指标的人还看了:
黄托底指标    买卖提示指标
紫黄同现必涨指标    精准抄底指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表