请选择 进入手机版|继续访问电脑版

均衡加仓买线指标 通达信 主图 波段 无未来函数 短线 买卖点 趋势 操盘控盘

[复制链接]

admin  管理员

发表于 6 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 趋势 操盘控盘 
均衡加仓买线指标 通达信 主图 波段 无未来函数 短线 买卖点 趋势 操盘控盘 炒股叉第10155张

均衡加仓买线指标 通达信 主图 波段 无未来函数 短线 买卖点 趋势 操盘控盘 炒股叉第10156张

[lywrap=通达信主图指标公式][lycode=tdx,true]N:=8;{N:5,30,13;参数N,短线选8,中线选13,长线选21;}
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA60:=MA(CLOSE,60);
MA120:=MA(CLOSE,120);
{彩带}
DRAWBAND(MA60,RGB(86,0,0),MA120,RGB(0,86,0));
DRAWBAND(MA5,RGB(128,0,128),MA10,RGB(20,92,100));
高山:HHV(MA(H,N),N),COLORRED,LINETHICK2;
流水:MA(H,N),COLORFFFFFF,LINETHICK2;
出水:=IF(C>HHV(MA(H,N),8) AND HHV(MA(H,N),8)>MA(H,N),1,0);
回踩:=IF((CROSS(MA(H,N),L) OR CROSS(MA(H,N)*1.01,C))AND BARSLAST(出水)<=5,1,0);
STICKLINE(出水,(C+O)/2,(C+O)/2,3,0),COLORFF00FF;
STICKLINE(出水,H,L,0,0),COLORFF00FF;
DRAWTEXT(回踩,L, '↑'),COLORFFFFFF;
HHV(流水,2),COLOR00FF00;
HHV(流水,3),COLOR00FF00;
HHV(流水,4),COLOR00FF00;
HHV(流水,5),COLOR00FF00;
HHV(流水,6),COLOR00FF00;
HHV(流水,7),COLOR00FF00;
HHV(流水,8),COLOR00FF00;
HHV(MA(H,N),N),COLORRED,LINETHICK2;
空:=EMA(C,5);
均衡:=EMA(空,5);
中轨:=HHV(MA(H,13),13);
趋势:=LLV(MA(H,13),1);
VAR1R:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2R:=REF(VAR1R,1);
VAR3R:=SMA(MAX(VAR1R-VAR2R,0),10,1)/SMA(ABS(VAR1R-VAR2R),10,1)*100;
VAR4R:=FILTER(IF(COUNT(VAR3R<20,5)>=1 AND COUNT(VAR1R=LLV(VAR1R,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0),5);
DRAWICON(VAR4R,LOW,1);
VAR5R:=FILTER(均衡>REF(均衡,1)AND 中轨<REF(中轨,1)AND C>REF(C,1),11);
DRAWTEXT(VAR5R,LOW*0.985,'加仓'),COLORYELLOW;
DRAWTEXT(VAR5R,LOW*0.995,'^' ),COLORYELLOW;
VAR6R:=REF(CLOSE,1);
VAR7R:=SMA(MAX(CLOSE-VAR6R,0),6,1)/SMA(ABS(CLOSE-VAR6R),6,1)*100;
DRAWTEXT(CROSS(84,VAR7R),H*1.035,'减仓'),COLOR00FF00 ;
DRAWTEXT(CROSS(84,VAR7R),H*1.015,'◇' ),COLOR00FF00;
买线:=EMA(C,2);
操盘线:(MA(C,30)+MA(C,72))/2,COLORYELLOW,LINETHICK2;
趋势线:EMA(EMA(EMA(EMA(CLOSE,2),2),5),5),LINETHICK2,COLORFFFF00;
{生命线:EMA(CLOSE,60),COLORRED,LINETHICK2;}
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
STICKLINE(买线>=卖线,LOW,HIGH,0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,3.2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,3.2,1),COLORGREEN;
STICKLINE(BU,OPEN,CLOSE,3.2,0),COLORYELLOW;
STICKLINE(SEL,OPEN,CLOSE,3.2,0),COLORBLUE;[/lycode][lycode=tdx2,true]N赋值:8
MA5赋值:收盘价的5日简单移动平均
MA10赋值:收盘价的10日简单移动平均
MA20赋值:收盘价的20日简单移动平均
MA60赋值:收盘价的60日简单移动平均
MA120赋值:收盘价的120日简单移动平均
画带状线
画带状线
输出高山:N日内最高价的N日简单移动平均的最高值,画红色,线宽为2
输出流水:最高价的N日简单移动平均,COLORFFFFFF,线宽为2
出水赋值:如果收盘价>8日内最高价的N日简单移动平均的最高值ANDHHV(最高价的N日简单移动平均,8)>最高价的N日简单移动平均,返回1,否则返回0
回踩赋值:如果(最高价的N日简单移动平均上穿最低价ORCROSS(最高价的N日简单移动平均*1.01,收盘价))ANDBARSLAST(出水)<=5,返回1,否则返回0
当满足条件出水时,在(收盘价+开盘价)/2和(收盘价+开盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF00FF
当满足条件出水时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFF00FF
当满足条件回踩时,在最低价位置书写文字,COLORFFFFFF
2日内流水的最高值,COLOR00FF00
3日内流水的最高值,COLOR00FF00
4日内流水的最高值,COLOR00FF00
5日内流水的最高值,COLOR00FF00
6日内流水的最高值,COLOR00FF00
7日内流水的最高值,COLOR00FF00
8日内流水的最高值,COLOR00FF00
N日内最高价的N日简单移动平均的最高值,画红色,线宽为2
空赋值:收盘价的5日指数移动平均
均衡赋值:空的5日指数移动平均
中轨赋值:13日内最高价的13日简单移动平均的最高值
趋势赋值:1日内最高价的13日简单移动平均的最低值
VAR1R赋值:(最高价+最低价+开盘价+2*收盘价)/5
VAR2R赋值:1日前的VAR1R
VAR3R赋值:VAR1R-VAR2R和0的较大值的10日[1日权重]移动平均/VAR1R-VAR2R的绝对值的10日[1日权重]移动平均*100
VAR4R赋值:如果统计5日中满足VAR3R<20的天数>=1ANDCOUNT(VAR1R=10日内VAR1R的最低值,10)>=1ANDCLOSE>=开盘价*1.038ANDVOL>成交量(手)的5日简单移动平均*1.2,返回1,否则返回0的5日过滤
当满足条件VAR4R时,在最低价位置画1号图标
VAR5R赋值:均衡>1日前的均衡AND中轨<1日前的中轨ANDC>1日前的收盘价的11日过滤
当满足条件VAR5R时,在最低价*0.985位置书写文字,画黄色
当满足条件VAR5R时,在最低价*0.995位置书写文字,画黄色
VAR6R赋值:1日前的收盘价
VAR7R赋值:收盘价-VAR6R和0的较大值的6日[1日权重]移动平均/收盘价-VAR6R的绝对值的6日[1日权重]移动平均*100
当满足条件84上穿VAR7R时,在最高价*1.035位置书写文字,COLOR00FF00
当满足条件84上穿VAR7R时,在最高价*1.015位置书写文字,COLOR00FF00
买线赋值:收盘价的2日指数移动平均
输出操盘线:(收盘价的30日简单移动平均+收盘价的72日简单移动平均)/2,画黄色,线宽为2
输出趋势线:收盘价的2日指数移动平均的2日指数移动平均的5日指数移动平均的5日指数移动平均,线宽为2,COLORFFFF00
卖线赋值:收盘价的21日线性回归斜率*20+收盘价的42日指数移动平均
BU赋值:买线上穿卖线
SEL赋值:卖线上穿买线
当满足条件买线>=卖线时,在最低价和最高价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画红色
当满足条件买线>=卖线时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,1不为0则画空心柱.,画红色
当满足条件买线<卖线时,在最低价和最高价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画绿色
当满足条件买线<卖线时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,1不为0则画空心柱.,画绿色
当满足条件BU时,在开盘价和收盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,画黄色
当满足条件SEL时,在开盘价和收盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,画蓝色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1aasxkjdIm0uyd_vX3xHwWg

看了该指标的人还看了:
60日价值中枢指标    超跌阻击指标
建仓启动指标    买卖点指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表