请选择 进入手机版|继续访问电脑版

抄底王指标 通达信 主图 波段 短线 买卖点 抄底逃顶 画线 压力支撑

[复制链接]

admin  管理员

发表于 2018-10-9 08:00:11 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 抄底逃顶 画线 压力支撑 
抄底王指标 通达信 主图 波段 短线 买卖点 抄底逃顶 画线 压力支撑 炒股叉第10151张

抄底王指标 通达信 主图 波段 短线 买卖点 抄底逃顶 画线 压力支撑 炒股叉第10152张

[lywrap=通达信公式][lycode=tdx,true]M1:=5;
M2:=10;
M3:=20;
M4:=30;
M5:=60;
N:=80;
N1:=14;
M:=3;
黄金柱B:=V/REF(V,1)>=2.0;
K1B:=SUMBARS(黄金柱B,1) ;
K2B:=SUMBARS(黄金柱B,2);
K3B:=SUMBARS(黄金柱B,3);
K4B:=SUMBARS(黄金柱B,4);
K5B:=SUMBARS(黄金柱B,5);
K6B:=SUMBARS(黄金柱B,6);
K7B:=SUMBARS(黄金柱B,7);
K8B:=SUMBARS(黄金柱B,8);
K9B:=SUMBARS(黄金柱B,9);
K10B:=SUMBARS(黄金柱B,10);
AABB:STICKLINE(K1B,REFV(L,K1B-1)*1.002,REFV(L,K1B-1),2,0),COLORYELLOW;
T60B:=V=HHV(V,60);
T100B:=V=HHV(V,100);
T2B:=V/REF(VOL,1)>=3;
T3B:=REF(C,1)/REF( O,1)<3;
MA5:=MA(CLOSE,M1),LINETHICK1,COLORYELLOW;
MA10:=MA(CLOSE,M2),LINETHICK1,COLORWHITE;
MA20:=MA(CLOSE,M3),LINETHICK1,COLORYELLOW;
稳健操盘线:MA(CLOSE,M4),POINTDOT,COLORRED;
MA60:=MA(CLOSE,M5),POINTDOT,LINETHICK1,COLORGREEN;
TR1:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N1,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N1,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N1,1);
PDI:=DMP*100/TR1,COLORRED;
MDI:=DMM*100/TR1,COLORGREEN;
ADX:=SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N1,1),COLORYELLOW;
阶段线1:=16;
阶段线2:=30;
DMI1:=PDI>MDI AND ADX>=30;
DMI2:=PDI<MDI AND ADX>=30;
DMI3:=PDI>MDI AND 16<ADX<30;
DMI4:=PDI<MDI AND 16<ADX<30;
DMI5:=ADX<=16 AND (PDI>MDI OR PDI<MDI);
DMI6:=ADX>60;
ZT:=C/REF(C,1)>1.097;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
STICKLINE(ZT,O,C,3,0),COLORRED;
DRAWTEXT(ZT,L*0.98,' '),COLORF00FF0;
VARZT:=BARSLAST(C/REF(C,1)>1.097);
{涨跌停显示}
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,3,0),COLORRED;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,3,0),COLORGREEN;
VAR111:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买:=IF(CLOSE>OPEN,VAR111*(HIGH-LOW),IF(CLOSE<OPEN,VAR111*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED;
卖:=IF(CLOSE>OPEN,0-VAR111*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR111*(HIGH-LOW),0-VOL/2)),COLOR00FF00 ;
买卖差:=(买+卖);
买卖比:=ABS(买/卖);
水平面:=MA(CLOSE,89),COLORFF00FF;
BBI:=(MA(CLOSE,M1)+MA(CLOSE,M2)+MA(CLOSE,M3)+MA(CLOSE,M4))/4;
MA1:=MA(CLOSE,24),COLOR00E300,LINETHICK1;
V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
MA13:=MA(CLOSE,13);
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
A1:=MIN(O,C);
B1:=ABS(O-C);
T1:=FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
T2:=COUNT(CROSS(BBI,3),3)=1 AND CROSS(C,BBI);

T12:=V2>=1;
T0:=BARSLAST(T12);
L1:=REF(L,T0);
H1:=REF(H,T0);
L11:=MIN(REF(L,1),L);
L10:=MIN(L11,REF(L,2));
L21:=MAX(REF(L,1),L);
L20:=MAX(L21,REF(L,2));
T111:=(REF(V2>=1,3) OR REF(V2>=1,2) OR REF(V2>=1,1)) AND
((L10>L1 AND L20>H1) OR (L11>L1 AND L21>H1));
T11:=T111 AND REF(T111,1)=0;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2X:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
A1XX:=CROSS(MA(C,1),MA(C,3));
XG:=A1XX;
VAR1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
A10:=CROSS(控盘,0);
无庄控盘:=IF(控盘<0,控盘,0),COLORGRAY,NODRAW;
短线:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*20,LINETHICK0,COLORWHITE;
中线:=(CLOSE-MA(CLOSE,4))/MA(CLOSE,4)*20,LINETHICK0,COLORYELLOW;
红柱:=SMA(短线,3,1),LINETHICK0,COLORFF00FF;
绿柱:=SMA(中线,3,1),COLORSTICK,COLOR00FF00;
开始控盘:=IF(A10,5,0),LINETHICK1,COLORWHITE;
有庄控盘:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
VAR2:=100*WINNER(CLOSE*0.95);
高度控盘:=IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
主力出货:=IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;
DIF1:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA1:=EMA(DIF1,9);
{柱状线}
AAA1:=(DIF1-DEA1)*2*60;
买入线:=10;
绝密:=AAA1-REF(AAA1,1),COLORMAGENTA;
金叉:=CROSS(EMA(C,1),EMA(C,3));
AAA上:=IF(AAA1>REF(AAA1,1),AAA1,DRAWNULL);
AAA下:=IF(AAA1<REF(AAA1,1),AAA1,DRAWNULL);
选股王:=CROSS(绝密,买入线);
突破买点:=有庄控盘 AND 选股王;
XXBB:= EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*4,5)*100;
抄牛底:=REF(XXBB,1)<50 AND XXBB-REF(XXBB,1)>25;
蓝宝石:=抄牛底 AND 金叉;
追拉升:=REF(XXBB,1)>50 AND XXBB-REF(XXBB,1)>40;
回踩买点:=主力出货 AND 选股王;
DRAWTEXT(回踩买点,L*0.995,'↖牛回踩'),COLORYELLOW;
DRAWICON(回踩买点,L*0.985,26);
抄底王:=金叉 AND 选股王,COLORGRAY;
DRAWTEXT(抄底王,L*0.985,'↖抄底王'),COLORWHITE;
DRAWICON(抄底王,L*0.975,27);
VV1:=(C*2+H+L)/4*10;
VV2:=EMA(VV1,13)-EMA(VV1,34);
VV3:=EMA(VV2,5); V4:=2*(VV2-VV3)*5.5;
主力撤:=IF(V4<=0,V4,0),COLORGREEN;
主力进:=IF(V4>=0,V4,0);
VV5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*VV5-2*SMA(VV5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);
VB:=(V9-VA)/2;
大盘资金进场:=IF(VB>=0,VB,0),COLORYELLOW;
大盘资金撤走:=IF(VB<=0,VB,0),COLORRED;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,3);
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*100;
准备现金:=STICKLINE(趋势线<=13,0,20,5,0),COLORCC9900;
AA:=(趋势线<=13) AND FILTER((趋势线<=13),15);
{DRAWTEXT (AA,30,'准备现金'),COLORCC9900;}
买入股票:=STICKLINE(趋势线<=13 AND V12>13,0,50,5,0),COLOR0099FF;
BB:=(趋势线<=13 AND V12>13) AND FILTER((趋势线<=13 AND V12>13),10) ;
{DRAWTEXT (BB,60,'买入股票'),COLOR0099FF;}
红宝石:=BB AND 金叉;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
加仓:=IF(FILTER(YXF=1,5),1,0),STICK,COLORFFFFFF,LINETHICK3;
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV
(L,55))*100,5,1);
FY:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
QS:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
绿宝石:=加仓 AND 金叉;
{DRAWTEXT (绿宝石,L*0.945,'绿宝石'),COLORFF00FF;}
LC20:=REF(CLOSE,1);
RSI20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100;
底线买阳:=CROSS(RSI20,11)*1,COLORRED;
黄宝石:=底线买阳 AND 金叉;
{DRAWTEXT (黄宝石,L*0.935,'黄宝石'),COLOR0099FF;}
控盘B:=FILTER(IF(A10,1,0),5);
{分时价格原码}
JJ:=DYNAINFO(11);
{波段买卖原码}
P:=55;S:=8;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*10,COLORRED,LINETHICK2;
神:=EMA(财,M1),COLORGREEN,LINETHICK1;
{股价与均线偏离买卖条件}
BTJ1:=(C-JJ)/JJ<-0.005;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
{控盘买卖条件}
STJ01:=控盘<REF(控盘,1) AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
{波段买卖条件}
BTJ3:=CROSS(财,神) AND 财<-0.3;
BTJ32:=CROSS(财,神) AND 财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND 财>1.618;
{以下为信号};
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
{DRAWICON(BTJ82,L*0.993,23);}{追买};
{DRAWICON(BTJ811,L*0.980,5);}
{DRAWICON(绿宝石,L*0.988,27);
DRAWICON(黄宝石,L*0.986,26);}
{DRAWICON(蓝宝石,L*0.982,24);
DRAWICON(红宝石,L*0.980,25);}
DRAWICON(追拉升,L*0.985,23);
{DRAWICON(突破买点,L*0.985,21);}
VAR1A:=EMA(EMA(CLOSE,9),9);
专用:=(VAR1A-REF(VAR1A,1))/REF(VAR1A,1)*1000;
VAR2A:=100*WINNER(CLOSE*0.95);
高手专用:=VAR2A>50 AND COST(85)<CLOSE AND 专用>0;
CV:=CLOSE;
BBIBOLL:=(MA(CV,3)+MA(CV,6)+MA(CV,12)+MA(CV,24))/4;
UPR:=BBIBOLL+6*STD(BBIBOLL,11);
DWN:=BBIBOLL-6*STD(BBIBOLL,11);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=(IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2)));
HSL:=(XVL/20)/1.15;
强势股:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22))>1500;
绝杀前十:=高手专用 AND 高度控盘,COLORFF00FF;
{机构增仓}
JA1:=(DVOL/C)/2;
A2:=SUM(IF(JA1>100 AND CLOSE>REF(CLOSE,1),JA1,0),0);
A3:=SUM(IF(JA1>100 AND CLOSE<REF(CLOSE,1),JA1,0),0);
A4:=SUM(IF(JA1<100 AND CLOSE>REF(CLOSE,1),JA1,0),0);
A5:=SUM(IF(JA1<100 AND CLOSE<REF(CLOSE,1),JA1,0),0);
A6:=A2+A3+A4+A5;
机买:=(A2/A6)*100;
机卖:=(A3/A6)*100;
主力差:=机买-机卖;
机构加仓:=(主力差>=REF(主力差,1)+1.5)*50 AND 机买>机卖;
机构抄底:=金叉 AND 机构加仓;
DRAWTEXT (机构抄底,L*0.97,'↖机构入驻'),COLORCYAN;
机构追买:=机构加仓 AND 追拉升;
DRAWTEXT (机构追买,L*0.97,'↖机构吃单'),COLORFF00FF;
{猎庄}
LVAR2:=(CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100;
LVAR3:=SMA(LVAR2,20,1);
LVAR4:=SMA(LVAR3,15,1);
猎庄:=LVAR3-LVAR4;
多空分界:=1;
抓庄:=CROSS(猎庄,多空分界) AND 猎庄>=REF(MA(猎庄,多空分界),1);
跟庄抄底:=金叉 AND 抓庄;
{DRAWTEXT (跟庄抄底,L*0.97,'跟庄'),COLORCYAN;}
{稳健追涨}
WMA1:=EMA(CLOSE,5);
WMA2:=EMA(CLOSE,10);
WMA3:=EMA(CLOSE,20);
WMA4:=EMA(CLOSE,30);
WMA5:=EMA(CLOSE,60);
WVAR1:=MAX(WMA1,MAX(WMA2,MAX(WMA3,WMA4)));
WVAR2:=MIN(WMA1,MIN(WMA2,MIN(WMA3,WMA4)));
WVAR3:=(WVAR1-WVAR2)/WVAR2*1000;
WVAR4:=WMA1>REF(WMA1,1) AND WMA2>REF(WMA2,1) AND WMA3>REF(WMA3,1) AND WMA4>REF(WMA4,1) AND WMA5>REF(WMA5,1);
WVAR5:=WVAR3<5;
WVAR6:=COUNT(WVAR5=1,5)>0;
WVAR7:=CROSS(WMA1,WMA4);
稳健追涨:=WVAR4 AND WVAR6 AND WVAR7;
稳健抄底:=金叉 AND 稳健追涨;
{DRAWTEXT (稳健抄底,L*0.97,'稳健'),COLORCYAN;}
{均线粘合}
JDIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
JDEA:=EMA(JDIF,9);
JMACD:=(JDIF-JDEA)*2;
JBOLL:=MA(CLOSE,20);
JUPPER:=JBOLL+2*STD(CLOSE,20);
JLOWER:=JBOLL-2*STD(CLOSE,20);
JK1:=CLOSE>OPEN ;
JK2:=VOL>=2*REF(VOL,1);
JK3:=CROSS(JDIF,JDEA) AND JDIF<=0 ;
JK4:=CROSS(CLOSE,JBOLL);
均线粘合:=JK1 AND JK2 AND JK3 AND JK4 ;
机构拉升:=机构加仓 AND 均线粘合;
DRAWTEXT (机构拉升,L*0.97,'↖机构拉升'),COLORFF00FF;
VARC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARC),H*1.02,2);
{DRAWTEXT(CROSS(82,VARC),2,'|逃庄'),COLORWHITE ;}
VAR34:=(INDEXC-REF(INDEXC, 1))/REF(INDEXC, 1);
VAR35:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1);
VAR36:=IF(VAR34>0.010, 0.900, 1) AND IF(VAR34>(-0.025), 1, 1.200);
VAR37:=VAR36*(VAR35-VAR34)*100;
VAR38:=SUM(VAR37, 10);
VAR310:=VAR38>20;
VAR326:=IF(CLOSE AND MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,1,0);{VAR38>VAR39;}
VAR327:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND HIGH/CLOSE<1.010 AND VAR326>0, 1, 0);
{STICKLINE(VAR327=1,0,1,2,0),COLORYELLOW;}
DRAWICON(VAR327=1,L*0.95,1);
{DRAWTEXT(VAR327=1,-1,'|杀庄'),COLORWHITE;}
HZ:=EMA(CLOSE,13);

短波:=EMA(HZ,1);
中波:=EMA(HZ,26);
均线148天:=EMA(C,148);
成本:=SUM(AMOUNT,0)/SUM(VOL,0)/100;
HZ2:=EMA(HZ,8);
拉升一号:=CROSS(短波,HZ2);
DRAWICON(拉升一号,L*0.99,11);
DRAWTEXT (拉升一号,L*0.97,'↖黑马拉升'),COLORFF00FF;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
红线上牛股起:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED,LINETHICK2;
绿线下熊股出:MA(红线上牛股起,6),COLORGREEN,LINETHICK2;
涨停紫色:STICKLINE((C-REF(C,1))/REF(C,1)>0.095,C,O,3.05,0),COLORMAGENTA;[/lycode][lycode=tdx2,true]M1赋值:5
M2赋值:10
M3赋值:20
M4赋值:30
M5赋值:60
N赋值:80
N1赋值:14
M赋值:3
黄金柱B赋值:成交量(手)/1日前的成交量(手)>=2.0
K1B赋值:黄金柱B累加至1的天数
K2B赋值:黄金柱B累加至2的天数
K3B赋值:黄金柱B累加至3的天数
K4B赋值:黄金柱B累加至4的天数
K5B赋值:黄金柱B累加至5的天数
K6B赋值:黄金柱B累加至6的天数
K7B赋值:黄金柱B累加至7的天数
K8B赋值:黄金柱B累加至8的天数
K9B赋值:黄金柱B累加至9的天数
K10B赋值:黄金柱B累加至10的天数
输出AABB:当满足条件K1B时,在K1B-1日前的(未作平滑处理)最低价*1.002和K1B-1日前的(未作平滑处理)最低价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
T60B赋值:成交量(手)=60日内成交量(手)的最高值
T100B赋值:成交量(手)=100日内成交量(手)的最高值
T2B赋值:成交量(手)/1日前的成交量(手)>=3
T3B赋值:1日前的收盘价/1日前的开盘价<3
MA5赋值:收盘价的M1日简单移动平均,线宽为1,画黄色
MA10赋值:收盘价的M2日简单移动平均,线宽为1,画白色
MA20赋值:收盘价的M3日简单移动平均,线宽为1,画黄色
输出稳健操盘线:收盘价的M4日简单移动平均,POINTDOT,画红色
MA60赋值:收盘价的M5日简单移动平均,POINTDOT,线宽为1,画绿色
TR1赋值:最高价-最低价和最高价-1日前的收盘价的绝对值的较大值和最低价-1日前的收盘价的绝对值的较大值的N1日[1日权重]移动平均
HD赋值:最高价-1日前的最高价
LD赋值:1日前的最低价-最低价
DMP赋值:如果HD>0ANDHD>LD,返回HD,否则返回0的N1日[1日权重]移动平均
DMM赋值:如果LD>0ANDLD>HD,返回LD,否则返回0的N1日[1日权重]移动平均
PDI赋值:DMP*100/TR1,画红色
MDI赋值:DMM*100/TR1,画绿色
ADX赋值:MDI-PDI的绝对值/(MDI+PDI)*100的N1日[1日权重]移动平均,画黄色
阶段线1赋值:16
阶段线2赋值:30
DMI1赋值:PDI>MDI AND ADX>=30
DMI2赋值:PDI<MDI AND ADX>=30
DMI3赋值:PDI>MDI AND 16<ADX<30
DMI4赋值:PDI<MDI AND 16<ADX<30
DMI5赋值:ADX<=16 AND (PDI>MDI OR PDI<MDI)
DMI6赋值:ADX>60
ZT赋值:收盘价/1日前的收盘价>1.097
XH赋值:ZT的13日过滤
BH赋值:上次ZT距今天数
CZ赋值:BH日前的最高价-BH日前的最低价
当满足条件ZT时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
当满足条件ZT时,在最低价*0.98位置书写文字,COLORF00FF0
VARZT赋值:上次收盘价/1日前的收盘价>1.097距今天数
涨停赋值:如果(收盘价-1日前的收盘价)*100/1日前的收盘价>=(10-0.01*100/1日前的开盘价),返回1,否则返回0
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
ZDF赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100
当满足条件ZDF<-9.9时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画绿色
VAR111赋值:成交量(手)/((最高价-最低价)*2-收盘价-开盘价的绝对值)
买赋值:如果收阳线,返回VAR111*(最高价-最低价),否则返回如果收阴线,返回VAR111*((最高价-开盘价)+(收盘价-最低价)),否则返回成交量(手)/2,画红色
卖赋值:如果收阳线,返回0-VAR111*((最高价-收盘价)+(开盘价-最低价)),否则返回如果收阴线,返回0-VAR111*(最高价-最低价),否则返回0-成交量(手)/2,COLOR00FF00
买卖差赋值:(买+卖)
买卖比赋值:买/卖的绝对值
水平面赋值:收盘价的89日简单移动平均,COLORFF00FF
BBI赋值:(收盘价的M1日简单移动平均+收盘价的M2日简单移动平均+收盘价的M3日简单移动平均+收盘价的M4日简单移动平均)/4
MA1赋值:收盘价的24日简单移动平均,COLOR00E300,线宽为1
V2赋值:如果到最后交易的周期=1,返回成交量(手)*240/当前离开盘分钟数/1日前的成交量(手)-1,否则返回成交量(手)/1日前的成交量(手)-1
MA13赋值:收盘价的13日简单移动平均
X1赋值:(收盘价+最低价+最高价)/3
BB13赋值:X1的13日指数移动平均-1日前的X1的13日指数移动平均的反正切*3.1416*10
EMA8赋值:收盘价的8日指数移动平均
A1赋值:开盘价和收盘价的较小值
B1赋值:开盘价-收盘价的绝对值
T1赋值:BB13>1ANDEMA(X1,13)>1日前的X1的8日指数移动平均的10日过滤
LC赋值:1日前的收盘价
RSI赋值:(((收盘价-LC)和0的较大值的3日[1日权重]移动平均 / (收盘价-LC)的绝对值的3日[1日权重]移动平均) * 100)
FF赋值:收盘价的3日指数移动平均
MA15赋值:收盘价的21日指数移动平均
T2赋值:统计3日中满足BBI上穿3的天数=1 AND 收盘价上穿BBI
T12赋值:V2>=1
T0赋值:上次T12距今天数
L1赋值:T0日前的最低价
H1赋值:T0日前的最高价
L11赋值:1日前的最低价和最低价的较小值
L10赋值:L11和2日前的最低价的较小值
L21赋值:1日前的最低价和最低价的较大值
L20赋值:L21和2日前的最低价的较大值
T111赋值:(3日前的V2>=1 OR 2日前的V2>=1 OR 1日前的V2>=1) AND((L10>L1 AND L20>H1) OR (L11>L1 AND L21>H1))
T11赋值:T111 AND 1日前的T111=0
V1赋值:(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均
V2X赋值:(1-7/100)*(以V1为权重收盘价的动态移动平均)
V3赋值:(1+7/100)*(以V1为权重收盘价的动态移动平均)
V5赋值:(最低价+最高价+收盘价)/3的5日简单移动平均
A1XX赋值:收盘价的1日简单移动平均上穿收盘价的3日简单移动平均
XG赋值:A1XX
VAR1赋值:收盘价的13日指数移动平均的13日指数移动平均
控盘赋值:(VAR1-1日前的VAR1)/1日前的VAR1*1000
A10赋值:控盘上穿0
无庄控盘赋值:如果控盘<0,返回控盘,否则返回0,画深灰色,NODRAW
短线赋值:(收盘价-收盘价的13日简单移动平均)/收盘价的13日简单移动平均*20,线宽为0,画白色
中线赋值:(收盘价-收盘价的4日简单移动平均)/收盘价的4日简单移动平均*20,线宽为0,画黄色
红柱赋值:短线的3日[1日权重]移动平均,线宽为0,COLORFF00FF
绿柱赋值:中线的3日[1日权重]移动平均,COLORSTICK,COLOR00FF00
开始控盘赋值:如果A10,返回5,否则返回0,线宽为1,画白色
有庄控盘赋值:如果控盘>1日前的控盘AND控盘>0,返回控盘,否则返回0,画红色,NODRAW
VAR2赋值:100*以收盘价*0.95计算的获利盘比例
高度控盘赋值:如果VAR2>50ANDCOST(85)<CLOSEAND控盘>0,返回控盘,否则返回0,COLORFF00FF,NODRAW
主力出货赋值:如果控盘<1日前的控盘AND控盘>0,返回控盘,否则返回0,COLOR00FF00,NODRAW
DIF1赋值:不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均
DEA1赋值:DIF1的9日指数移动平均
AAA1赋值:(DIF1-DEA1)*2*60
买入线赋值:10
绝密赋值:AAA1-1日前的AAA1,画洋红色
金叉赋值:收盘价的1日指数移动平均上穿收盘价的3日指数移动平均
AAA上赋值:如果AAA1>1日前的AAA1,返回AAA1,否则返回无效数
AAA下赋值:如果AAA1<1日前的AAA1,返回AAA1,否则返回无效数
选股王赋值:绝密上穿买入线
突破买点赋值:有庄控盘 AND 选股王
XXBB赋值: (收盘价-25日内最低价的最低值)/(25日内最高价的最高值-25日内最低价的最低值)*4的5日指数移动平均*100
抄牛底赋值:1日前的XXBB<50 AND XXBB-1日前的XXBB>25
蓝宝石赋值:抄牛底 AND 金叉
追拉升赋值:1日前的XXBB>50 AND XXBB-1日前的XXBB>40
回踩买点赋值:主力出货 AND 选股王
当满足条件回踩买点时,在最低价*0.995位置书写文字,画黄色
当满足条件回踩买点时,在最低价*0.985位置画26号图标
抄底王赋值:金叉 AND 选股王,画深灰色
当满足条件抄底王时,在最低价*0.985位置书写文字,画白色
当满足条件抄底王时,在最低价*0.975位置画27号图标
VV1赋值:(收盘价*2+最高价+最低价)/4*10
VV2赋值:VV1的13日指数移动平均-VV1的34日指数移动平均
VV3赋值:VV2的5日指数移动平均
V4赋值:2*(VV2-VV3)*5.5
主力撤赋值:如果V4<=0,返回V4,否则返回0,画绿色
主力进赋值:如果V4>=0,返回V4,否则返回0
VV5赋值:(8日内大盘的最高价的最高值-大盘的收盘价)/(8日内大盘的最高价的最高值-8日内大盘的最低价的最低值)*8
V6赋值:3*VV5-2*VV5的18日[1日权重]移动平均的5日指数移动平均
V7赋值:(大盘的收盘价-8日内大盘的最低价的最低值)/(8日内大盘的最高价的最高值-8日内大盘的最低价的最低值)*10
V8赋值:(大盘的收盘价*2+大盘的最高价+大盘的最低价)/4
V9赋值:V8的13日指数移动平均-V8的34日指数移动平均
VA赋值:V9的3日指数移动平均
VB赋值:(V9-VA)/2
大盘资金进场赋值:如果VB>=0,返回VB,否则返回0,画黄色
大盘资金撤走赋值:如果VB<=0,返回VB,否则返回0,画红色
V11赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
趋势线赋值:V11的3日指数移动平均
V12赋值:(趋势线-1日前的趋势线)/1日前的趋势线*100
准备现金赋值:当满足条件趋势线<=13时,在0和20位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORCC9900
AA赋值:(趋势线<=13) AND (趋势线<=13)的15日过滤
买入股票赋值:当满足条件趋势线<=13ANDV12>13时,在0和50位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR0099FF
BB赋值:(趋势线<=13 AND V12>13) AND (趋势线<=13ANDV12>13)的10日过滤
红宝石赋值:BB AND 金叉
MTM赋值:收盘价-1日前的收盘价
DX赋值:100*MTM的6日指数移动平均的6日指数移动平均/MTM的绝对值的6日指数移动平均的6日指数移动平均
YXF赋值:如果2日内DX的最低值=7日内DX的最低值ANDCOUNT(DX<0,2)ANDCROSS(DX,DX的2日简单移动平均),返回1,否则返回0
加仓赋值:如果YXF=1的5日过滤,返回1,否则返回0,STICK,COLORFFFFFF,线宽为3
A51赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均
FY赋值:A51的5日指数移动平均
A54赋值:((收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值))*100
QS赋值:(3*A54的6日[1日权重]移动平均-2*A54的5日[1日权重]移动平均的5日[1日权重]移动平均的2日简单移动平均)
绿宝石赋值:加仓 AND 金叉
LC20赋值:1日前的收盘价
RSI20赋值:收盘价-LC20和0的较大值的4.1日[1日权重]移动平均/收盘价-LC20的绝对值的4.1日[1日权重]移动平均*100
底线买阳赋值:RSI20上穿11*1,画红色
黄宝石赋值:底线买阳 AND 金叉
控盘B赋值:如果A10,返回1,否则返回0的5日过滤
JJ赋值:均价
P赋值:55
S赋值:8
财赋值:(收盘价的S日指数移动平均-收盘价的P日指数移动平均)*10,画红色,线宽为2
神赋值:财的M1日指数移动平均,画绿色,线宽为1
BTJ1赋值:(收盘价-JJ)/JJ<-0.005
BTJ11赋值:(收盘价-JJ)/JJ<-0.03
BTJ12赋值:从前5日到前1日持续JJ>=1日前的JJ AND (收盘价-JJ)/JJ<0.005
STJ1赋值:(收盘价-JJ)/JJ>0.005
STJ01赋值:控盘<1日前的控盘 AND 控盘>0.5
STJ02赋值:控盘>0
BTJ2赋值:控盘>1日前的控盘 AND 控盘<-0.2
BTJ22赋值:控盘>1日前的控盘 AND 控盘<0
BTJ3赋值:财上穿神 AND 财<-0.3
BTJ32赋值:财上穿神 AND 财<-0.1
STJ31赋值:神上穿财
STJ32赋值:神上穿财 AND 财>1.618

BTJ81赋值:BTJ1ANDBTJ2ANDBTJ3的13日过滤
BTJ811赋值:BTJ11ANDBTJ2ANDBTJ3的13日过滤
BTJ82赋值:BTJ12ANDBTJ22ANDBTJ32的13日过滤

当满足条件追拉升时,在最低价*0.985位置画23号图标
VAR1A赋值:收盘价的9日指数移动平均的9日指数移动平均
专用赋值:(VAR1A-1日前的VAR1A)/1日前的VAR1A*1000
VAR2A赋值:100*以收盘价*0.95计算的获利盘比例
高手专用赋值:VAR2A>50 AND 获利盘为85%的成本分布<收盘价 AND 专用>0
CV赋值:收盘价
BBIBOLL赋值:(CV的3日简单移动平均+CV的6日简单移动平均+CV的12日简单移动平均+CV的24日简单移动平均)/4
UPR赋值:BBIBOLL+6*BBIBOLL的11日估算标准差
DWN赋值:BBIBOLL-6*BBIBOLL的11日估算标准差
QJJ赋值:成交量(手)/((最高价-最低价)*2-收盘价-开盘价的绝对值)
XVL赋值:(如果收阳线,返回QJJ*(最高价-最低价),否则返回如果收阴线,返回QJJ*(最高价-开盘价+收盘价-最低价),否则返回成交量(手)/2+如果收阳线,返回0-QJJ*(最高价-收盘价+开盘价-最低价),否则返回如果收阴线,返回0-QJJ*(最高价-最低价),否则返回0-成交量(手)/2)
HSL赋值:(XVL/20)/1.15
强势股赋值:((HSL*0.55+(1日前的HSL*0.33))+(2日前的HSL*0.22))>1500
绝杀前十赋值:高手专用 AND 高度控盘,COLORFF00FF
JA1赋值:(不定周期成交量/收盘价)/2
A2赋值:如果JA1>100ANDCLOSE>1日前的收盘价,返回JA1,否则返回0的历史累和
A3赋值:如果JA1>100ANDCLOSE<1日前的收盘价,返回JA1,否则返回0的历史累和
A4赋值:如果JA1<100ANDCLOSE>1日前的收盘价,返回JA1,否则返回0的历史累和
A5赋值:如果JA1<100ANDCLOSE<1日前的收盘价,返回JA1,否则返回0的历史累和
A6赋值:A2+A3+A4+A5
机买赋值:(A2/A6)*100
机卖赋值:(A3/A6)*100
主力差赋值:机买-机卖
机构加仓赋值:(主力差>=1日前的主力差+1.5)*50 AND 机买>机卖
机构抄底赋值:金叉 AND 机构加仓
当满足条件机构抄底时,在最低价*0.97位置书写文字,画青色
机构追买赋值:机构加仓 AND 追拉升
当满足条件机构追买时,在最低价*0.97位置书写文字,COLORFF00FF
LVAR2赋值:(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100
LVAR3赋值:LVAR2的20日[1日权重]移动平均
LVAR4赋值:LVAR3的15日[1日权重]移动平均
猎庄赋值:LVAR3-LVAR4
多空分界赋值:1
抓庄赋值:猎庄上穿多空分界 AND 猎庄>=1日前的猎庄的多空分界日简单移动平均
跟庄抄底赋值:金叉 AND 抓庄
WMA1赋值:收盘价的5日指数移动平均
WMA2赋值:收盘价的10日指数移动平均
WMA3赋值:收盘价的20日指数移动平均
WMA4赋值:收盘价的30日指数移动平均
WMA5赋值:收盘价的60日指数移动平均
WVAR1赋值:WMA1和WMA2和WMA3和WMA4的较大值的较大值的较大值
WVAR2赋值:WMA1和WMA2和WMA3和WMA4的较小值的较小值的较小值
WVAR3赋值:(WVAR1-WVAR2)/WVAR2*1000
WVAR4赋值:WMA1>1日前的WMA1 AND WMA2>1日前的WMA2 AND WMA3>1日前的WMA3 AND WMA4>1日前的WMA4 AND WMA5>1日前的WMA5
WVAR5赋值:WVAR3<5
WVAR6赋值:统计5日中满足WVAR5=1的天数>0
WVAR7赋值:WMA1上穿WMA4
稳健追涨赋值:WVAR4 AND WVAR6 AND WVAR7
稳健抄底赋值:金叉 AND 稳健追涨
JDIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
JDEA赋值:JDIF的9日指数移动平均
JMACD赋值:(JDIF-JDEA)*2
JBOLL赋值:收盘价的20日简单移动平均
JUPPER赋值:JBOLL+2*收盘价的20日估算标准差
JLOWER赋值:JBOLL-2*收盘价的20日估算标准差
JK1赋值:收阳线
JK2赋值:成交量(手)>=2*1日前的成交量(手)
JK3赋值:JDIF上穿JDEA AND JDIF<=0
JK4赋值:收盘价上穿JBOLL
均线粘合赋值:JK1 AND JK2 AND JK3 AND JK4
机构拉升赋值:机构加仓 AND 均线粘合
当满足条件机构拉升时,在最低价*0.97位置书写文字,COLORFF00FF
VARC赋值:收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均*100
当满足条件82上穿VARC时,在最高价*1.02位置画2号图标
VAR34赋值:(大盘的收盘价-1日前的大盘的收盘价)/1日前的大盘的收盘价
VAR35赋值:(收盘价-1日前的收盘价)/1日前的收盘价
VAR36赋值:如果VAR34>0.010,返回0.900,否则返回1 AND 如果VAR34>(-0.025),返回1,否则返回1.200
VAR37赋值:VAR36*(VAR35-VAR34)*100
VAR38赋值:VAR37的10日累和
VAR310赋值:VAR38>20
VAR326赋值:如果CLOSEANDMA(成交量(手),5)/240ANDCLOSE>1日前的收盘价*1.0ANDCLOSE,返回1,否则返回0
VAR327赋值:如果收盘价/1日前的收盘价>1.050ANDVOL/当前流通股本(手)*100<10ANDCLOSE<17ANDHIGH/收盘价<1.010ANDVAR326>0,返回1,否则返回0
当满足条件VAR327=1时,在最低价*0.95位置画1号图标
HZ赋值:收盘价的13日指数移动平均
短波赋值:HZ的1日指数移动平均
中波赋值:HZ的26日指数移动平均
均线148天赋值:收盘价的148日指数移动平均
成本赋值:成交额(元)的历史累和/成交量(手)的历史累和/100
HZ2赋值:HZ的8日指数移动平均
拉升一号赋值:短波上穿HZ2
当满足条件拉升一号时,在最低价*0.99位置画11号图标
当满足条件拉升一号时,在最低价*0.97位置书写文字,COLORFF00FF
MID赋值:(3*收盘价+最低价+开盘价+最高价)/6
输出红线上牛股起:(20*MID+19*1日前的MID+18*2日前的MID+17*3日前的MID+16*4日前的MID+15*5日前的MID+14*6日前的MID+13*7日前的MID+12*8日前的MID+11*9日前的MID+10*10日前的MID+9*11日前的MID+8*12日前的MID+7*13日前的MID+6*14日前的MID+5*15日前的MID+4*16日前的MID+3*17日前的MID+2*18日前的MID+20日前的MID)/210,画红色,线宽为2
输出绿线下熊股出:红线上牛股起的6日简单移动平均,画绿色,线宽为2
输出涨停紫色:当满足条件(收盘价-1日前的收盘价)/1日前的收盘价>0.095时,在收盘价和开盘价位置之间画柱状线,宽度为3.05,0不为0则画空心柱.,画洋红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1Af_QLz5Hxe0gdBsa8uTVEA

看了该指标的人还看了:
牛气冲天指标    分时攻击力度指标
大肚线指标    五虎上将出征指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表