指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 
TIM截图20180906103240.png

TIM截图20180906103249.png

[lywrap=通达信主图指标公式][lycode=tdx,true]MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);
VAR1:=(CLOSE+HIGH+LOW)/3;
VAR2:=EMA(VAR1,10);
VAR3:=REF(VAR2,1);
STICKLINE((VAR2>VAR3),CLOSE,OPEN,2.8,0),COLOR000088;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,2.6,0),COLOR000099;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,2.4,0),COLOR0000AA;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,2.2,0),COLOR0000BB;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,2.0,0),COLOR0000CC;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,1.8,0),COLOR0000DD;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,1.5,0),COLOR0000EE;
STICKLINE((VAR2>VAR3),CLOSE,OPEN,1,0),COLOR0000FF;
STICKLINE((VAR2>VAR3),LOW,HIGH,0.0,0),COLOR0000FF;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,2.8,0),COLOR888800;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,2.6,0),COLOR999900;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,2.4,0),COLORAAAA00;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,2,2),COLORBBBB00;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,2.0,0),COLORCCCC00;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,1.8,0),COLORDDDD00;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,1.5,0),COLOREEEE00;
STICKLINE((VAR3>VAR2),CLOSE,OPEN,1,0),COLORFFFF00;
STICKLINE((VAR3>VAR2),LOW,HIGH,0.0,0),COLORFFFF00;
STICKLINE((OPEN>CLOSE),CLOSE,OPEN,0,0),COLORFFFF00;
STICKLINE((OPEN<CLOSE),CLOSE,OPEN,0,0),COLORRED;
C4:=CROSS(VAR2,VAR3);
C5:=CROSS(VAR3,VAR2);
DRAWICON(C4,LOW-0.2,7);
DRAWICON(C5,HIGH+0.2,8);
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.03),'小心变盘'),COLORFFFFFF;
DRAWTEXT(CROSS(83,RSI),H*1.04,' 逃顶')COLORYELLOW;[/lycode][lycode=tdx2,true]输出MA5:收盘价的5日简单移动平均
输出MA10:收盘价的10日简单移动平均
输出MA20:收盘价的20日简单移动平均
VAR1赋值:(收盘价+最高价+最低价)/3
VAR2赋值:VAR1的10日指数移动平均
VAR3赋值:1日前的VAR2
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR000088
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为2.6,0不为0则画空心柱.,COLOR000099
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为2.4,0不为0则画空心柱.,COLOR0000AA
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR0000BB
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为2.0,0不为0则画空心柱.,COLOR0000CC
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR0000DD
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000EE
当满足条件(VAR2>VAR3)时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000FF
当满足条件(VAR2>VAR3)时,在最低价和最高价位置之间画柱状线,宽度为0.0,0不为0则画空心柱.,COLOR0000FF
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR888800
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为2.6,0不为0则画空心柱.,COLOR999900
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为2.4,0不为0则画空心柱.,COLORAAAA00
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为2,2不为0则画空心柱.,COLORBBBB00
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为2.0,0不为0则画空心柱.,COLORCCCC00
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLORDDDD00
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOREEEE00
当满足条件(VAR3>VAR2)时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFFFF00
当满足条件(VAR3>VAR2)时,在最低价和最高价位置之间画柱状线,宽度为0.0,0不为0则画空心柱.,COLORFFFF00
当满足条件(收阴线)时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLORFFFF00
当满足条件(收阳线)时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
C4赋值:VAR2上穿VAR3
C5赋值:VAR3上穿VAR2
当满足条件C4时,在最低价-0.2位置画7号图标
当满足条件C5时,在最高价+0.2位置画8号图标
A1AA赋值:9
A2AA赋值:(A1AA+1日前的收盘价<收盘价)
当满足条件(A2AA>-0.5)的84日过滤时,在(最高价)*(1.03)位置书写文字,COLORFFFFFF
当满足条件83上穿RSI时,在最高价*1.04位置书写文字画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1Y8SLLydlka6I4IPy-XVXkA

看了该指标的人还看了:
主力买卖指标    底部拉升指标    股海拾贝指标
敢死队操作线指标    抄底趋势线指标    短线黑马指标

使用道具 举报

回复