请选择 进入手机版|继续访问电脑版

主力拉升出货指标 通达信 副图 波段 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 7 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 操盘控盘 
主力拉升出货指标 通达信 副图 波段 短线 买卖点 操盘控盘 炒股叉第10129张

主力拉升出货指标 通达信 副图 波段 短线 买卖点 操盘控盘 炒股叉第10130张

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
XG:=(FILTER((VAR4AA>90),45)),COLORYELLOW;
STICKLINE(XG,150,0,4,0),COLOR000099;
STICKLINE(XG,150,0,2,0),COLOR0000BB;
STICKLINE(XG,150,0,1,0),COLOR0000DD;
STICKLINE(XG,150,0,0.9,0),COLOR0000FF;
DRAWTEXT(XG>0,130,'★起暴点'),COLOR00C5FF;
DIFF :=( EMA(CLOSE,12) - EMA(CLOSE,26))*100;
DEA :=EMA(DIFF,9);
MACD :=2*(DIFF-DEA);
抄底1:=ABS((CROSS("MACD.DIF","MACD.DEA")
&&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.09,COLORLIMAGENTA,LINETHICK2;
STICKLINE(抄底1,0,50,4,0),COLOR770077;
STICKLINE(抄底1,0,50,3,0),COLOR990099;
STICKLINE(抄底1,0,50,2,0),COLORBB00BB;
STICKLINE(抄底1,0,50,1,0),COLORDD00DD;
STICKLINE(抄底1,0,50,0.3,0),COLORFF00FF;
DRAWTEXT(抄底1>0,38,'★超级拐点'),COLOR00C5FF;
反向钟摆线:=MA((LLV(LOW,45)-CLOSE)/(HHV(HIGH,45)-LLV(LOW,45))*100,20);
DK:=CROSS(-5,反向钟摆线);
STICKLINE(DK,0,50,4,0),COLOR770077;
STICKLINE(DK,0,50,3,0),COLOR990099;
STICKLINE(DK,0,50,2,0),COLORBB00BB;
STICKLINE(DK,0,50,1,0),COLORDD00DD;
STICKLINE(DK,0,50,0.3,0),COLORFF00FF;
DRAWTEXT(DK>0,48,'★终极低点'),COLOR00C5FF;
VAR2:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VAR3:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VAR4:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAR5:=(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6);
VAR6:=MA(VAR5,3);
VAR7:=DMA(EMA(CLOSE,12),((SUM(VOL,5) / 3) / CAPITAL));
VAR8:=(((CLOSE - VAR7) / VAR7) * 100);
VAR9:=((((REF(VAR8,1) < (0 - 40)) AND (VAR8 > REF(VAR8,1))) AND (REF(VAR8,1) < REF(VAR8,2))) AND ((VAR8 - REF(VAR8,1)) > 2.5));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),5,1) / SMA(ABS((CLOSE - VARD)),5,1)) * 100);
VARF:=(((HIGH + LOW) + CLOSE) / 3);
VAR10:=((VARF - MA(VARF,14)) / (0.015 * AVEDEV(VARF,14)));
VAR11:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < (0 - 0.273));
VAR12:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));
VAR13:=(VAR11 AND VAR12);
VAR14:=((((VAR2 >= (0 - 45)) AND (VAR2 <= (0 - 10))) AND (VAR3 <= (0 - 15))) AND (VAR4 <= (0 - 20)));
VAR15:=(COUNT(VAR14,1) >= 1);
VAR16:=(VAR13 AND VAR15);
VAR17:=1;
VAR18:=(CLOSE * VOL);
VAR19:=EMA((((((MA(VAR18,4) / MA(VOL,4)) + (MA(VAR18,6) / MA(VOL,6))) + (MA(VAR18,13) / MA(VOL,13))) + (MA(VAR18,24) / MA(VOL,24))) / 4),1);
VAR1A:=(1 * VAR19);
VAR1B:=(VAR19 * 0.92);
VAR1C:=EMA(CLOSE,34);
VAR1D:=MA((VAR1C * 1.12),5);
VAR1E:=MA((VAR1C * 0.82),5);
VAR1F:=(CLOSE < VAR1E);
VAR20:=((((((MA(AMOUNT,5) * VAR17) / MA(VOL,5)) / 100) - ((MA(AMOUNT,125) / MA(VOL,125)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < ((0 - 0.4) * VAR17));
VAR21:=HHV(HIGH,500);
VAR22:=LLV(LOW,500);
VAR23:=HHV(HIGH,250);
VAR24:=LLV(LOW,250);
VAR25:=HHV(HIGH,125);
VAR26:=LLV(LOW,125);
VAR27:=MA(((((((VAR21 * 0.45) + (VAR23 * 0.5)) + VAR22) + VAR24) + VAR26) / 5),35);
VAR28:=MA((((VAR23 * 0.62) + VAR26) / 2),35);
VAR29:=MA((((VAR23 * 0.75) + VAR26) / 2),18);
VAR2A:=MA((((((VAR23 * 0.93) + (VAR27 * 2)) + (VAR28 * 1.8)) + (VAR29 * 1.5)) / 4),18);
VAR2B:=MA(((((VAR21 * 0.95) + (VAR27 * 3)) + (VAR28 * 2)) / 3),35);
VAR2C:=VAR27;
VAR2D:=VAR28;
VAR2E:=VAR29;
VAR2F:=VAR2A;
VAR30:=VAR2B;
VAR31:=((CLOSE - REF(MA(CLOSE,20),11)) < (0 - 2));
VAR35:=((VAR18 / (VAR18 + VAR19)) * VAR17);
VAR36:=((VAR19 / (VAR18 + VAR19)) * VAR17);
VAR37:=EMA(VAR35,10);
VAR38:=EMA(VAR36,10);
VAR39:=EMA(VAR37,10);
VAR3A:=EMA(VAR38,20);
VAR3B:=EMA(VAR37,3);
VAR3C:=EMA(VAR39,6);
VAR3D:=EMA(VAR3A,2);
VAR3E:=(VAR3C - VAR3D);
VAR3F:=(((VAR3C - REF(VAR3C,1)) > 0) AND ((REF(VAR3C,1) - REF(VAR3C,2)) < 0));
VAR40:=IF((CROSS(VAR3B,VAR3C) AND (VAR3C <= 20)),30,0);
VAR41:=VAR40;
VAR42:=(SMA(((AMOUNT / VOL) / 100),13,1) * 1.15);
VAR43:=(SMA(((AMOUNT / VOL) / 100),13,1) * 0.85);
VAR44:=(CLOSE - REF(MA(CLOSE,20),11));
VAR45:=(((((((((((((CLOSE < VAR1E) AND VAR20) AND (CLOSE < VAR43)) OR (((CLOSE < VAR1E) AND VAR31) AND VAR20)) OR ((CLOSE < VAR1E) AND (CLOSE < VAR43))) OR (((CLOSE < VAR1E) AND VAR20) AND (CLOSE < VAR43))) OR (VAR20 AND (CLOSE < VAR2C))) OR ((VAR20 AND VAR31) AND (VAR44 < (0 - 1.5)))) OR (VAR20 AND (CLOSE < VAR1E))) OR (VAR20 AND (VAR44 < (0 - 1.5)))) OR (VAR31 AND (CLOSE < VAR43))) OR ((CLOSE < VAR2C) AND (VAR44 < (0 - 1.5)))) OR ((CLOSE < VAR1E) AND VAR31));
VAR4B:=(((HIGH + LOW) + CLOSE) / 3);
VAR4C:=((VAR4B - MA(VAR4B,14)) / (0.015 * AVEDEV(VAR4B,14)));
VAR4D:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < (0 - 0.273));
VAR4E:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));
VAR4F:=(VAR11 AND VAR12);
VAR50:=((((VAR2 >= (0 - 45)) AND (VAR2 <= (0 - 7))) AND (VAR3 <= (0 - 11))) AND (VAR4 <= (0 - 14)));
VAR51:=(COUNT(VAR50,1) >= 1);
VAR52:=(VAR4F AND VAR51);
VAR53:=(((((VAR20 AND (CLOSE < VAR1E)) AND VAR31) AND (CLOSE < VAR2C)) AND VAR45) AND VAR52);
VAR5B:=((((((VAR2 >= (0 - 15.8)) AND (VAR2 <= (0 - 12.2))) AND (VAR3 <= (0 - 20.8))) AND (VAR4 <= (0 - 27.5))) AND (VARE <= 11.7)) AND (VAR4C <= (0 - 145)));
VAR5C:=9.999999884842E+0.26;
VAR5D:=(COST(10) * 0);
VAR5E:=((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,125) / MA(VOL,125)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100));
VAR5F:=MA((((LLV(LOW,45) - CLOSE) / (HHV(HIGH,45) - LLV(LOW,45))) * 100),5);
VAR60:=((CROSS((0 - 5),VAR5F) AND (VAR5E < (0 - 0.4))) AND (((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.19)));
VAR61:=MA(CLOSE,3);
VAR62:=(REF(CLOSE,2) * 0.865);
VAR63:=(REF(CLOSE,13) * 0.772);
VAR64:=MIN(VAR62,VAR63);
VAR65:=((100 * VOL) / CAPITAL);
抄底:IF(((((VAR9 OR VAR16) OR VAR53) OR VAR5B) OR ((((CLOSE - VAR64) / CLOSE) < 0.03) AND ((SUM(VAR65,5) / 5) < 1.8))),80,0),LINETHICK4,COLORRED;
DRAWTEXT(抄底>0,抄底,'★游资'),COLOR00C5FF;
小V逆转:=REF(C,1)<REF(O,1) AND O>REF(C,1) AND C>=REF(C,1)*1.08;
STICKLINE(小V逆转,20,0,4,0),COLOR000099;
STICKLINE(小V逆转,30,0,2,0),COLOR0000BB;
STICKLINE(小V逆转,40,0,1,0),COLOR0000DD;
STICKLINE(小V逆转,60,0,0.9,0),COLOR0000FF;
DRAWICON(小V逆转,60,34);
DRAWTEXT(小V逆转>0,30,'小V逆转'),COLOR00C5FF;
HAN:=1;  {DATE<1151230;}
MA13:=MA(C,13),COLORWHITE;
MA34:=MA(C,34),COLORYELLOW;
MA55:=MA(C,55),COLORRED;
YY1:=O<MA13 AND C>MA13;
YY2:=O<MA34 AND C>MA34;
YY3:=O<MA55 AND C>MA55;
YY4:=C/O>=1.04;
YY5:=V>HHV(H,10);
YY6:=MA13>=REF(MA13,1);
天天涨停:=YY1 AND YY2 AND YY3 AND YY4 AND YY5 AND YY6;
IF(天天涨停,57,DRAWNULL),LINETHICK4,POINTDOT,COLOR00FF00;
STICKLINE(天天涨停,26,20,1,0),COLORFFFFFF;
STICKLINE(天天涨停,33,25,1,0),COLOR8800CC;
STICKLINE(天天涨停,46,32,1,0),COLORAA00DD;
STICKLINE(天天涨停,37,34,1,0),COLOR00AAFF;
STICKLINE(天天涨停,50,44,1,0),COLOR000000;
DRAWICON(天天涨停,39,9);
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
OBV2:=EMA(OBV1,3)-MA(OBV1,9);
OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
MAC3:=MA(C,3);
SHORT:=12;LONG:=26;MID:=9;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;
主力买:IF(DIF>REF(DIF,1),DIF,0),NODRAW;
主力卖:IF(DIF<REF(DIF,1),DIF,0),NODRAW;
STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,4.9,0),COLORYELLOW;
吸:=MACD<0 AND MACD>REF(MACD,1);
拉:=MACD>0 AND MACD>REF(MACD,1);
派:=MACD>0 AND MACD<REF(MACD,1);
落:=MACD<0 AND MACD<REF(MACD,1);
STICKLINE(吸,0,MACD,2.8,0),COLORRED;
STICKLINE(拉,0,MACD,2.8,0),COLORRED;
STICKLINE(派,0,MACD,3.8,0),COLORGREEN;
STICKLINE(落,0,MACD,2.8,0),COLORGREEN;
主力吸筹:吸,COLORYELLOW,NODRAW;
主力拉升:拉,COLORRED,NODRAW;
主力出逃:派,COLORGREEN,NODRAW;
主力砸盘:落,COLORFFAA00,NODRAW;
RSV:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
K:=SMA(RSV,2,1);
D:=SMA(K,2,1);
J:=3*K-2*D;
RS:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
F:=100;
K1:=RS>=100;
K2:=RS<100;
DRAWICON(CROSS(K1,K2),K1,27);
DRAWTEXT_FIX(1,0.0,0.01,0, ' 水晶出现次日10:30之前是最佳“卖点”')COLORYELLOW;
DRAWTEXT(CROSS(REF(ZIG(3,6),1),ZIG(3,6)),HIGH*0.1,'★卖')COLORGREEN;
DRAWICON(CROSS(REF(ZIG(3,6),1),ZIG(3,6)),HIGH*0.1,9);
V1:=EMA(CLOSE,60)-EMA(CLOSE,300);
V6:=CLOSE/REF(CLOSE,3)>=1.1;
V7:=BACKSET(V6,3);
买入暴张:IF((V7 AND COUNT(V7,3)=1),30,0),COLORYELLOW,LINETHICK3;
DRAWTEXT(V7*0.8>0,32,'。'),COLOR00C5FF;
买卖盘比▇: 1/DYNAINFO(51),COLORGRAY,NODRAW;
IF(买卖盘比▇ >0.9,买卖盘比▇,DRAWNULL),COLORWHITE,NODRAW;
IF(买卖盘比▇ >1.3,买卖盘比▇,DRAWNULL),COLORRED,NODRAW;
DRAWTEXT_FIX(1,0.5,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.51,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.52,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.53,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.54,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.55,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.56,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.57,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.58,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(买卖盘比▇ >0.5,0.5,0,0,'▇'),COLORLIGREEN;
DRAWTEXT_FIX(买卖盘比▇ >0.6,0.51,0,0,'▇'),COLORLIGREEN;
DRAWTEXT_FIX(买卖盘比▇ >0.7,0.52,0,0,'▇'),COLORLIGREEN;
DRAWTEXT_FIX(买卖盘比▇ >0.75,0.53,0,0,'▇'),COLOR00CCFF;
DRAWTEXT_FIX(买卖盘比▇ >0.8,0.54,0,0,'▇'),COLOR00CCFF;
DRAWTEXT_FIX(买卖盘比▇ >0.85,0.55,0,0,'▇'),COLOR00CCFF;
DRAWTEXT_FIX(买卖盘比▇ >0.9,0.56,0,0,'▇'),COLOR000066;
DRAWTEXT_FIX(买卖盘比▇ >0.95,0.57,0,0,'▇'),COLOR000066;
DRAWTEXT_FIX(买卖盘比▇ >1,0.58,0,0,'▇'),COLOR000066;
DRAWTEXT_FIX(1,0.56,0,0,' 9'),COLORBLACK;
DRAWTEXT_FIX(1,0.6,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.61,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.62,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.63,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.64,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.65,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.66,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.67,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(1,0.68,0,0,'▇'),COLORGRAY;
DRAWTEXT_FIX(买卖盘比▇ >1.05,0.6,0,0,'▇'),COLORGREEN;
DRAWTEXT_FIX(买卖盘比▇ >1.1,0.61,0,0,'▇'),COLORGREEN;
DRAWTEXT_FIX(买卖盘比▇ >1.15,0.62,0,0,'▇'),COLORGREEN;
DRAWTEXT_FIX(买卖盘比▇ >1.2,0.63,0,0,'▇'),COLORYELLOW;
DRAWTEXT_FIX(买卖盘比▇ >1.25,0.64,0,0,'▇'),COLORYELLOW;
DRAWTEXT_FIX(买卖盘比▇ >1.3,0.65,0,0,'▇'),COLORYELLOW;
DRAWTEXT_FIX(买卖盘比▇ >1.4,0.66,0,0,'▇'),COLORRED;
DRAWTEXT_FIX(买卖盘比▇ >1.5,0.67,0,0,'▇'),COLORRED;
DRAWTEXT_FIX(买卖盘比▇ >1.6,0.68,0,0,'▇'),COLORRED;
DRAWTEXT_FIX(1,0.65,0,0,' 7'),COLORBLACK;
MA1:EXPMA(C,5),COLORYELLOW,LINETHICK6;
KK:=MA1<REF(MA1,1);
IF(KK,MA1,DRAWNULL),COLORGREEN,LINETHICK6;
DD:=MA1>REF(MA1,1);
IF(DD,MA1,DRAWNULL),COLORBLUE,LINETHICK6;
B1:=(HHV(H,30)-C)/(HHV(H,30)-LLV(LOW,30))*100-30;
B2:=SMA(B1,30,1)+100;
B3:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
控盘程度:(IF(B6>1,B6-1,0))*2.5,COLORRED,LINETHICK0;
控盘度:100,COLORWHITE LINETHICK4;
{SAR};
持币:IF(SAR(10,2,20)>=H,100,DRAWNULL),LINETHICK4 COLORBLUE;
持股:IF(SAR(10,2,20)<=L,100,DRAWNULL),LINETHICK4,COLORRED;
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),60,5);
DRAWTEXT(CROSS(82,VARR1),60,'★逃顶'),COLORGREEN,LINETHICK4;[/lycode][lycode=tdx2,true]VAR3AA赋值:如果(收盘价>1日前的收盘价),返回88,否则返回0
VAR4AA赋值:如果((收盘价)/(1日前的收盘价)>1.05)AND((最高价)/(收盘价)<1.01)AND(VAR3AA>0),返回91,否则返回0
XG赋值:((VAR4AA>90)的45日过滤),画黄色
当满足条件XG时,在150和0位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR000099
当满足条件XG时,在150和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0000BB
当满足条件XG时,在150和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000DD
当满足条件XG时,在150和0位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLOR0000FF
当满足条件XG>0时,在130位置书写文字,COLOR00C5FF
赋值:( 收盘价的12日指数移动平均 - 收盘价的26日指数移动平均)*100
赋值:DIFF的9日指数移动平均
赋值:2*(DIFF-DEA)
抄底1赋值:("平滑异同平均的DIF"上穿"平滑异同平均的DEA"并且"平滑异同平均的DEA"<=-0.07)*"平滑异同平均的DIF"的绝对值*1.09,画淡洋红色,线宽为2
当满足条件抄底1时,在0和50位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR770077
当满足条件抄底1时,在0和50位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR990099
当满足条件抄底1时,在0和50位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORBB00BB
当满足条件抄底1时,在0和50位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORDD00DD
当满足条件抄底1时,在0和50位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORFF00FF
当满足条件抄底1>0时,在38位置书写文字,COLOR00C5FF
反向钟摆线赋值:(45日内最低价的最低值-收盘价)/(45日内最高价的最高值-45日内最低价的最低值)*100的20日简单移动平均
DK赋值:-5上穿反向钟摆线
当满足条件DK时,在0和50位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR770077
当满足条件DK时,在0和50位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR990099
当满足条件DK时,在0和50位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORBB00BB
当满足条件DK时,在0和50位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORDD00DD
当满足条件DK时,在0和50位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORFF00FF
当满足条件DK>0时,在48位置书写文字,COLOR00C5FF
VAR2赋值:(((收盘价 - 收盘价的6日简单移动平均) / 收盘价的6日简单移动平均) * 100)
VAR3赋值:(((收盘价 - 收盘价的12日简单移动平均) / 收盘价的12日简单移动平均) * 100)
VAR4赋值:(((收盘价 - 收盘价的24日简单移动平均) / 收盘价的24日简单移动平均) * 100)
VAR5赋值:(((VAR2 + (2 * VAR3)) + (3 * VAR4)) / 6)
VAR6赋值:VAR5的3日简单移动平均
VAR7赋值:以((成交量(手)的5日累和/3)/当前流通股本(手))为权重收盘价的12日指数移动平均的动态移动平均
VAR8赋值:(((收盘价 - VAR7) / VAR7) * 100)
VAR9赋值:((((1日前的VAR8 < (0 - 40)) AND (VAR8 > 1日前的VAR8)) AND (1日前的VAR8 < 2日前的VAR8)) AND ((VAR8 - 1日前的VAR8) > 2.5))
VARD赋值:1日前的收盘价
VARE赋值:(((收盘价-VARD)和0的较大值的5日[1日权重]移动平均 / (收盘价-VARD)的绝对值的5日[1日权重]移动平均) * 100)
VARF赋值:(((最高价 + 最低价) + 收盘价) / 3)
VAR10赋值:((VARF - VARF的14日简单移动平均) / (0.015 * VARF的14日平均绝对偏差))
VAR11赋值:(((((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100) - ((成交额(元)的110日简单移动平均 / 成交量(手)的110日简单移动平均) / 100)) / ((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100)) < (0 - 0.273))
VAR12赋值:(((收盘价 - 收盘价的30日简单移动平均) / 收盘价的30日简单移动平均) < (0 - 0.125))
VAR13赋值:(VAR11 AND VAR12)
VAR14赋值:((((VAR2 >= (0 - 45)) AND (VAR2 <= (0 - 10))) AND (VAR3 <= (0 - 15))) AND (VAR4 <= (0 - 20)))
VAR15赋值:(统计1日中满足VAR14的天数 >= 1)
VAR16赋值:(VAR13 AND VAR15)
VAR17赋值:1
VAR18赋值:(收盘价 * 成交量(手))
VAR19赋值:(((((VAR18的4日简单移动平均/成交量(手)的4日简单移动平均)+(VAR18的6日简单移动平均/成交量(手)的6日简单移动平均))+(VAR18的13日简单移动平均/成交量(手)的13日简单移动平均))+(VAR18的24日简单移动平均/成交量(手)的24日简单移动平均))/4)的1日指数移动平均
VAR1A赋值:(1 * VAR19)
VAR1B赋值:(VAR19 * 0.92)
VAR1C赋值:收盘价的34日指数移动平均
VAR1D赋值:(VAR1C*1.12)的5日简单移动平均
VAR1E赋值:(VAR1C*0.82)的5日简单移动平均
VAR1F赋值:(收盘价 < VAR1E)
VAR20赋值:((((((成交额(元)的5日简单移动平均 * VAR17) / 成交量(手)的5日简单移动平均) / 100) - ((成交额(元)的125日简单移动平均 / 成交量(手)的125日简单移动平均) / 100)) / ((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100)) < ((0 - 0.4) * VAR17))
VAR21赋值:500日内最高价的最高值
VAR22赋值:500日内最低价的最低值
VAR23赋值:250日内最高价的最高值
VAR24赋值:250日内最低价的最低值
VAR25赋值:125日内最高价的最高值
VAR26赋值:125日内最低价的最低值
VAR27赋值:((((((VAR21*0.45)+(VAR23*0.5))+VAR22)+VAR24)+VAR26)/5)的35日简单移动平均
VAR28赋值:(((VAR23*0.62)+VAR26)/2)的35日简单移动平均
VAR29赋值:(((VAR23*0.75)+VAR26)/2)的18日简单移动平均
VAR2A赋值:(((((VAR23*0.93)+(VAR27*2))+(VAR28*1.8))+(VAR29*1.5))/4)的18日简单移动平均
VAR2B赋值:((((VAR21*0.95)+(VAR27*3))+(VAR28*2))/3)的35日简单移动平均
VAR2C赋值:VAR27
VAR2D赋值:VAR28
VAR2E赋值:VAR29
VAR2F赋值:VAR2A
VAR30赋值:VAR2B
VAR31赋值:((收盘价 - 11日前的收盘价的20日简单移动平均) < (0 - 2))
VAR35赋值:((VAR18 / (VAR18 + VAR19)) * VAR17)
VAR36赋值:((VAR19 / (VAR18 + VAR19)) * VAR17)
VAR37赋值:VAR35的10日指数移动平均
VAR38赋值:VAR36的10日指数移动平均
VAR39赋值:VAR37的10日指数移动平均
VAR3A赋值:VAR38的20日指数移动平均
VAR3B赋值:VAR37的3日指数移动平均
VAR3C赋值:VAR39的6日指数移动平均
VAR3D赋值:VAR3A的2日指数移动平均
VAR3E赋值:(VAR3C - VAR3D)
VAR3F赋值:(((VAR3C - 1日前的VAR3C) > 0) AND ((1日前的VAR3C - 2日前的VAR3C) < 0))
VAR40赋值:如果(VAR3B上穿VAR3CAND(VAR3C<=20)),返回30,否则返回0
VAR41赋值:VAR40
VAR42赋值:(((成交额(元)/成交量(手))/100)的13日[1日权重]移动平均 * 1.15)
VAR43赋值:(((成交额(元)/成交量(手))/100)的13日[1日权重]移动平均 * 0.85)
VAR44赋值:(收盘价 - 11日前的收盘价的20日简单移动平均)
VAR45赋值:(((((((((((((收盘价 < VAR1E) AND VAR20) AND (收盘价 < VAR43)) OR (((收盘价 < VAR1E) AND VAR31) AND VAR20)) OR ((收盘价 < VAR1E) AND (收盘价 < VAR43))) OR (((收盘价 < VAR1E) AND VAR20) AND (收盘价 < VAR43))) OR (VAR20 AND (收盘价 < VAR2C))) OR ((VAR20 AND VAR31) AND (VAR44 < (0 - 1.5)))) OR (VAR20 AND (收盘价 < VAR1E))) OR (VAR20 AND (VAR44 < (0 - 1.5)))) OR (VAR31 AND (收盘价 < VAR43))) OR ((收盘价 < VAR2C) AND (VAR44 < (0 - 1.5)))) OR ((收盘价 < VAR1E) AND VAR31))
VAR4B赋值:(((最高价 + 最低价) + 收盘价) / 3)
VAR4C赋值:((VAR4B - VAR4B的14日简单移动平均) / (0.015 * VAR4B的14日平均绝对偏差))
VAR4D赋值:(((((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100) - ((成交额(元)的110日简单移动平均 / 成交量(手)的110日简单移动平均) / 100)) / ((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100)) < (0 - 0.273))
VAR4E赋值:(((收盘价 - 收盘价的30日简单移动平均) / 收盘价的30日简单移动平均) < (0 - 0.125))
VAR4F赋值:(VAR11 AND VAR12)
VAR50赋值:((((VAR2 >= (0 - 45)) AND (VAR2 <= (0 - 7))) AND (VAR3 <= (0 - 11))) AND (VAR4 <= (0 - 14)))
VAR51赋值:(统计1日中满足VAR50的天数 >= 1)
VAR52赋值:(VAR4F AND VAR51)
VAR53赋值:(((((VAR20 AND (收盘价 < VAR1E)) AND VAR31) AND (收盘价 < VAR2C)) AND VAR45) AND VAR52)
VAR5B赋值:((((((VAR2 >= (0 - 15.8)) AND (VAR2 <= (0 - 12.2))) AND (VAR3 <= (0 - 20.8))) AND (VAR4 <= (0 - 27.5))) AND (VARE <= 11.7)) AND (VAR4C <= (0 - 145)))
VAR5C赋值:9.999999884842E+0.26
VAR5D赋值:(获利盘为10%的成本分布 * 0)
VAR5E赋值:((((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100) - ((成交额(元)的125日简单移动平均 / 成交量(手)的125日简单移动平均) / 100)) / ((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100))
VAR5F赋值:(((45日内最低价的最低值-收盘价)/(45日内最高价的最高值-45日内最低价的最低值))*100)的5日简单移动平均
VAR60赋值:(((0-5)上穿VAR5F AND (VAR5E < (0 - 0.4))) AND (((收盘价 - 收盘价的30日简单移动平均) / 收盘价的30日简单移动平均) < (0 - 0.19)))
VAR61赋值:收盘价的3日简单移动平均
VAR62赋值:(2日前的收盘价 * 0.865)
VAR63赋值:(13日前的收盘价 * 0.772)
VAR64赋值:VAR62和VAR63的较小值
VAR65赋值:((100 * 成交量(手)) / 当前流通股本(手))
输出抄底:如果((((VAR9ORVAR16)ORVAR53)ORVAR5B)OR((((收盘价-VAR64)/收盘价)<0.03)AND((VAR65的5日累和/5)<1.8))),返回80,否则返回0,线宽为4,画红色
当满足条件抄底>0时,在抄底位置书写文字,COLOR00C5FF
小V逆转赋值:1日前的收盘价<1日前的开盘价 AND 开盘价>1日前的收盘价 AND 收盘价>=1日前的收盘价*1.08
当满足条件小V逆转时,在20和0位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR000099
当满足条件小V逆转时,在30和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0000BB
当满足条件小V逆转时,在40和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000DD
当满足条件小V逆转时,在60和0位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,COLOR0000FF
当满足条件小V逆转时,在60位置画34号图标
当满足条件小V逆转>0时,在30位置书写文字,COLOR00C5FF
HAN赋值:1
MA13赋值:收盘价的13日简单移动平均,画白色
MA34赋值:收盘价的34日简单移动平均,画黄色
MA55赋值:收盘价的55日简单移动平均,画红色
YY1赋值:开盘价<MA13 AND 收盘价>MA13
YY2赋值:开盘价<MA34 AND 收盘价>MA34
YY3赋值:开盘价<MA55 AND 收盘价>MA55
YY4赋值:收盘价/开盘价>=1.04
YY5赋值:成交量(手)>10日内最高价的最高值
YY6赋值:MA13>=1日前的MA13
天天涨停赋值:YY1 AND YY2 AND YY3 AND YY4 AND YY5 AND YY6
如果天天涨停,返回57,否则返回无效数,线宽为4,POINTDOT,COLOR00FF00
当满足条件天天涨停时,在26和20位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFFFFFF
当满足条件天天涨停时,在33和25位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR8800CC
当满足条件天天涨停时,在46和32位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORAA00DD
当满足条件天天涨停时,在37和34位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00AAFF
当满足条件天天涨停时,在50和44位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR000000
当满足条件天天涨停时,在39位置画9号图标
VA赋值:如果收盘价>1日前的收盘价,返回成交量(手),否则返回-成交量(手)
OBV1赋值:如果收盘价=1日前的收盘价,返回0,否则返回VA的历史累和
OBV2赋值:OBV1的3日指数移动平均-OBV1的9日简单移动平均
OBV3赋值:如果OBV2>0,返回OBV2,否则返回0的3日指数移动平均
MAC3赋值:收盘价的3日简单移动平均
SHORT赋值:12
LONG赋值:26
MID赋值:9
输出DIF:收盘价的SHORT日指数移动平均-收盘价的LONG日指数移动平均画黄色
输出主力买:如果DIF>1日前的DIF,返回DIF,否则返回0,NODRAW
输出主力卖:如果DIF<1日前的DIF,返回DIF,否则返回0,NODRAW
当满足条件OBV3>1日前的OBV3ANDMAC3>1日前的MAC3时,在0和平滑异同平均位置之间画柱状线,宽度为4.9,0不为0则画空心柱.,画黄色
吸赋值:平滑异同平均<0 AND 平滑异同平均>1日前的平滑异同平均
拉赋值:平滑异同平均>0 AND 平滑异同平均>1日前的平滑异同平均
派赋值:平滑异同平均>0 AND 平滑异同平均<1日前的平滑异同平均
落赋值:平滑异同平均<0 AND 平滑异同平均<1日前的平滑异同平均
当满足条件吸时,在0和平滑异同平均位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,画红色
当满足条件拉时,在0和平滑异同平均位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,画红色
当满足条件派时,在0和平滑异同平均位置之间画柱状线,宽度为3.8,0不为0则画空心柱.,画绿色
当满足条件落时,在0和平滑异同平均位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,画绿色
输出主力吸筹:吸,画黄色,NODRAW
输出主力拉升:拉,画红色,NODRAW
输出主力出逃:派,画绿色,NODRAW
输出主力砸盘:落,COLORFFAA00,NODRAW
RSV赋值:(收盘价-6日内最低价的最低值)/(6日内最高价的最高值-6日内最低价的最低值)*100
K赋值:RSV的2日[1日权重]移动平均
D赋值:K的2日[1日权重]移动平均
J赋值:3*K-2*D
RS赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
F赋值:100
K1赋值:RS>=100
K2赋值:RS<100
当满足条件K1上穿K2时,在K1位置画27号图标
当满足条件1时,在横轴0.0纵轴0.01位置书写文字画黄色
当满足条件1日前的收盘价6%的之字转向上穿收盘价6%的之字转向时,在最高价*0.1位置书写文字画绿色
当满足条件1日前的收盘价6%的之字转向上穿收盘价6%的之字转向时,在最高价*0.1位置画9号图标
V1赋值:收盘价的60日指数移动平均-收盘价的300日指数移动平均
V6赋值:收盘价/3日前的收盘价>=1.1
V7赋值:若V6则将最近3周期置为1
输出买入暴张:如果(V7ANDCOUNT(V7,3)=1),返回30,否则返回0,画黄色,线宽为3
当满足条件V7*0.8>0时,在32位置书写文字,COLOR00C5FF
输出买卖盘比▇: 1/内外比,画深灰色,NODRAW
如果买卖盘比▇>0.9,返回买卖盘比▇,否则返回无效数,画白色,NODRAW
如果买卖盘比▇>1.3,返回买卖盘比▇,否则返回无效数,画红色,NODRAW
当满足条件1时,在横轴0.5纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.51纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.52纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.53纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.54纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.55纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.56纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.57纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.58纵轴0位置书写文字,画深灰色
当满足条件买卖盘比▇>0.5时,在横轴0.5纵轴0位置书写文字,画淡绿色
当满足条件买卖盘比▇>0.6时,在横轴0.51纵轴0位置书写文字,画淡绿色
当满足条件买卖盘比▇>0.7时,在横轴0.52纵轴0位置书写文字,画淡绿色
当满足条件买卖盘比▇>0.75时,在横轴0.53纵轴0位置书写文字,COLOR00CCFF
当满足条件买卖盘比▇>0.8时,在横轴0.54纵轴0位置书写文字,COLOR00CCFF
当满足条件买卖盘比▇>0.85时,在横轴0.55纵轴0位置书写文字,COLOR00CCFF
当满足条件买卖盘比▇>0.9时,在横轴0.56纵轴0位置书写文字,COLOR000066
当满足条件买卖盘比▇>0.95时,在横轴0.57纵轴0位置书写文字,COLOR000066
当满足条件买卖盘比▇>1时,在横轴0.58纵轴0位置书写文字,COLOR000066
当满足条件1时,在横轴0.56纵轴0位置书写文字,画黑色
当满足条件1时,在横轴0.6纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.61纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.62纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.63纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.64纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.65纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.66纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.67纵轴0位置书写文字,画深灰色
当满足条件1时,在横轴0.68纵轴0位置书写文字,画深灰色
当满足条件买卖盘比▇>1.05时,在横轴0.6纵轴0位置书写文字,画绿色
当满足条件买卖盘比▇>1.1时,在横轴0.61纵轴0位置书写文字,画绿色
当满足条件买卖盘比▇>1.15时,在横轴0.62纵轴0位置书写文字,画绿色
当满足条件买卖盘比▇>1.2时,在横轴0.63纵轴0位置书写文字,画黄色
当满足条件买卖盘比▇>1.25时,在横轴0.64纵轴0位置书写文字,画黄色
当满足条件买卖盘比▇>1.3时,在横轴0.65纵轴0位置书写文字,画黄色
当满足条件买卖盘比▇>1.4时,在横轴0.66纵轴0位置书写文字,画红色
当满足条件买卖盘比▇>1.5时,在横轴0.67纵轴0位置书写文字,画红色
当满足条件买卖盘比▇>1.6时,在横轴0.68纵轴0位置书写文字,画红色
当满足条件1时,在横轴0.65纵轴0位置书写文字,画黑色
输出MA1:收盘价的5日指数移动平均,画黄色,线宽为6
KK赋值:MA1<1日前的MA1
如果KK,返回MA1,否则返回无效数,画绿色,线宽为6
DD赋值:MA1>1日前的MA1
如果DD,返回MA1,否则返回无效数,画蓝色,线宽为6
B1赋值:(30日内最高价的最高值-收盘价)/(30日内最高价的最高值-30日内最低价的最低值)*100-30
B2赋值:B1的30日[1日权重]移动平均+100
B3赋值:(收盘价-30日内最低价的最低值)/(30日内最高价的最高值-30日内最低价的最低值)*100
B4赋值:B3的3日[1日权重]移动平均
B5赋值:B4的3日[1日权重]移动平均+100
B6赋值:B5-B2
输出控盘程度:(如果B6>1,返回B6-1,否则返回0)*2.5,画红色,线宽为0
输出控盘度:100,画白色 线宽为4

输出持币:如果步长为2极限值为20的10日抛物转向>=最高价,返回100,否则返回无效数,线宽为4 画蓝色
输出持股:如果步长为2极限值为20的10日抛物转向<=最低价,返回100,否则返回无效数,线宽为4,画红色
VARR1赋值:收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均*100
当满足条件82上穿VARR1时,在60位置画5号图标
当满足条件82上穿VARR1时,在60位置书写文字,画绿色,线宽为4[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1tjWxyLAIZtvMAw3AziGPmQ

看了该指标的人还看了:
买卖点指标    底部警戒指标
峰谷买卖指标    买卖提示指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表