请选择 进入手机版|继续访问电脑版

黑马早发现指标 通达信 副图 波段 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-10-8 08:00:11 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
黑马早发现指标 通达信 副图 波段 短线 买卖点 炒股叉第10123张

黑马早发现指标 通达信 副图 波段 短线 买卖点 炒股叉第10124张

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR2N:=1;
V1:=(MA(((100 * (CLOSE - LLV(CLOSE,34))) / (HHV(HIGH,34) - LLV(LOW,34))),5) - 20);
V2:=(2 * ABS(V1));
V3:=(100 - ((100 - (3 * SMA((((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1))) + (2 * SMA(SMA((((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1),15,1))));
V4:=(100 - ((100 - (3 * SMA((((OPEN - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1))) + (2 * SMA(SMA((((OPEN - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100),20,1),15,1))));
V5:=(((HIGH + LOW) + CLOSE) / 3);
V6:=((V5 - MA(V5,10)) / (0.015 * AVEDEV(V5,10)));
V7:=((V5 - MA(V5,30)) / (0.015 * AVEDEV(V5,30)));
V8:=IF(((((V6 >= 150) AND (V6 < 200)) AND (V7 >= 150)) AND (V7 < 200)),10,0);
V9:=(IF(((((V6 <= (0 - 150)) AND (V6 > (0 - 200))) AND (V7 <= (0 - 150))) AND (V7 > (0 - 200))),(0 - 10),V8) * VAR2N);
VA:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * 100);
VB:=(100 - ABS(VA));
VC:=((3 * SMA((((INDEXC - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1)) - (2 * SMA(SMA((((INDEXC - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1),15,1)));
VD:=((3 * SMA((((INDEXO - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1)) - (2 * SMA(SMA((((INDEXO - LLV(INDEXL,55)) / (HHV(INDEXH,55) - LLV(INDEXL,55))) * 100),20,1),15,1)));
VE:=(REF(LOW,1) * 0.9);
VF:=(LOW * 0.9);
V10:=(((VF * VOL) + (VE * (CAPITAL - VOL))) / CAPITAL);
V11:=EMA(V10,30);
V12:=(V11 - CLOSE);
V13:=REF(CLOSE,1);
V14:=((SMA(MAX((CLOSE - V13),0),7,1) / SMA(ABS((CLOSE - V13)),7,1)) * 100);
V15:=((SMA(MAX((CLOSE - V13),0),13,1) / SMA(ABS((CLOSE - V13)),13,1)) * 100);
V16:=BARSCOUNT(CLOSE);
V17:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),6,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),6,1)) * 100);
V18:=(((((0 - 100) * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60))) + 50) * 2);
V19:=(((CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15))) * 100);
V1A:=((SMA(V19,4,1) - 50) * 2);
V1B:=SMA(V1A,3,1);
V1C:=(((INDEXC - LLV(INDEXL,14)) / (HHV(INDEXH,14) - LLV(INDEXL,14))) * 100);
V1D:=SMA(V1C,4,1);
V1E:=SMA(V1D,3,1);
V1F:=(((HHV(HIGH,30) - CLOSE) / CLOSE) * 100);
V20:=(IF((((((((((V17 <= 25) AND (V18 < (0 - 95))) AND (V1F > 20)) AND (V1B < (0 - 30))) AND (V1E < 30)) AND (V12 >= (0 - 0.25))) AND (V14 < 22)) AND (V15 < 28)) AND (V16 > 50)),80,0) * VAR2N);
空方:(0 - (IF((V1 < 0),V2,0) * VAR2N)),LINESTICK;
(0 - 40);
C0:=(((HIGH + LOW) + CLOSE) / 3);
A1:=HHV(C0,14);
A2:=LLV(C0,14);
A3:=(A1 - A2);
A4:=(EMA(((C0 - A2) / A3),2) * 100);
B1:=HHV(C0,30);
B2:=LLV(C0,30);
B3:=(B1 - B2);
B4:=(EMA(((C0 - B2) / B3),2) * 100);
C1:=HHV(C0,55);
C2:=LLV(C0,55);
C3:=(C1 - C2);
C4:=(EMA(((C0 - C2) / C3),2) * 100);
A10:=(A4 - 50);
A20:=(B4 - 50);
A30:=(C4 - 50);
DRAWICON(CROSS(A1,0),0,4);
RSV2:=(((CLOSE - LLV(LOW,30)) / (HHV(HIGH,30) - LLV(LOW,30))) * 100);
K2:=SMA(RSV2,3,1);
D2:=SMA(K2,3,1);
J2:=((3 * K2) - (2 * D2));
动力线:(EMA(J2,6) * VAR2N),COLOR00FFFF;
VAR2W:=EMA(CLOSE,5);
RSI1W:=((SMA(MAX((CLOSE - VAR2W),0),6,1) / SMA(ABS((CLOSE - VAR2W)),6,1)) * 100);
RSI2W:=((SMA(MAX((CLOSE - VAR2W),0),3,1) / SMA(ABS((CLOSE - VAR2W)),3,1)) * 100);
VAR1F:="KDJ.D"(18,5,6);
虎:IF(((((((((动力线 < 15.5) AND (空方 < (0 - 30))) AND (VAR1F < 35)) AND (RSI1W < 10)) AND (RSI2W < 6.5)) AND (A10 < (0 - 47))) AND (A20 < (0 - 47))) AND (A30 < (0 - 48.5))),50,0);
牛:(IF(((空方 < (0 - 38)) AND (虎 > 0)),70,0) * VAR2N);
VAR2:=(((((MA(AMOUNT,5) / MA(VOL,5)) / 100) - ((MA(AMOUNT,110) / MA(VOL,110)) / 100)) / ((MA(AMOUNT,5) / MA(VOL,5)) / 100)) < (0 - 0.273));
VAR21:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
VAR22:=(((CLOSE - MA(CLOSE,30)) / MA(CLOSE,30)) < (0 - 0.125));
获利线:=(VAR2 AND VAR22);
LC:=EMA((WINNER(CLOSE) * 100),3);
VAR2Q:=EMA(CLOSE,3);
神奇线:=((SMA(MAX((CLOSE - VAR2Q),0),6,1) / SMA(ABS((CLOSE - VAR2Q)),6,1)) * 100);
买点一:=MA(神奇线,10);
牛A:(IF((VAR22 AND (神奇线 < 3)),(0 - 40),0) * VAR2N),LINETHICK2,COLOR3399FF;
牛B:(IF((VAR22 AND (买点一 < 9)),(0 - 38),0) * VAR2N),LINETHICK2,COLOR3399FF;
剑:(FILTER(((神奇线 < 6) AND 获利线),35) * 1),STICK,LINETHICK2,COLORFF0000;
DRAWICON((剑 > 0),1,1);
牛3:(IF((((LC < 1.5) AND (买点一 < 21)) AND (神奇线 < 5.5)),80,0) * VAR2N),LINETHICK2,COLOR3399FF;
VAR1N:=1050431;
VAR2N1:=IF((DATE<=VAR1N),1,0);
稳赚:=(MA(CLOSE,80) - (MA(CLOSE,13) / 3));
买点二:=MA(((CLOSE - 稳赚) / 稳赚),1);
XA:=IF((CROSS(买点二,0) AND ((LOW / REF(HIGH,1)) < 1.012)),0.5,0);
XB:=IF((((COUNT((买点二 > REF(买点二,1)),3) = 3) AND (COUNT((买点二 < 0),10) = 10)) AND (REF(买点二,3) = LLV(买点二,10))),0.5,0);
VAR82:=IF((((((REF(买点二,2) = LLV(买点二,20)) AND (REF(买点二,2) < 0.071)) AND (REF(买点二,2) < REF(买点二,1))) AND NOT(((REF(LOW,1) > REF(HIGH,2)) AND (LOW > REF(HIGH,1))))) AND (CLOSE > REF(CLOSE,1))),0.5,0);
VAR83:=(EMA(买点二,12) * 0.7);
VAR84:=EMA(买点二,3);
底部将成:(IF((LLV((VAR84 - VAR83),5) > 0),0,(0 - 40)) * VAR2N1),COLORFFCC66;[/lycode][lycode=tdx2,true]VAR2N赋值:1
V1赋值:(((100*(收盘价-34日内收盘价的最低值))/(34日内最高价的最高值-34日内最低价的最低值))的5日简单移动平均 - 20)
V2赋值:(2 * V1的绝对值)
V3赋值:(100 - ((100 - (3 * (((收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值))*100)的20日[1日权重]移动平均)) + (2 * (((收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值))*100)的20日[1日权重]移动平均的15日[1日权重]移动平均)))
V4赋值:(100 - ((100 - (3 * (((开盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值))*100)的20日[1日权重]移动平均)) + (2 * (((开盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值))*100)的20日[1日权重]移动平均的15日[1日权重]移动平均)))
V5赋值:(((最高价 + 最低价) + 收盘价) / 3)
V6赋值:((V5 - V5的10日简单移动平均) / (0.015 * V5的10日平均绝对偏差))
V7赋值:((V5 - V5的30日简单移动平均) / (0.015 * V5的30日平均绝对偏差))
V8赋值:如果((((V6>=150)AND(V6<200))AND(V7>=150))AND(V7<200)),返回10,否则返回0
V9赋值:(如果((((V6<=(0-150))AND(V6>(0-200)))AND(V7<=(0-150)))AND(V7>(0-200))),返回(0-10),否则返回V8 * VAR2N)
VA赋值:(((收盘价 - 收盘价的13日简单移动平均) / 收盘价的13日简单移动平均) * 100)
VB赋值:(100 - VA的绝对值)
VC赋值:((3 * (((大盘的收盘价-55日内大盘的最低价的最低值)/(55日内大盘的最高价的最高值-55日内大盘的最低价的最低值))*100)的20日[1日权重]移动平均) - (2 * (((大盘的收盘价-55日内大盘的最低价的最低值)/(55日内大盘的最高价的最高值-55日内大盘的最低价的最低值))*100)的20日[1日权重]移动平均的15日[1日权重]移动平均))
VD赋值:((3 * (((大盘的开盘价-55日内大盘的最低价的最低值)/(55日内大盘的最高价的最高值-55日内大盘的最低价的最低值))*100)的20日[1日权重]移动平均) - (2 * (((大盘的开盘价-55日内大盘的最低价的最低值)/(55日内大盘的最高价的最高值-55日内大盘的最低价的最低值))*100)的20日[1日权重]移动平均的15日[1日权重]移动平均))
VE赋值:(1日前的最低价 * 0.9)
VF赋值:(最低价 * 0.9)
V10赋值:(((VF * 成交量(手)) + (VE * (当前流通股本(手) - 成交量(手)))) / 当前流通股本(手))
V11赋值:V10的30日指数移动平均
V12赋值:(V11 - 收盘价)
V13赋值:1日前的收盘价
V14赋值:(((收盘价-V13)和0的较大值的7日[1日权重]移动平均 / (收盘价-V13)的绝对值的7日[1日权重]移动平均) * 100)
V15赋值:(((收盘价-V13)和0的较大值的13日[1日权重]移动平均 / (收盘价-V13)的绝对值的13日[1日权重]移动平均) * 100)
V16赋值:收盘价的有效数据周期数
V17赋值:(((收盘价-1日前的收盘价)和0的较大值的6日[1日权重]移动平均 / (收盘价-1日前的收盘价)的绝对值的6日[1日权重]移动平均) * 100)
V18赋值:(((((0 - 100) * (60日内最高价的最高值 - 收盘价)) / (60日内最高价的最高值 - 60日内最低价的最低值)) + 50) * 2)
V19赋值:(((收盘价 - 15日内最低价的最低值) / (15日内最高价的最高值 - 15日内最低价的最低值)) * 100)
V1A赋值:((V19的4日[1日权重]移动平均 - 50) * 2)
V1B赋值:V1A的3日[1日权重]移动平均
V1C赋值:(((大盘的收盘价 - 14日内大盘的最低价的最低值) / (14日内大盘的最高价的最高值 - 14日内大盘的最低价的最低值)) * 100)
V1D赋值:V1C的4日[1日权重]移动平均
V1E赋值:V1D的3日[1日权重]移动平均
V1F赋值:(((30日内最高价的最高值 - 收盘价) / 收盘价) * 100)
V20赋值:(如果(((((((((V17<=25)AND(V18<(0-95)))AND(V1F>20))AND(V1B<(0-30)))AND(V1E<30))AND(V12>=(0-0.25)))AND(V14<22))AND(V15<28))AND(V16>50)),返回80,否则返回0 * VAR2N)
输出空方:(0 - (如果(V1<0),返回V2,否则返回0 * VAR2N)),LINESTICK
(0 - 40)
C0赋值:(((最高价 + 最低价) + 收盘价) / 3)
A1赋值:14日内C0的最高值
A2赋值:14日内C0的最低值
A3赋值:(A1 - A2)
A4赋值:(((C0-A2)/A3)的2日指数移动平均 * 100)
B1赋值:30日内C0的最高值
B2赋值:30日内C0的最低值
B3赋值:(B1 - B2)
B4赋值:(((C0-B2)/B3)的2日指数移动平均 * 100)
C1赋值:55日内C0的最高值
C2赋值:55日内C0的最低值
C3赋值:(C1 - C2)
C4赋值:(((C0-C2)/C3)的2日指数移动平均 * 100)
A10赋值:(A4 - 50)
A20赋值:(B4 - 50)
A30赋值:(C4 - 50)
当满足条件A1上穿0时,在0位置画4号图标
RSV2赋值:(((收盘价 - 30日内最低价的最低值) / (30日内最高价的最高值 - 30日内最低价的最低值)) * 100)
K2赋值:RSV2的3日[1日权重]移动平均
D2赋值:K2的3日[1日权重]移动平均
J2赋值:((3 * K2) - (2 * D2))
输出动力线:(J2的6日指数移动平均 * VAR2N),COLOR00FFFF
VAR2W赋值:收盘价的5日指数移动平均
RSI1W赋值:(((收盘价-VAR2W)和0的较大值的6日[1日权重]移动平均 / (收盘价-VAR2W)的绝对值的6日[1日权重]移动平均) * 100)
RSI2W赋值:(((收盘价-VAR2W)和0的较大值的3日[1日权重]移动平均 / (收盘价-VAR2W)的绝对值的3日[1日权重]移动平均) * 100)
VAR1F赋值:"KDJ的D"(18,5,6)
输出虎:如果((((((((动力线<15.5)AND(空方<(0-30)))AND(VAR1F<35))AND(RSI1W<10))AND(RSI2W<6.5))AND(A10<(0-47)))AND(A20<(0-47)))AND(A30<(0-48.5))),返回50,否则返回0
输出牛:(如果((空方<(0-38))AND(虎>0)),返回70,否则返回0 * VAR2N)
VAR2赋值:(((((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100) - ((成交额(元)的110日简单移动平均 / 成交量(手)的110日简单移动平均) / 100)) / ((成交额(元)的5日简单移动平均 / 成交量(手)的5日简单移动平均) / 100)) < (0 - 0.273))
VAR21赋值:(((收盘价 - 9日内最低价的最低值) / (9日内最高价的最高值 - 9日内最低价的最低值)) * 100)
VAR22赋值:(((收盘价 - 收盘价的30日简单移动平均) / 收盘价的30日简单移动平均) < (0 - 0.125))
获利线赋值:(VAR2 AND VAR22)
LC赋值:(以收盘价计算的获利盘比例*100)的3日指数移动平均
VAR2Q赋值:收盘价的3日指数移动平均
神奇线赋值:(((收盘价-VAR2Q)和0的较大值的6日[1日权重]移动平均 / (收盘价-VAR2Q)的绝对值的6日[1日权重]移动平均) * 100)
买点一赋值:神奇线的10日简单移动平均
输出牛A:(如果(VAR22AND(神奇线<3)),返回(0-40),否则返回0 * VAR2N),线宽为2,COLOR3399FF
输出牛B:(如果(VAR22AND(买点一<9)),返回(0-38),否则返回0 * VAR2N),线宽为2,COLOR3399FF
输出剑:(((神奇线<6)AND获利线)的35日过滤 * 1),STICK,线宽为2,COLORFF0000
当满足条件(剑>0)时,在1位置画1号图标
输出牛3:(如果(((LC<1.5)AND(买点一<21))AND(神奇线<5.5)),返回80,否则返回0 * VAR2N),线宽为2,COLOR3399FF
VAR1N赋值:1050431
VAR2N1赋值:如果(日期<=VAR1N),返回1,否则返回0
稳赚赋值:(收盘价的80日简单移动平均 - (收盘价的13日简单移动平均 / 3))
买点二赋值:((收盘价-稳赚)/稳赚)的1日简单移动平均
XA赋值:如果(买点二上穿0AND((最低价/1日前的最高价)<1.012)),返回0.5,否则返回0
XB赋值:如果(((统计3日中满足(买点二>1日前的买点二)的天数=3)AND(统计10日中满足(买点二<0)的天数=10))AND(3日前的买点二=10日内买点二的最低值)),返回0.5,否则返回0
VAR82赋值:如果(((((2日前的买点二=20日内买点二的最低值)AND(2日前的买点二<0.071))AND(2日前的买点二<1日前的买点二))ANDNOT(((1日前的最低价>2日前的最高价)AND(最低价>1日前的最高价))))AND(收盘价>RE,返回(收盘价,1))),否则返回0.5
VAR83赋值:(买点二的12日指数移动平均 * 0.7)
VAR84赋值:买点二的3日指数移动平均
输出底部将成:(如果(5日内(VAR84-VAR83)的最低值>0),返回0,否则返回(0-40) * VAR2N1),COLORFFCC66[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1F7v3sVXSCcCqrhj7fZoa7Q

看了该指标的人还看了:
金钱摸鬼指标    精准抄底指标
最佳综合顶底指标    一年四倍指标 改编自飞狐主图

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表