请选择 进入手机版|继续访问电脑版

绝密一号指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 7 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 
绝密一号指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第10121张

绝密一号指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第10122张

[lywrap=通达信主图指标公式][lycode=tdx,true]V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
支撑:REFDATE(V2,DATE),POINTDOT,LINETHICK3,COLORCC66FF;
阻力:REFDATE(V3,DATE),POINTDOT,LINETHICK3,COLORGREEN;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,L,L*0.98,3,0),COLORYELLOW;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,H*1.01,H,3,0),COLOR00FF00{98FD};
MA3:MA(C,3);
MA5:MA(C,5),COLORWHITE;
MA10:=MA(C,10),NODRAW;
MA30:MA(C,34),NODRAW;
五日乖离率:=(C-MA5)/MA5*100;
BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORRED;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORGREEN;
DD5:=MA5<REF(MA5,1);
IF(DD5,MA5,DRAWNULL),COLOR00FF00;
X:=(3*C+L+O+H)/6;
多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK1;
{用法:黄托底买进,绿压顶买出。}
DD:=多空线<REF(多空线,1);
IF(DD,多空线,DRAWNULL),COLORBLUE,LINETHICK2;
A:=(MA5>多空线);
IF(A,多空线,DRAWNULL),COLORYELLOW,POINTDOT;
A1:=(MA5<多空线);
IF(A1,多空线,DRAWNULL),COLORWHITE;
A2:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
A4:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
A5:=EMA(CLOSE,12)-EMA(CLOSE,26);
A6:=EMA(A5,9);
A7:=(A5<-0.1 AND A5>A6);
财神:IF(A7,LLV(L,21),DRAWNULL)COLORRED,CIRCLEDOT;
CYS:=(EMA((CLOSE-V2)/V2,1)*100);
AA:=CYS;
MIDD:=MA(CYS,20);
CC:=MIDD+0.85*STD(CYS,10);
TM6:=AA>CC;
IF(TM6,MA5,DRAWNULL),COLORRED,LINETHICK1;
A0:=(L+H+C*2)/4;
工作:=EMA(A0,14)COLORYELLOW,LINETHICK1;
度假:=EMA(A0,25)COLORYELLOW,LINETHICK1;
A1X:=(工作-REF(工作,1))/REF(工作,1)*100;
A2X:=(度假-REF(度假,1))/REF(度假,1)*100;
G:=BARSLAST(CROSS(A1X,0));
{KDJ}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
买1:=(VAR14 OR VAR15) AND VAR11;
买2:=(VAR14 OR VAR15) AND VAR4;
买3:=(VAR14 OR VAR15) AND VAR2;
买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);
买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);
{涨停}
STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;
{跌停}
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;
{蓝}
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;
{红}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
{绿}
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3,0),COLOR009900;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00;
STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;
{灰}
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;
STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;
STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;
STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLOR000099;
DRAWICON(VAR16,LOW-0.02,7);
DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5,LOW-0.01,1);
DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR9),HIGH+0.01,2);
STICKLINE(CROSS(A1X,0),C,O,1,0)COLORFFFFFF;
STICKLINE(CROSS(0,A1X),C,O,1,0)COLORGREEN;[/lycode][lycode=tdx2,true]V1赋值:(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均
V2赋值:(1-7/100)*(以V1为权重收盘价的动态移动平均)
V3赋值:(1+7/100)*(以V1为权重收盘价的动态移动平均)
V5赋值:(最低价+最高价+收盘价)/3的5日简单移动平均
输出支撑:日期日V2,POINTDOT,线宽为3,COLORCC66FF
输出阻力:日期日V3,POINTDOT,线宽为3,画绿色
VAR1赋值:收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价
VAR2赋值:1日前的VAR1 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR3赋值:1日前的VAR2 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR4赋值:1日前的VAR3 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR5赋值:1日前的VAR4 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR6赋值:1日前的VAR5 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR7赋值:1日前的VAR6 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR8赋值:1日前的VAR7 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR9赋值:1日前的VAR8 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARA赋值:1日前的VAR9 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VARB赋值:1日前的VARA AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARC赋值:1日前的VARB AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VARD赋值:收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价
VARE赋值:1日前的VARD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VARF赋值:1日前的VARE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR10赋值:1日前的VARF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR11赋值:1日前的VAR10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR12赋值:1日前的VAR11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR13赋值:1日前的VAR12 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR14赋值:1日前的VAR13 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR15赋值:1日前的VAR14 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR16赋值:1日前的VAR15 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR17赋值:1日前的VAR16 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
VAR18赋值:1日前的VAR17 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
VAR19赋值:1日前的VARDORVAREORVARFORVAR10ORVAR11ORVAR12ORVAR13ORVAR14ORVAR15ORVAR16ORVAR17ORVAR18 AND VAR1
当满足条件VAR19时,在最低价和最低价*0.98位置之间画柱状线,宽度为3,0不为0则画空心柱.,画黄色
VAR1A赋值:1日前的VAR1ORVAR2ORVAR3ORVAR4ORVAR5ORVAR6ORVAR7ORVAR8ORVAR9ORVARAORVARBORVARC AND VARD
当满足条件VAR1A时,在最高价*1.01和最高价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FF00
输出MA3:收盘价的3日简单移动平均
输出MA5:收盘价的5日简单移动平均,画白色
MA10赋值:收盘价的10日简单移动平均,NODRAW
输出MA30:收盘价的34日简单移动平均,NODRAW
五日乖离率赋值:(收盘价-MA5)/MA5*100
BB5赋值:(MA5/1日前的MA5-1)*100的反正切*180/3.1416
如果BB5>30ANDMA5>1日前的MA5,返回MA5,否则返回无效数,线宽为1,画红色
BB10赋值:(MA10/1日前的MA10-1)*100的反正切*180/3.1416
如果BB5<0ANDMA5<1日前的MA5,返回MA5,否则返回无效数,线宽为1,画绿色
DD5赋值:MA5<1日前的MA5
如果DD5,返回MA5,否则返回无效数,COLOR00FF00
X赋值:(3*收盘价+最低价+开盘价+最高价)/6
输出多空线:(20*X+19*1日前的X+18*2日前的X+17*3日前的X+16*4日前的X+15*5日前的X+14*6日前的X+13*7日前的X+12*8日前的X+11*9日前的X+10*10日前的X+9*11日前的X+8*12日前的X+7*13日前的X+6*14日前的X+5*15日前的X+4*16日前的X+3*17日前的X+2*18日前的X+20日前的X)/210,COLORFF00FF,线宽为1
DD赋值:多空线<1日前的多空线
如果DD,返回多空线,否则返回无效数,画蓝色,线宽为2
A赋值:(MA5>多空线)
如果A,返回多空线,否则返回无效数,画黄色,POINTDOT
A1赋值:(MA5<多空线)
如果A1,返回多空线,否则返回无效数,画白色
A2赋值:3*(收盘价-30日内最低价的最低值)/(30日内最高价的最高值-30日内最低价的最低值)*100的5日指数移动平均-2*(收盘价-30日内最低价的最低值)/(30日内最高价的最高值-30日内最低价的最低值)*100的5日指数移动平均
A4赋值:(34日内最高价的最高值-收盘价)/(34日内最高价的最高值-34日内最低价的最低值)*100
A5赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
A6赋值:A5的9日指数移动平均
A7赋值:(A5<-0.1 AND A5>A6)
输出财神:如果A7,返回21日内最低价的最低值,否则返回无效数画红色,CIRCLEDOT
CYS赋值:((收盘价-V2)/V2的1日指数移动平均*100)
AA赋值:CYS
MIDD赋值:CYS的20日简单移动平均
CC赋值:MIDD+0.85*CYS的10日估算标准差
TM6赋值:AA>CC
如果TM6,返回MA5,否则返回无效数,画红色,线宽为1
A0赋值:(最低价+最高价+收盘价*2)/4
工作赋值:A0的14日指数移动平均画黄色,线宽为1
度假赋值:A0的25日指数移动平均画黄色,线宽为1
A1X赋值:(工作-1日前的工作)/1日前的工作*100
A2X赋值:(度假-1日前的度假)/1日前的度假*100
G赋值:上次A1X上穿0距今天数
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
J赋值:3*K-2*D
金叉赋值:J上穿D
死叉赋值:D上穿J
买1赋值:(VAR14 OR VAR15) AND VAR11
买2赋值:(VAR14 OR VAR15) AND VAR4
买3赋值:(VAR14 OR VAR15) AND VAR2
买4赋值:(VAR2 AND VAR11) OR (VAR4 AND VAR11)
买5赋值:(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11)
当满足条件收盘价>1日前的收盘价*1.0985ANDCLOSE=最高价时,在收盘价和开盘价位置之间画柱状线,宽度为4,-1不为0则画空心柱.,COLOR00FFFF
当满足条件收盘价<1日前的收盘价*0.9015ANDCLOSE=最低价时,在收盘价和开盘价位置之间画柱状线,宽度为4,-1不为0则画空心柱.,画绿色
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF7700
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLORFF9900
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFFBB00
当满足条件开盘价>=收盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画青色
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000099
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR0000CC
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000FF
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORCC66FF
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR009900
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR00BB00
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR00DD00
当满足条件VAR3时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00FF00
当满足条件VAR4时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR999999
当满足条件VAR4时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLORBBBBBB
当满足条件VAR4时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORDDDDDD
当满足条件VAR4时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFFFFF
当满足条件金叉时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画黄色
当满足条件死叉时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR000099
当满足条件VAR16时,在最低价-0.02位置画7号图标
当满足条件买1OR买2OR买3OR买4OR买5时,在最低价-0.01位置画1号图标
当满足条件死叉ORVAR12ORCROSS(40,VAR9)时,在最高价+0.01位置画2号图标
当满足条件A1X上穿0时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.COLORFFFFFF
当满足条件0上穿A1X时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.画绿色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1tZ4v3ouejzpTn5_fyYrumA

看了该指标的人还看了:
自动波浪指标    星光灿烂指标
一柱擎天指标    波浪自动画线指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表