请选择 进入手机版|继续访问电脑版

暴涨启动指标 通达信 主图 波段 无未来函数 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-10-8 08:00:11 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 
暴涨启动指标 通达信 主图 波段 无未来函数 短线 买卖点 炒股叉第10115张

暴涨启动指标 通达信 主图 波段 无未来函数 短线 买卖点 炒股叉第10116张

[lywrap=通达信主图指标公式][lycode=tdx,true]MA5:MA(C,5);
MA10 :MA(CLOSE,10);
MA60 : MA(CLOSE,60);
GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10));
GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20));
GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30));
BAIJIN1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2;
BAIJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
BAIJIN3:=GJTJ1>60 AND GJTJ4>70;
DRAWTEXT(BAIJIN1 AND BAIJIN2 AND BAIJIN3,L-0.02,'白金');
HUANGJIN1:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3;
HUANGJIN2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4;
DRAWTEXT(HUANGJIN1 AND HUANGJIN2,L-0.03,'黄金');
XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5 AND GJTJ1>GJTJ4;
DRAWTEXT(COUNT(XG,3)=1 AND XG AND C>MA(C,20),L-0.02,'暴涨启动'),COLORRED;
ZHENCANG1:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
ZHENCANG2:=BARSLAST(CROSS(GJTJ4,GJTJ2));
ZHENCANG3:=GJTJ3<GJTJ4 AND GJTJ2<GJTJ4;
ZHENCANG4:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3;
ZHENCANG5:=GJTJ2<GJTJ3 AND GJTJ2<GJTJ4 AND GJTJ2<GJTJ1 AND GJTJ1=100;
ZCB1:=ZHENCANG1>0 AND REF(ZHENCANG1,1)=0 AND REF(ZHENCANG1,2)>0;
DRAWTEXT(ZHENCANG1 AND ZHENCANG2 AND ZHENCANG3 AND ZHENCANG4 AND ZHENCANG5,L-0.05,'震仓启点');
AA:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BB:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA1:=AA AND BB;
AAA:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAA:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA2:=AA AND BB ;
AAAA:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1;
BAAA:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1;
AA3:=AAAA AND BAAA ;
BB1:=REF(AA1,1);
BB2:=REF(AA2,1);
BB3:=REF(AA3,1);

DD1:=GJTJ1=100 AND GJTJ2=100 AND AA1 ;
DD2:=GJTJ1=100 AND GJTJ2=100 AND AA2 ;
DD3:=GJTJ1=100 AND GJTJ2=100 AND AA3 ;
DRAWTEXT(DD1 OR DD2 OR DD3,L-0.02,'短线追涨');
AW:=BARSLAST(CROSS(95,GJTJ1))<=2;
BW:=BARSLAST(CROSS(95,GJTJ2))<=2;
EW:= GJTJ4<GJTJ1 AND GJTJ1<GJTJ2 AND GJTJ1<GJTJ3;
FW:=GJTJ2>50 AND GJTJ3>50;
GW:=GJTJ1=100 AND GJTJ2=100;
TXW:=COUNT(GW,2)=1;
DRAWTEXT(AW AND BW AND EW AND FW AND TXW,L-0.03,'起涨首日');
AQ:=GJTJ3=100;
BQ:=GJTJ4<90;
DRAWTEXT(COUNT(AQ,2) = 2 AND BQ,L-0.02,'波启前兆');[/lycode][lycode=tdx2,true]输出MA5:收盘价的5日简单移动平均
输出MA10 :收盘价的10日简单移动平均
输出MA60 : 收盘价的60日简单移动平均
GJTJ1赋值:100*(收盘价-5日内最低价的最低值)/(5日内收盘价的最高值-5日内最低价的最低值)
GJTJ2赋值:100*(收盘价-10日内最低价的最低值)/(10日内收盘价的最高值-10日内最低价的最低值)
GJTJ3赋值:100*(收盘价-20日内最低价的最低值)/(20日内收盘价的最高值-20日内最低价的最低值)
GJTJ4赋值:100*(收盘价-30日内最低价的最低值)/(30日内收盘价的最高值-30日内最低价的最低值)
BAIJIN1赋值:上次30上穿GJTJ1距今天数<2 AND 上次GJTJ1上穿50距今天数<2
BAIJIN2赋值:上次GJTJ4上穿GJTJ1距今天数<2 AND GJTJ1>GJTJ4
BAIJIN3赋值:GJTJ1>60 AND GJTJ4>70
当满足条件BAIJIN1ANDBAIJIN2ANDBAIJIN3时,在最低价-0.02位置书写文字
HUANGJIN1赋值:上次50上穿GJTJ1距今天数<3 AND 上次GJTJ1上穿50距今天数<3
HUANGJIN2赋值:上次GJTJ4上穿GJTJ1距今天数<2 AND GJTJ1>GJTJ4
当满足条件HUANGJIN1ANDHUANGJIN2时,在最低价-0.03位置书写文字
XG赋值:上次GJTJ4上穿GJTJ1距今天数<5 AND GJTJ1>GJTJ4
当满足条件统计3日中满足XG的天数=1ANDXGANDC>收盘价的20日简单移动平均时,在最低价-0.02位置书写文字,画红色
ZHENCANG1赋值:上次GJTJ4上穿GJTJ1距今天数>3 AND 上次GJTJ1上穿GJTJ4距今天数<3
ZHENCANG2赋值:上次GJTJ4上穿GJTJ2距今天数
ZHENCANG3赋值:GJTJ3<GJTJ4 AND GJTJ2<GJTJ4
ZHENCANG4赋值:上次GJTJ4上穿GJTJ3距今天数>3 AND 上次GJTJ1上穿GJTJ4距今天数<3
ZHENCANG5赋值:GJTJ2<GJTJ3 AND GJTJ2<GJTJ4 AND GJTJ2<GJTJ1 AND GJTJ1=100
ZCB1赋值:ZHENCANG1>0 AND 1日前的ZHENCANG1=0 AND 2日前的ZHENCANG1>0
当满足条件ZHENCANG1ANDZHENCANG2ANDZHENCANG3ANDZHENCANG4ANDZHENCANG5时,在最低价-0.05位置书写文字
AA赋值:上次97上穿GJTJ1距今天数<=1 AND 上次GJTJ1上穿85距今天数<=1
BB赋值:上次97上穿GJTJ2距今天数<=1 AND 上次GJTJ2上穿85距今天数<=1
AA1赋值:AA AND BB
AAA赋值:上次97上穿GJTJ1距今天数<=2 AND 上次GJTJ1上穿85距今天数<=1
BAA赋值:上次97上穿GJTJ2距今天数<=2 AND 上次GJTJ2上穿85距今天数<=1
AA2赋值:AA AND BB
AAAA赋值:上次97上穿GJTJ1距今天数<=3 AND 上次GJTJ1上穿85距今天数<=1
BAAA赋值:上次97上穿GJTJ2距今天数<=3 AND 上次GJTJ2上穿85距今天数<=1
AA3赋值:AAAA AND BAAA
BB1赋值:1日前的AA1
BB2赋值:1日前的AA2
BB3赋值:1日前的AA3
DD1赋值:GJTJ1=100 AND GJTJ2=100 AND AA1
DD2赋值:GJTJ1=100 AND GJTJ2=100 AND AA2
DD3赋值:GJTJ1=100 AND GJTJ2=100 AND AA3
当满足条件DD1ORDD2ORDD3时,在最低价-0.02位置书写文字
AW赋值:上次95上穿GJTJ1距今天数<=2
BW赋值:上次95上穿GJTJ2距今天数<=2
EW赋值: GJTJ4<GJTJ1 AND GJTJ1<GJTJ2 AND GJTJ1<GJTJ3
FW赋值:GJTJ2>50 AND GJTJ3>50
GW赋值:GJTJ1=100 AND GJTJ2=100
TXW赋值:统计2日中满足GW的天数=1
当满足条件AWANDBWANDEWANDFWANDTXW时,在最低价-0.03位置书写文字
AQ赋值:GJTJ3=100
BQ赋值:GJTJ4<90
当满足条件统计2日中满足AQ的天数=2ANDBQ时,在最低价-0.02位置书写文字[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1Q7WoFCGyUrxjSzd7CRlzMg

看了该指标的人还看了:
600万指标 每一波赚钱    60日价值中枢指标
突破划线指标    五彩周J指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表