指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
TIM截图20180905111439.png

TIM截图20180905111456.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=REF(LOW,1);
VAR2:=(SMA(ABS(LOW-VAR1),13,1))/(SMA(MAX(LOW-VAR1,0),13,1))*4;
VAR3:=EMA(VAR2,13);
VAR4:=LLV(LOW,34);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
VAR6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR8:=VAR6<REF(VAR7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,8,0),COLORAA00BB;{粉色住}
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,8,0),COLORBB11BB;
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,5,0),COLORCC22BB;
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,3,0),COLORDD33BB;
STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,1,0),COLOREE44BB;
DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,16,'●↙大资金进场'),COLOR0099FF;
DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,12,'●↙择机买入'),COLOR0033FF;
DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,8,'●↙多数会涨'),COLORFFFFAA;[/lycode][lycode=tdx2,true]VAR1赋值:1日前的最低价
VAR2赋值:(最低价-VAR1的绝对值的13日[1日权重]移动平均)/(最低价-VAR1和0的较大值的13日[1日权重]移动平均)*4
VAR3赋值:VAR2的13日指数移动平均
VAR4赋值:34日内最低价的最低值
VAR5赋值:如果最低价<=VAR4,返回VAR3,否则返回0的3日指数移动平均
VAR6赋值:100-3*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR7赋值:100-3*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR8赋值:VAR6<1日前的VAR7 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价
当满足条件VAR8ANDCOUNT(VAR8,18)=1时,在0和18位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLORAA00BB
当满足条件VAR8ANDCOUNT(VAR8,18)=1时,在0和18位置之间画柱状线,宽度为8,0不为0则画空心柱.,COLORBB11BB
当满足条件VAR8ANDCOUNT(VAR8,18)=1时,在0和18位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLORCC22BB
当满足条件VAR8ANDCOUNT(VAR8,18)=1时,在0和18位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORDD33BB
当满足条件VAR8ANDCOUNT(VAR8,18)=1时,在0和18位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOREE44BB
当满足条件VAR8ANDCOUNT(VAR8,18)=1时,在16位置书写文字,COLOR0099FF
当满足条件VAR8ANDCOUNT(VAR8,18)=1时,在12位置书写文字,COLOR0033FF
当满足条件VAR8ANDCOUNT(VAR8,18)=1时,在8位置书写文字,COLORFFFFAA[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/13XLFfnhhwZq-5PIYaOH57g

看了该指标的人还看了:
主力买卖指标    底部拉升指标    股海拾贝指标
敢死队操作线指标    抄底趋势线指标    短线黑马指标

使用道具 举报

回复