请选择 进入手机版|继续访问电脑版

波段抄底指标 通达信 副图 波段 无未来函数 短线 买卖点 抄底逃顶

[复制链接]

admin  管理员

发表于 2018-10-5 08:00:13 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 抄底逃顶 
波段抄底指标 通达信 副图 波段 无未来函数 短线 买卖点 抄底逃顶 炒股叉第10053张

波段抄底指标 通达信 副图 波段 无未来函数 短线 买卖点 抄底逃顶 炒股叉第10054张

[lywrap=通达信副图指标公式][lycode=tdx,true]E:=CROSS(83,RSI);
STICKLINE( E,E,55,1,0),COLORFFFF00;
DRAWTEXT(E,50,' 减'),COLORFFFF00;
VA1:=HHV(HIGH,9)-LLV(LOW,9);
VA2:=HHV(HIGH,9)-CLOSE;
VA3:=CLOSE-LLV(LOW,9);
VA4:=VA2/VA1*100-70;
VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VA6:=(CLOSE+HIGH+LOW)/3;
VA7:=SMA(VA3/VA1*100,3,1);
VA8:=LLV(LOW,34);
VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);
VARA:=IF(VA9>100,VA9-100,0);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
DRAWKLINE(EMA(B1,5),EMA(B1,5),B1+1,B1);
领先:EMA(B1,5),COLORCYAN;
生命线:EMA(VARD,1),COLORYELLOW;
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
VV:=V1 AND V2 AND V3 AND V4;
A1:=EMA(CLOSE,8);
A2:=EMA(A1,20);
A3:=CROSS(A1,A2);
A4:=A1<EMA(CLOSE,120);
STICKLINE((A3 AND A4)OR(V1 AND V2 AND V3 AND V4),B1*1.03,B1*1.120,1,0),COLORYELLOW;
A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*
SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1),CIRCLEDOT ,COLORFF9900 ;
安全位:=20;
低位转强:IF(CROSS(A5,安全位),50,0),STICK,COLORMAGENTA,LINETHICK2;
开始拉升:IF(CROSS(VARC,生命线) AND VARC>VARD AND VARC<55 AND C>O,50,0),
COLORLIRED,POINTDOT;
A6:=LLV(C,500)=LLV(C,5) AND C/REF(C,1)>(1+9.8/100);
极地上涨:IF(A6,领先,0),COLORGREEN,LINETHICK2;
STICKLINE(开始拉升>0,15,开始拉升*1.1,0.5,0),COLORBLUE;
STICKLINE((开始拉升>0 AND 开始拉升<400) OR (极地上涨>0 AND 极地上涨<400)
OR (低位转强>0 AND 低位转强<400) OR (低位转强>0),30,开始拉升,1,0),COLORRED;
STICKLINE(开始拉升>0,15,开始拉升*0.6,3,0),COLORBLUE;
STICKLINE(开始拉升>0,15,开始拉升*0.4,3,0),COLOR00FF00;
STICKLINE(开始拉升>0,15,开始拉升*0.2,3,0),COLOR0099CC;
STICKLINE(低位转强>0,15,低位转强*1.01,1,0),COLORMAGENTA;
STICKLINE((低位转强>0)OR(极地上涨>0),15,低位转强*0.4,2,0),COLORYELLOW;
STICKLINE(低位转强>0,15,低位转强*0.2,2,0),COLORFFCC66;
STICKLINE(极地上涨>0,15,极地上涨*1.01,1,0),COLORYELLOW;
_红柱:IF("MACD.MACD">REF("MACD.MACD",1),"MACD.MACD"*20,DRAWNULL),
STICK,COLORRED;
绿柱:IF("MACD.MACD"<REF("MACD.MACD",1),"MACD.MACD"*20,DRAWNULL),
STICK,COLORYELLOW;
_抄底:ABS((CROSS("MACD.DIF","MACD.DEA")&&"MACD.DEA"<=-0.07))*10,COLORLIMAGENTA;
_DIF:"MACD.DIF"*30,COLORWHITE;
_DEA:"MACD.DEA"*30,COLORYELLOW;
__强度:IF(_DIF>_DEA,_DIF,DRAWNULL),COLORRED,LINETHICK2;
_强度:IF(_DEA<_DIF,_DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ABS(_抄底)>0,_抄底*1.10,' 抄底'),COLORYELLOW;
DRAWICON(ABS(_抄底)>0,_抄底*1.50,4);
DRAWICON(CROSS(_DIF,_DEA),_DEA,1);
DRAWICON(CROSS(_DEA,_DIF),_DEA,2);[/lycode][lycode=tdx2,true]E赋值:83上穿RSI
当满足条件E时,在E和55位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORFFFF00
当满足条件E时,在50位置书写文字,COLORFFFF00
VA1赋值:9日内最高价的最高值-9日内最低价的最低值
VA2赋值:9日内最高价的最高值-收盘价
VA3赋值:收盘价-9日内最低价的最低值
VA4赋值:VA2/VA1*100-70
VA5赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*100
VA6赋值:(收盘价+最高价+最低价)/3
VA7赋值:VA3/VA1*100的3日[1日权重]移动平均
VA8赋值:34日内最低价的最低值
VA9赋值:VA7的3日[1日权重]移动平均-VA4的9日[1日权重]移动平均
VARA赋值:如果VA9>100,返回VA9-100,否则返回0
VARB赋值:34日内最高价的最高值
VARC赋值:(VA6-VA8)/(VARB-VA8)*100的13日指数移动平均
VARD赋值:0.667*1日前的VARC+0.333*VARC的2日指数移动平均
VARE赋值:收盘价-1日前的收盘价和0的较大值/收盘价的8日[1日权重]移动平均/大盘的收盘价-1日前的大盘的收盘价的绝对值/大盘的收盘价的8日[1日权重]移动平均*100-25
VARF赋值:VARE的3日简单移动平均
VAR1赋值:9日内最高价的最高值-9日内最低价的最低值
VAR2赋值:9日内最高价的最高值-收盘价
VAR3赋值:收盘价-9日内最低价的最低值
VAR4赋值:((VAR2)/(VAR1))*(100)-70
VAR5赋值:((收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值))*(100)
VAR6赋值:((2)*(收盘价)+最高价+最低价)/(4)
VAR7赋值:((VAR3)/(VAR1))*(100)的3日[1日权重]移动平均
VAR8赋值:34日内最低价的最低值
VAR9赋值:VAR7的3日[1日权重]移动平均-VAR4的9日[1日权重]移动平均
VAR10赋值:如果(VAR9>100),返回VAR9-100,否则返回0
VAR11赋值:34日内最高价的最高值
B1赋值:((VAR6-VAR8)/(VAR11-VAR8))*(100)的8日指数移动平均
K线
输出领先:B1的5日指数移动平均,画青色
输出生命线:VARD的1日指数移动平均,画黄色
V1赋值:收盘价的5日简单移动平均=20日内收盘价的5日简单移动平均的最高值
V2赋值:收盘价的5日简单移动平均>收盘价的10日简单移动平均
V3赋值:成交量(手)的5日简单移动平均>成交量(手)的40日简单移动平均*1.01
V4赋值:统计2日中满足收盘价的1日简单移动平均>1日前的收盘价的天数=2
VV赋值:V1 AND V2 AND V3 AND V4
A1赋值:收盘价的8日指数移动平均
A2赋值:A1的20日指数移动平均
A3赋值:A1上穿A2
A4赋值:A1<收盘价的120日指数移动平均
当满足条件(A3ANDA4)OR(V1ANDV2ANDV3ANDV4)时,在B1*1.03和B1*1.120位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
A5赋值:3*(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100的21日[1日权重]移动平均-2*(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100的20日[1日权重]移动平均的8日[1日权重]移动平均,CIRCLEDOT ,COLORFF9900
安全位赋值:20
输出低位转强:如果A5上穿安全位,返回50,否则返回0,STICK,画洋红色,线宽为2
输出开始拉升:如果VARC上穿生命线ANDVARC>VARDANDVARC<55ANDC>开盘价,返回50,否则返回0,画淡红色,POINTDOT
A6赋值:500日内收盘价的最低值=5日内收盘价的最低值 AND 收盘价/1日前的收盘价>(1+9.8/100)
输出极地上涨:如果A6,返回领先,否则返回0,画绿色,线宽为2
当满足条件开始拉升>0时,在15和开始拉升*1.1位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画蓝色
当满足条件(开始拉升>0AND开始拉升<400)OR(极地上涨>0AND极地上涨<400)OR(低位转强>0AND低位转强<400)OR(低位转强>0)时,在30和开始拉升位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色
当满足条件开始拉升>0时,在15和开始拉升*0.6位置之间画柱状线,宽度为3,0不为0则画空心柱.,画蓝色
当满足条件开始拉升>0时,在15和开始拉升*0.4位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FF00
当满足条件开始拉升>0时,在15和开始拉升*0.2位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR0099CC
当满足条件低位转强>0时,在15和低位转强*1.01位置之间画柱状线,宽度为1,0不为0则画空心柱.,画洋红色
当满足条件(低位转强>0)OR(极地上涨>0)时,在15和低位转强*0.4位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
当满足条件低位转强>0时,在15和低位转强*0.2位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFFCC66
当满足条件极地上涨>0时,在15和极地上涨*1.01位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
输出_红柱:如果"平滑异同平均的MACD">1日前的"平滑异同平均的MACD",返回"平滑异同平均的MACD"*20,否则返回无效数,STICK,画红色
输出绿柱:如果"平滑异同平均的MACD"<1日前的"平滑异同平均的MACD",返回"平滑异同平均的MACD"*20,否则返回无效数,STICK,画黄色
输出_抄底:("平滑异同平均的DIF"上穿"平滑异同平均的DEA"并且"平滑异同平均的DEA"<=-0.07)的绝对值*10,画淡洋红色
输出_DIF:"平滑异同平均的DIF"*30,画白色
输出_DEA:"平滑异同平均的DEA"*30,画黄色
输出__强度:如果_DIF>_DEA,返回_DIF,否则返回无效数,画红色,线宽为2
输出_强度:如果_DEA<_DIF,返回_DEA,否则返回无效数,画洋红色,线宽为2
当满足条件_抄底的绝对值>0时,在_抄底*1.10位置书写文字,画黄色
当满足条件_抄底的绝对值>0时,在_抄底*1.50位置画4号图标
当满足条件_DIF上穿_DEA时,在_DEA位置画1号图标
当满足条件_DEA上穿_DIF时,在_DEA位置画2号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1zr60FWTowqZ1x-etwaHkHA

看了该指标的人还看了:
高抛低吸指标    校长抓黑马指标
看色操作指标    做足波段指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表