请选择 进入手机版|继续访问电脑版

神准超短指标主图 抓牛股 通达信 主图

[复制链接]

admin  管理员

发表于 2017-7-6 10:33:22 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类:  
神准超短指标主图 抓牛股 通达信 主图 炒股叉第140张
神准超短指标主图 抓牛股 通达信 主图 炒股叉第141张

神准超短指标主图 抓牛股 通达信 主图 炒股叉第142张


[lycode=tdx,true]DA1:=IF(130>TOTALBARSCOUNT,TOTALBARSCOUNT,130);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L2/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L3/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L4/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L5/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L6/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L7/SS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L8/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L9/SS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L10/SS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
DRAWKLINE(H,O,L,C);MA1:MA(CLOSE,5);
MA2:MA(CLOSE,10);
MA3:MA(CLOSE,30);
MA4:MA(CLOSE,60);

VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买入'),COLORRED;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,'卖出'),COLORGREEN;
{决策}
VAR100:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR200:=(100 - ((90 * (HHV(HIGH,20) - CLOSE)) / (HHV(HIGH,20) - LLV(LOW,20))));
VAR300:=(100 - MA(((100 * (HHV(HIGH,5) - CLOSE)) / (HHV(HIGH,5) - LLV(LOW,5))),34));
F:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;
年:MA(CLOSE,22),LINETHICK2,COLORWHITE;      
[/lycode]

解释:
[lycode=tdx,true]DA1赋值:如果130>总的周期数,返回总的周期数,否则返回130
DA赋值:如果到最后交易的周期>DA1,返回0,否则返回DA1
HI赋值:日期日DA日内最高价的最高值
LO赋值:日期日DA日内最低价的最低值
C1赋值:如果到最后交易的周期<=DA,返回收盘价,否则返回无效数
GZ赋值:HI/LO的自然对数/10的指数
LH1赋值:如果C1>=(HI/GZ),返回成交量(手),否则返回0的DA日累和
LH2赋值:如果C1>=(HI/GZ的2乘幂)ANDC1<(HI/GZ),返回成交量(手),否则返回0的DA日累和
LH3赋值:如果C1>=(HI/GZ的3乘幂)ANDC1<(HI/GZ的2乘幂),返回成交量(手),否则返回0的DA日累和
LH4赋值:如果C1>=(HI/GZ的4乘幂)ANDC1<(HI/GZ的3乘幂),返回成交量(手),否则返回0的DA日累和
LH5赋值:如果C1>=(HI/GZ的5乘幂)ANDC1<(HI/GZ的4乘幂),返回成交量(手),否则返回0的DA日累和
LH6赋值:如果C1>=(HI/GZ的6乘幂)ANDC1<(HI/GZ的5乘幂),返回成交量(手),否则返回0的DA日累和
LH7赋值:如果C1>=(HI/GZ的7乘幂)ANDC1<(HI/GZ的6乘幂),返回成交量(手),否则返回0的DA日累和
LH8赋值:如果C1>=(HI/GZ的8乘幂)ANDC1<(HI/GZ的7乘幂),返回成交量(手),否则返回0的DA日累和
LH9赋值:如果C1>=(LO*GZ)ANDC1<LO*GZ的2乘幂,返回成交量(手),否则返回0的DA日累和
LH10赋值:如果C1>=LOANDC1<LO*GZ,返回成交量(手),否则返回0的DA日累和
L1赋值:日期日DA日内LH1的最高值,线宽为0
L2赋值:日期日DA日内LH2的最高值,线宽为0
L3赋值:日期日DA日内LH3的最高值,线宽为0
L4赋值:日期日DA日内LH4的最高值
L5赋值:日期日DA日内LH5的最高值
L6赋值:日期日DA日内LH6的最高值
L7赋值:日期日DA日内LH7的最高值
L8赋值:日期日DA日内LH8的最高值
L9赋值:日期日DA日内LH9的最高值
L10赋值:日期日DA日内LH10的最高值
SS赋值:(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10)
当满足条件DA*L1/SS的向上舍入*3>=到最后交易的周期时,在HI*99/100和HI/GZ位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L2/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的1乘幂*99/100和HI/GZ的2乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L3/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的2乘幂*99/100和HI/GZ的3乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L4/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的3乘幂*99/100和HI/GZ的4乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L5/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的4乘幂*99/100和HI/GZ的5乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L6/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的5乘幂*99/100和HI/GZ的6乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L7/SS的向上舍入*3>=到最后交易的周期时,在HI/GZ的6乘幂*99/100和HI/GZ的7乘幂位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L8/SS的向上舍入*3>=到最后交易的周期时,在LO*GZ的2乘幂和LO*GZ的3乘幂*99/100位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L9/SS的向上舍入*3>=到最后交易的周期时,在LO*GZ的1乘幂和LO*GZ的2乘幂*99/100位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
当满足条件DA*L10/SS的向上舍入*3>=到最后交易的周期时,在LO和LO*GZ的1乘幂*99/100位置之间画柱状线,宽度为9,0不为0则画空心柱.COLOR3C3C3A,线宽为3
K线
输出MA1:收盘价的5日简单移动平均
输出均线:收盘价的10日简单移动平均
输出MA3:收盘价的30日简单移动平均
输出MA4:收盘价的60日简单移动平均
VAR3赋值:240日内最高价的最低值
VAR4赋值:100*(收盘价-VAR3)/VAR3
VAR5赋值:(收盘价-528日内最低价的最低值)/(528日内最高价的最高值-528日内最低价的最低值)*100
VAR6赋值:(收盘价-530日内收盘价的最低值)/(530日内收盘价的最高值-530日内收盘价的最低值)*100
VAR7赋值:0
VAR8赋值:收盘价-1日前的收盘价和0的较大值的34日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的7日[1日权重]移动平均*100
VAR9赋值:收盘价-1日前的收盘价和0的较大值的13日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的13日[1日权重]移动平均*100
VAR10赋值:如果收盘价16%之字转向的前1个波谷位置=0ANDHIGH>最低价+0.04,返回4,否则返回0
VAR11赋值:收盘价6%的之字转向>1日前的收盘价6%的之字转向 AND 1日前的收盘价6%的之字转向<=2日前的收盘价6%的之字转向 AND 2日前的收盘价6%的之字转向<=3日前的收盘价6%的之字转向
VAR12赋值:收盘价6%的之字转向<1日前的收盘价6%的之字转向 AND 1日前的收盘价6%的之字转向>=2日前的收盘价6%的之字转向 AND 2日前的收盘价6%的之字转向>=3日前的收盘价6%的之字转向
VAR13赋值:收盘价22%的之字转向>1日前的收盘价22%的之字转向 AND 1日前的收盘价22%的之字转向<=2日前的收盘价22%的之字转向 AND 2日前的收盘价22%的之字转向<=3日前的收盘价22%的之字转向
VAR14赋值:收盘价22%的之字转向<1日前的收盘价22%的之字转向 AND 1日前的收盘价22%的之字转向>=2日前的收盘价22%的之字转向 AND 2日前的收盘价22%的之字转向>=3日前的收盘价22%的之字转向
VAR15赋值:收盘价51%的之字转向>1日前的收盘价51%的之字转向 AND 1日前的收盘价51%的之字转向<=2日前的收盘价51%的之字转向 AND 2日前的收盘价51%的之字转向<=3日前的收盘价51%的之字转向
VAR16赋值:收盘价51%的之字转向<1日前的收盘价51%的之字转向 AND 1日前的收盘价51%的之字转向>=2日前的收盘价51%的之字转向 AND 2日前的收盘价51%的之字转向>=3日前的收盘价51%的之字转向
VAR17赋值:收盘价72%的之字转向>1日前的收盘价72%的之字转向 AND 1日前的收盘价72%的之字转向<=2日前的收盘价72%的之字转向 AND 2日前的收盘价72%的之字转向<=3日前的收盘价72%的之字转向
VAR18赋值:收盘价72%的之字转向<1日前的收盘价72%的之字转向 AND 1日前的收盘价72%的之字转向>=2日前的收盘价72%的之字转向 AND 2日前的收盘价72%的之字转向>=3日前的收盘价72%的之字转向
VAR19赋值:收盘价的2日指数移动平均-收盘价的150日指数移动平均
买1赋值:VAR10
买2赋值:(VAR11+VAR13+VAR15+VAR17)
卖1赋值:(VAR12+VAR14+VAR16+VAR18)
输出B:如果买1>0OR买2>0,返回最低价*0.99,否则返回无效数,CROSSDOT,线宽为3,画黄色
当满足条件买1>0OR买2>0时,在最低价*0.99位置书写文字,画红色
输出S:如果卖1>0,返回最高价*1.01,否则返回无效数,CROSSDOT,线宽为3,画绿色
当满足条件卖1>0时,在最高价*1.02位置书写文字,画绿色
VAR100赋值:(100 - ((90 * (20日内最高价的最高值 - 收盘价)) / (20日内最高价的最高值 - 20日内最低价的最低值)))
VAR200赋值:(100 - ((90 * (20日内最高价的最高值 - 收盘价)) / (20日内最高价的最高值 - 20日内最低价的最低值)))
VAR300赋值:(100 - ((100*(5日内最高价的最高值-收盘价))/(5日内最高价的最高值-5日内最低价的最低值))的34日简单移动平均)
输出F:如果VAR200上穿VAR300的5日简单移动平均,返回最低价*0.98,否则返回无效数,CROSSDOT,线宽为3,COLOREE00EE
输出年:收盘价的22日简单移动平均,线宽为2,画白色
      
[/lycode]

下载地址:
游客,如果您要查看本帖隐藏内容请回复


看了该指标的人还看了:
均衡加仓买线指标    熊百组合极品指标
减仓逃顶指标    波浪自动画线指标

举报 使用道具

回复

精彩评论6

fenlin  注册会员

发表于 2018-6-29 14:40:20 | 显示全部楼层

谢谢分享,关注中

举报 使用道具

回复

dlseabird  注册会员

发表于 2018-7-11 13:39:09 | 显示全部楼层

我想看看怎么样

举报 使用道具

回复

809721923  新手上路

发表于 2018-8-15 07:30:47 | 显示全部楼层

看看!!!!!!1

举报 使用道具

回复

zjsxd  新手上路

发表于 2018-8-16 14:07:14 | 显示全部楼层

谢谢分享

举报 使用道具

回复

cgx_xhtc  中级会员

发表于 2018-10-6 11:33:46 | 显示全部楼层

谢谢楼主分享!

举报 使用道具

回复

蓝盾  注册会员

发表于 2018-10-7 20:54:28 | 显示全部楼层

谢谢分享               

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表