指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
TIM截图20180622102231.png

TIM截图20180622102240.png

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR2:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1)/28.57;
VAR4:=EMA(VAR3,5);
VAR5:=3*VAR3-2*VAR4;
AA:=CROSS(VAR5,VAR3) AND VAR3<2.1 AND ADVANCE>OPEN;
VAR6:=(2*CLOSE+HIGH+LOW)/4;

VAR7:=LLV(LOW,13);
VAR8:=HHV(HIGH,13);
VAR9:=EMA((VAR6-VAR7)/(VAR8-VAR7)*100,13);
VARA:=EMA(0.667*REF(VAR9,1)+0.333*VAR9,2);
多:VAR9,POINTDOT,COLORRED;
空:EMA(0.382*REF(VAR9,2)+0.618*VAR9,12),COLORGREEN;
买:IF(CROSS(多,空),85,0),COLORRED;
TDXSTEP165:STICKLINE(VAR9>VARA,VAR9,VARA,6,0),COLORRED;
TDXSTEP166:STICKLINE(VAR9<=VARA,VAR9,VARA,6,0),COLORFFCC66;
TDXSTEP167:STICKLINE(AA,0,30,40,1),COLORYELLOW;
TDXSTEP168:STICKLINE(AA,16,29,38,0),COLORRED;
TDXSTEP169:STICKLINE(AA,1,14,38,0),COLORRED;
TDXSTEP170:STICKLINE(AA,15,15,40,1),COLORYELLOW;
TDXSTEP171:STICKLINE(AA,30,50,10,0),COLORYELLOW;
TDXSTEP172:STICKLINE(AA,53,55,10,1),COLORRED;
TDXSTEP173:STICKLINE(AA,57,59,10,1),COLORRED;
TDXSTEP174:STICKLINE(AA,61,63,10,1),COLORRED;
TDXSTEP175:STICKLINE(AA,65,67,10,1),COLORRED;
TDXSTEP176:STICKLINE(AA,69,75,12,0),COLORFFCCCC;
底:IF(AA,85,0),COLORYELLOW;[/lycode][lycode=tdx2,true]VAR2赋值:(收盘价-20日内最低价的最低值)/(20日内最高价的最高值-20日内最低价的最低值)*100
VAR3赋值:VAR2的3日[1日权重]移动平均的3日[1日权重]移动平均/28.57
VAR4赋值:VAR3的5日指数移动平均
VAR5赋值:3*VAR3-2*VAR4
AA赋值:VAR5上穿VAR3 AND VAR3<2.1 AND 上涨家数>开盘价
VAR6赋值:(2*收盘价+最高价+最低价)/4
VAR7赋值:13日内最低价的最低值
VAR8赋值:13日内最高价的最高值
VAR9赋值:(VAR6-VAR7)/(VAR8-VAR7)*100的13日指数移动平均
VARA赋值:0.667*1日前的VAR9+0.333*VAR9的2日指数移动平均
输出多:VAR9,POINTDOT,画红色
输出空:0.382*2日前的VAR9+0.618*VAR9的12日指数移动平均,画绿色
输出买:如果多上穿空,返回85,否则返回0,画红色
输出TDXSTEP165:当满足条件VAR9>VARA时,在VAR9和VARA位置之间画柱状线,宽度为6,0不为0则画空心柱.,画红色
输出TDXSTEP166:当满足条件VAR9<=VARA时,在VAR9和VARA位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLORFFCC66
输出TDXSTEP167:当满足条件AA时,在0和30位置之间画柱状线,宽度为40,1不为0则画空心柱.,画黄色
输出TDXSTEP168:当满足条件AA时,在16和29位置之间画柱状线,宽度为38,0不为0则画空心柱.,画红色
输出TDXSTEP169:当满足条件AA时,在1和14位置之间画柱状线,宽度为38,0不为0则画空心柱.,画红色
输出TDXSTEP170:当满足条件AA时,在15和15位置之间画柱状线,宽度为40,1不为0则画空心柱.,画黄色
输出TDXSTEP171:当满足条件AA时,在30和50位置之间画柱状线,宽度为10,0不为0则画空心柱.,画黄色
输出TDXSTEP172:当满足条件AA时,在53和55位置之间画柱状线,宽度为10,1不为0则画空心柱.,画红色
输出TDXSTEP173:当满足条件AA时,在57和59位置之间画柱状线,宽度为10,1不为0则画空心柱.,画红色
输出TDXSTEP174:当满足条件AA时,在61和63位置之间画柱状线,宽度为10,1不为0则画空心柱.,画红色
输出TDXSTEP175:当满足条件AA时,在65和67位置之间画柱状线,宽度为10,1不为0则画空心柱.,画红色
输出TDXSTEP176:当满足条件AA时,在69和75位置之间画柱状线,宽度为12,0不为0则画空心柱.,COLORFFCCCC
输出底:如果AA,返回85,否则返回0,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1PKZQRimWiOMOxiKTyel5aw

看了该指标的人还看了:
涨势跌势确立指标    三增三阳指标    明明白白指标
超级抄底指标    股海扬帆指标    博奕杀手指标

使用道具 举报

回复