请选择 进入手机版|继续访问电脑版

成交分析指标 通达信 副图 无未来函数 操盘控盘 成交量

[复制链接]

admin  管理员

发表于 2018-7-12 09:00:23 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 无未来函数 操盘控盘 成交量 
成交分析指标 通达信 副图 无未来函数 操盘控盘 成交量 炒股叉第8243张

成交分析指标 通达信 副图 无未来函数 操盘控盘 成交量 炒股叉第8244张

[lywrap=通达信副图指标公式][lycode=tdx,true]{-------【成交分析】带预测功能五彩虚拟成交量图,可作短线操作的看图依据------}
{-----------------------------五彩虚拟成交量分析公式-----------------------}
成交【万手】:VOL/10000,COLORC08080,NODRAW;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLOR3333AA,NODRAW;
主动卖:=IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR009900,NODRAW;
主买:主动买/10000,COLOR3333AA,NODRAW;
主卖:主动卖/10000,COLOR009900,NODRAW;
差额%:(主动买-主动卖)/(VOL/100),COLOR8AA0D8,NODRAW;
量比:VOL/MA(VOL,5),COLOR999999,NODRAW;
启动线:MA(成交【万手】,5),COLORFFFFFF,NODRAW;
洗盘线:MA(成交【万手】,10),COLOR00FFFF,NODRAW;
异动线:MA(成交【万手】,20),COLORFF0000,NODRAW;
{------------------------盘中虚拟成交量条件判断----------------------------}
日线预测:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
预测:日线预测/10000,COLOR009999;

{------------------------盘中虚拟成交量黄色虚线柱画线----------------------}
当日预测画柱:STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,日线预测,0,3.8,-1),COLOR00CCCC;
{---------------------二十日量线补及五彩成交量柱形画线---------------------}
收盘价>昨收:STICKLINE(CLOSE> REF(CLOSE,1),0,VOL,3.0,0),COLOR6666FF;
收盘价<昨收:STICKLINE(CLOSE< REF(CLOSE,1),0,VOL,3.0,0),COLORCYAN;
收盘价=昨收:STICKLINE(CLOSE= REF(CLOSE,1),0,VOL,3.0,0),COLORC0C0C0;
{-------------主动卖盘柱形,主动买盘柱形,五日量线,十日量线补画--------------}
主动卖盘柱形:STICKLINE(主动卖>=0,0,主动卖,2.0,0),COLOR009900;
主动买盘柱形:STICKLINE(主动买>=0,0,主动买,2.0,0),COLOR3333AA;
{--------------------------虚拟分钟预测量高点补画--------------------------}
预测量高点:STICKLINE(日线预测,日线预测,日线预测,3.8,-1),COLOR00CCCC;
二十日量线补画:DRAWBAND(MA(V,135),RGB(0,0,255),MA(V,135),RGB(255,51,51));
DRAWBAND(MA(V,135),RGB(0,102,255),MA(V,135)*0.99,RGB(0,102,255));
DRAWBAND(MA(V,135),RGB(0,0,255),MA(V,135)*0.99,RGB(0,0,255));
十日量线补画:DRAWBAND(MA(V,35),RGB(255,255,0),MA(V,35),RGB(255,255,0));
五日量线补画:DRAWBAND(MA(V,5),RGB(255,255,255),MA(V,5),RGB(255,255,255));
主力启动线:=MA(V,5),COLORFFFFFF,NODRAW;
主力洗盘线:=MA(V,35),COLOR00FFFF,NODRAW;
资金异动线:=MA(V,135),COLORFF0000,NODRAW;
{----------------------------买卖参考--------------------------------------}
出击:STICKLINE(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线)),0,VOL*0.13,2,0),COLORYELLOW;
启动:STICKLINE(主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) OR REF(VOL,2)<REF(资金异动线,2))),0,VOL*0.08,2,0),COLOR45AAEE;[/lycode][lycode=tdx2,true]输出成交【万手】:成交量(手)/10000,COLORC08080,NODRAW
VAR1赋值:成交量(手)/((最高价-最低价)*2-收盘价-开盘价的绝对值)
主动买赋值:如果收阳线,返回VAR1*(最高价-最低价),否则返回如果收阴线,返回VAR1*((最高价-开盘价)+(收盘价-最低价)),否则返回成交量(手)/2,COLOR3333AA,NODRAW
主动卖赋值:如果收阳线,返回VAR1*((最高价-收盘价)+(开盘价-最低价)),否则返回如果收阴线,返回VAR1*(最高价-最低价),否则返回成交量(手)/2,COLOR009900,NODRAW
输出主买:主动买/10000,COLOR3333AA,NODRAW
输出主卖:主动卖/10000,COLOR009900,NODRAW
输出差额%:(主动买-主动卖)/(成交量(手)/100),COLOR8AA0D8,NODRAW
输出量比:成交量(手)/成交量(手)的5日简单移动平均,COLOR999999,NODRAW
输出启动线:成交【万手】的5日简单移动平均,COLORFFFFFF,NODRAW
输出洗盘线:成交【万手】的10日简单移动平均,COLOR00FFFF,NODRAW
输出异动线:成交【万手】的20日简单移动平均,COLORFF0000,NODRAW
日线预测赋值:如果到最后交易的周期=1ANDPERIOD=5,返回成交量(手)*240/当前离开盘分钟数,否则返回无效数,NODRAW
输出预测:日线预测/10000,COLOR009999
输出当日预测画柱:当满足条件到最后交易的周期=1ANDPERIOD=5时,在日线预测和0位置之间画柱状线,宽度为3.8,-1不为0则画空心柱.,COLOR00CCCC
输出收盘价>昨收:当满足条件收盘价>1日前的收盘价时,在0和成交量(手)位置之间画柱状线,宽度为3.0,0不为0则画空心柱.,COLOR6666FF
输出收盘价<昨收:当满足条件收盘价<1日前的收盘价时,在0和成交量(手)位置之间画柱状线,宽度为3.0,0不为0则画空心柱.,画青色
输出收盘价=昨收:当满足条件收盘价=1日前的收盘价时,在0和成交量(手)位置之间画柱状线,宽度为3.0,0不为0则画空心柱.,COLORC0C0C0
输出主动卖盘柱形:当满足条件主动卖>=0时,在0和主动卖位置之间画柱状线,宽度为2.0,0不为0则画空心柱.,COLOR009900
输出主动买盘柱形:当满足条件主动买>=0时,在0和主动买位置之间画柱状线,宽度为2.0,0不为0则画空心柱.,COLOR3333AA
输出预测量高点:当满足条件日线预测时,在日线预测和日线预测位置之间画柱状线,宽度为3.8,-1不为0则画空心柱.,COLOR00CCCC
输出二十日量线补画:画带状线
画带状线
画带状线
输出十日量线补画:画带状线
输出五日量线补画:画带状线
主力启动线赋值:成交量(手)的5日简单移动平均,COLORFFFFFF,NODRAW
主力洗盘线赋值:成交量(手)的35日简单移动平均,COLOR00FFFF,NODRAW
资金异动线赋值:成交量(手)的135日简单移动平均,COLORFF0000,NODRAW
输出出击:当满足条件主力启动线上穿资金异动线OR((主力洗盘线>资金异动线)ANDCROSS(主力启动线,主力洗盘线))时,在0和成交量(手)*0.13位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
输出启动:当满足条件主力启动线>1日前的主力启动线AND(成交量(手)上穿主力启动线AND(1日前的成交量(手)<1日前的资金异动线ORREF(成交量(手),2)<2日前的资金异动线))时,在0和成交量(手)*0.08位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR45AAEE[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1kKe74nM3u1fL5iHYe22J-w

看了该指标的人还看了:
金钻沉鱼指标    底部启动点指标
海艺中线指标    五里操盘1号指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表