请选择 进入手机版|继续访问电脑版

减仓警告指标 通达信 副图 操盘控盘 建仓

[复制链接]

admin  管理员

发表于 2018-7-12 09:00:23 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 操盘控盘 建仓 
减仓警告指标 通达信 副图 操盘控盘 建仓 炒股叉第8229张

减仓警告指标 通达信 副图 操盘控盘 建仓 炒股叉第8230张

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=EMA(CLOSE, 5)/EMA(EMA(CLOSE, 9), 16);
VAR5:=(CLOSE-LLV(LOW, 75))/(HHV(HIGH, 75)-LLV(LOW, 75))*100;
VAR6:=SMA(VAR5, 20, 1);
VAR7:=SMA(VAR6, 15, 1);
VAR8:=100-3*VAR6+2*VAR7;
VAR9:=((EMA(IF(VAR8>REF(VAR8, 1), VAR8, VAR8-3), 3)-50)*(-1)*2/2+50)/10;
VAR10:=EMA(AMOUNT, 13)/EMA(VOL, 13);
VAR11:=(VAR10/REF(VAR10, 1)-1)*100;
VAR12:=VOL/CAPITAL*100;
VAR13:=(HIGH-LOW)/((HIGH+LOW)/2)*100;
VAR14:=(VAR9+VAR12)*VAR13*VAR11;
VAR15:=REF(CLOSE, 1);
VAR18:=(CLOSE-LLV(LOW, 9))/(HHV(HIGH, 9)-LLV(LOW, 9))*100;
VAR19:=SMA(VAR18, 3, 1);
VAR20:=SMA(VAR19, 3, 1);
VAR21:=3*VAR19-2*VAR20;
VAR22:=(CLOSE-LLV(LOW, 26))/(HHV(HIGH, 26)-LLV(LOW, 26))*100;
VAR23:=SMA(VAR22, 6, 1);
VAR24:=SMA(VAR23, 3, 1);
VAR25:=3*VAR23-2*VAR24;
VAR26:=IF(CROSS(VAR21, VAR25) AND VAR25<20, (-1), 0)+IF(CROSS(VAR25, VAR21) AND VAR25>80, 1, 0);
VAR27:=(HIGH+LOW+CLOSE)/3;
VAR28:=(VAR27-MA(VAR27, 14))/(0.015*AVEDEV(VAR27, 14))/2;
VAR29:=SMA(MAX(CLOSE-VAR15, 0), 6, 1)/SMA(ABS(CLOSE-VAR15), 6, 1)*100;
VAR30:=LLV(LOW, 36);
VAR31:=HHV(HIGH, 36);
VAR32:=EMA((CLOSE-VAR30)/(VAR31-VAR30)*100, 9);
VAR33:=IF(VAR28>100 AND VAR32>50 AND CLOSE>OPEN, 0.5, 0)+IF(VAR29>80 AND VAR32>50 AND CLOSE>OPEN, 0.5, 0);
VAR34:=(CLOSE-LLV(LOW, 100))/(HHV(HIGH, 100)-LLV(LOW, 100))*100;
VAR35:=SMA(VAR34, 21, 1);
VAR36:=SMA(VAR19, 3, 1);
VAR37:=3*VAR35-2*VAR36;
VAR38:=IF(VAR37>80 AND VAR29>88, 0.5, 0);
减四分一:IF((VAR14>50 AND VAR14<100) OR (VAR26+VAR33+VAR38>0), 25, 0), STICK, COLORWHITE;
减三分一:IF(VAR14>100 AND VAR14<200, 33, 0), STICK, COLORYELLOW;
减二分一:IF(VAR14>200, 50, 0), STICK, COLORMAGENTA;
减三分二:IF(VAR1>1.100 AND VAR1<1.150 AND VAR1<REF(VAR1, 1) OR VAR1>1.150 AND VAR1<REF(VAR1, 1), 67, 0), STICK, COLORGREEN;
警示录:MAX(MAX(减四分一, 减三分一), MAX(减二分一, 减三分二)), POINTDOT,LINETHICK2, COLORRED;[/lycode][lycode=tdx2,true]VAR1赋值:收盘价的5日指数移动平均/收盘价的9日指数移动平均的16日指数移动平均
VAR5赋值:(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100
VAR6赋值:VAR5的20日[1日权重]移动平均
VAR7赋值:VAR6的15日[1日权重]移动平均
VAR8赋值:100-3*VAR6+2*VAR7
VAR9赋值:((如果VAR8>1日前的VAR8,返回VAR8,否则返回VAR8-3的3日指数移动平均-50)*(-1)*2/2+50)/10
VAR10赋值:成交额(元)的13日指数移动平均/成交量(手)的13日指数移动平均
VAR11赋值:(VAR10/1日前的VAR10-1)*100
VAR12赋值:成交量(手)/当前流通股本(手)*100
VAR13赋值:(最高价-最低价)/((最高价+最低价)/2)*100
VAR14赋值:(VAR9+VAR12)*VAR13*VAR11
VAR15赋值:1日前的收盘价
VAR18赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VAR19赋值:VAR18的3日[1日权重]移动平均
VAR20赋值:VAR19的3日[1日权重]移动平均
VAR21赋值:3*VAR19-2*VAR20
VAR22赋值:(收盘价-26日内最低价的最低值)/(26日内最高价的最高值-26日内最低价的最低值)*100
VAR23赋值:VAR22的6日[1日权重]移动平均
VAR24赋值:VAR23的3日[1日权重]移动平均
VAR25赋值:3*VAR23-2*VAR24
VAR26赋值:如果VAR21上穿VAR25ANDVAR25<20,返回(-1),否则返回0+如果VAR25上穿VAR21ANDVAR25>80,返回1,否则返回0
VAR27赋值:(最高价+最低价+收盘价)/3
VAR28赋值:(VAR27-VAR27的14日简单移动平均)/(0.015*VAR27的14日平均绝对偏差)/2
VAR29赋值:收盘价-VAR15和0的较大值的6日[1日权重]移动平均/收盘价-VAR15的绝对值的6日[1日权重]移动平均*100
VAR30赋值:36日内最低价的最低值
VAR31赋值:36日内最高价的最高值
VAR32赋值:(收盘价-VAR30)/(VAR31-VAR30)*100的9日指数移动平均
VAR33赋值:如果VAR28>100ANDVAR32>50ANDCLOSE>开盘价,返回0.5,否则返回0+如果VAR29>80ANDVAR32>50ANDCLOSE>开盘价,返回0.5,否则返回0
VAR34赋值:(收盘价-100日内最低价的最低值)/(100日内最高价的最高值-100日内最低价的最低值)*100
VAR35赋值:VAR34的21日[1日权重]移动平均
VAR36赋值:VAR19的3日[1日权重]移动平均
VAR37赋值:3*VAR35-2*VAR36
VAR38赋值:如果VAR37>80ANDVAR29>88,返回0.5,否则返回0
输出减四分一:如果(VAR14>50ANDVAR14<100)OR(VAR26+VAR33+VAR38>0),返回25,否则返回0, STICK, 画白色
输出减三分一:如果VAR14>100ANDVAR14<200,返回33,否则返回0, STICK, 画黄色
输出减二分一:如果VAR14>200,返回50,否则返回0, STICK, 画洋红色
输出减三分二:如果VAR1>1.100ANDVAR1<1.150ANDVAR1<1日前的VAR1ORVAR1>1.150ANDVAR1<1日前的VAR1,返回67,否则返回0, STICK, 画绿色
输出警示录:减四分一和减三分一的较大值和减二分一和减三分二的较大值的较大值, POINTDOT,线宽为2, 画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1SQ4lWnfjYuugmgViHgeEeA

看了该指标的人还看了:
冲破天网指标    自动波浪指标
黄托底指标    OBV能量顶底指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表