请选择 进入手机版|继续访问电脑版

波动原理指标 通达信 副图 波段 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-7-11 09:00:09 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 操盘控盘 
波动原理指标 通达信 副图 波段 短线 买卖点 操盘控盘 炒股叉第8207张

波动原理指标 通达信 副图 波段 短线 买卖点 操盘控盘 炒股叉第8208张

[lywrap=通达信副图指标公式][lycode=tdx,true]DRAWGBK(CLOSE>0,RGB(41,36,33),RGB(0,0,0),0,302,0);
HJ_1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
HJ_2:=LLV(LOW,34);
HJ_3:=HHV(HIGH,34);
SK:EMA((HJ_1-HJ_2)/(HJ_3-HJ_2)*100,13);
SD:EMA(SK,13);
IF(SK>REF(SK,1),SK,DRAWNULL),COLORRED,LINETHICK2;
上证:"999999$CLOSE",NODRAW,COLORWHITE;
中小:"399005$CLOSE",NODRAW,COLORWHITE;
创业:"399006$CLOSE",NODRAW,COLORWHITE;
现价:CLOSE,NODRAW,COLORWHITE;
涨家数:INDEXADV,NODRAW,COLORRED;
跌家数:INDEXDEC,NODRAW,COLORGREEN;
正量能:涨家数/(涨家数+跌家数)*100,NODRAW,COLORMAGENTA;
负量能:跌家数/(涨家数+跌家数)*100,NODRAW,COLORYELLOW;
HJ_4:=KDJ.K#MONTH;
HJ_5:=KDJ.D#MONTH;
HJ_6:=KDJ.K#WEEK;
HJ_7:=KDJ.D#WEEK;
HJ_8:=KD.K;
HJ_9:=KD.D;
HJ_10:=HJ_8>HJ_9;
HJ_11:=HJ_6>HJ_7;
HJ_12:=HJ_4>HJ_5;
HJ_13:=CROSS(HJ_8,HJ_9);
HJ_14:=CROSS(HJ_6,HJ_7);
HJ_15:=CROSS(HJ_4,HJ_5);
HJ_16:=HJ_11 AND HJ_10;
HJ_17:=HJ_10 AND HJ_12;
HJ_18:=HJ_11 AND HJ_12;
STICKLINE(HJ_16,1,20,1,1),COLORWHITE;
STICKLINE(HJ_17,30,35,1,1),COLORYELLOW;
STICKLINE(HJ_18,45,50,1,1),COLORRED;
DIFF:EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW,COLORWHITE;
DEAA:EMA(DIFF,9),NODRAW,COLORWHITE;
MACD形态:DIFF>DEAA AND DIFF>=0,NODRAW,COLORWHITE;
HJ_19:=2-1;
HJ_20:=IF(CROSS(DEAA,0),1,0);
HJ_21:=IF(DIFF<0 AND CROSS(DIFF,DEAA),2,0);
HJ_22:=IF(HJ_20,SUM(HJ_21,0),0);
HJ_23:=HHV(HJ_22,0);
HJ_24:=SUM(HJ_21,0);
HJ_25:=IF(HJ_24-HJ_23>HJ_19 AND HJ_24>REF(HJ_24,1),1,0);
HJ_26:=14;
HJ_27:=CCI(HJ_26);
STICKLINE(HJ_27>80 AND HJ_10,80,82,1,1),COLORBROWN;
HJ_28:=CLOSE>OPEN;
HJ_29:=HJ_28 AND CLOSE>MA(CLOSE,20) AND CLOSE>MA(CLOSE,40) AND CLOSE>MA(CLOSE,60);
HJ_30:=HJ_29 AND OPEN<MA(CLOSE,40) AND OPEN<MA(CLOSE,60);
HJ_31:=HJ_30 AND CLOSE-OPEN>0.0618*CLOSE;
HJ_32:=LONGCROSS(CCI#MONTH,(-100),5);
HJ_33:=LONGCROSS(CCI#MONTH,0,5);
HJ_34:=CROSS(KDJ.J#WEEK,20);
HJ_35:=CROSS(KDJ.J#MONTH,20);
HJ_36:=HJ_35 AND HIGH>REF(CLOSE,1) AND NOT(CLOSE>=REF(CLOSE,1)*1.097 AND CLOSE=OPEN AND HIGH=LOW);
STICKLINE(HJ_36,0,30,8,0),COLORRED;
STICKLINE(HJ_36,30,40,8,0),COLORRED;
STICKLINE(HJ_36,40,50,2,0),COLORYELLOW;
STICKLINE(HJ_36,50,80,1,0),COLORWHITE;
DRAWICON(HJ_36,50,28);
抄底信号2:HJ_34 AND HIGH>REF(CLOSE,1) AND NOT(CLOSE>=REF(CLOSE,1)*1.097 AND CLOSE=OPEN AND HIGH=LOW);
STICKLINE(抄底信号2,0,30,8,0),COLORRED;
STICKLINE(抄底信号2,30,40,8,0),COLORRED;
STICKLINE(抄底信号2,40,50,2,0),COLORYELLOW;
STICKLINE(抄底信号2,50,80,1,0),COLORWHITE;
DRAWICON(抄底信号2,50,29);[/lycode][lycode=tdx2,true]填充背景
HJ_1赋值:(2*收盘价+最高价+最低价+开盘价)/5
HJ_2赋值:34日内最低价的最低值
HJ_3赋值:34日内最高价的最高值
输出SK:(HJ_1-HJ_2)/(HJ_3-HJ_2)*100的13日指数移动平均
输出SD:SK的13日指数移动平均
如果SK>1日前的SK,返回SK,否则返回无效数,画红色,线宽为2
输出上证:"999999$收盘价",NODRAW,画白色
输出中小:"399005$收盘价",NODRAW,画白色
输出创业:"399006$收盘价",NODRAW,画白色
输出现价:收盘价,NODRAW,画白色
输出涨家数:大盘的上涨家数,NODRAW,画红色
输出跌家数:大盘的下跌家数,NODRAW,画绿色
输出正量能:涨家数/(涨家数+跌家数)*100,NODRAW,画洋红色
输出负量能:跌家数/(涨家数+跌家数)*100,NODRAW,画黄色
HJ_4赋值:KDJ的K[取月线数据]
HJ_5赋值:KDJ的D[取月线数据]
HJ_6赋值:KDJ的K[取周线数据]
HJ_7赋值:KDJ的D[取周线数据]
HJ_8赋值:随机指标KD的K
HJ_9赋值:随机指标KD的D
HJ_10赋值:HJ_8>HJ_9
HJ_11赋值:HJ_6>HJ_7
HJ_12赋值:HJ_4>HJ_5
HJ_13赋值:HJ_8上穿HJ_9
HJ_14赋值:HJ_6上穿HJ_7
HJ_15赋值:HJ_4上穿HJ_5
HJ_16赋值:HJ_11 AND HJ_10
HJ_17赋值:HJ_10 AND HJ_12
HJ_18赋值:HJ_11 AND HJ_12
当满足条件HJ_16时,在1和20位置之间画柱状线,宽度为1,1不为0则画空心柱.,画白色
当满足条件HJ_17时,在30和35位置之间画柱状线,宽度为1,1不为0则画空心柱.,画黄色
当满足条件HJ_18时,在45和50位置之间画柱状线,宽度为1,1不为0则画空心柱.,画红色
输出DIFF:收盘价的12日指数移动平均-收盘价的26日指数移动平均,NODRAW,画白色
输出DEAA:DIFF的9日指数移动平均,NODRAW,画白色
输出MACD形态:DIFF>DEAA AND DIFF>=0,NODRAW,画白色
HJ_19赋值:2-1
HJ_20赋值:如果DEAA上穿0,返回1,否则返回0
HJ_21赋值:如果DIFF<0ANDCROSS(DIFF,DEAA),返回2,否则返回0
HJ_22赋值:如果HJ_20,返回HJ_21的历史累和,否则返回0
HJ_23赋值:0日内HJ_22的最高值
HJ_24赋值:HJ_21的历史累和
HJ_25赋值:如果HJ_24-HJ_23>HJ_19ANDHJ_24>1日前的HJ_24,返回1,否则返回0
HJ_26赋值:14
HJ_27赋值:CCI(HJ_26)
当满足条件HJ_27>80ANDHJ_10时,在80和82位置之间画柱状线,宽度为1,1不为0则画空心柱.,画棕色
HJ_28赋值:收阳线
HJ_29赋值:HJ_28 AND 收盘价>收盘价的20日简单移动平均 AND 收盘价>收盘价的40日简单移动平均 AND 收盘价>收盘价的60日简单移动平均
HJ_30赋值:HJ_29 AND 开盘价<收盘价的40日简单移动平均 AND 开盘价<收盘价的60日简单移动平均
HJ_31赋值:HJ_30 AND 收盘价-开盘价>0.0618*收盘价
HJ_32赋值:CCI[取月线数据]小于(-100)保持5个交易日后交叉上穿
HJ_33赋值:CCI[取月线数据]小于0保持5个交易日后交叉上穿
HJ_34赋值:KDJ的J[取周线数据]上穿20
HJ_35赋值:KDJ的J[取月线数据]上穿20
HJ_36赋值:HJ_35 AND 最高价>1日前的收盘价 AND 取反
当满足条件HJ_36时,在0和30位置之间画柱状线,宽度为8,0不为0则画空心柱.,画红色
当满足条件HJ_36时,在30和40位置之间画柱状线,宽度为8,0不为0则画空心柱.,画红色
当满足条件HJ_36时,在40和50位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
当满足条件HJ_36时,在50和80位置之间画柱状线,宽度为1,0不为0则画空心柱.,画白色
当满足条件HJ_36时,在50位置画28号图标
输出抄底信号2:HJ_34 AND 最高价>1日前的收盘价 AND 取反
当满足条件抄底信号2时,在0和30位置之间画柱状线,宽度为8,0不为0则画空心柱.,画红色
当满足条件抄底信号2时,在30和40位置之间画柱状线,宽度为8,0不为0则画空心柱.,画红色
当满足条件抄底信号2时,在40和50位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
当满足条件抄底信号2时,在50和80位置之间画柱状线,宽度为1,0不为0则画空心柱.,画白色
当满足条件抄底信号2时,在50位置画29号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1s6gx-sSFSqqAhMcfTpFlGw

看了该指标的人还看了:
成交量判断趋势指标    福将牵牛优化指标 金钻选股
狂龙探底指标    大肚线指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表