请选择 进入手机版|继续访问电脑版

操盘马力指标 通达信 主图 波段 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-7-9 09:00:16 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 操盘控盘 
操盘马力指标 通达信 主图 波段 短线 买卖点 操盘控盘 炒股叉第8185张

操盘马力指标 通达信 主图 波段 短线 买卖点 操盘控盘 炒股叉第8186张

[lywrap=通达信主图指标公式][lycode=tdx,true]{操盘马力主图★,HLN(1,1000,55),通达信}
BCTC:=BARSCOUNT(C);
LC:=REF(CLOSE,1);
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORAA16FF;
顶UPR:=BBI+3*STD(BBI,13),COLOR004AFF;
底DWN:=BBI-3*STD(BBI,13),COLOR67FF00;
爆发临界:=BBI>REF(BBI,1) AND LLV(顶UPR-底DWN,3)=(顶UPR-底DWN) AND CROSS(C,顶UPR),COLORRED,LINESTICK;
DRAWBAND(BBI,RGB(57,55,00),底DWN,RGB(57,55,00));
DRAWBAND(BBI,RGB(25,45,55),顶UPR,RGB(25,45,55));
PE:MID/FINANCE(33),COLOR1816FF,NODRAW;{年市盈率}
BBI线:(MA(CLOSE,5)+MA(CLOSE,10)+MA(CLOSE,15)+MA(CLOSE,20))/4,COLORFFAA16;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{量能平台}
HV:=HHV(V,20)=V OR V/REF(V,1)>=5 ;
FT:=BARSLAST(HV);
量能平台1:IF(HV,C,REF(C,FT)),COLOR18AFAF,POINTDOT;{白点DOTLINE}
{量能平台2}
PTN:=10;
PT1:=CONST(HHVBARS(V,10)),COLOR0000FF,LINETHICK1;
量能平台:IF(CURRBARSCOUNT<=PTN+7,CONST(IF(PT1=0,C,REF(C,PT1))),DRAWNULL),COLOR1FFFFF,LINETHICK1,DOTLINE;{CURRBARSCOUNT<=PTN+15}
DRAWTEXT(ISLASTBAR,量能平台,'   量台'),COLOR18FFFF;
CPX40:=WMA(MID,40);
CPX30:=WMA(MID,30);
CPX20:=WMA(MID,20);
CPX15:=WMA(MID,15);
CPX10:=WMA(MID,10);
CPX5:=WMA(MID,5);
CPX3:=WMA(MID,3);
STZF:=(MAX(CLOSE,OPEN)/MIN(CLOSE,OPEN)-1)*100;
均STZF:=(SUM(STZF,21)-STZF)/20;
DYX:=CLOSE<LC AND (100*(LC-CLOSE)/LC>(均STZF*2.5));
ZNCPX3:=IFF(DYX,(6*CLOSE+2*REF(MID,1)+1*REF(MID,2))/9,CPX3);
DYKX:=CLOSE>LC AND (100*(CLOSE-LC)/LC>(均STZF*2.5));
ZNCPX5:=IFF(DYKX,(6*CLOSE+2*REF(MID,1)+1*REF(MID,2))/9,CPX5);
CPMXK:=CPX20;
CPMXM:=CPX30;
CPKXM:=ZNCPX3;
CPKXK:=ZNCPX3;
UP:=CPX30>REF(CPX30,1);
DOWN:=CPX30<REF(CPX30,1);
CPXM:=IFF(UP,CPMXK,IFF(DOWN,CPMXM,0));
CPXK:=IFF(UP,CPKXM,IFF(DOWN,CPKXK,0));
D:=CPXK> CPXM;
K:=CPXK<=CPXM;
长:=WMA(MID,30);
中:=WMA(MID,20);
短:=WMA(MID,10);
SXX:=短>REF(短,1) AND 中<REF(中,1) AND 长<REF(长,1);
SMX:=短>REF(短,1) AND 中>REF(中,1) AND 长<REF(长,1);
SML:=短>REF(短,1) AND 中>REF(中,1) AND 长>REF(长,1);
SXL:=短>REF(短,1) AND 中<REF(中,1) AND 长>REF(长,1);
XML:=短<REF(短,1) AND 中>REF(中,1) AND 长>REF(长,1);
XXL:=短<REF(短,1) AND 中<REF(中,1) AND 长>REF(长,1);
XXX:=短<REF(短,1) AND 中<REF(中,1) AND 长<REF(长,1);
均线最大:=MAX(CPX5,MAX(CPX10,MAX(CPX20,MAX(CPX30,CPX40))));
均线最小:=MIN(CPX5,MIN(CPX10,MIN(CPX20,MIN(CPX30,CPX40))));
高缠绕度:=1000*(均线最大/均线最小-1)<27;
低缠绕度:=1000*(均线最大/均线最小-1)>=27;
投机:=10;
试盘:=IFF(SXX,20,0);
加仓:=IFF(SMX AND D,40,IFF(SMX AND K,20,0));
重仓:=IFF(SML AND D AND 低缠绕度,90,IFF(SML AND D AND 高缠绕度,60,IFF(SML AND K,20,0)));
高仓:=IFF(SXL AND D AND 低缠绕度,70,IFF(SXL AND D AND 高缠绕度,40,IFF(SXL AND K,20,0)));
减仓:=IFF(XML AND D,60,IFF(XML AND K,20,0));
轻仓:=IFF(XXL AND D,30,IFF(XXL AND K,20,0));
空仓:=IFF(XXX,0,0);
仓位1:=IFF(SML AND D AND 低缠绕度,90,IFF(SXL AND D AND 低缠绕度,70,IFF((XML AND D) OR (SML AND D AND 高缠绕度),60,IFF((1/2)==10,50,IFF((SMX AND D) OR (SXL AND D AND 高缠绕度),40,IFF(XXL AND D,30,0))))));
仓位2:=IFF(SXX OR (SMX AND K) OR (SML AND K) OR (SXL AND K) OR
(XML AND K) OR (XXL AND K),20,10);
仓位A:=MAX(仓位1,仓位2);
配置仓位:=IFF(((REF(仓位A,1)==90) OR (REF(仓位A,1)==70)) AND (仓位A<=50 AND 仓位A>=30),60,仓位A),NODRAW,COLORWHITE;
修正一天:=COUNT(配置仓位>=70,2)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,2)==1;
修正二天:=COUNT(配置仓位>=70,3)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,3)==2;
修正三天:=COUNT(配置仓位>=70,4)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,4)==3;
修正四天:=COUNT(配置仓位>=70,5)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,5)==4;
修正五天:=COUNT(配置仓位>=70,6)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,6)==5;
修正六天:=COUNT(配置仓位>=70,7)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,7)==6;
修正七天:=COUNT(配置仓位>=70,8)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,8)==7;
修正八天:=COUNT(配置仓位>=70,9)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,9)==8;
修正九天:=COUNT(配置仓位>=70,10)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,10)==9;
修正十天:=COUNT(配置仓位>=70,11)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,11)==10;
修正十一天:=COUNT(配置仓位>=70,12)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,12)==11;
修正十二天:=COUNT(配置仓位>=70,13)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,13)==12;
修正十三天:=COUNT(配置仓位>=70,14)==1 AND COUNT(配置仓位>=30 AND 配置仓位<=60,14)==13;
蓝:=配置仓位<=20;
红:=(配置仓位>=70) OR 修正一天 OR 修正二天 OR 修正三天 OR 修正四天 OR 修正五天 OR 修正六天 OR
修正七天 OR 修正八天  OR 修正九天  OR 修正十天  OR 修正十一天  OR 修正十二天  OR 修正十三天;
黄:=(红==0) AND (蓝==0);
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=((VAR1-REF(VAR1,1))/REF(VAR1,1)*1000)>0;
仓位马力:IFF(控盘 AND 配置仓位<=50,50,配置仓位),NODRAW,COLOR1658AA;
黄新:=黄 OR (控盘==0 AND 红) OR (控盘 AND 蓝) OR (控盘==0 AND 仓位马力>=60);
蓝新:=蓝 OR (控盘==0 AND 黄);
红新:=红;
修一天:=COUNT(红新,2)==1 AND COUNT(黄新,2)==1;
修二天:=COUNT(红新,3)==1 AND COUNT(黄新,3)==2;
修三天:=COUNT(红新,4)==1 AND COUNT(黄新,4)==3;
修四天:=COUNT(红新,5 )==1 AND COUNT(黄新,5 )==4;
修五天:=COUNT(红新,6 )==1 AND COUNT(黄新,6 )==5;
修六天:=COUNT(红新,7 )==1 AND COUNT(黄新,7 )==6;
修七天:=COUNT(红新,8 )==1 AND COUNT(黄新,8 )==7;
修八天:=COUNT(红新,9 )==1 AND COUNT(黄新,9 )==8;
修九天:=COUNT(红新,10)==1 AND COUNT(黄新,10)==9;
修十天:=COUNT(红新,11)==1 AND COUNT(黄新,11)==10;
修十一天:=COUNT(红新,12)==1 AND COUNT(黄新,12)==11;
红色修正:=修一天 OR 修二天 OR 修三天 OR 修四天 OR 修五天 OR 修六天 OR
修七天 OR 修八天 OR 修九天 OR 修十天 OR 修十一天;
XYELLOW:= (控盘 AND 蓝) OR (控盘 AND 黄) OR (控盘==0 AND 红) OR (控盘==0 AND 仓位马力>=60);
XRED:=  (控盘 AND 红) OR 红色修正;
XBLUE:= (控盘==0 AND 蓝) OR (控盘==0 AND 黄);
黄柱:IF((XRED==0) AND XYELLOW,1,DRAWNULL),COLOR0088FF,NODRAW;{ISCOLORYELLOW}
红柱:IF(XRED,1,DRAWNULL),COLOR1816FF,NODRAW;{ISCOLORRED}
蓝柱:IF(XBLUE AND (XYELLOW)==0,1,DRAWNULL),COLORFF8800,NODRAW;{ISCOLORBLUE}
MA5:=MA(CLOSE,5),COLORFFEFDF;
EMA21:EMA(C,21),COLORFF16FF,LINETHICK2;
EMA55:EMA(C,55),COLOR16AA18,LINETHICK2;
EMA89:EMA(C,89),COLOR5856EE,LINETHICK2;
IF(BBI线>REF(BBI线,1),BBI线,DRAWNULL),COLOR18AAFF;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26),COLORAAA818;
DEA:=EMA(DIFF,9),COLORAAFF56,LINETHICK2;
MACD :=2*(DIFF-DEA),COLORAA5678;
牛回头:=CROSS(DEA,DIFF) AND DIFF>0 AND EMA55>REF(EMA55,2) AND MA(VOL,5)<REF(MA(VOL,5),5);
DRAWTEXT(FILTERX(牛回头,BCTC),MIN(EMA55,LOW*0.99),'牛回'),COLOR5816FF;
{箱体顶底}
HLN:=55;
顶线:HHV(MA((HIGH),6),HLN),DOTLINE,COLOR987868;
底线:LLV(MA((LOW),5),HLN),DOTLINE,COLOR688899;
操作:=MA(MID,5);
拉升:HHV(操作,13),DOTLINE,COLORFF18AA;
买卖:LLV(操作,13),DOTLINE,COLORCDFFFF;
STICKLINE((控盘==0 AND 仓位马力>=60),C,O,1.5,0),COLOR0088FF;
STICKLINE(红色修正,C,O,1.5,0),COLOR0000AA;
STICKLINE(控盘 AND 蓝,C,O,1.3,0),COLORFF5816;
STICKLINE(控盘 AND 红,C,O,1.3,0),COLOR0000FF;
STICKLINE(控盘 AND 黄,C,O,1.3,0),COLOR0088FF;
STICKLINE(控盘==0 AND 蓝,C,O,1.5,0),COLORFF8816;
STICKLINE(控盘==0 AND 红,C,O,1.3,0),COLOR0088FF;
STICKLINE(控盘==0 AND 黄,C,O,1.3,0),COLOR00FFFF;
CPM1:=MA(CLOSE,1);
CPM2:=(LOW+HIGH+CLOSE)/3;
CPM3:= MA(CPM2,5);
CPM4:= HHV(CPM3,10);
CPZ:=HHV((CPM1<CPM4),10) OR HHV((CPM1<CPM4),10);
RSI34S:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,35)-LLV(LOW,34)),3);
DRAWTEXT(FILTER(CROSS(RSI34S ,60),20),MIN(L*0.97,EMA55),'▲'),COLORYELLOW;
DRAWTEXT(FILTERX(爆发临界,BCTC),MIN(底DWN,EMA55),'界'),COLOR16FF58;
{量支撑}
MV135:=MA(VOL,135);
TJ1:=VOL=HHV(VOL,10) AND VOL>1.7*REF(VOL,1) AND C>=REF(C,1) AND C>=O AND VOL<=MV135*3.5;
STICKLINE(FILTER(TJ1,3),OPEN,CLOSE,1,0),COLORF05FF0;
DRAWTEXT(FILTERX(FILTER(TJ1,3),BCTC),MIN(L*0.965,EMA89),'量撑'),COLORAA16AA;
DRAWTEXT(FILTERX(CROSS(MA(CLOSE,10),MA5),BCTC),LOW*0.95,'坑?'),COLOR18FFAA;
BIAS5:=(CLOSE-MA5)/MA5*100;
DRAWTEXT(FILTERX(CROSS(-7.1,BIAS5),BCTC),MIN(LOW*0.97,EMA89),'鼠'),COLOR18FFAA;
{KDJ短抄底,信号出现等待股价放量上穿EMA14或至前低企稳,如果短抄底信号出现后向下调整,3天不回补,止损}
RSV8:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
操盘K:=SMA(RSV8,2,1);
{V5:=SMA(操盘K,2,1);}
短抄底信号:=操盘K>REF(操盘K,1) AND REF(操盘K,1)<REF(操盘K,2) AND 操盘K<23;
DRAWTEXT(FILTERX(短抄底信号,BCTC),MIN(LOW*0.975,EMA89),'待抄短'),COLOR16DFEF;
{抓主升浪,急涨7-12天卖出,五日内突破创新高就是买入机会}
涨空间L:=(HHV(H,89)-LLV(L,89))*100/LLV(L,89)>35 AND HIGH>REF(HIGH,5) AND HIGH>REF(HHV(H,83),5);
多头排列:=MA(CLOSE,10)>=MA(CLOSE,20) AND MA(CLOSE,20)>REF(MA(CLOSE,20),5){AND CLOSE>MA(CLOSE,10)};
HSL:=VOL/CAPITAL*100;{换手}
低换手30:=LLV(HSL,30)=HSL;
ZF:=(H-L)/REF(C,1)*100;
小振幅:=LLV(ZF,10)=ZF OR ZF<3.5;
主升起爆点:IF(涨空间L AND 多头排列 AND (低换手30 OR 小振幅),EMA21,DRAWNULL),COLORCFFFCF,LINETHICK3;
DRAWTEXT(FILTER(主升起爆点,3),EMA89*0.997,'爆'),COLORCFFFCF;
{强势逃顶卖出}
强势股:=H/REF(L,1)>1.15 OR H/REF(L,2)>1.18;
回调:=L/REF(H,1)<0.97 AND C<REF(C,1);
强势逃顶:=REF(强势股,1) AND 回调;
DRAWTEXT(FILTERX(强势逃顶,BCTC),H*1.039,'调'),COLORAFAF6F;
{}
顶HH:=REF(HHV(H,HLN),0);
底LL:=REF(LLV(L,HLN),0);
F80:=顶HH-(顶HH-底LL)*0.191,COLORFFA816,DOTLINE,NODRAW;
F61:=顶HH-(顶HH-底LL)*0.382,COLORGREEN,DOTLINE,NODRAW;
F中50:=顶HH-(顶HH-底LL)*0.5,COLOR3366AA,DOTLINE,NODRAW;
F38:=顶HH-(顶HH-底LL)*0.618,COLOR18FFFF,DOTLINE,NODRAW;
F19:=顶HH-(顶HH-底LL)*0.809,COLORAA18AA,DOTLINE,NODRAW;
{DRAWTEXT(ISLASTBAR AND 上涨,C,' ↑空间%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR AND 下跌,C,' ↓空间%'),COLORYELLOW;}
DRAWTEXT(ISLASTBAR,顶HH,'  ...最高%'),COLORWHITE;
DRAWTEXT(ISLASTBAR,底LL,'  ...最低%'),COLORWHITE;
DRAWTEXT(ISLASTBAR,F19,'   ..19.8%'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,F38,'  ...38.2%'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,F中50,'  ...中50%'),COLOR86789A;
DRAWTEXT(ISLASTBAR,F61,'  ...61.8%'),COLOR16FF18;
DRAWTEXT(ISLASTBAR,F80,'  ...80.9%'),COLORFFA816;
{主力介入}
VAR013:=IF(MA(CLOSE,13)>REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL);
主力介入:=(IF(CLOSE>MA(CLOSE,13) AND OPEN<CLOSE,-0.1,0))AND((C-REF(C,1))/(REF(C,1))>0.061)AND (MA(CLOSE,13)=VAR013) AND (MA(CLOSE,1),MA(CLOSE,13)) AND (VOL>REF(HHV(VOL,3),1)*2);
DRAWTEXT(主力介入,MIN(EMA55,L*0.95),'主力'),COLOR18AAFF;[/lycode][lycode=tdx2,true]BCTC赋值:收盘价的有效数据周期数
LC赋值:1日前的收盘价
MID赋值:(3*收盘价+最低价+开盘价+最高价)/6
BBI赋值:(收盘价的3日简单移动平均+收盘价的6日简单移动平均+收盘价的12日简单移动平均+收盘价的24日简单移动平均)/4,COLORAA16FF
顶UPR赋值:BBI+3*BBI的13日估算标准差,COLOR004AFF
底DWN赋值:BBI-3*BBI的13日估算标准差,COLOR67FF00
爆发临界赋值:BBI>1日前的BBI AND 3日内顶UPR-底DWN的最低值=(顶UPR-底DWN) AND 收盘价上穿顶UPR,画红色,LINESTICK
画带状线
画带状线
输出PE:MID/每股收益(全年折算),COLOR1816FF,NODRAW
输出BBI线:(收盘价的5日简单移动平均+收盘价的10日简单移动平均+收盘价的15日简单移动平均+收盘价的20日简单移动平均)/4,COLORFFAA16
K线
HV赋值:20日内成交量(手)的最高值=成交量(手) OR 成交量(手)/1日前的成交量(手)>=5
FT赋值:上次HV距今天数
输出量能平台1:如果HV,返回收盘价,否则返回FT日前的收盘价,COLOR18AFAF,POINTDOT
PTN赋值:10
PT1赋值:10日内成交量(手)距今天数的最后一日取值设为常数,COLOR0000FF,线宽为1
输出量能平台:如果到最后交易的周期<=PTN+7,返回如果PT1=0,返回收盘价,否则返回PT1日前的收盘价的最后一日取值设为常数,否则返回无效数,COLOR1FFFFF,线宽为1,DOTLINE
当满足条件是否最后一个周期时,在量能平台位置书写文字,COLOR18FFFF
CPX40赋值:MID的40日加权移动平均
CPX30赋值:MID的30日加权移动平均
CPX20赋值:MID的20日加权移动平均
CPX15赋值:MID的15日加权移动平均
CPX10赋值:MID的10日加权移动平均
CPX5赋值:MID的5日加权移动平均
CPX3赋值:MID的3日加权移动平均
STZF赋值:(收盘价和开盘价的较大值/收盘价和开盘价的较小值-1)*100
均STZF赋值:(STZF的21日累和-STZF)/20
DYX赋值:收盘价<LC AND (100*(LC-收盘价)/LC>(均STZF*2.5))
ZNCPX3赋值:如果DYX,返回(6*收盘价+2*1日前的MID+1*2日前的MID)/9,否则返回CPX3
DYKX赋值:收盘价>LC AND (100*(收盘价-LC)/LC>(均STZF*2.5))
ZNCPX5赋值:如果DYKX,返回(6*收盘价+2*1日前的MID+1*2日前的MID)/9,否则返回CPX5
CPMXK赋值:CPX20
CPMXM赋值:CPX30
CPKXM赋值:ZNCPX3
CPKXK赋值:ZNCPX3
UP赋值:CPX30>1日前的CPX30
DOWN赋值:CPX30<1日前的CPX30
CPXM赋值:如果UP,返回CPMXK,否则返回如果DOWN,返回CPMXM,否则返回0
CPXK赋值:如果UP,返回CPKXM,否则返回如果DOWN,返回CPKXK,否则返回0
D赋值:CPXK> CPXM
K赋值:CPXK<=CPXM
长赋值:MID的30日加权移动平均
中赋值:MID的20日加权移动平均
短赋值:MID的10日加权移动平均
SXX赋值:短>1日前的短 AND 中<1日前的中 AND 长<1日前的长
SMX赋值:短>1日前的短 AND 中>1日前的中 AND 长<1日前的长
SML赋值:短>1日前的短 AND 中>1日前的中 AND 长>1日前的长
SXL赋值:短>1日前的短 AND 中<1日前的中 AND 长>1日前的长
XML赋值:短<1日前的短 AND 中>1日前的中 AND 长>1日前的长
XXL赋值:短<1日前的短 AND 中<1日前的中 AND 长>1日前的长
XXX赋值:短<1日前的短 AND 中<1日前的中 AND 长<1日前的长
均线最大赋值:CPX5和CPX10和CPX20和CPX30和CPX40的较大值的较大值的较大值的较大值
均线最小赋值:CPX5和CPX10和CPX20和CPX30和CPX40的较小值的较小值的较小值的较小值
高缠绕度赋值:1000*(均线最大/均线最小-1)<27
低缠绕度赋值:1000*(均线最大/均线最小-1)>=27
投机赋值:10
试盘赋值:如果SXX,返回20,否则返回0
加仓赋值:如果SMXANDD,返回40,否则返回如果SMXANDK,返回20,否则返回0
重仓赋值:如果SMLANDDAND低缠绕度,返回90,否则返回如果SMLANDDAND高缠绕度,返回60,否则返回如果SMLANDK,返回20,否则返回0
高仓赋值:如果SXLANDDAND低缠绕度,返回70,否则返回如果SXLANDDAND高缠绕度,返回40,否则返回如果SXLANDK,返回20,否则返回0
减仓赋值:如果XMLANDD,返回60,否则返回如果XMLANDK,返回20,否则返回0
轻仓赋值:如果XXLANDD,返回30,否则返回如果XXLANDK,返回20,否则返回0
空仓赋值:如果XXX,返回0,否则返回0
仓位1赋值:如果SMLANDDAND低缠绕度,返回90,否则返回如果SXLANDDAND低缠绕度,返回70,否则返回如果(XMLANDD)OR(SMLANDDAND高缠绕度),返回60,否则返回如果(1/2))10,返回50,否则返回如果(SMXANDD)OR(SXLANDDAND高缠绕度),返回40,否则返回如果XXLANDD,返回30,否则返回0
仓位2赋值:如果SXXOR(SMXANDK)OR(SMLANDK)OR(SXLANDK)OR(XMLANDK)OR(XXLANDK),返回20,否则返回10
仓位A赋值:仓位1和仓位2的较大值
配置仓位赋值:如果((1日前的仓位A(90)OR(1日前的仓位A(70))AND(仓位A<=50AND仓位A>=30),返回60,否则返回仓位A,NODRAW,画白色
修正一天赋值:统计2日中满足配置仓位>=70的天数赋值:1 AND 统计2日中满足配置仓位>=30AND配置仓位<=60的天数 1
修正二天赋值:统计3日中满足配置仓位>=70的天数赋值:1 AND 统计3日中满足配置仓位>=30AND配置仓位<=60的天数 2
修正三天赋值:统计4日中满足配置仓位>=70的天数赋值:1 AND 统计4日中满足配置仓位>=30AND配置仓位<=60的天数 3
修正四天赋值:统计5日中满足配置仓位>=70的天数赋值:1 AND 统计5日中满足配置仓位>=30AND配置仓位<=60的天数 4
修正五天赋值:统计6日中满足配置仓位>=70的天数赋值:1 AND 统计6日中满足配置仓位>=30AND配置仓位<=60的天数 5
修正六天赋值:统计7日中满足配置仓位>=70的天数赋值:1 AND 统计7日中满足配置仓位>=30AND配置仓位<=60的天数 6
修正七天赋值:统计8日中满足配置仓位>=70的天数赋值:1 AND 统计8日中满足配置仓位>=30AND配置仓位<=60的天数 7
修正八天赋值:统计9日中满足配置仓位>=70的天数赋值:1 AND 统计9日中满足配置仓位>=30AND配置仓位<=60的天数 8
修正九天赋值:统计10日中满足配置仓位>=70的天数赋值:1 AND 统计10日中满足配置仓位>=30AND配置仓位<=60的天数 9
修正十天赋值:统计11日中满足配置仓位>=70的天数赋值:1 AND 统计11日中满足配置仓位>=30AND配置仓位<=60的天数 10
修正十一天赋值:统计12日中满足配置仓位>=70的天数赋值:1 AND 统计12日中满足配置仓位>=30AND配置仓位<=60的天数 11
修正十二天赋值:统计13日中满足配置仓位>=70的天数赋值:1 AND 统计13日中满足配置仓位>=30AND配置仓位<=60的天数 12
修正十三天赋值:统计14日中满足配置仓位>=70的天数赋值:1 AND 统计14日中满足配置仓位>=30AND配置仓位<=60的天数 13
蓝赋值:配置仓位<=20
红赋值:(配置仓位>=70) OR 修正一天 OR 修正二天 OR 修正三天 OR 修正四天 OR 修正五天 OR 修正六天 OR修正七天 OR 修正八天  OR 修正九天  OR 修正十天  OR 修正十一天  OR 修正十二天  OR 修正十三天
黄赋值:(红(0) AND (蓝(0)
VAR1赋值:收盘价的9日指数移动平均的9日指数移动平均
控盘赋值:((VAR1-1日前的VAR1)/1日前的VAR1*1000)>0
输出仓位马力:如果控盘AND配置仓位<=50,返回50,否则返回配置仓位,NODRAW,COLOR1658AA
黄新赋值:黄 OR (控盘(0 AND 红) OR (控盘 AND 蓝) OR (控盘(0 AND 仓位马力>=60)
蓝新赋值:蓝 OR (控盘(0 AND 黄)
红新赋值:红
修一天赋值:统计2日中满足红新的天数赋值:1 AND 统计2日中满足黄新的天数 1
修二天赋值:统计3日中满足红新的天数赋值:1 AND 统计3日中满足黄新的天数 2
修三天赋值:统计4日中满足红新的天数赋值:1 AND 统计4日中满足黄新的天数 3
修四天赋值:统计5日中满足红新的天数赋值:1 AND 统计5日中满足黄新的天数 4
修五天赋值:统计6日中满足红新的天数赋值:1 AND 统计6日中满足黄新的天数 5
修六天赋值:统计7日中满足红新的天数赋值:1 AND 统计7日中满足黄新的天数 6
修七天赋值:统计8日中满足红新的天数赋值:1 AND 统计8日中满足黄新的天数 7
修八天赋值:统计9日中满足红新的天数赋值:1 AND 统计9日中满足黄新的天数 8
修九天赋值:统计10日中满足红新的天数赋值:1 AND 统计10日中满足黄新的天数 9
修十天赋值:统计11日中满足红新的天数赋值:1 AND 统计11日中满足黄新的天数 10
修十一天赋值:统计12日中满足红新的天数赋值:1 AND 统计12日中满足黄新的天数 11
红色修正赋值:修一天 OR 修二天 OR 修三天 OR 修四天 OR 修五天 OR 修六天 OR修七天 OR 修八天 OR 修九天 OR 修十天 OR 修十一天
XYELLOW赋值: (控盘 AND 蓝) OR (控盘 AND 黄) OR (控盘(0 AND 红) OR (控盘(0 AND 仓位马力>=60)
XRED赋值:  (控盘 AND 红) OR 红色修正
XBLUE赋值: (控盘(0 AND 蓝) OR (控盘(0 AND 黄)
输出黄柱:如果(XRED(0)ANDXYELLOW,返回1,否则返回无效数,COLOR0088FF,NODRAW
输出红柱:如果XRED,返回1,否则返回无效数,COLOR1816FF,NODRAW
输出蓝柱:如果XBLUEAND(XYELLOW))0,返回1,否则返回无效数,COLORFF8800,NODRAW
MA5赋值:收盘价的5日简单移动平均,COLORFFEFDF
输出EMA21:收盘价的21日指数移动平均,COLORFF16FF,线宽为2
输出EMA55:收盘价的55日指数移动平均,COLOR16AA18,线宽为2
输出EMA89:收盘价的89日指数移动平均,COLOR5856EE,线宽为2
如果BBI线>1日前的BBI线,返回BBI线,否则返回无效数,COLOR18AAFF
DIFF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均,COLORAAA818
DEA赋值:DIFF的9日指数移动平均,COLORAAFF56,线宽为2
赋值:2*(DIFF-DEA),COLORAA5678
牛回头赋值:DEA上穿DIFF AND DIFF>0 AND EMA55>2日前的EMA55 AND 成交量(手)的5日简单移动平均<5日前的成交量(手)的5日简单移动平均
当满足条件牛回头的BCTC日反向过滤时,在EMA55和最低价*0.99的较小值位置书写文字,COLOR5816FF
HLN赋值:55
输出顶线:HLN日内(最高价)的6日简单移动平均的最高值,DOTLINE,COLOR987868
输出底线:HLN日内(最低价)的5日简单移动平均的最低值,DOTLINE,COLOR688899
操作赋值:MID的5日简单移动平均
输出拉升:13日内操作的最高值,DOTLINE,COLORFF18AA
输出买卖:13日内操作的最低值,DOTLINE,COLORCDFFFF
当满足条件(控盘(0AND仓位马力>=60)时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0088FF
当满足条件红色修正时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000AA
当满足条件控盘AND蓝时,在收盘价和开盘价位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLORFF5816
当满足条件控盘AND红时,在收盘价和开盘价位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLOR0000FF
当满足条件控盘AND黄时,在收盘价和开盘价位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLOR0088FF
当满足条件控盘0AND蓝时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFF8816
当满足条件控盘0AND红时,在收盘价和开盘价位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLOR0088FF
当满足条件控盘0AND黄时,在收盘价和开盘价位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLOR00FFFF
CPM1赋值:收盘价的1日简单移动平均
CPM2赋值:(最低价+最高价+收盘价)/3
CPM3赋值: CPM2的5日简单移动平均
CPM4赋值: 10日内CPM3的最高值
CPZ赋值:10日内(CPM1<CPM4)的最高值 OR 10日内(CPM1<CPM4)的最高值
RSI34S赋值:100*(收盘价-34日内最低价的最低值)/(35日内最高价的最高值-34日内最低价的最低值)的3日指数移动平均
当满足条件RSI34S上穿60的20日过滤时,在最低价*0.97和EMA55的较小值位置书写文字,画黄色
当满足条件爆发临界的BCTC日反向过滤时,在底DWN和EMA55的较小值位置书写文字,COLOR16FF58
MV135赋值:成交量(手)的135日简单移动平均
TJ1赋值:成交量(手)=10日内成交量(手)的最高值 AND 成交量(手)>1.7*1日前的成交量(手) AND 收盘价>=1日前的收盘价 AND 收盘价>=开盘价 AND 成交量(手)<=MV135*3.5
当满足条件TJ1的3日过滤时,在开盘价和收盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORF05FF0
当满足条件TJ1的3日过滤的BCTC日反向过滤时,在最低价*0.965和EMA89的较小值位置书写文字,COLORAA16AA
当满足条件收盘价的10日简单移动平均上穿MA5的BCTC日反向过滤时,在最低价*0.95位置书写文字,COLOR18FFAA
BIAS5赋值:(收盘价-MA5)/MA5*100
当满足条件-7.1上穿BIAS5的BCTC日反向过滤时,在最低价*0.97和EMA89的较小值位置书写文字,COLOR18FFAA
RSV8赋值:(收盘价-8日内最低价的最低值)/(8日内最高价的最高值-8日内最低价的最低值)*100
操盘K赋值:RSV8的2日[1日权重]移动平均
短抄底信号赋值:操盘K>1日前的操盘K AND 1日前的操盘K<2日前的操盘K AND 操盘K<23
当满足条件短抄底信号的BCTC日反向过滤时,在最低价*0.975和EMA89的较小值位置书写文字,COLOR16DFEF
涨空间L赋值:(89日内最高价的最高值-89日内最低价的最低值)*100/89日内最低价的最低值>35 AND 最高价>5日前的最高价 AND 最高价>5日前的83日内最高价的最高值
多头排列赋值:收盘价的10日简单移动平均>=收盘价的20日简单移动平均 AND 收盘价的20日简单移动平均>5日前的收盘价的20日简单移动平均
HSL赋值:成交量(手)/当前流通股本(手)*100
低换手30赋值:30日内HSL的最低值=HSL
ZF赋值:(最高价-最低价)/1日前的收盘价*100
小振幅赋值:10日内ZF的最低值=ZF OR ZF<3.5
输出主升起爆点:如果涨空间LAND多头排列AND(低换手30OR小振幅),返回EMA21,否则返回无效数,COLORCFFFCF,线宽为3
当满足条件主升起爆点的3日过滤时,在EMA89*0.997位置书写文字,COLORCFFFCF
强势股赋值:最高价/1日前的最低价>1.15 OR 最高价/2日前的最低价>1.18
回调赋值:最低价/1日前的最高价<0.97 AND 收盘价<1日前的收盘价
强势逃顶赋值:1日前的强势股 AND 回调
当满足条件强势逃顶的BCTC日反向过滤时,在最高价*1.039位置书写文字,COLORAFAF6F
顶HH赋值:0日前的HLN日内最高价的最高值
底LL赋值:0日前的HLN日内最低价的最低值
F80赋值:顶HH-(顶HH-底LL)*0.191,COLORFFA816,DOTLINE,NODRAW
F61赋值:顶HH-(顶HH-底LL)*0.382,画绿色,DOTLINE,NODRAW
F中50赋值:顶HH-(顶HH-底LL)*0.5,COLOR3366AA,DOTLINE,NODRAW
F38赋值:顶HH-(顶HH-底LL)*0.618,COLOR18FFFF,DOTLINE,NODRAW
F19赋值:顶HH-(顶HH-底LL)*0.809,COLORAA18AA,DOTLINE,NODRAW
当满足条件是否最后一个周期时,在顶HH位置书写文字,画白色
当满足条件是否最后一个周期时,在底LL位置书写文字,画白色
当满足条件是否最后一个周期时,在F19位置书写文字,画洋红色
当满足条件是否最后一个周期时,在F38位置书写文字,画黄色
当满足条件是否最后一个周期时,在F中50位置书写文字,COLOR86789A
当满足条件是否最后一个周期时,在F61位置书写文字,COLOR16FF18
当满足条件是否最后一个周期时,在F80位置书写文字,COLORFFA816
VAR013赋值:如果收盘价的13日简单移动平均>1日前的收盘价的13日简单移动平均,返回收盘价的13日简单移动平均,否则返回无效数
主力介入赋值:(如果收盘价>收盘价的13日简单移动平均ANDOPEN<收盘价,返回-0.1,否则返回0)AND((收盘价-1日前的收盘价)/(1日前的收盘价)>0.061)AND (收盘价的13日简单移动平均=VAR013) AND (收盘价的1日简单移动平均,收盘价的13日简单移动平均) AND (成交量(手)>1日前的3日内成交量(手)的最高值*2)
当满足条件主力介入时,在EMA55和最低价*0.95的较小值位置书写文字,COLOR18AAFF[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1d7tLb_afjmQbNBIb79N9Hg

看了该指标的人还看了:
超牛底部启动点指标    短线反弹指标
买入时机指标    五指标共振指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表