请选择 进入手机版|继续访问电脑版

新庄指标 通达信 副图 波段 短线 买卖点 抄底逃顶 庄家主力

[复制链接]

admin  管理员

发表于 2018-7-9 09:00:16 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 抄底逃顶 庄家主力 
新庄指标 通达信 副图 波段 短线 买卖点 抄底逃顶 庄家主力 炒股叉第8183张

新庄指标 通达信 副图 波段 短线 买卖点 抄底逃顶 庄家主力 炒股叉第8184张

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=1/WINNER(CLOSE);
VAR2:=MA(CLOSE,13);
VAR3:=100-ABS((CLOSE-VAR2)/VAR2*100);
VAR4:=LLV(LOW,75);
VAR5:=HHV(HIGH,75);
VAR6:=(VAR5-VAR4)/100;
VAR7:=SMA((CLOSE-VAR4)/VAR6,20,1);
VAR8:=SMA((OPEN-VAR4)/VAR6,20,1);
VAR9:=3*VAR7-2*SMA(VAR7,15,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=100-VARA;
VARC:=IF(900101<DATE AND DATE<99991230,1,0);
看实力: (100-VAR9)*VARC, , {000B0001};
散户区: MA(WINNER(CLOSE*0.95)*100,3)*VARC, , COLORLICYAN;
新庄区: (100-IF(VAR1>5,IF(VAR1<100,VAR1,VAR3-10),0))*VARC, , COLORYELLOW;
VARD:=散户区>VAR3;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
VAR21:=(HIGH+LOW+CLOSE)/3;
VAR22:=(VAR21-MA(VAR21,14))/(0.015*AVEDEV(VAR21,14));
VAR23:=(VAR21-MA(VAR21,70))/(0.015*AVEDEV(VAR21,70));
VAR24:=IF(VAR22>=150 AND VAR22<200 AND VAR23>=150 AND VAR23<200,10,0);
VAR25:=IF(VAR22<=-150 AND VAR22>-200 AND VAR23<=-150 AND VAR23>-200,-10,VAR24);
VAR26:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR27:=REVERSE(VAR26);
VAR28:=SMA(VAR26,3,1);
散户: SMA(VAR28,3,1)*VARC, , ;
新庄: SMA(散户,3,1)*VARC, , COLORYELLOW;
地狱: IF(CROSS(散户,新庄) AND 散户<30,新庄,0)*VARC, , COLORRED;
天堂: IF(CROSS(新庄,散户) AND 新庄>75,新庄,100)*VARC, , COLORGREEN;
DRAWTEXT(CROSS(散户,新庄) AND 散户<30,新庄,'吸'), ,COLORWHITE;
DRAWTEXT(CROSS(新庄,散户) AND 新庄>75,新庄,'减'), , COLORRED;
小心断裂: (IF(VAR23>=200 AND VAR22>=150,15,IF(VAR23<=-200 AND VAR22<=-150,-15,VAR25))+50)*VARC, , COLORRED{00050006};
DRAWTEXT(CROSS(VAR20,0.5) AND COUNT(VAR20=1,10)=1,35,'抄'), , COLORYELLOW;
IF(CROSS(VARD,0.5) AND COUNT(VARD=1,10)=1,50,100) COLORMAGENTA;
{DRAWTEXT(CROSS(VARD,0.5) AND COUNT(VARD=1,10)=1,65,'逃'), , COLORRED;}
STICKLINE(VARD,100,25,1,0), , ;
STICKLINE(1,散户区,0,1,0), , COLOR302000;
STICKLINE(1,新庄区,100,1,0), , COLORLICYAN;
STICKLINE(VAR20,0,80,1,0), , COLORRED;[/lycode][lycode=tdx2,true]VAR1赋值:1/以收盘价计算的获利盘比例
VAR2赋值:收盘价的13日简单移动平均
VAR3赋值:100-(收盘价-VAR2)/VAR2*100的绝对值
VAR4赋值:75日内最低价的最低值
VAR5赋值:75日内最高价的最高值
VAR6赋值:(VAR5-VAR4)/100
VAR7赋值:(收盘价-VAR4)/VAR6的20日[1日权重]移动平均
VAR8赋值:(开盘价-VAR4)/VAR6的20日[1日权重]移动平均
VAR9赋值:3*VAR7-2*VAR7的15日[1日权重]移动平均
VARA赋值:3*VAR8-2*VAR8的15日[1日权重]移动平均
VARB赋值:100-VARA
VARC赋值:如果900101<DATEANDDATE<99991230,返回1,否则返回0
输出看实力: (100-VAR9)*VARC, ,
输出散户区: 以收盘价*0.95计算的获利盘比例*100的3日简单移动平均*VARC, , 画淡青色
输出新庄区: (100-如果VAR1>5,返回如果VAR1<100,返回VAR1,否则返回VAR3-10,否则返回0)*VARC, , 画黄色
VARD赋值:散户区>VAR3
VARE赋值:1日前的最低价*0.9
VARF赋值:最低价*0.9
VAR10赋值:(VARF*成交量(手)+VARE*(当前流通股本(手)-成交量(手)))/当前流通股本(手)
VAR11赋值:VAR10的30日指数移动平均
VAR12赋值:收盘价-1日前的收盘价
VAR13赋值:VAR12和0的较大值
VAR14赋值:VAR12的绝对值
VAR15赋值:VAR13的7日[1日权重]移动平均/VAR14的7日[1日权重]移动平均*100
VAR16赋值:VAR13的13日[1日权重]移动平均/VAR14的13日[1日权重]移动平均*100
VAR17赋值:收盘价的有效数据周期数
VAR18赋值:VAR12和0的较大值的6日[1日权重]移动平均/VAR12的绝对值的6日[1日权重]移动平均*100
VAR19赋值:(-200)*(60日内最高价的最高值-收盘价)/(60日内最高价的最高值-60日内最低价的最低值)+100
VAR1A赋值:(收盘价-15日内最低价的最低值)/(15日内最高价的最高值-15日内最低价的最低值)*100
VAR1B赋值:(VAR1A的4日[1日权重]移动平均-50)*2的3日[1日权重]移动平均
VAR1C赋值:(大盘的收盘价-14日内大盘的最低价的最低值)/(14日内大盘的最高价的最高值-14日内大盘的最低价的最低值)*100
VAR1D赋值:VAR1C的4日[1日权重]移动平均
VAR1E赋值:VAR1D的3日[1日权重]移动平均
VAR1F赋值:(30日内最高价的最高值-收盘价)/收盘价*100
VAR20赋值:VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-收盘价>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50
VAR21赋值:(最高价+最低价+收盘价)/3
VAR22赋值:(VAR21-VAR21的14日简单移动平均)/(0.015*VAR21的14日平均绝对偏差)
VAR23赋值:(VAR21-VAR21的70日简单移动平均)/(0.015*VAR21的70日平均绝对偏差)
VAR24赋值:如果VAR22>=150ANDVAR22<200ANDVAR23>=150ANDVAR23<200,返回10,否则返回0
VAR25赋值:如果VAR22<=-150ANDVAR22>-200ANDVAR23<=-150ANDVAR23>-200,返回-10,否则返回VAR24
VAR26赋值:(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100
VAR27赋值:VAR26的相反数
VAR28赋值:VAR26的3日[1日权重]移动平均
输出散户: VAR28的3日[1日权重]移动平均*VARC, ,
输出新庄: 散户的3日[1日权重]移动平均*VARC, , 画黄色
输出地狱: 如果散户上穿新庄AND散户<30,返回新庄,否则返回0*VARC, , 画红色
输出天堂: 如果新庄上穿散户AND新庄>75,返回新庄,否则返回100*VARC, , 画绿色
当满足条件散户上穿新庄AND散户<30时,在新庄位置书写文字, ,画白色
当满足条件新庄上穿散户AND新庄>75时,在新庄位置书写文字, , 画红色
输出小心断裂: (如果VAR23>=200ANDVAR22>=150,返回15,否则返回如果VAR23<=-200ANDVAR22<=-150,返回-15,否则返回VAR25+50)*VARC, , 画红色
当满足条件VAR20上穿0.5ANDCOUNT(VAR20=1,10)=1时,在35位置书写文字, , 画黄色
如果VARD上穿0.5ANDCOUNT(VARD=1,10)=1,返回50,否则返回100 画洋红色
当满足条件VARD时,在100和25位置之间画柱状线,宽度为1,0不为0则画空心柱., ,
当满足条件1时,在散户区和0位置之间画柱状线,宽度为1,0不为0则画空心柱., , COLOR302000
当满足条件1时,在新庄区和100位置之间画柱状线,宽度为1,0不为0则画空心柱., , 画淡青色
当满足条件VAR20时,在0和80位置之间画柱状线,宽度为1,0不为0则画空心柱., , 画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1FvPzRRDVbUrD0oZVQ1aygQ

看了该指标的人还看了:
金钱摸鬼指标    一股当先指标
主力通侧底指标    缠论108课公式最终版本

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表