请选择 进入手机版|继续访问电脑版

趋线支撑与压力指标 通达信 副图 波段 无未来函数 买卖点 抄底逃顶

[复制链接]

admin  管理员

发表于 2018-7-9 09:00:16 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 买卖点 抄底逃顶 
趋线支撑与压力指标 通达信 副图 波段 无未来函数 买卖点 抄底逃顶 炒股叉第8179张

趋线支撑与压力指标 通达信 副图 波段 无未来函数 买卖点 抄底逃顶 炒股叉第8180张

[lywrap=通达信副图指标公式][lycode=tdx,true]DIF:EMA(CLOSE,6)-EMA(CLOSE,19),,NODRAW;
DEA:EMA(DIF,9),NODRAW;
MACD:2*(DIF-DEA),COLORSTICK;
STICKLINE(MACD>0,MACD,0,0.5,0),COLORRED;
STICKLINE(MACD<0,MACD,0,0.5,0),COLORGREEN;
STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.5,0),COLORWHITE;
STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.5,0),COLORFF00FF;
FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
FH5:=FH1 AND FH2 AND MACD<0.10;
VV:=CLOSE>OPEN AND MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,30)
AND DIF>DEA AND MACD>REF(MACD,1) AND DIF>0 AND DEA>0 AND
MA(VOL,5)>MA(VOL,34) AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1);
佛手:IF(VV,1,0),NODRAW;
X0:=BARSLAST((CROSS(MACD,REF(MACD,1)) AND MACD>0) OR CROSS(MACD,0));
X1:=BARSLAST(CROSS(0.5,COUNT(MACD>REF(MACD,1),X0+1)=X0+1));
X2:=COUNT(MACD<REF(MACD,1),X1+1)=X1+1 AND COUNT(MACD<0,X1+1)<=2;
X3:=REF(X2,1) AND MACD>REF(MACD,1) AND C>O AND C>REF(C,1);
STICKLINE(X1=0 AND MACD>0,MACD,0,2,0),COLORDCDC00;
STICKLINE(X3,MACD,0,2,0),COLOR0854FF;
DRAWICON(佛手,-0.15,11);
二次翻红:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
低买:CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,NODRAW;
加油:CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,NODRAW;
DRAWICON(二次翻红,-0.05,1);
DRAWTEXT(二次翻红,-0.15,'↖翻红'),COLORRED;
DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,'↖低买'),COLORFF00FF;
DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,'↖加油'),COLORYELLOW;
XG:二次翻红 OR 低买 OR 加油,NODRAW;
YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
阻价:=IF(CLOSE=INDEXC,YLZC+INDEXC-INDEXL,YLZC+(CLOSE-LOW));
支价:=IF(CLOSE=INDEXC,INDEXL+INDEXC-YLZC,LOW+(CLOSE-YLZC));
今压:REF(阻价,1),LINETHICK0,COLORAA11BB,NODRAW;
今撑:REF(支价,1),LINETHICK0,COLOR009900,NODRAW;
明压:阻价,LINETHICK0,NODRAW;
明撑:支价,LINETHICK0,NODRAW;
DIFF:DIF,COLORRED,LINETHICK2;
DDEA:DEA,COLORYELLOW,LINETHICK2;VAR1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)
-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋线1:=EMA(VAR1,3) ;
VAR2:=(趋线1-REF(趋线1,1))/REF(趋线1,1)*100;
清仓:IF(趋线1>=90 AND VAR2<0,100,80),STICK,LINETHICK3,COLOR00FF00;80,STICK,LINETHICK3,COLOR000000;
准备:IF(趋线1<=13,20,0),STICK,LINETHICK3,COLORYELLOW;
买入:IF(趋线1<=13 AND VAR2>13,50,0),STICK,LINETHICK3,COLORRED;
0, LINETHICK0, COLOR999999;100, LINETHICK0, COLOR999999;
趋线:趋线1,LINETHICK1,COLORF0F000;[/lycode][lycode=tdx2,true]输出DIF:收盘价的6日指数移动平均-收盘价的19日指数移动平均,,NODRAW
输出DEA:DIF的9日指数移动平均,NODRAW
输出平滑异同平均:2*(DIF-DEA),COLORSTICK
当满足条件MACD>0时,在MACD和0位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画红色
当满足条件MACD<0时,在MACD和0位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画绿色
当满足条件MACD>0ANDMACD<1日前的MACD时,在MACD和0位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画白色
当满足条件MACD<0ANDMACD>1日前的MACD时,在MACD和0位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFF00FF
FH1赋值:1日前的MACD<2日前的MACD AND 2日前的MACD<3日前的MACD AND 3日前的MACD<4日前的MACD
FH2赋值:MACD>=0 AND 统计1日中满足MACD>1日前的MACD的天数=1
FH3赋值:FH1 AND FH2 AND 收盘价的13日指数移动平均>1日前的收盘价的13日指数移动平均
FH4赋值:FH1 AND FH2 AND (DIF-DEA)/收盘价的绝对值<0.018
FH5赋值:FH1 AND FH2 AND MACD<0.10
VV赋值:收阳线ANDSE 收盘价的5日简单移动平均>收盘价的10日简单移动平均 AND 收盘价的10日简单移动平均>收盘价的30日简单移动平均AND DIF>DEA AND MACD>1日前的MACD AND DIF>0 AND DEA>0 ANDMA(成交量(手),5)>成交量(手)的34日简单移动平均 AND 收盘价的30日简单移动平均>=1日前的收盘价的30日简单移动平均
输出佛手:如果VV,返回1,否则返回0,NODRAW
X0赋值:上次(MACD上穿1日前的MACDANDMACD>0)ORCROSS(MACD,0)距今天数
X1赋值:上次0.5上穿统计X0+1日中满足MACD>1日前的MACD的天数=X0+1距今天数
X2赋值:统计X1+1日中满足MACD<1日前的MACD的天数=X1+1 AND 统计X1+1日中满足MACD<0的天数<=2
X3赋值:1日前的X2 AND MACD>1日前的MACD AND 收阳线AND 收盘价>1日前的收盘价
当满足条件X1=0ANDMACD>0时,在MACD和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORDCDC00
当满足条件X3时,在MACD和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR0854FF
当满足条件佛手时,在-0.15位置画11号图标
输出二次翻红:(FH3 OR FH4 OR FH5),画红色,NODRAW
输出低买:DIF上穿DEA AND DIF<0,COLORFF00FF,NODRAW
输出加油:DIF上穿DEA AND DIF>0,画黄色,NODRAW
当满足条件二次翻红时,在-0.05位置画1号图标
当满足条件二次翻红时,在-0.15位置书写文字,画红色
当满足条件DIF上穿DEAANDDIF<0时,在DEA-0.02位置书写文字,COLORFF00FF
当满足条件DIF上穿DEAANDDIF>0时,在DEA-0.05位置书写文字,画黄色
输出XG:二次翻红 OR 低买 OR 加油,NODRAW
YLZC赋值:如果收盘价=大盘的收盘价,返回(大盘的收盘价+大盘的最高价+大盘的最低价+大盘的开盘价)/4,否则返回成交额(元)/(成交量(手)+0.01)/100
阻价赋值:如果收盘价=大盘的收盘价,返回YLZC+大盘的收盘价-大盘的最低价,否则返回YLZC+(收盘价-最低价)
支价赋值:如果收盘价=大盘的收盘价,返回大盘的最低价+大盘的收盘价-YLZC,否则返回最低价+(收盘价-YLZC)
输出今压:1日前的阻价,线宽为0,COLORAA11BB,NODRAW
输出今撑:1日前的支价,线宽为0,COLOR009900,NODRAW
输出明压:阻价,线宽为0,NODRAW
输出明撑:支价,线宽为0,NODRAW
输出DIFF:DIF,画红色,线宽为2
输出DDEA:DEA,画黄色,线宽为2
VAR1赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
趋线1赋值:VAR1的3日指数移动平均
VAR2赋值:(趋线1-1日前的趋线1)/1日前的趋线1*100
输出清仓:如果趋线1>=90ANDVAR2<0,返回100,否则返回80,STICK,线宽为3,COLOR00FF00
80,STICK,线宽为3,COLOR000000
输出准备:如果趋线1<=13,返回20,否则返回0,STICK,线宽为3,画黄色
输出买入:如果趋线1<=13ANDVAR2>13,返回50,否则返回0,STICK,线宽为3,画红色
0, 线宽为0, COLOR999999
100, 线宽为0, COLOR999999
输出趋线:趋线1,线宽为1,COLORF0F000[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1QhwyXigcd3iaDZpkxYfuBg

看了该指标的人还看了:
涨停板抄底指标    主力看盘指标
底顶指标    横盘启动买点指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表