请选择 进入手机版|继续访问电脑版

八卦太极指标 成功率89% 通达信 副图 波段 无未来函数 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-7-9 09:00:16 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 
八卦太极指标 成功率89% 通达信 副图 波段 无未来函数 短线 买卖点 炒股叉第8165张

八卦太极指标 成功率89% 通达信 副图 波段 无未来函数 短线 买卖点 炒股叉第8166张

[lywrap=通达信副图指标公式][lycode=tdx,true]BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,11)*100;
老二:=IF(BIAS2<=-10,1,0);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,150);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
爆发:=MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)
AND REF(MACD ,2)<REF(MACD ,3)
AND REF(MACD ,3)<REF(MACD ,4);
VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
大底:=VAR6<=-10;
VAR11:=CLOSE/MA(CLOSE,20)*100<80;
VAR12:=CLOSE/MA(CLOSE,40)*100<78;
VAR13:=CLOSE/MA(CLOSE,60)*100<72;
VAR14:=HIGH>LOW*1.051;
VAR15:=VAR14 AND COUNT(VAR14,5)>1;
中底:=VAR15 AND (VAR11 OR VAR12 OR VAR13);
趋势线:=(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 ;
AA:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-30) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-30,趋势线),1) AND CROSS(趋势线,-30)) OR 趋势线=-30;
砸盘:=IF(AA,500,-30);
BB:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-20 AND 趋势线>-25) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));
XG:=BB;
操盘:=EMA((CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
跟风:=EMA((CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
见到曙光:=CROSS(操盘,跟风) AND 操盘 <0 AND 跟风 <0;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓区:=VARO7<10;
TJ:=COUNT(建仓区,3);
VAR81:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
上升:=CROSS(VAR1,8);
准备上:=(建仓区 OR REF(建仓区,0.5)) AND 上升;
出手:=-FILTER((CROSS((EMA(CLOSE,2)-EMA(CLOSE,10)),
EMA((EMA(CLOSE,2)-EMA(CLOSE,10)),2))
AND EMA((EMA(CLOSE,2)-EMA(CLOSE,10)),2)
<0 AND CROSS(C,MA(C,20))),90);
D1:="WR.WR1"<5;
D2:=CROSS("KDJ.K","KDJ.D") AND "KDJ.K"<50;
D3:=CROSS("MACD.DIF","MACD.DEA");
D4:="CCI.CCI">-100 AND "CCI.CCI"<-90;
D5:=CROSS("RSI.RSI1","RSI.RSI2")AND "RSI.RSI1"<50;
S1:=20;
M2:=40;
L1:=60;
AAA:=CLOSE>OPEN;
BBB:=AAA&&CLOSE>MA(CLOSE,S1)&&CLOSE>MA(CLOSE,M2)&&CLOSE>MA(CLOSE,L1);
CCC:=BBB&&OPEN<MA(CLOSE,M2)&&OPEN<MA(CLOSE,L1);
XG1:=CCC&&(CLOSE-OPEN)>0.0618*CLOSE;
AA1:=D1 AND D2;
AA2:=D2 AND D3;
AA3:=D1 AND D3;
XG2:=AA1 OR AA2 OR AA3;
强势:=IF(XG1 AND XG2,1,0);
WW:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
MM:=DMA(CLOSE,WW);
通道4:=(1-7/100)*MM;
VAR84:=EXPMA(CLOSE,9);
LDN:=EXPMA(VAR84*0.86,5);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
TTRR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),
ABS(REF(CLOSE,1)-LOW)),14);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/TTRR;
MDI:=DMM*100/TTRR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
买底:=C<=通道4 AND C<=LDN AND CCI<-100
AND ADX>=60 AND MDI >= PDI AND CLOSE>OPEN;
VAR82:=LLV(LOW,10);
VAR83:=HHV(HIGH,25);
能量:=EMA((CLOSE-VAR82)/(VAR83-VAR82)*4,4);
底:=0.2;
关注:=0.5;
红色箭头:=FILTER(CROSS(能量,关注),20);
买入:=FILTER(CROSS(能量,底),20);
XXG:=买底 OR 红色箭头;
A:=SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,4,1);
B:=SMA((CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100,4,1);
MB:=SMA((B-50)*2,3,1)+SMA((A-50)*2,3,1)/2;
狗头金:=MB<-90;

综合: 狗头金 AND COUNT(XG,5) AND COUNT(中底,3) AND NOT(COUNT(XXG,1)) AND NOT(COUNT(见到曙光,3)) AND COUNT(老二,3) AND 大底 AND 爆发;[/lycode][lycode=tdx2,true]BIAS1赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100
BIAS2赋值:(收盘价-收盘价的12日简单移动平均)/收盘价的12日简单移动平均*100
BIAS3赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的11日简单移动平均*100
老二赋值:如果BIAS2<=-10,返回1,否则返回0
DIF赋值:收盘价的12日指数移动平均-收盘价的150日指数移动平均
DEA赋值:DIF的9日指数移动平均
MACD赋值:(DIF-DEA)*2
爆发赋值:MACD<0 AND MACD>1日前的MACD AND 1日前的MACD<2日前的MACDAND 2日前的MACD<3日前的MACDAND 3日前的MACD<4日前的MACD
VAR1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VAR2赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100
VAR3赋值:(收盘价-收盘价的12日简单移动平均)/收盘价的12日简单移动平均*100
VAR4赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100
VAR5赋值:(VAR2+2*VAR3+3*VAR4)/6
VAR6赋值:VAR5的3日简单移动平均
大底赋值:VAR6<=-10
VAR11赋值:收盘价/收盘价的20日简单移动平均*100<80
VAR12赋值:收盘价/收盘价的40日简单移动平均*100<78
VAR13赋值:收盘价/收盘价的60日简单移动平均*100<72
VAR14赋值:最高价>最低价*1.051
VAR15赋值:VAR14 AND 统计5日中满足VAR14的天数>1
中底赋值:VAR15 AND (VAR11 OR VAR12 OR VAR13)
趋势线赋值:(收盘价-收盘价的40日简单移动平均)/收盘价的40日简单移动平均*100
AA赋值:((1日前的趋势线<2日前的趋势线 AND 趋势线<-30) AND 趋势线>=1日前的趋势线) OR (1日前的-30上穿趋势线 AND 趋势线上穿-30) OR 趋势线=-30
砸盘赋值:如果AA,返回500,否则返回-30
BB赋值:((1日前的趋势线<2日前的趋势线 AND 趋势线<-20 AND 趋势线>-25) AND 趋势线>=1日前的趋势线) OR (1日前的-20上穿趋势线 AND 趋势线上穿-20)
XG赋值:BB
操盘赋值:(收盘价-收盘价的3日简单移动平均)/收盘价的3日简单移动平均的2日指数移动平均
跟风赋值:(收盘价-收盘价的20日简单移动平均)/收盘价的20日简单移动平均的7日指数移动平均
见到曙光赋值:操盘上穿跟风 AND 操盘 <0 AND 跟风 <0
VARO5赋值:27日内最低价的最低值
VARO6赋值:34日内最高价的最高值
VARO7赋值:(收盘价-VARO5)/(VARO6-VARO5)*4的4日指数移动平均*25
建仓区赋值:VARO7<10
TJ赋值:统计3日中满足建仓区的天数
VAR81赋值:4*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均-3*(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100的5日[1日权重]移动平均的3.2日[1日权重]移动平均
上升赋值:VAR1上穿8
准备上赋值:(建仓区 OR 0.5日前的建仓区) AND 上升
出手赋值:-((收盘价的2日指数移动平均-收盘价的10日指数移动平均)上穿(收盘价的2日指数移动平均-收盘价的10日指数移动平均)的2日指数移动平均ANDEMA((收盘价的2日指数移动平均-收盘价的10日指数移动平均),2)<0ANDCROSS(收盘价,收盘价的20日简单移动平均))的90日过滤
D1赋值:"WR的WR1"<5
D2赋值:"KDJ的K"上穿"KDJ的D" AND "KDJ的K"<50
D3赋值:"MACD.DIF"上穿"MACD.DEA"
D4赋值:"CCI的CCI">-100 AND "CCI的CCI"<-90
D5赋值:"RSI的RSI1"上穿"RSI的RSI2"AND "RSI的RSI1"<50
S1赋值:20
M2赋值:40
L1赋值:60
AAA赋值:收阳线
BBB赋值:AAA并且收盘价>收盘价的S1日简单移动平均并且收盘价>收盘价的M2日简单移动平均并且收盘价>收盘价的L1日简单移动平均
CCC赋值:BBB并且开盘价<收盘价的M2日简单移动平均并且开盘价<收盘价的L1日简单移动平均
XG1赋值:CCC并且(收盘价-开盘价)>0.0618*收盘价
AA1赋值:D1 AND D2
AA2赋值:D2 AND D3
AA3赋值:D1 AND D3
XG2赋值:AA1 OR AA2 OR AA3
强势赋值:如果XG1ANDXG2,返回1,否则返回0
WW赋值:(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均
MM赋值:以WW为权重收盘价的动态移动平均
通道4赋值:(1-7/100)*MM
VAR84赋值:收盘价的9日指数移动平均
LDN赋值:VAR84*0.86的5日指数移动平均
TYP赋值:(最高价+最低价+收盘价)/3
CCI赋值:(TYP-TYP的14日简单移动平均)/(0.015*TYP的14日平均绝对偏差)
TTRR赋值:最高价-最低价和最高价-1日前的收盘价的绝对值的较大值和1日前的收盘价-最低价的绝对值的较大值的14日指数平滑移动平均
HD赋值:最高价-1日前的最高价
LD赋值:1日前的最低价-最低价
DMP赋值:如果HD>0并且HD>LD,返回HD,否则返回0的14日指数平滑移动平均
DMM赋值:如果LD>0并且LD>HD,返回LD,否则返回0的14日指数平滑移动平均
PDI赋值:DMP*100/TTRR
MDI赋值:DMM*100/TTRR
ADX赋值:MDI-PDI的绝对值/(MDI+PDI)*100的6日指数平滑移动平均
买底赋值:收盘价<=通道4 AND 收盘价<=LDN AND CCI<-100AND ADX>=60 AND MDI >= PDI AND 收阳线
VAR82赋值:10日内最低价的最低值
VAR83赋值:25日内最高价的最高值
能量赋值:(收盘价-VAR82)/(VAR83-VAR82)*4的4日指数移动平均
底赋值:0.2
关注赋值:0.5
红色箭头赋值:能量上穿关注的20日过滤
买入赋值:能量上穿底的20日过滤
XXG赋值:买底 OR 红色箭头
A赋值:(收盘价-14日内最低价的最低值)/(14日内最高价的最高值-14日内最低价的最低值)*100的4日[1日权重]移动平均
B赋值:(收盘价-15日内最低价的最低值)/(15日内最高价的最高值-15日内最低价的最低值)*100的4日[1日权重]移动平均
MB赋值:(B-50)*2的3日[1日权重]移动平均+(A-50)*2的3日[1日权重]移动平均/2
狗头金赋值:MB<-90
输出综合: 狗头金 AND 统计5日中满足XG的天数 AND 统计3日中满足中底的天数 AND 取反 AND 取反 AND 统计3日中满足老二的天数 AND 大底 AND 爆发[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/16Z1KSvyE-9IKhNXF5o6gYg

看了该指标的人还看了:
主力潜伏吃货指标    次新擒牛指标
看色操作指标    操盘利器CCI指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表