请选择 进入手机版|继续访问电脑版

飞鱼箱体指标 通达信 副图 波段 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-7-8 09:00:24 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 操盘控盘 
飞鱼箱体指标 通达信 副图 波段 短线 买卖点 操盘控盘 炒股叉第8153张

飞鱼箱体指标 通达信 副图 波段 短线 买卖点 操盘控盘 炒股叉第8154张

[lywrap=通达信副图指标公式][lycode=tdx,true]箱顶:HHV(MA((LOW+HIGH+CLOSE+O)/4,5),58),COLOR00AAFF;
箱底:LLV(MA((LOW+HIGH+CLOSE+O)/4,6),88),COLORGREEN,LINETHICK2;
VAR2:=EMA((HIGH+LOW+CLOSE)/3*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*20/10+箱底,2);
VAR3:=(3*VAR2-2*SMA(VAR2,5,1))*0.3;
VAR4:=(HHV(INDEXH,13)-INDEXC)/(HHV(INDEXH,13)-LLV(INDEXL,13));
VAR5:=EMA(3*VAR4-2*SMA(VAR4,18,1),5);
VAR6:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8));
VAR7:=3*SMA(VAR6,3,1)-2*SMA(SMA(VAR6,3,1),5,1);
VAR8:=(INDEXC*2+INDEXH+INDEXL)/4;
VAR9:=EMA(VAR8,13)-EMA(VAR8,34);
VARA:=EMA(VAR9,5);
资金流向:=(VAR9-VARA+箱底)*1,COLORYELLOW;
VARG1:=1.86*EMA(CLOSE,5)-EMA(CLOSE,13);
趋势力度:VARG1,COLORFFAA99;
K2:=BACKSET(趋势力度>REF(趋势力度,1),2);
IF(K2,趋势力度,DRAWNULL),COLORFF00FF,LINETHICK1;
AS:=箱底;
牛气冲天:STICKLINE( 趋势力度>=AS,AS ,趋势力度 ,0,0 ) ,COLORRED ;
STICKLINE( 趋势力度<= REF(趋势力度,1)
AND 趋势力度>AS,AS ,趋势力度 ,0,1 ) ,COLORWHITE;
趁机派发:STICKLINE( REF(趋势力度,2)<REF(趋势力度,1) AND 趋势力度<= REF(趋势力度,1)
AND 趋势力度>AS,AS ,趋势力度 ,0 ,0 ) ,COLORGREEN ;
熊气盖天:STICKLINE( 趋势力度<AS-0.5,AS-0.5 ,趋势力度 ,0 ,1 ) , ;
MA3:MA(C,3),COLORAAEE00;
MA21:MA(C,21),COLORGREEN;
MA151:MA(C,151),COLOR0000CF;
K1:=BACKSET(MA21>REF(MA21,1),2);
强A:IF(K1,MA21,DRAWNULL),COLOR0000FF,LINETHICK2;
{DRAWTEXT( CROSS(MA3 , 箱底),L*0.99 , '试'),COLORRED;}
DRAWTEXT( CROSS(MA3 , MA21),L , '买'),COLORYELLOW;
DRAWTEXT( CROSS(MA3 , 箱顶) AND C>箱顶,箱顶 , '追'),COLOR00EEAA;
DRAWTEXT( CROSS(箱顶,MA3)AND C<箱顶 ,H , '卖') ,COLORFFAA99;
DRAWTEXT( REF(资金流向 ,2)<REF(资金流向 ,1) AND REF(资金流向 ,1)>资金流向
AND 资金流向>箱顶 AND C>箱顶,H*1.02, '顶'),COLORWHITE;
DRAWTEXT( CROSS(趋势力度 , 箱底),箱底, '加仓'),COLORRED;
E1:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
B0:=(AH-AL)/40;
KB1:=H+B0;
KB2:=L-B0;
STICKLINE((E1+0)/34=FLOOR((E1+0)/34),KB2,KB2-3*B0,1,0),COLORYELLOW,LINETHICK2;
DRAWTEXT((E1+0)/34=FLOOR((E1+0)/34),KB2-2*B0,'时间窗'),COLORWHITE;[/lycode][lycode=tdx2,true]输出箱顶:58日内(最低价+最高价+收盘价+开盘价)/4的5日简单移动平均的最高值,COLOR00AAFF
输出箱底:88日内(最低价+最高价+收盘价+开盘价)/4的6日简单移动平均的最低值,画绿色,线宽为2
VAR2赋值:(最高价+最低价+收盘价)/3*(10日内最高价的最高值-收盘价)/(10日内最高价的最高值-10日内最低价的最低值)*20/10+箱底的2日指数移动平均
VAR3赋值:(3*VAR2-2*VAR2的5日[1日权重]移动平均)*0.3
VAR4赋值:(13日内大盘的最高价的最高值-大盘的收盘价)/(13日内大盘的最高价的最高值-13日内大盘的最低价的最低值)
VAR5赋值:3*VAR4-2*VAR4的18日[1日权重]移动平均的5日指数移动平均
VAR6赋值:(大盘的收盘价-8日内大盘的最低价的最低值)/(8日内大盘的最高价的最高值-8日内大盘的最低价的最低值)
VAR7赋值:3*VAR6的3日[1日权重]移动平均-2*VAR6的3日[1日权重]移动平均的5日[1日权重]移动平均
VAR8赋值:(大盘的收盘价*2+大盘的最高价+大盘的最低价)/4
VAR9赋值:VAR8的13日指数移动平均-VAR8的34日指数移动平均
VARA赋值:VAR9的5日指数移动平均
资金流向赋值:(VAR9-VARA+箱底)*1,画黄色
VARG1赋值:1.86*收盘价的5日指数移动平均-收盘价的13日指数移动平均
输出趋势力度:VARG1,COLORFFAA99
K2赋值:若趋势力度>1日前的趋势力度则将最近2周期置为1
如果K2,返回趋势力度,否则返回无效数,COLORFF00FF,线宽为1
AS赋值:箱底
输出牛气冲天:当满足条件趋势力度>=AS时,在AS和趋势力度位置之间画柱状线,宽度为0,0不为0则画空心柱. ,画红色
当满足条件趋势力度<=1日前的趋势力度AND趋势力度>AS时,在AS和趋势力度位置之间画柱状线,宽度为0,1不为0则画空心柱. ,画白色
输出趁机派发:当满足条件2日前的趋势力度<1日前的趋势力度AND趋势力度<=1日前的趋势力度AND趋势力度>AS时,在AS和趋势力度位置之间画柱状线,宽度为0,0不为0则画空心柱. ,画绿色
输出熊气盖天:当满足条件趋势力度<AS-0.5时,在AS-0.5和趋势力度位置之间画柱状线,宽度为0,1不为0则画空心柱. ,
输出MA3:收盘价的3日简单移动平均,COLORAAEE00
输出MA21:收盘价的21日简单移动平均,画绿色
输出MA151:收盘价的151日简单移动平均,COLOR0000CF
K1赋值:若MA21>1日前的MA21则将最近2周期置为1
输出强A:如果K1,返回MA21,否则返回无效数,COLOR0000FF,线宽为2
当满足条件MA3上穿MA21时,在最低价位置书写文字,画黄色
当满足条件MA3上穿箱顶ANDC>箱顶时,在箱顶位置书写文字,COLOR00EEAA
当满足条件箱顶上穿MA3ANDC<箱顶时,在最高价位置书写文字 ,COLORFFAA99
当满足条件2日前的资金流向<1日前的资金流向ANDREF(资金流向,1)>资金流向AND资金流向>箱顶ANDC>箱顶时,在最高价*1.02位置书写文字,画白色
当满足条件趋势力度上穿箱底时,在箱底位置书写文字,画红色
E1赋值:收盘价的有效数据周期数
AH赋值:200日内最高价的最高值
AL赋值:200日内最低价的最低值
B0赋值:(AH-AL)/40
KB1赋值:最高价+B0
KB2赋值:最低价-B0
当满足条件(E1+0)/34=(E1+0)/34的向下舍入时,在KB2和KB2-3*B0位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色,线宽为2
当满足条件(E1+0)/34=(E1+0)/34的向下舍入时,在KB2-2*B0位置书写文字,画白色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1NFScLDy27fcWsac7CJEIfw

看了该指标的人还看了:
游资吸筹指标    机构私募仓位指标
五指标共振指标    买入时机指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表