请选择 进入手机版|继续访问电脑版

方大炭素指标,信号少成功率高 通达信 副图 波段 短线 买卖点

[复制链接]

admin  管理员

发表于 2018-7-5 09:00:09 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
方大炭素指标,信号少成功率高 通达信 副图 波段 短线 买卖点 炒股叉第8087张

方大炭素指标,信号少成功率高 通达信 副图 波段 短线 买卖点 炒股叉第8088张

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=MA(CLOSE,13);
VAR2:=MA(CLOSE,34);
VAR3:=MA(CLOSE,55);
VAR4:=OPEN<VAR1 AND CLOSE>VAR1;
VAR5:=OPEN<VAR2 AND CLOSE>VAR2;
VAR6:=OPEN<VAR3 AND CLOSE>VAR3;
VAR7:=CLOSE/OPEN>=1.04;
VAR8:=VOL>HHV(HIGH,10);
VAR9:=VAR1>=REF(VAR1,1);
VAR10:=1;
VAR11:=VAR4 AND VAR5 AND VAR6 AND VAR7 AND VAR8 AND VAR9;
VAR12:=MA(CLOSE,5);
VAR13:=MA(CLOSE,10);
VAR14:=MA(CLOSE,30);
VAR22:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VAR23:=INTPART(VAR22*100)/100;
VAR24:=EMA(CLOSE,5)-EMA(CLOSE,10)*VAR10;
VAR25:=EMA(VAR24,9);
VAR27:=1;
VAR31:=REF(VAR25,1)*VAR27;
VAR32:=VAR25;
VAR33:=VAR32-VAR31;
VAR34:=REF(VAR24,1)*VAR10;
VAR35:=VAR24;
VAR36:=VAR35-VAR34;
VAR37:=OPEN;
VAR38:=CLOSE;
VAR39:=VAR37<=VAR12 AND VAR37<=VAR13 AND VAR37<=VAR14 AND VAR38>=VAR12 AND VAR38>=VAR23 AND VAR33>0 AND VAR36>0;
VAR40:=(EMA(CLOSE,4)+MA(CLOSE,8)+MA(CLOSE,16))/3;
VAR41:=(EMA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/3;
VAR42:=(EMA(CLOSE,9)+MA(CLOSE,18)+MA(CLOSE,36))/3;
VAR43:=(EMA(CLOSE,13)+MA(CLOSE,26)+MA(CLOSE,52))/3;
VAR44:=(EMA(CLOSE,18)+MA(CLOSE,36)+MA(CLOSE,72))/3;
VAR45:=(EMA(CLOSE,24)+MA(CLOSE,48)+MA(CLOSE,96))/3;
VAR46:=OPEN<VAR40 AND OPEN<VAR41 AND OPEN<VAR42 AND OPEN<VAR43 AND OPEN<VAR44 AND OPEN<VAR45 AND CLOSE>VAR40 AND CLOSE>VAR41 AND CLOSE>VAR42 AND CLOSE>VAR43 AND CLOSE>VAR44 AND CLOSE>VAR45;
VAR47:=CLOSE;
VAR48:=(MA(VAR47,3)+MA(VAR47,6)+MA(VAR47,12)+MA(VAR47,24))/4;
VAR49:=VAR48+6*STD(VAR48,11)*VAR27;
VAR51:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
VAR52:=(IF(CLOSE>OPEN,VAR51*(HIGH-LOW),IF(CLOSE<OPEN,VAR51*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-VAR51*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-VAR51*(HIGH-LOW),0-VOL/2)))*VAR27;
VAR53:=VAR52/20/1.15;
VAR54:=(VAR53*0.55+REF(VAR53,1)*0.33+REF(VAR53,2)*0.22)*VAR10;
VAR55:=EMA(VAR54,3)*VAR10;
VAR56:=SUM(VAR55,1);
VAR57:=SUM(VAR55,2);
VAR58:=SUM(VAR55,3);
VAR59:=SUM(VAR55,4);
VAR60:=SUM(VAR55,5);
VAR61:=SUM(VAR55,6);
VAR62:=SUM(VAR55,7);
VAR63:=SUM(VAR55,8);
VAR64:=SUM(VAR55,9);
VAR65:=SUM(VAR55,10);
VAR66:=VAR56 AND VAR57 AND VAR58 AND VAR59 AND VAR60 AND VAR61 AND VAR62 AND VAR63 AND VAR64 AND VAR65 AND CLOSE-OPEN>=VAR49-VAR48 AND VOL/REF(VOL,1)>=1.9;
VAR67:=DATETODAY(DATE);
VAR68:=VOL/REF(MA(VOL,5),1);
VAR69:=VOL/CAPITAL*100;
VAR70:=(VAR68>3.75 AND VAR68<3.77)*(VAR67>9435 AND VAR67<9440) AND (VAR69>1.44 AND VAR69<1.46)*(VAR67>9435 AND VAR67<9440);
VAR71:=(VAR68>3.28 AND VAR68<3.3)*(VAR67>9225 AND VAR67<9228) AND (VAR69>11.79 AND VAR69<11.81)*(VAR67>9225 AND VAR67<9228);
VAR72:=(VAR68>2.07 AND VAR68<2.08)*(VAR67>9322 AND VAR67<9325) AND (VAR69>2.68 AND VAR69<2.7)*(VAR67>9322 AND VAR67<9325);
VAR73:=(VAR68>2.08 AND VAR68<2.1)*(VAR67>9672 AND VAR67<9680) AND (VAR69>2.76 AND VAR69<2.78)*(VAR67>9672 AND VAR67<9680);
VAR74:=(VAR68>5.7 AND VAR68<5.72)*(VAR67>9735 AND VAR67<9740) AND (VAR69>4.85 AND VAR69<4.87)*(VAR67>9735 AND VAR67<9740);
VAR75:=(VAR68>1.58 AND VAR68<1.6)*(VAR67>9690 AND VAR67<9698) AND (VAR69>24.07 AND VAR69<24.09)*(VAR67>9690 AND VAR67<9698);
VAR76:=(VAR68>7.92 AND VAR68<7.94)*(VAR67>9565 AND VAR67<9570) AND (VAR69>12.46 AND VAR69<12.48)*(VAR67>9565 AND VAR67<9570);
VAR77:=VAR71 OR VAR72 OR VAR73 OR VAR74 OR VAR75 OR VAR70 OR VAR76;
VAR78:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3)*VAR10;
VAR79:=IF(CROSS(VAR78,0),40,0)*VAR10;
VAR81:=LLV(LOW,94);
VAR82:=HHV(HIGH,89)*VAR27;
VAR83:=EMA((CLOSE-VAR81)/(VAR82-VAR81)*100,8);
VAR84:=EMA(0.667*REF(VAR83,1)+0.333*VAR83,10);
VAR85:=COUNT(VAR79>=40,5)>0;
VAR86:=IF(CROSS(VAR83,VAR84) AND VAR85,60,0)*VAR10;
VAR87:=VAR79+VAR86>=1;
VAR88:=MA(CLOSE,5);
VAR89:=MA(CLOSE,10);
VAR90:=MA(CLOSE,20);
VAR91:=MA(CLOSE,30)*VAR27;
VAR92:=MA(CLOSE,55)*VAR27;
VAR93:=OPEN<VAR88 AND OPEN<VAR89 AND OPEN<VAR90 AND LOW<VAR91 AND LOW<VAR92;
VAR94:=CLOSE>VAR88 AND CLOSE>VAR89 AND HIGH>VAR90 AND HIGH>VAR91 AND HIGH>VAR92;
VAR95:=VAR93 AND VAR94;
VAR101:=MA(CLOSE,20);
VAR102:=MA(CLOSE,6);
VAR103:=CROSS(VAR102,VAR101)*VAR10;
VAR104:=(BARSLAST(MA(CLOSE,120)<REF(MA(CLOSE,120),1) OR MA(CLOSE,100)<REF(MA(CLOSE,100),1) OR MA(CLOSE,80)<REF(MA(CLOSE,80),1) OR MA(CLOSE,60)<REF(MA(CLOSE,60),1) OR MA(CLOSE,40)<REF(MA(CLOSE,40),1) OR MA(CLOSE,20)<REF(MA(CLOSE,20),1) OR MA(CLOSE,15)<REF(MA(CLOSE,15),1) OR MA(CLOSE,10)<REF(MA(CLOSE,10),1) OR MA(CLOSE,5)<REF(MA(CLOSE,5),1))=1 AND (BARSLAST(BARSLASTCOUNT(VOL>REF(VOL,1))>1 AND CLOSE>=OPEN)<3 OR (VOL>REF(VOL,1) AND REF(CLOSE,1)<=REF(OPEN,1))) AND (CLOSE>OPEN AND BARSLAST(LOW<MA(CLOSE,20))<5 AND BARSLAST(MA(CLOSE,5)<MA(CLOSE,10))<10 AND (HIGH>FINDHIGH(MAX(CLOSE,CLOSE),1,19,1) OR OPEN<MA(CLOSE,5)) AND (VOL>MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MAX(MA(VOL,3)*(1-2/88),MA(VOL,5)*(1-4/88)),MA(VOL,7)*(1-6/88)),MA(VOL,9)*(1-8/88)),MA(VOL,11)*(1-10/88)),MA(VOL,13)*(1-12/88)),MA(VOL,15)*(1-14/88)),MA(VOL,17)*(1-16/88)),MA(VOL,19)*(1-18/88)),MA(VOL,21)*(1-20/88)),MA(VOL,23)*(1-22/88)),MA(VOL,25)*(1-24/88)),MA(VOL,27)*(1-26/88)),MA(VOL,29)*(1-28/88)),MA(VOL,31)*(1-30/88)),MA(VOL,33)*(1-32/88)),MA(VOL,35)*(1-34/88)),MA(VOL,37)*(1-36/88)),MA(VOL,39)*(1-38/88)) OR VOL>MA(VOL,50)*(1+49/88))))*VAR10;
VAR105:=VAR11+VAR39+VAR46+VAR66+VAR87+VAR95+VAR103+VAR104>=7;
启动:(VAR77 OR VAR105),COLORRED;
STICKLINE(IF(启动,(-120),0),1,0,6,0),COLOR00BBFF;
STICKLINE(IF(启动,(-120),0),1,0,5,0),COLOR00BBFF;
STICKLINE(IF(启动,(-120),0),1,0,4,0),COLOR00BBFF;
STICKLINE(IF(启动,(-120),0),1,0,3,0),COLOR00CCFF;
STICKLINE(IF(启动,(-120),0),1,0,2,0),COLOR00DDFF;
STICKLINE(IF(启动,(-120),0),1,0,1,0),COLOR00EEFF;
STICKLINE(IF(启动,(-120),0),1,0,0.9,0),COLORYELLOW;
DRAWICON(启动,0.01,24);
DRAWICON(启动,0.1,24);
DRAWICON(启动,0.2,24);
DRAWICON(启动,0.3,24);
DRAWICON(启动,0.4,24);
DRAWICON(启动,0.5,24);
DRAWICON(启动,0.6,24);
DRAWICON(启动,0.7,24);
DRAWICON(启动,0.8,24);
DRAWICON(启动,0.9,24);
DRAWICON(启动,1.01,24);[/lycode][lycode=tdx2,true]VAR1赋值:收盘价的13日简单移动平均
VAR2赋值:收盘价的34日简单移动平均
VAR3赋值:收盘价的55日简单移动平均
VAR4赋值:开盘价<VAR1 AND 收盘价>VAR1
VAR5赋值:开盘价<VAR2 AND 收盘价>VAR2
VAR6赋值:开盘价<VAR3 AND 收盘价>VAR3
VAR7赋值:收盘价/开盘价>=1.04
VAR8赋值:成交量(手)>10日内最高价的最高值
VAR9赋值:VAR1>=1日前的VAR1
VAR10赋值:1
VAR11赋值:VAR4 AND VAR5 AND VAR6 AND VAR7 AND VAR8 AND VAR9
VAR12赋值:收盘价的5日简单移动平均
VAR13赋值:收盘价的10日简单移动平均
VAR14赋值:收盘价的30日简单移动平均
VAR22赋值:收盘价*成交量(手)*100的28日累和/成交量(手)*100的28日累和
VAR23赋值:VAR22*100的整数部分/100
VAR24赋值:收盘价的5日指数移动平均-收盘价的10日指数移动平均*VAR10
VAR25赋值:VAR24的9日指数移动平均
VAR27赋值:1
VAR31赋值:1日前的VAR25*VAR27
VAR32赋值:VAR25
VAR33赋值:VAR32-VAR31
VAR34赋值:1日前的VAR24*VAR10
VAR35赋值:VAR24
VAR36赋值:VAR35-VAR34
VAR37赋值:开盘价
VAR38赋值:收盘价
VAR39赋值:VAR37<=VAR12 AND VAR37<=VAR13 AND VAR37<=VAR14 AND VAR38>=VAR12 AND VAR38>=VAR23 AND VAR33>0 AND VAR36>0
VAR40赋值:(收盘价的4日指数移动平均+收盘价的8日简单移动平均+收盘价的16日简单移动平均)/3
VAR41赋值:(收盘价的6日指数移动平均+收盘价的12日简单移动平均+收盘价的24日简单移动平均)/3
VAR42赋值:(收盘价的9日指数移动平均+收盘价的18日简单移动平均+收盘价的36日简单移动平均)/3
VAR43赋值:(收盘价的13日指数移动平均+收盘价的26日简单移动平均+收盘价的52日简单移动平均)/3
VAR44赋值:(收盘价的18日指数移动平均+收盘价的36日简单移动平均+收盘价的72日简单移动平均)/3
VAR45赋值:(收盘价的24日指数移动平均+收盘价的48日简单移动平均+收盘价的96日简单移动平均)/3
VAR46赋值:开盘价<VAR40 AND 开盘价<VAR41 AND 开盘价<VAR42 AND 开盘价<VAR43 AND 开盘价<VAR44 AND 开盘价<VAR45 AND 收盘价>VAR40 AND 收盘价>VAR41 AND 收盘价>VAR42 AND 收盘价>VAR43 AND 收盘价>VAR44 AND 收盘价>VAR45
VAR47赋值:收盘价
VAR48赋值:(VAR47的3日简单移动平均+VAR47的6日简单移动平均+VAR47的12日简单移动平均+VAR47的24日简单移动平均)/4
VAR49赋值:VAR48+6*VAR48的11日估算标准差*VAR27
VAR51赋值:成交量(手)/((最高价-最低价)*2-收盘价-开盘价的绝对值)
VAR52赋值:(如果收阳线,返回VAR51*(最高价-最低价),否则返回如果收阴线,返回VAR51*(最高价-开盘价+收盘价-最低价),否则返回成交量(手)/2+如果收阳线,返回0-VAR51*(最高价-收盘价+开盘价-最低价),否则返回如果收阴线,返回0-VAR51*(最高价-最低价),否则返回0-成交量(手)/2)*VAR27
VAR53赋值:VAR52/20/1.15
VAR54赋值:(VAR53*0.55+1日前的VAR53*0.33+2日前的VAR53*0.22)*VAR10
VAR55赋值:VAR54的3日指数移动平均*VAR10
VAR56赋值:VAR55的1日累和
VAR57赋值:VAR55的2日累和
VAR58赋值:VAR55的3日累和
VAR59赋值:VAR55的4日累和
VAR60赋值:VAR55的5日累和
VAR61赋值:VAR55的6日累和
VAR62赋值:VAR55的7日累和
VAR63赋值:VAR55的8日累和
VAR64赋值:VAR55的9日累和
VAR65赋值:VAR55的10日累和
VAR66赋值:VAR56 AND VAR57 AND VAR58 AND VAR59 AND VAR60 AND VAR61 AND VAR62 AND VAR63 AND VAR64 AND VAR65 AND 收盘价-开盘价>=VAR49-VAR48 AND 成交量(手)/1日前的成交量(手)>=1.9
VAR67赋值:日期对应的转换天数
VAR68赋值:成交量(手)/1日前的成交量(手)的5日简单移动平均
VAR69赋值:成交量(手)/当前流通股本(手)*100
VAR70赋值:(VAR68>3.75 AND VAR68<3.77)*(VAR67>9435 AND VAR67<9440) AND (VAR69>1.44 AND VAR69<1.46)*(VAR67>9435 AND VAR67<9440)
VAR71赋值:(VAR68>3.28 AND VAR68<3.3)*(VAR67>9225 AND VAR67<9228) AND (VAR69>11.79 AND VAR69<11.81)*(VAR67>9225 AND VAR67<9228)
VAR72赋值:(VAR68>2.07 AND VAR68<2.08)*(VAR67>9322 AND VAR67<9325) AND (VAR69>2.68 AND VAR69<2.7)*(VAR67>9322 AND VAR67<9325)
VAR73赋值:(VAR68>2.08 AND VAR68<2.1)*(VAR67>9672 AND VAR67<9680) AND (VAR69>2.76 AND VAR69<2.78)*(VAR67>9672 AND VAR67<9680)
VAR74赋值:(VAR68>5.7 AND VAR68<5.72)*(VAR67>9735 AND VAR67<9740) AND (VAR69>4.85 AND VAR69<4.87)*(VAR67>9735 AND VAR67<9740)
VAR75赋值:(VAR68>1.58 AND VAR68<1.6)*(VAR67>9690 AND VAR67<9698) AND (VAR69>24.07 AND VAR69<24.09)*(VAR67>9690 AND VAR67<9698)
VAR76赋值:(VAR68>7.92 AND VAR68<7.94)*(VAR67>9565 AND VAR67<9570) AND (VAR69>12.46 AND VAR69<12.48)*(VAR67>9565 AND VAR67<9570)
VAR77赋值:VAR71 OR VAR72 OR VAR73 OR VAR74 OR VAR75 OR VAR70 OR VAR76
VAR78赋值:(收盘价-(2*收盘价+最高价+最低价)/4的30日简单移动平均)/(2*收盘价+最高价+最低价)/4的30日简单移动平均*100的3日指数移动平均*VAR10
VAR79赋值:如果VAR78上穿0,返回40,否则返回0*VAR10
VAR81赋值:94日内最低价的最低值
VAR82赋值:89日内最高价的最高值*VAR27
VAR83赋值:(收盘价-VAR81)/(VAR82-VAR81)*100的8日指数移动平均
VAR84赋值:0.667*1日前的VAR83+0.333*VAR83的10日指数移动平均
VAR85赋值:统计5日中满足VAR79>=40的天数>0
VAR86赋值:如果VAR83上穿VAR84ANDVAR85,返回60,否则返回0*VAR10
VAR87赋值:VAR79+VAR86>=1
VAR88赋值:收盘价的5日简单移动平均
VAR89赋值:收盘价的10日简单移动平均
VAR90赋值:收盘价的20日简单移动平均
VAR91赋值:收盘价的30日简单移动平均*VAR27
VAR92赋值:收盘价的55日简单移动平均*VAR27
VAR93赋值:开盘价<VAR88 AND 开盘价<VAR89 AND 开盘价<VAR90 AND 最低价<VAR91 AND 最低价<VAR92
VAR94赋值:收盘价>VAR88 AND 收盘价>VAR89 AND 最高价>VAR90 AND 最高价>VAR91 AND 最高价>VAR92
VAR95赋值:VAR93 AND VAR94
VAR101赋值:收盘价的20日简单移动平均
VAR102赋值:收盘价的6日简单移动平均
VAR103赋值:VAR102上穿VAR101*VAR10
VAR104赋值:(上次收盘价的120日简单移动平均<1日前的收盘价的120日简单移动平均ORMA(收盘价,100)<1日前的收盘价的100日简单移动平均ORMA(收盘价,80)<1日前的收盘价的80日简单移动平均ORMA(收盘价,60)<1日前的收盘价的60日简单移动平均ORMA(收盘价,40)<?日前的简单移动平均距今天数=1 AND (上次条件连续成立次数>1ANDCLOSE>=开盘价距今天数<3 OR (成交量(手)>1日前的成交量(手) AND 1日前的收盘价<=1日前的开盘价)) AND (收阳线ANDSE 上次最低价<收盘价的20日简单移动平均距今天数<5 AND 上次收盘价的5日简单移动平均<收盘价的10日简单移动平均距今天数<10 AND (最高价>收盘价和收盘价的较大值在1日前的19天内第1个最高价 OR 开盘价<收盘价的5日简单移动平均) AND (成交量(手)>成交量(手)的3日简单移动平均*(1-2/88)和成交量(手)的5日简单移动平均*(1-4/88)的较大值和成交量(手)的7日简单移动平均*(1-6/88)的较大值和成交量(手)的9日简单移动平均*(1-8/88)的较大值和成交量(手)的11日简单移动平均*(的较大值和?的较大值和?的较大值和?的较大值和?的较大值和?的较大值和?的较大值和?的较大值和?的较大值和?的较大值和?的较大值和?的较大值和?的较大值和?的较大值和-10/88)),成交量(手)的13日简单移动平均*(1-12/88)),成交量(手)的15日简单移动平均*(1-14/88)),成交量(手)的17日简单移动平均*(1-16/88)),成交量(手)的19日简单移动平均*(1-18/88)),成交量(手)的21日简单移动平均*(1-20/88)),成交量(手)的23日简单移动平均*(1-22/88)),成交量(手)的25日简单移动平均*(1-24/8的较大值 OR 成交量(手)>成交量(手)的50日简单移动平均*(1+49/88))))*VAR10
VAR105赋值:VAR11+VAR39+VAR46+VAR66+VAR87+VAR95+VAR103+VAR104>=7
输出启动:(VAR77 OR VAR105),画红色
当满足条件如果启动,返回(-120),否则返回0时,在1和0位置之间画柱状线,宽度为6,0不为0则画空心柱.,COLOR00BBFF
当满足条件如果启动,返回(-120),否则返回0时,在1和0位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR00BBFF
当满足条件如果启动,返回(-120),否则返回0时,在1和0位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR00BBFF
当满足条件如果启动,返回(-120),否则返回0时,在1和0位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00CCFF
当满足条件如果启动,返回(-120),否则返回0时,在1和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00DDFF
当满足条件如果启动,返回(-120),否则返回0时,在1和0位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00EEFF
当满足条件如果启动,返回(-120),否则返回0时,在1和0位置之间画柱状线,宽度为0.9,0不为0则画空心柱.,画黄色
当满足条件启动时,在0.01位置画24号图标
当满足条件启动时,在0.1位置画24号图标
当满足条件启动时,在0.2位置画24号图标
当满足条件启动时,在0.3位置画24号图标
当满足条件启动时,在0.4位置画24号图标
当满足条件启动时,在0.5位置画24号图标
当满足条件启动时,在0.6位置画24号图标
当满足条件启动时,在0.7位置画24号图标
当满足条件启动时,在0.8位置画24号图标
当满足条件启动时,在0.9位置画24号图标
当满足条件启动时,在1.01位置画24号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/146CM8Ihu0k089lPqUDxF7A

看了该指标的人还看了:
操盘买卖指标    牛股启爆点指标
无极神枪指标    一柱擎天指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表