请选择 进入手机版|继续访问电脑版

多空买卖指标 通达信 主图 波段 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-7-4 09:00:16 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 操盘控盘 
多空买卖指标 通达信 主图 波段 短线 买卖点 操盘控盘 炒股叉第8065张

多空买卖指标 通达信 主图 波段 短线 买卖点 操盘控盘 炒股叉第8066张

[lywrap=通达信主图指标公式][lycode=tdx,true]多空线: SMA((CLOSE+HIGH+LOW)/3,9,1);
主力成本: EMA(COST(9),250);
长命线: EMA(COST(27),120), CIRCLEDOT;
FL:=MA(CLOSE,13)+ABS(MA(CLOSE,13)-REF(MA(CLOSE,13),1));
FS:=MA(CLOSE,13)+MA(CLOSE,13)-REF(MA(CLOSE,13),1);
CG:=IF(MA(CLOSE,13)<FS,FS,MA(CLOSE,13));
A:=CG-(EMA(C,3)-CG);
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(X,13);
卖1:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);
DRAWICON(FILTER(卖1=1,1),H*1.007,24);
买1:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWICON(FILTER(买1=1,5),L*0.98,25);
A1:=MAX(MAX(MA(C,5),MA(C,10)),MA(C,20));
A2:=MIN(MIN(MA(C,5),MA(C,10)),MA(C,20));
DRAWTEXT(H>REF(O,3)*1.19,H,'小心'),COLORGREEN;
DRAWTEXT(H>REF(O,3)*1.36,H,'绝对小心'),COLORFF7F00;
绝对量顶天立地:=V>REF(HHV(V,60),1) OR V>REF(HHV(V,120),1);{绝对量顶天立地};
DRAWTEXT(绝对量顶天立地 AND O>C AND C<REF(C,1),C,'收钱了'),COLOR7F00FF;
MA(C,3);
N:=10;
T1:=CONST(HHVBARS(V,N));
T0:IF(CURRBARSCOUNT<=N+3,CONST(IF(T1=0,C,REF(C,T1))),DRAWNULL),COLORFF00FF;
IF(CURRBARSCOUNT=T1+1,T0,DRAWNULL),CIRCLEDOT,COLORFF00FF;
DRAWTEXT(ISLASTBAR,T0,' 量能平台'),COLORCC00CC;
W:=20;
W1:=CONST(REF(HHVBARS(V,W),T1+1)+T1+1);
W0:IF(CURRBARSCOUNT<=T1+W+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,W1)),DRAWNULL),COLOR009999;
IF(CURRBARSCOUNT=W1+1,W0,DRAWNULL),CIRCLEDOT,COLOR00CCCC;
M:=10;
Q1:=CONST(REF(HHVBARS(V,M),T1+1)+T1+1);
Q0:IF(CURRBARSCOUNT<=T1+M+3 AND CURRBARSCOUNT>=T1+1,CONST(REF(C,Q1)),DRAWNULL),COLOR009900;
IF(CURRBARSCOUNT=Q1+1,Q0,DRAWNULL),CIRCLEDOT,COLOR00CC00;
VAR1:=(HIGH+LOW+CLOSE)/3;
VAR2:=(VAR1-MA(VAR1,14))/(0.015*AVEDEV(VAR1,14));
AA:=CROSS(VAR2,-100);
BB:=BARSLAST(AA)+2;
{CC:=FINANCE(40)<400000000000000000;}
DRAWICON(AA ,L*0.99,1);
DRAWTEXT(AA ,REF(L,2),'---------------------------------止损');
XG2:=CROSS(C,MA(CLOSE,120));
DRAWICON(XG2,H*0.96,27);[/lycode][lycode=tdx2,true]输出多空线: (收盘价+最高价+最低价)/3的9日[1日权重]移动平均
输出主力成本: 获利盘为9%的成本分布的250日指数移动平均
输出长命线: 获利盘为27%的成本分布的120日指数移动平均, CIRCLEDOT
FL赋值:收盘价的13日简单移动平均+收盘价的13日简单移动平均-1日前的收盘价的13日简单移动平均的绝对值
FS赋值:收盘价的13日简单移动平均+收盘价的13日简单移动平均-1日前的收盘价的13日简单移动平均
CG赋值:如果收盘价的13日简单移动平均<FS,返回FS,否则返回收盘价的13日简单移动平均
A赋值:CG-(收盘价的3日指数移动平均-CG)
X赋值:(20*A+19*1日前的A+18*2日前的A+17*3日前的A+16*4日前的A+15*5日前的A+14*6日前的A+13*7日前的A+12*8日前的A+11*9日前的A+10*10日前的A+9*11日前的A+8*12日前的A+7*13日前的A+6*14日前的A+5*15日前的A+4*16日前的A+3*17日前的A+2*18日前的A+20日前的A)/210
MTM赋值:收盘价-1日前的收盘价
DX赋值:100*MTM的6日指数移动平均的6日指数移动平均/MTM的绝对值的6日指数移动平均的6日指数移动平均
CB赋值:X的13日指数移动平均
卖1赋值:如果2日内DX的最高值=7日内DX的最高值ANDCOUNT(DX>50,2)ANDCROSS(DX的2日简单移动平均,DX),返回1,否则返回0
当满足条件卖1=1的1日过滤时,在最高价*1.007位置画24号图标
买1赋值:如果2日内DX的最低值=7日内DX的最低值ANDCOUNT(DX<0,2)ANDCROSS(DX,DX的2日简单移动平均),返回1,否则返回0
当满足条件买1=1的5日过滤时,在最低价*0.98位置画25号图标
A1赋值:收盘价的5日简单移动平均和收盘价的10日简单移动平均的较大值和收盘价的20日简单移动平均的较大值
A2赋值:收盘价的5日简单移动平均和收盘价的10日简单移动平均的较小值和收盘价的20日简单移动平均的较小值
当满足条件最高价>3日前的开盘价*1.19时,在最高价位置书写文字,画绿色
当满足条件最高价>3日前的开盘价*1.36时,在最高价位置书写文字,COLORFF7F00
绝对量顶天立地赋值:成交量(手)>1日前的60日内成交量(手)的最高值 OR 成交量(手)>1日前的120日内成交量(手)的最高值

当满足条件绝对量顶天立地ANDO>CANDC<1日前的收盘价时,在收盘价位置书写文字,COLOR7F00FF
收盘价的3日简单移动平均
N赋值:10
T1赋值:N日内成交量(手)距今天数的最后一日取值设为常数
输出T0:如果到最后交易的周期<=N+3,返回如果T1=0,返回收盘价,否则返回T1日前的收盘价的最后一日取值设为常数,否则返回无效数,COLORFF00FF
如果到最后交易的周期=T1+1,返回T0,否则返回无效数,CIRCLEDOT,COLORFF00FF
当满足条件是否最后一个周期时,在T0位置书写文字,COLORCC00CC
W赋值:20
W1赋值:T1+1日前的W日内成交量(手)距今天数+T1+1的最后一日取值设为常数
输出W0:如果到最后交易的周期<=T1+W+3ANDCURRBARSCOUNT>=T1+1,返回W1日前的收盘价的最后一日取值设为常数,否则返回无效数,COLOR009999
如果到最后交易的周期=W1+1,返回W0,否则返回无效数,CIRCLEDOT,COLOR00CCCC
M赋值:10
Q1赋值:T1+1日前的M日内成交量(手)距今天数+T1+1的最后一日取值设为常数
输出Q0:如果到最后交易的周期<=T1+M+3ANDCURRBARSCOUNT>=T1+1,返回Q1日前的收盘价的最后一日取值设为常数,否则返回无效数,COLOR009900
如果到最后交易的周期=Q1+1,返回Q0,否则返回无效数,CIRCLEDOT,COLOR00CC00
VAR1赋值:(最高价+最低价+收盘价)/3
VAR2赋值:(VAR1-VAR1的14日简单移动平均)/(0.015*VAR1的14日平均绝对偏差)
AA赋值:VAR2上穿-100
BB赋值:上次AA距今天数+2
当满足条件AA时,在最低价*0.99位置画1号图标
当满足条件AA时,在2日前的最低价位置书写文字
XG2赋值:收盘价上穿收盘价的120日简单移动平均
当满足条件XG2时,在最高价*0.96位置画27号图标[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1CIk4oPpps_Vf5DLOmn8yog

看了该指标的人还看了:
呯凡军师操盘指标    宝岛精英指标
游资吸筹指标    主力监控指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表