请选择 进入手机版|继续访问电脑版

中短趋势指标 通达信 主图 波段 无未来函数 短线 买卖点 趋势

[复制链接]

admin  管理员

发表于 2018-7-3 09:00:08 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 趋势 
中短趋势指标 通达信 主图 波段 无未来函数 短线 买卖点 趋势 炒股叉第8039张

中短趋势指标 通达信 主图 波段 无未来函数 短线 买卖点 趋势 炒股叉第8040张

[lywrap=通达信主图指标公式][lycode=tdx,true]{阴线买入}
R1:=(C+L+H)/3;
R2:=EMA(R1,6);
R3:=EMA(R2,5);
生命线:EMA(R3,30),COLOR00AAFF,LINETHICK2;
N:=5;
M1:=6;
M2:=6;
M3:=8;
R:=IF(DATE<1910612,1,0);
EE:=(H+MAX(C,O))/2;
EE1:=MA(EE,3);
EE2:=(L+MIN(C,O))/2;
EE3:=MA(EE2,3);
超短生命线:MA(EE,3),COLORWHITE;
FF:=(H+L+C+O)/4,COLORWHITE;
FF1:=MA(FF,3),COLORGREEN;
FF3:=REF((C+O)/2,1)>REF((C+O)/2,2) AND REF(MIN(C,O),1)>REF(MAX(C,O),2);
实际乖离:=(MAX(FF,FF1)-MIN(FF,FF1))/MIN(FF,FF1)*100,LINETHICK;
FF4:=(((FF1-(REF(FF1,1)-FF1))-L)/L)*100;
FF5:=(((EE1+(EE1-REF(EE1,1)))-L)/L)*100;
FF6:=FF1-(REF(FF1,1)-FF1);
FF7:=EE1+(EE1-REF(EE1,1));
期望获利率:=IF(FF3,FF5,FF4),LINETHICK;
YY1:=REF(EVERY(C>=O,4),1) AND REF(EVERY((C+O)/2>FF1,4),1) AND (C+O)/2<FF1;
YY2:=NOT(YY1) AND (FF1-O)/O*1000>5 AND O<REF(MIN(C,O),1);
A:=SMA(L,4,3);
B:=SMA(H,4,3);
BB:=SMA(MIN(C,O),4,3);
BB1:=REF(L,1)-HHV((MAX(REF(L,2),REF(L,1))-MIN(REF(L,2),REF(L,1))),2);
BB2:=REF((C+O)/2,1)>REF((C+O)/2,2);
BB3:=L<=BB1+BB1*0.01 AND O>REF(O,2) AND O>=REF(L,3) AND COUNT(C>O,7)>3;
BB6:=(BB1-L)/L*100;
BB7:=(REF(L,1)-BB1)/BB1*100;
A1:=(A-L)/L>N/1000 ;
A8:=A1;
A9:=(REF(H,1)-O)/O*100-(REF(MAX(C,O),2)-REF(MAX(C,O),1))/REF(MAX(C,O),1)*100;
A10:=IF(BB2,BB6,A9);
BB4:=BB6+A10>2;
BB5:=IF(BB2,BB3,BB4) AND 期望获利率>2;
D5:=R AND A8 AND BB5;
STICKLINE(D5,A*0.995,A*0.992,4,0)COLORYELLOW;
DRAWICON(R AND (REF((D5),1)) AND (L<REF((L/0.995),1)),L*0.97,11);


{中短趋势}
{R:=IF(DATE<1900612,1,0);}
_持仓:IF(R AND CLOSE>=SAR(4,2,20),SAR(4,2,20),DRAWNULL),CIRCLEDOT,COLORRED ;
_空仓:IF(R AND CLOSE<=SAR(4,2,20),SAR(4,2,20),DRAWNULL),CIRCLEDOT,COLORGREEN ;
_现价:CLOSE,COLORWHITE,NODRAW;
_10日涨跌%: (C-REF(CLOSE,10))/REF(CLOSE,10)*100,COLORGREEN,NODRAW;
VAR1A:=(2*CLOSE+HIGH+LOW)/4;
VAR2A:=MA(VAR1A,7);
VAR3A:=VAR2A-MA(VAR1A,7/2)<0;
VAR4A:=VAR2A-MA(VAR1A,7/2)>0;
VAR5A:=BARSLAST(VAR3A);
VAR6A:=0-BARSLAST(VAR4A);
VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
VAR11A:=(CLOSE*2+HIGH+LOW)/4;
VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);
VAR31A:=EMA(VAR21A,5);
VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1B:=(R AND REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1) AND VAR2);
STICKLINE(VAR1B,O,O+(C-O)/3,2,0),COLOR10FFFF;
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR00FFFF;
AA:=(R AND REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);
STICKLINE(AA,O,O+(C-O)/3,2,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;[/lycode][lycode=tdx2,true]R1赋值:(收盘价+最低价+最高价)/3
R2赋值:R1的6日指数移动平均
R3赋值:R2的5日指数移动平均
输出生命线:R3的30日指数移动平均,COLOR00AAFF,线宽为2
N赋值:5
M1赋值:6
M2赋值:6
M3赋值:8
R赋值:如果日期<1910612,返回1,否则返回0
EE赋值:(最高价+收盘价和开盘价的较大值)/2
EE1赋值:EE的3日简单移动平均
EE2赋值:(最低价+收盘价和开盘价的较小值)/2
EE3赋值:EE2的3日简单移动平均
输出超短生命线:EE的3日简单移动平均,画白色
FF赋值:(最高价+最低价+收盘价+开盘价)/4,画白色
FF1赋值:FF的3日简单移动平均,画绿色
FF3赋值:1日前的(收盘价+开盘价)/2>2日前的(收盘价+开盘价)/2 AND 1日前的收盘价和开盘价的较小值>2日前的收盘价和开盘价的较大值
实际乖离赋值:(FF和FF1的较大值-FF和FF1的较小值)/FF和FF1的较小值*100,线宽为0
FF4赋值:(((FF1-(1日前的FF1-FF1))-最低价)/最低价)*100
FF5赋值:(((EE1+(EE1-1日前的EE1))-最低价)/最低价)*100
FF6赋值:FF1-(1日前的FF1-FF1)
FF7赋值:EE1+(EE1-1日前的EE1)
期望获利率赋值:如果FF3,返回FF5,否则返回FF4,线宽为0
YY1赋值:1日前的最近4日一直存在收盘价>=开盘价 AND 1日前的最近4日一直存在(收盘价+开盘价)/2>FF1 AND (收盘价+开盘价)/2<FF1
YY2赋值:取反 AND (FF1-开盘价)/开盘价*1000>5 AND 开盘价<1日前的收盘价和开盘价的较小值
A赋值:最低价的4日[3日权重]移动平均
B赋值:最高价的4日[3日权重]移动平均
BB赋值:收盘价和开盘价的较小值的4日[3日权重]移动平均
BB1赋值:1日前的最低价-2日内(2日前的最低价和1日前的最低价的较大值-2日前的最低价和1日前的最低价的较小值)的最高值
BB2赋值:1日前的(收盘价+开盘价)/2>2日前的(收盘价+开盘价)/2
BB3赋值:最低价<=BB1+BB1*0.01 AND 开盘价>2日前的开盘价 AND 开盘价>=3日前的最低价 AND 统计7日中满足收阳线的天数>3
BB6赋值:(BB1-最低价)/最低价*100
BB7赋值:(1日前的最低价-BB1)/BB1*100
A1赋值:(A-最低价)/最低价>N/1000
A8赋值:A1
A9赋值:(1日前的最高价-开盘价)/开盘价*100-(2日前的收盘价和开盘价的较大值-1日前的收盘价和开盘价的较大值)/1日前的收盘价和开盘价的较大值*100
A10赋值:如果BB2,返回BB6,否则返回A9
BB4赋值:BB6+A10>2
BB5赋值:如果BB2,返回BB3,否则返回BB4 AND 期望获利率>2
D5赋值:R AND A8 AND BB5
当满足条件D5时,在A*0.995和A*0.992位置之间画柱状线,宽度为4,0不为0则画空心柱.画黄色
当满足条件随机正整数AND(最低价<1日前的(最低价/0.995))时,在最低价*0.97位置画11号图标
输出_持仓:如果RANDCLOSE>=步长为2极限值为20的4日抛物转向,返回步长为2极限值为20的4日抛物转向,否则返回无效数,CIRCLEDOT,画红色
输出_空仓:如果RANDCLOSE<=步长为2极限值为20的4日抛物转向,返回步长为2极限值为20的4日抛物转向,否则返回无效数,CIRCLEDOT,画绿色
输出_现价:收盘价,画白色,NODRAW
输出_10日涨跌%: (收盘价-10日前的收盘价)/10日前的收盘价*100,画绿色,NODRAW
VAR1A赋值:(2*收盘价+最高价+最低价)/4
VAR2A赋值:VAR1A的7日简单移动平均
VAR3A赋值:VAR2A-VAR1A的7/2日简单移动平均<0
VAR4A赋值:VAR2A-VAR1A的7/2日简单移动平均>0
VAR5A赋值:上次VAR3A距今天数
VAR6A赋值:0-上次VAR4A距今天数
VAR7A赋值:如果VAR3A<=0,返回VAR5A,否则返回VAR6A
VAR11A赋值:(收盘价*2+最高价+最低价)/4
VAR21A赋值:VAR11A的13日指数移动平均-VAR11A的34日指数移动平均
VAR31A赋值:VAR21A的5日指数移动平均
VAR2赋值:((收盘价 > 1日前的收盘价) AND (收盘价 > 2日前的收盘价))
VAR3赋值:((1日前的VAR2 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR4赋值:((1日前的VAR3 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR5赋值:((1日前的VAR4 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR6赋值:((1日前的VAR5 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR7赋值:((1日前的VAR6 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR8赋值:((1日前的VAR7 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR9赋值:((1日前的VAR8 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VARA赋值:((1日前的VAR9 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VARB赋值:((1日前的VARA AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VARC赋值:((1日前的VARB AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VARD赋值:((1日前的VARC AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VARE赋值:((收盘价 < 1日前的收盘价) AND (收盘价 < 2日前的收盘价))
VARF赋值:((1日前的VARE AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR10赋值:((1日前的VARF AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR11赋值:((1日前的VAR10 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR12赋值:((1日前的VAR11 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR13赋值:((1日前的VAR12 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR14赋值:((1日前的VAR13 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR15赋值:((1日前的VAR14 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR16赋值:((1日前的VAR15 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR17赋值:((1日前的VAR16 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR18赋值:((1日前的VAR17 AND (收盘价 <= 1日前的收盘价)) AND (收盘价 >= 2日前的收盘价))
VAR19赋值:((1日前的VAR18 AND (收盘价 >= 1日前的收盘价)) AND (收盘价 <= 2日前的收盘价))
VAR1B赋值:(R AND 1日前的(((((((((((VAREORVARF)ORVAR10)ORVAR11)ORVAR12)ORVAR13)ORVAR14)ORVAR15)ORVAR16)ORVAR17)ORVAR18)ORVAR19) AND VAR2)
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR10FFFF
当满足条件VAR1B时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00FFFF
AA赋值:(R AND 1日前的(((((((((((VAR2ORVAR3)ORVAR4)ORVAR5)ORVAR6)ORVAR7)ORVAR8)ORVAR9)ORVARA)ORVARB)ORVARC)ORVARD) AND VARE)
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00EE00
当满足条件AA时,在开盘价和开盘价+(收盘价-开盘价)/3位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00FF00[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1ILO_pAxabr2VhdqhtQ9UKQ

看了该指标的人还看了:
精准抄底指标    多空精准线指标
瞄准底部指标    五里金莲指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表