请选择 进入手机版|继续访问电脑版

超级全波段指标 通达信 副图 波段 无未来函数 短线 买卖点 抄底逃顶

[复制链接]

admin  管理员

发表于 2018-7-2 09:00:02 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 无未来函数 短线 买卖点 抄底逃顶 
超级全波段指标 通达信 副图 波段 无未来函数 短线 买卖点 抄底逃顶 炒股叉第8035张

超级全波段指标 通达信 副图 波段 无未来函数 短线 买卖点 抄底逃顶 炒股叉第8036张

[lywrap=通达信副图指标公式][lycode=tdx,true]VAR1:=(CLOSE+HIGH+LOW+OPEN)/4;
VAR2:=SUMBARS(VOL,CAPITAL);
VAR3:=HHV(VAR1,VAR2);
VAR4:=LLV(VAR1,VAR2);
VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);
VAR6:=(VAR1-VAR4)/(VAR3-VAR4);
VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);
VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9:=EMA(VAR8,7);
VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
VARC:=HHV(HIGH,9)-LLV(LOW,9);
VARD:=HHV(HIGH,9)-CLOSE;
VARE:=CLOSE-LLV(LOW,9);
VARF:=VARD/VARC*100-70;
VAR10:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR11:=(2*CLOSE+HIGH+LOW)/4;
VAR12:=SMA(VARE/VARC*100,3,1);
VAR13:=LLV(LOW,34);
VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);
VAR15:=IF(VAR14>100,VAR14-100,0);
VAR16:=HHV(HIGH,34);
VAR17:=EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);
VAR18:=EMA(VAR17,5);
STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,1),COLORRED ;
STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1),COLORGREEN ;
Q1:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1)*100;
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
AA:3*Q3-2*Q4 ,COLORYELLOW;
Q5:=AA>1*REF(AA, 1);
Q6:=LLVBARS(LOW, 50);
Q7:=SUM(VOL, Q6);
Q8:=HHVBARS(HIGH, 50);
Q9:=SUM(VOL, Q8);
Q10:=(CLOSE-REF(OPEN, Q8))/REF(OPEN, Q8)*100;
Q11:=HHV(AA,5);
A1:EMA(Q3, 3) , COLORFFDDCC;
A2:EMA(A1, 3) , COLORFFBBCC;
A3:EMA(A2, 3) , COLORFF99CC;
A4:EMA(A3, 3) , COLORFF55CC;
A5:EMA(A4, 3) , COLORFF33CC;
A6:EMA(A5, 3) , COLORFF11CC;
A:EMA(A4, 3), COLORFF00CC;
DRAWTEXT(CROSS(AA, 20) AND Q10<-13,10,'☆大底'), COLOR00FF00;
DRAWTEXT(CROSS(AA, A5) AND REF(AA,1)<34,REF(AA,1),'☆发财了'), COLORRED ;
DRAWTEXT(CROSS(A1, AA) AND REF(AA,1)>80, REF(AA,3), '☆闪人'), COLORCFB53B ;
DRAWTEXT(CROSS(AA, A1) AND Q5 AND A1<20 AND Q1>9 OR A1>1*REF(A1, 1)
AND Q1>4 AND A1<60, 30, '拉'), COLORFFFFCC;[/lycode][lycode=tdx2,true]VAR1赋值:(收盘价+最高价+最低价+开盘价)/4
VAR2赋值:成交量(手)累加至当前流通股本(手)的天数
VAR3赋值:VAR2日内VAR1的最高值
VAR4赋值:VAR2日内VAR1的最低值
VAR5赋值:(2*VAR1-VAR4-1日前的VAR4)/(VAR3-VAR4)
VAR6赋值:(VAR1-VAR4)/(VAR3-VAR4)
VAR7赋值:如果VAR1<=VAR4,返回VAR5*60,否则返回VAR6*60
VAR8赋值:600*(收盘价的3日指数移动平均-最低价的30日指数移动平均)/最低价的30日指数移动平均
VAR9赋值:VAR8的7日指数移动平均
VARA赋值:(以120*收盘价/100元价格计算的获利盘比例-以100*收盘价/100元价格计算的获利盘比例)*100
VARB赋值:(-100)*(以120*收盘价/100元价格计算的获利盘比例-以100*收盘价/100元价格计算的获利盘比例)+5
VARC赋值:9日内最高价的最高值-9日内最低价的最低值
VARD赋值:9日内最高价的最高值-收盘价
VARE赋值:收盘价-9日内最低价的最低值
VARF赋值:VARD/VARC*100-70
VAR10赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*100
VAR11赋值:(2*收盘价+最高价+最低价)/4
VAR12赋值:VARE/VARC*100的3日[1日权重]移动平均
VAR13赋值:34日内最低价的最低值
VAR14赋值:VAR12的3日[1日权重]移动平均-VARF的9日[1日权重]移动平均
VAR15赋值:如果VAR14>100,返回VAR14-100,否则返回0
VAR16赋值:34日内最高价的最高值
VAR17赋值:(VAR11-VAR13)/(VAR16-VAR13)*100的8日指数移动平均
VAR18赋值:VAR17的5日指数移动平均
当满足条件VAR17-VAR18>0时,在VAR17和VAR18位置之间画柱状线,宽度为8,1不为0则画空心柱.,画红色
当满足条件VAR17-VAR18<0时,在VAR17和VAR18位置之间画柱状线,宽度为8,1不为0则画空心柱.,画绿色
Q1赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100
Q2赋值:(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*100
Q3赋值:Q2的9日[1日权重]移动平均
Q4赋值:Q3的3日[1日权重]移动平均
输出AA:3*Q3-2*Q4 ,画黄色
Q5赋值:AA>1*1日前的AA
Q6赋值:50日内最低价距今天数
Q7赋值:成交量(手)的Q6日累和
Q8赋值:50日内最高价距今天数
Q9赋值:成交量(手)的Q8日累和
Q10赋值:(收盘价-Q8日前的开盘价)/Q8日前的开盘价*100
Q11赋值:5日内AA的最高值
输出A1:Q3的3日指数移动平均 , COLORFFDDCC
输出A2:A1的3日指数移动平均 , COLORFFBBCC
输出A3:A2的3日指数移动平均 , COLORFF99CC
输出A4:A3的3日指数移动平均 , COLORFF55CC
输出A5:A4的3日指数移动平均 , COLORFF33CC
输出A6:A5的3日指数移动平均 , COLORFF11CC
输出A:A4的3日指数移动平均, COLORFF00CC
当满足条件AA上穿20ANDQ10<-13时,在10位置书写文字, COLOR00FF00
当满足条件AA上穿A5ANDREF(AA,1)<34时,在1日前的AA位置书写文字, 画红色
当满足条件A1上穿AAANDREF(AA,1)>80时,在3日前的AA位置书写文字, COLORCFB53B
当满足条件AA上穿A1ANDQ5ANDA1<20ANDQ1>9ORA1>1*1日前的A1ANDQ1>4ANDA1<60时,在30位置书写文字, COLORFFFFCC[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1xA90dmqqqyM3vv-IbQNLWQ

看了该指标的人还看了:
超级主力建仓指标    狂龙出海指标
百万导弹指标    股海英雄指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表