指标公式
软件: 通达信 
公式类型: 副图 选股 
二级分类: 波段 短线 买卖点 抄底逃顶 
TIM截图20180607110021.png

TIM截图20180607110032.png

[lywrap=通达信副图选股指标公式][lycode=tdx,true]HJ_1:=EMA((CLOSE*3+HIGH+LOW+OPEN)/6,5);
HJ_2:=HJ_1;
HJ_3:=HHV(HJ_1,13);
HJ_4:=LLV(HJ_1,13);
HJ_5:=MACD.MACD#DAY(12,26,9);
HJ_6:=MACD.MACD#WEEK(12,26,9);
HJ_7:=HJ_3-HJ_4;
HJ_8:=COUNT(HJ_7>REF(HJ_7,1) AND HJ_3>REF(HJ_3,1),5)=1 AND HJ_7>REF(HJ_7,1) AND HJ_3>REF(HJ_3,1) AND HJ_1>=REF(HJ_1,1);
HJ_9:=FILTER(HJ_8=1,10);
HJ_10:=BARSLAST(HJ_9>0);
HJ_11:=IF(HJ_10>0 AND HJ_10<=10,1,0)=1 AND (CLOSE-REF(CLOSE,HJ_10))/REF(CLOSE,HJ_10)*100>=5;
HJ_12:=SUM(FILTER(HJ_11,10),0)/SUM(HJ_9>0,0)*100;
HJ_13:=COUNT(HJ_5>=0 AND HJ_6>=0,5)=1 AND HJ_5>=0 AND HJ_6>=0;
HJ_14:=FILTER(HJ_13=1,10);
HJ_15:=BARSLAST(HJ_14>0);
HJ_16:=IF(HJ_15>0 AND HJ_15<=10,1,0)=1 AND (CLOSE-REF(CLOSE,HJ_15))/REF(CLOSE,HJ_15)*100>=5;
HJ_17:=SUM(FILTER(HJ_16,10),0)/SUM(HJ_14>0,0)*100;
HJ_18:=FILTER(COUNT(HJ_1=HJ_4,3)>=2 AND HJ_1>HJ_4,5);
XG:HJ_18;[/lycode][lycode=tdx2,true]HJ_1赋值:(收盘价*3+最高价+最低价+开盘价)/6的5日指数移动平均
HJ_2赋值:HJ_1
HJ_3赋值:13日内HJ_1的最高值
HJ_4赋值:13日内HJ_1的最低值
HJ_5赋值:平滑异同平均的MACD[取日线数据](12,26,9)
HJ_6赋值:平滑异同平均的MACD[取周线数据](12,26,9)
HJ_7赋值:HJ_3-HJ_4
HJ_8赋值:统计5日中满足HJ_7>1日前的HJ_7ANDHJ_3>1日前的HJ_3的天数=1 AND HJ_7>1日前的HJ_7 AND HJ_3>1日前的HJ_3 AND HJ_1>=1日前的HJ_1
HJ_9赋值:HJ_8=1的10日过滤
HJ_10赋值:上次HJ_9>0距今天数
HJ_11赋值:如果HJ_10>0ANDHJ_10<=10,返回1,否则返回0=1 AND (收盘价-HJ_10日前的收盘价)/HJ_10日前的收盘价*100>=5
HJ_12赋值:HJ_11的10日过滤的历史累和/HJ_9>0的历史累和*100
HJ_13赋值:统计5日中满足HJ_5>=0ANDHJ_6>=0的天数=1 AND HJ_5>=0 AND HJ_6>=0
HJ_14赋值:HJ_13=1的10日过滤
HJ_15赋值:上次HJ_14>0距今天数
HJ_16赋值:如果HJ_15>0ANDHJ_15<=10,返回1,否则返回0=1 AND (收盘价-HJ_15日前的收盘价)/HJ_15日前的收盘价*100>=5
HJ_17赋值:HJ_16的10日过滤的历史累和/HJ_14>0的历史累和*100
HJ_18赋值:统计3日中满足HJ_1=HJ_4的天数>=2ANDHJ_1>HJ_4的5日过滤
输出XG:HJ_18[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1lMOLbe-MO0VSHySkIm_lIQ

看了该指标的人还看了:
横扫天下指标    愿赌服输BS指标    牛市追牛股指标
牛气冲天指标    主力通侧底指标    长短结合指标

使用道具 举报

回复