请选择 进入手机版|继续访问电脑版

无影脚波段底指标 通达信 副图 波段 短线 买卖点

[复制链接]

admin  管理员

发表于 5 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 
无影脚波段底指标 通达信 副图 波段 短线 买卖点 炒股叉第7645张

无影脚波段底指标 通达信 副图 波段 短线 买卖点 炒股叉第7646张

[lywrap=通达信副图指标公式][lycode=tdx,true]DRAWGBK(OPEN>0,RGB(0,0,250),RGB(0,0,0),0,'02',0);
DIFF:= EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:= EMA(DIFF,9),COLORFFFF00;
MACD:= (DIFF-DEA)*2;
A1: BARSLAST(DIFF<REF(DIFF,1)),COLOR00FFFF,LINETHICK1;
A11: A1*-1,COLOR00FFFF,LINETHICK1;
A2: BARSLAST(DEA<REF(DEA,1)),COLORRED,LINETHICK1;
A22: A2*-1,COLORRED,LINETHICK1;
DRAWBAND(A2,RGB(150,50,20),A1,RGB(150,100,150));
DRAWBAND(A22,RGB(150,100,150),A11,RGB(150,50,20));
STICKLINE(CROSS(DIFF,DEA) AND DIFF<0,A11,0,2,0),COLORRED;
STICKLINE(CROSS(DIFF,DEA) AND DIFF>0,0,A1,2,0),COLORRED;
STICKLINE(CROSS(DEA,DIFF) AND DIFF<0,A11,0,2,0),COLORBLUE;
STICKLINE(CROSS(DEA,DIFF) AND DIFF>0,0,A1,2,0),COLORBLUE;
MACD底背离:
STICKLINE(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),-25,25,0.00001,0),COLORYELLOW;
STICKLINE(A1>0 AND A2>0,A2,A1,0.00001,0),COLORFFFFFF;
STICKLINE(A1>0 AND A2>0,A22,A11,0.00001,0),COLORFFFFFF;
STICKLINE(A1>0 AND A2>0,0,A1,0.000001,0),COLORFF00FF;
STICKLINE(A1>0 AND A2>0,0,A11,0.000001,0),COLORGREEN;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF<0,-5,'〇'),COLORCYAN;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF<0,-12,'〇'),COLORCYAN;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF>0,5,'〇'),COLORGREEN;
DRAWTEXT(CROSS(DIFF,DEA) AND DIFF>0,12,'〇'),COLORGREEN;
DRAWTEXT(A2>A1 AND A22<A11 AND A1=0 AND A11=0,A2,'∈'),COLORGREEN;
DRAWTEXT(A2>A1 AND A22<A11 AND A1=0 AND A11=0,0,'∈'),COLORGREEN;
DRAWTEXT(A2>A1 AND A22<A11 AND A1=0 AND A11=0,A22,'∈'),COLORGREEN;
STICKLINE(CROSS(DIFF,DEA) AND DIFF<0,A11,0,2,0),COLORRED;
STICKLINE(CROSS(DIFF,DEA) AND DIFF>0,0,A1,2,0),COLORRED;
STICKLINE(CROSS(DEA,DIFF) AND DIFF<0,A11,0,2,0),COLORBLUE;
STICKLINE(CROSS(DEA,DIFF) AND DIFF>0,0,A1,2,0),COLORBLUE;
N:=5;M1:=5;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,M1,5);
J:=3*K-2*D;
VARB2:=(RSV/2+22)*1;
量:=EMA(VOL,13);
资金:=EMA(AMOUNT,13);
过滤:=((资金 /量) / 100);
提纯:=(((CLOSE -过滤) / 过滤) * 100);
黄金:=((提纯 < (0)) AND ZXNH);
低买:=IF(黄金 AND RSV<VARB2-2,50,0);
高卖:=IF(黄金 AND RSV>VARB2,80,120);
上涨分界:=25;
KDJ提前金叉: (CROSS(上涨分界,低买)),COLORFF00FF,NODRAW;
DRAWTEXT(KDJ提前金叉,0,'⊙'),COLORYELLOW;
DRAWTEXT(KDJ提前金叉,-2,'买'),COLORRED;
AAA1:=STRCAT('沪深总上涨家数:',CON2STR(DYNAINFO(60),0));
AAA2:=STRCAT('沪深总下跌家数:',CON2STR(DYNAINFO(61),0));
DRAWTEXT_FIX(ISLASTBAR,0,0,0,AAA1),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,AAA2),COLORGREEN;[/lycode][lycode=tdx2,true]填充背景
DIFF赋值: 不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均
DEA赋值: DIFF的9日指数移动平均,COLORFFFF00
MACD赋值: (DIFF-DEA)*2
输出A1: 上次DIFF<1日前的DIFF距今天数,COLOR00FFFF,线宽为1
输出A11: A1*-1,COLOR00FFFF,线宽为1
输出A2: 上次DEA<1日前的DEA距今天数,画红色,线宽为1
输出A22: A2*-1,画红色,线宽为1
画带状线
画带状线
当满足条件DIFF上穿DEAANDDIFF<0时,在A11和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
当满足条件DIFF上穿DEAANDDIFF>0时,在0和A1位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
当满足条件DEA上穿DIFFANDDIFF<0时,在A11和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
当满足条件DEA上穿DIFFANDDIFF>0时,在0和A1位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
输出MACD底背离:当满足条件A1+1日前的收盘价>CLOSEANDDIFF>A1+1日前的DIFFANDCROSS(DIFF,DEA)时,在-25和25位置之间画柱状线,宽度为0.00001,0不为0则画空心柱.,画黄色
当满足条件A1>0ANDA2>0时,在A2和A1位置之间画柱状线,宽度为0.00001,0不为0则画空心柱.,COLORFFFFFF
当满足条件A1>0ANDA2>0时,在A22和A11位置之间画柱状线,宽度为0.00001,0不为0则画空心柱.,COLORFFFFFF
当满足条件A1>0ANDA2>0时,在0和A1位置之间画柱状线,宽度为0.000001,0不为0则画空心柱.,COLORFF00FF
当满足条件A1>0ANDA2>0时,在0和A11位置之间画柱状线,宽度为0.000001,0不为0则画空心柱.,画绿色
当满足条件DIFF上穿DEAANDDIFF<0时,在-5位置书写文字,画青色
当满足条件DIFF上穿DEAANDDIFF<0时,在-12位置书写文字,画青色
当满足条件DIFF上穿DEAANDDIFF>0时,在5位置书写文字,画绿色
当满足条件DIFF上穿DEAANDDIFF>0时,在12位置书写文字,画绿色
当满足条件A2>A1ANDA22<A11ANDA1=0ANDA11=0时,在A2位置书写文字,画绿色
当满足条件A2>A1ANDA22<A11ANDA1=0ANDA11=0时,在0位置书写文字,画绿色
当满足条件A2>A1ANDA22<A11ANDA1=0ANDA11=0时,在A22位置书写文字,画绿色
当满足条件DIFF上穿DEAANDDIFF<0时,在A11和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
当满足条件DIFF上穿DEAANDDIFF>0时,在0和A1位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
当满足条件DEA上穿DIFFANDDIFF<0时,在A11和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
当满足条件DEA上穿DIFFANDDIFF>0时,在0和A1位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
N赋值:5
M1赋值:5
RSV赋值:(收盘价-N日内最低价的最低值)/(N日内最高价的最高值-N日内最低价的最低值)*100
K赋值:RSV的5日[1日权重]移动平均
D赋值:K的M1日[5日权重]移动平均
J赋值:3*K-2*D
VARB2赋值:(RSV/2+22)*1
量赋值:成交量(手)的13日指数移动平均
资金赋值:成交额(元)的13日指数移动平均
过滤赋值:((资金 /量) / 100)
提纯赋值:(((收盘价 -过滤) / 过滤) * 100)
黄金赋值:((提纯 < (0)) AND 直线拟合)
低买赋值:如果黄金ANDRSV<VARB2-2,返回50,否则返回0
高卖赋值:如果黄金ANDRSV>VARB2,返回80,否则返回120
上涨分界赋值:25
输出KDJ提前金叉: (上涨分界上穿低买),COLORFF00FF,NODRAW
当满足条件KDJ提前金叉时,在0位置书写文字,画黄色
当满足条件KDJ提前金叉时,在-2位置书写文字,画红色
AAA1赋值:字符串相加
AAA2赋值:字符串相加
当满足条件是否最后一个周期时,在横轴0纵轴0位置书写文字,画红色
当满足条件是否最后一个周期时,在横轴0纵轴0.06位置书写文字,画绿色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1v6kHWkVcKLkfnuMIZSmgUw

看了该指标的人还看了:
黄金点指标    龙行天下指标
抓主升浪指标    一招定乾坤指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表