请选择 进入手机版|继续访问电脑版

擒龙飞天自动买卖点提示指标 通达信 主图 波段 短线 买卖点 画线 操盘控盘 压力支撑

[复制链接]

admin  管理员

发表于 2018-6-14 09:00:18 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 短线 买卖点 画线 操盘控盘 压力支撑 
擒龙飞天自动买卖点提示指标 通达信 主图 波段 短线 买卖点 画线 操盘控盘 压力支撑 炒股叉第7641张

擒龙飞天自动买卖点提示指标 通达信 主图 波段 短线 买卖点 画线 操盘控盘 压力支撑 炒股叉第7642张

[lywrap=通达信主图指标公式][lycode=tdx,true]C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
圣:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
灵:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
石:=SMA(灵,13,8);
仙:=CEILING(SMA(石,13,8));
编著:=SMA(圣,21,8);
AABB:=IF(L,CONST(L),DRAWNULL);
启动:STICKLINE(仙-编著>75,AABB,AABB*0.99,15,1),COLOR0000FF;
{VARZT:=BARSLAST(平台启动);}
{DRAWTEXT(VARZT=1,0.99*(AABB+AABB*0.98)/2,'平台启动'),COLORYELLOW;}
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));
短线:VAR1,COLORWHITE;
中线:VAR6,COLORYELLOW;
下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1;
立桩量:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
突破:=TJ2=1;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),COLORCYAN;
STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),COLORYELLOW;
TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));
三天法则:=TJ3=1;
成立:=三天法则 AND 突破;
条件成立:=FILTER(成立,3);
DRAWTEXT(条件成立,L*0.99,'成立'),COLORYELLOW;

STICKLINE(C>=O,C,O,3,0),COLOR000045;
STICKLINE(C>=O,C,O,2.5,0),COLOR000065;
STICKLINE(C>=O,C,O,2,0),COLOR000085;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;
STICKLINE(C>=O,C,O,1,0),COLOR0000C5;
STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;
STICKLINE(C>=O,H,L,0,0),COLOR0000F5;
STICKLINE(C<O,C,O,3,0),COLOR353500;
STICKLINE(C<O,C,O,2.5,0),COLOR454500;
STICKLINE(C<O,C,O,2,0),COLOR555500;
STICKLINE(C<O,C,O,1.5,0),COLOR656500;
STICKLINE(C<O,C,O,1,0),COLOR757500;
STICKLINE(C<O,C,O,0.5,0),COLOR858500;
STICKLINE(C<O,H,L,0,0),COLOR959500;
HIGHN:=10;
LOWN:=10;
HIGHDISPLAY:=0;
LOWDISPLAY:=0;
ZGDISPLAY:=0;
MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DRAWICON(CC,H*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
上轨:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORBLUE,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT;
AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1);
DRAWICON(CC1,L*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(L,DD1),L);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
下轨:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK1;
ZGSTAR:=(上轨+下轨)/2;
ZGEND:=CONST((上轨+下轨)/2);
STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);
中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT;
DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'买'),COLORRED;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,'卖'),COLORGREEN;
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ;
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2);
ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;
VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
K:=EMA(VAR7,5)*2, , COLORFF00FF;
D:=EMA(K,5), , COLORWHITE;
J:=K*3-D*2, ,COLORYELLOW;
VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;
HS:=VOL/CAPITAL*100, , COLORGREEN;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'降龙'),LINETHICK1,COLORFF00FF;
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'大顶(底)') COLORWHITE;
指标王:=CROSS(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),SMA(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),3,1)) AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1)<20;

DRAWTEXT(指标王,L,'擒龙抓妖'),COLORYELLOW;
DRAWTEXT(VAR1,L*0.98,'★短买'),COLORYELLOW;
DRAWTEXT(CROSS(MA(C,3),MA(C,9)) AND C>=REF(C,1) AND C>O,L*0.98,'★加仓'),COLORMAGENTA;
下降压力线:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),LINETHICK2;
STICKLINE(CURRBARSCOUNT=2,L,L,10,0),COLORGREEN,;
DRAWNUMBER(ISLASTBAR,REF(L,1),REF(L,1));
字:=STRCAT(STRCAT(STRCAT(STRCAT('名称: ',STKNAME),' 代码: '),CODE),' ' );
板块:=STRCAT('概念板块: ',GNBLOCK);

YC:=REF(CLOSE,1);
止损价位:=(YC*1.0035*97+0.2)/99.65;
DRAWTEXT_FIX(C!=0,0.02,0.05,0,'★ =================='),COLORRED;
DRAWTEXT_FIX(C!=0,0.02,0.1,0,'操 '),COLORRED;
DRAWTEXT_FIX(C!=0,0.02,0.15,0,'盘 '),COLORRED;
DRAWTEXT_FIX(C!=0,0.02,0.2,0,'铁 '),COLORRED;
DRAWTEXT_FIX(C!=0,0.02,0.25,0,'律 '),COLORRED;
DRAWTEXT_FIX(C!=0,0.02,0.3,0,'★ =================='),COLORRED;
DRAWTEXT_FIX(C!=0,0.35
,0.12,0,STRCAT(字,板块)),COLORYELLOW;
DRAWTEXT_FIX(C!=0,0.04,0.1,0,'买入条件 E13 CCI'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,0.04,0.15,0,'买入条件 2:30以后'),COLORYELLOW;
DRAWTEXT_FIX(C!=0,0.04,0.2,0,STRCAT('止损价位 ',STRCAT(CON2STR(止损价位,2),' 元'))),COLORYELLOW;
DRAWTEXT_FIX(C!=0,0.04,0.25,0,'线上:工作 线下:休息'),COLORYELLOW;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*E-LOW;
明日支撑:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反转:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
DRAWTEXT_FIX(C!=0,0.2,0.05,0,STRCAT('今日阻力: ',STRCAT(CON2STR(今日阻力,2),' 元'))),COLORFFFF00;
DRAWTEXT_FIX(C!=0,0.2,0.1,0,STRCAT('今日支撑: ',STRCAT(CON2STR(今日支撑,2),' 元'))),COLORRED;
DRAWTEXT_FIX(C!=0,0.2,0.15,0,STRCAT('明日突破: ',STRCAT(CON2STR(明日突破,2),' 元'))),COLORFF00FF;
DRAWTEXT_FIX(C!=0,0.2,0.2,0,STRCAT('明日阻力: ',STRCAT(CON2STR(明日阻力,2),' 元'))),COLORFFFF00;
DRAWTEXT_FIX(C!=0,0.2,0.25,0,STRCAT('明日支撑: ',STRCAT(CON2STR(明日支撑,2),' 元'))),COLORRED;
DRAWTEXT_FIX(C!=0,0.2,0.3,0,STRCAT('明日反转: ',STRCAT(CON2STR(明日反转,2),' 元'))),COLORYELLOW;[/lycode][lycode=tdx2,true]C2赋值:1日前的收盘价
涨停赋值:如果(收盘价-C2)*100/C2>=(10-0.01*100/C2),返回1,否则返回0
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
当满足条件涨停时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
跌停赋值:如果(C2-收盘价)*100/C2>=(10-0.01*100/C2),返回1,否则返回0
当满足条件跌停时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色
当满足条件跌停时,在最高价和最低价位置之间画柱状线,宽度为0,1不为0则画空心柱.,画绿色
圣赋值:(21日内最高价的最高值-收盘价)/(21日内最高价的最高值-21日内最低价的最低值)*100-10
灵赋值:(收盘价-21日内最低价的最低值)/(21日内最高价的最高值-21日内最低价的最低值)*100
石赋值:灵的13日[8日权重]移动平均
仙赋值:石的13日[8日权重]移动平均的向上舍入
编著赋值:圣的21日[8日权重]移动平均
AABB赋值:如果最低价,返回最低价的最后一日取值设为常数,否则返回无效数
输出启动:当满足条件仙-编著>75时,在AABB和AABB*0.99位置之间画柱状线,宽度为15,1不为0则画空心柱.,COLOR0000FF
AAA赋值:(3*收盘价+最高价+最低价+开盘价)/6
VAR1赋值:(8*AAA+7*1日前的AAA+6*2日前的AAA+5*3日前的AAA+4*4日前的AAA+3*5日前的AAA+2*6日前的AAA+8日前的AAA)/36
VAR2赋值:(5日内VAR1的最高值+10日内VAR1的最高值+20日内VAR1的最高值)/3
VAR3赋值:(5日内VAR1的最低值+10日内VAR1的最低值+20日内VAR1的最低值)/3
VAR4赋值:(5日内VAR2的最高值+10日内VAR2的最高值+20日内VAR2的最高值)/3
VAR5赋值:(5日内VAR3的最低值+10日内VAR3的最低值+20日内VAR3的最低值)/3
VAR6赋值:(2日内VAR1的最低值+4日内VAR1的最低值+6日内VAR1的最低值)/3
画带状线
输出短线:VAR1,画白色
输出中线:VAR6,画黄色
输出下跌:如果VAR1=VAR6,返回VAR6,否则返回无效数,画绿色
TJ1赋值:成交量(手)=10日内成交量(手)的最高值 AND 成交量(手)>2*1日前的成交量(手) AND 收盘价>VAR1
立桩量赋值:TJ1的5日过滤
TJ2赋值:如果上次立桩量距今天数=1ANDCLOSE>1日前的最高价,返回1,否则返回如果上次立桩量距今天数=2ANDCLOSE>2日前的最高价,返回1,否则返回如果上次立桩量距今天数=3ANDCLOSE>3日前的最高价,返回1,否则返回0
突破赋值:TJ2=1
当满足条件收盘价时,在上次立桩量距今天数日前的最高价和上次立桩量距今天数日前的最高价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画青色
当满足条件收盘价时,在上次立桩量距今天数日前的最低价和上次立桩量距今天数日前的最低价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
TJ3赋值:如果上次立桩量距今天数=1ANDCLOSE>1日前的最低价,返回1,否则返回如果上次立桩量距今天数=2ANDCLOSE>2日前的最低价,返回1,否则返回如果上次立桩量距今天数=3ANDCLOSE>3日前的最低价,返回1,否则返回0
三天法则赋值:TJ3=1
成立赋值:三天法则 AND 突破
条件成立赋值:成立的3日过滤
当满足条件条件成立时,在最低价*0.99位置书写文字,画黄色
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000045
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR000065
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR000085
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR0000A5
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR0000C5
当满足条件收盘价>=开盘价时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR0000E5
当满足条件收盘价>=开盘价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR0000F5
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR353500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR454500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR555500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR656500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR757500
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR858500
当满足条件收阴线时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR959500
HIGHN赋值:10
LOWN赋值:10
HIGHDISPLAY赋值:0
LOWDISPLAY赋值:0
ZGDISPLAY赋值:0
MADISPLAY赋值:0
AA赋值:HIGHN日前的最高价=2*HIGHN+1日内最高价的最高值
QY赋值:若AA则将最近HIGHN+1周期置为1
CC赋值:QY的HIGHN日过滤 AND 最高价=HIGHN+1日内最高价的最高值
当满足条件CC时,在最高价*1.02位置画2号图标
DDD赋值:上次CC距今天数
GDTS赋值:如果CC,返回到最后交易的周期,否则返回0
DINGBU赋值:如果DDD,返回DDD日前的最高价,否则返回最高价
DINGBUTS赋值:如果DDD,返回DDD日前的GDTS,否则返回GDTS
DINGBU1赋值:DDD+1日前的DINGBU
GDCS1赋值:DINGBUTS的最后一日取值设为常数
DINGBUTS1赋值:DDD+1日前的DINGBUTS
GDCS2赋值:DINGBUTS1的最后一日取值设为常数
DINGBU2赋值:DDD+1日前的DINGBU1
MM赋值:如果到最后交易的周期>GDCS2,返回0,否则返回1
输出上轨:当满足条件到最后交易的周期=GDCS2时,在最高价位置画直线起点,当满足条件到最后交易的周期=GDCS1时,在最高价位置画直线终点,1表示是否延长. 画蓝色,线宽为1
当满足条件到最后交易的周期=GDCS2时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在GDCS2-1日前的最高价位置画直线终点,1表示是否延长.,COLOR0055FF,POINTDOT
当满足条件到最后交易的周期=GDCS1时,在最高价位置画直线起点,当满足条件是否最后一个周期时,在GDCS1-1日前的最高价位置画直线终点,1表示是否延长.,画黄色,POINTDOT
AA1赋值:LOWN日前的最低价=2*LOWN+1日内最低价的最低值
QY1赋值:若AA1则将最近LOWN+1周期置为1
CC1赋值:QY1的LOWN日过滤 AND 最低价=LOWN+1日内最低价的最低值
当满足条件CC1时,在最低价*0.98位置画1号图标
DD1赋值:上次CC1距今天数
DDTS赋值:如果CC1,返回到最后交易的周期,否则返回0
YDB赋值:如果DD1,返回DD1日前的最低价,否则返回最低价
DDTS1赋值:如果DD1,返回DD1日前的DDTS,否则返回DDTS
DDCS1赋值:DDTS1的最后一日取值设为常数
ZDB赋值:DD1+1日前的YDB
DDTS2赋值:DD1+1日前的DDTS1
DDCS2赋值:DDTS2的最后一日取值设为常数
输出下轨:当满足条件到最后交易的周期=DDCS2时,在最低价位置画直线起点,当满足条件到最后交易的周期=DDCS1时,在最低价位置画直线终点,1表示是否延长. 画红色,线宽为1
ZGSTAR赋值:(上轨+下轨)/2
ZGEND赋值:(上轨+下轨)/2的最后一日取值设为常数
STARDAY赋值:如果DDCS2<GDCS2,返回DDCS2,否则返回GDCS2
输出中轨:当满足条件到最后交易的周期=STARDAY时,在ZGSTAR位置画直线起点,当满足条件是否最后一个周期时,在ZGEND位置画直线终点,1表示是否延长.,COLORFF55BB,线宽为1
当满足条件到最后交易的周期=DDCS1时,在最低价位置画直线起点,当满足条件是否最后一个周期时,在DDCS1-1日前的最低价位置画直线终点,1表示是否延长.,画洋红色,POINTDOT
当满足条件到最后交易的周期=DDCS2时,在最低价位置画直线起点,当满足条件是否最后一个周期时,在DDCS2-1日前的最低价位置画直线终点,1表示是否延长.,画青色,POINTDOT
VAR7赋值:0
VAR8赋值:收盘价-1日前的收盘价和0的较大值的34日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的7日[1日权重]移动平均*100
VAR9赋值:收盘价-1日前的收盘价和0的较大值的13日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的13日[1日权重]移动平均*100
VAR10赋值:如果收盘价16%之字转向的前1个波谷位置=0ANDHIGH>最低价+0.04,返回4,否则返回0
VAR11赋值:收盘价6%的之字转向>1日前的收盘价6%的之字转向 AND 1日前的收盘价6%的之字转向<=2日前的收盘价6%的之字转向 AND 2日前的收盘价6%的之字转向<=3日前的收盘价6%的之字转向
VAR12赋值:收盘价6%的之字转向<1日前的收盘价6%的之字转向 AND 1日前的收盘价6%的之字转向>=2日前的收盘价6%的之字转向 AND 2日前的收盘价6%的之字转向>=3日前的收盘价6%的之字转向
VAR13赋值:收盘价22%的之字转向>1日前的收盘价22%的之字转向 AND 1日前的收盘价22%的之字转向<=2日前的收盘价22%的之字转向 AND 2日前的收盘价22%的之字转向<=3日前的收盘价22%的之字转向
VAR14赋值:收盘价22%的之字转向<1日前的收盘价22%的之字转向 AND 1日前的收盘价22%的之字转向>=2日前的收盘价22%的之字转向 AND 2日前的收盘价22%的之字转向>=3日前的收盘价22%的之字转向
VAR15赋值:收盘价51%的之字转向>1日前的收盘价51%的之字转向 AND 1日前的收盘价51%的之字转向<=2日前的收盘价51%的之字转向 AND 2日前的收盘价51%的之字转向<=3日前的收盘价51%的之字转向
VAR16赋值:收盘价51%的之字转向<1日前的收盘价51%的之字转向 AND 1日前的收盘价51%的之字转向>=2日前的收盘价51%的之字转向 AND 2日前的收盘价51%的之字转向>=3日前的收盘价51%的之字转向
VAR17赋值:收盘价72%的之字转向>1日前的收盘价72%的之字转向 AND 1日前的收盘价72%的之字转向<=2日前的收盘价72%的之字转向 AND 2日前的收盘价72%的之字转向<=3日前的收盘价72%的之字转向
VAR18赋值:收盘价72%的之字转向<1日前的收盘价72%的之字转向 AND 1日前的收盘价72%的之字转向>=2日前的收盘价72%的之字转向 AND 2日前的收盘价72%的之字转向>=3日前的收盘价72%的之字转向
VAR19赋值:收盘价的2日指数移动平均-收盘价的150日指数移动平均
买1赋值:VAR10
买2赋值:(VAR11+VAR13+VAR15+VAR17)
卖1赋值:(VAR12+VAR14+VAR16+VAR18)
输出B:如果买1>0OR买2>0,返回最低价*0.99,否则返回无效数,CROSSDOT,线宽为3,画黄色
当满足条件买1>0OR买2>0时,在最低价*0.99位置书写文字,画红色
输出S:如果卖1>0,返回最高价*1.01,否则返回无效数,CROSSDOT,线宽为3,画绿色
当满足条件卖1>0时,在最高价*1.02位置书写文字,画绿色
当满足条件(收盘价5%的之字转向>1日前的收盘价5%的之字转向)AND(1日前的收盘价5%的之字转向<=2日前的收盘价5%的之字转向)AND(2日前的收盘价5%的之字转向<=3日前的收盘价5%的之字转向)时,在最低价*0.98位置画1号图标
当满足条件(收盘价5%的之字转向<1日前的收盘价5%的之字转向)AND(1日前的收盘价5%的之字转向>=2日前的收盘价5%的之字转向)AND(2日前的收盘价5%的之字转向>=3日前的收盘价5%的之字转向)时,在最高价*1.01位置画2号图标
ZB赋值:VAR3的5日指数移动平均的5日指数移动平均*3, COLORSTICK
VARA赋值:如果VAR9ANDCROSS(收盘价的3日简单移动平均,收盘价的5日简单移动平均),返回20,否则返回0
K赋值:VAR7的5日指数移动平均*2, , COLORFF00FF
D赋值:K的5日指数移动平均, , 画白色
J赋值:K*3-D*2, ,画黄色
VARB赋值:收盘价位于收盘价的3日简单移动平均和收盘价的5日简单移动平均之间 AND J>10
HS赋值:成交量(手)/当前流通股本(手)*100, , 画绿色
VARE赋值:100*(收盘价-34日内收盘价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的5日简单移动平均-20
VARF赋值:100-3*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
当满足条件VAR11ANDCOUNT(VAR11,30)=1时,在最低价*0.95位置书写文字,线宽为1,COLORFF00FF
VAR1A赋值:如果VARE>0,返回VARE,否则返回0
VAR1B赋值:如果VAR14>=200ANDVAR13>=150,返回15,否则返回如果VAR14<=-200ANDVAR13<=-150,返回-15,否则返回VAR16+60
VAR1C赋值:VAR1A>48 AND VAR1B>60 AND VAR19<100
当满足条件VAR1CANDCOUNT(VAR1C,30)=1时,在最低价*0.95位置书写文字 画白色
指标王赋值:(收盘价-8日内最低价的最低值)/(8日内最高价的最高值-8日内最低价的最低值)*100的3日[1日权重]移动平均上穿(收盘价-8日内最低价的最低值)/(8日内最高价的最高值-8日内最低价的最低值)*100的3日[1日权重]移动平均的3日[1日权重]移动平均 AND (收盘价-8日内最低价的最低值)/(8日内最高价的最高值-8日内最低价的最低值)*100的3日[1日权重]移动平均<20
当满足条件指标王时,在最低价位置书写文字,画黄色
当满足条件VAR1时,在最低价*0.98位置书写文字,画黄色
当满足条件收盘价的3日简单移动平均上穿收盘价的9日简单移动平均ANDC>=1日前的收盘价ANDC>开盘价时,在最低价*0.98位置书写文字,画洋红色
输出下降压力线:当满足条件最高价>=10日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价<=3日内最低价的最低值时,在3日内最高价的最高值位置画直线终点,1表示是否延长.,线宽为2
当满足条件到最后交易的周期=2时,在最低价和最低价位置之间画柱状线,宽度为10,0不为0则画空心柱.,画绿色,
当满足条件是否最后一个周期时,在1日前的最低价位置书写数字
字赋值:字符串相加
板块赋值:字符串相加
YC赋值:1日前的收盘价
止损价位赋值:(YC*1.0035*97+0.2)/99.65
当满足条件收盘价不等于0时,在横轴0.02纵轴0.05位置书写文字,画红色
当满足条件收盘价不等于0时,在横轴0.02纵轴0.1位置书写文字,画红色
当满足条件收盘价不等于0时,在横轴0.02纵轴0.15位置书写文字,画红色
当满足条件收盘价不等于0时,在横轴0.02纵轴0.2位置书写文字,画红色
当满足条件收盘价不等于0时,在横轴0.02纵轴0.25位置书写文字,画红色
当满足条件收盘价不等于0时,在横轴0.02纵轴0.3位置书写文字,画红色
当满足条件收盘价不等于0时,在横轴0.35纵轴0.12位置书写文字,画黄色
当满足条件收盘价不等于0时,在横轴0.04纵轴0.1位置书写文字,画黄色
当满足条件收盘价不等于0时,在横轴0.04纵轴0.15位置书写文字,画黄色
当满足条件收盘价不等于0时,在横轴0.04纵轴0.2位置书写文字,画黄色
当满足条件收盘价不等于0时,在横轴0.04纵轴0.25位置书写文字,画黄色
E赋值:(最高价+最低价+开盘价+2*收盘价)/5
明日阻力赋值:2*E-最低价
明日支撑赋值:2*E-最高价
明日突破赋值:E+(最高价-最低价)
明日反转赋值:E-(最高价-最低价)
今日阻力赋值:1日前的明日阻力
今日支撑赋值:1日前的明日支撑
当满足条件收盘价不等于0时,在横轴0.2纵轴0.05位置书写文字,COLORFFFF00
当满足条件收盘价不等于0时,在横轴0.2纵轴0.1位置书写文字,画红色
当满足条件收盘价不等于0时,在横轴0.2纵轴0.15位置书写文字,COLORFF00FF
当满足条件收盘价不等于0时,在横轴0.2纵轴0.2位置书写文字,COLORFFFF00
当满足条件收盘价不等于0时,在横轴0.2纵轴0.25位置书写文字,画红色
当满足条件收盘价不等于0时,在横轴0.2纵轴0.3位置书写文字,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1xKH-Sbz8kz8VwY03jnl5rQ

看了该指标的人还看了:
黄金阶梯指标    黑马起爆点暴力拉升指标
200万指标    MACD+KDJ指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表