请选择 进入手机版|继续访问电脑版

涨停板抄底指标 通达信 副图 波段 短线 买卖点 抄底逃顶

[复制链接]

admin  管理员

发表于 6 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 波段 短线 买卖点 抄底逃顶 
涨停板抄底指标 通达信 副图 波段 短线 买卖点 抄底逃顶 炒股叉第7621张

涨停板抄底指标 通达信 副图 波段 短线 买卖点 抄底逃顶 炒股叉第7622张

[lywrap=通达信副图指标公式][lycode=tdx,true]{涨停板抄底 V型反转 副图}
涨停:=BETWEEN(CLOSE/REF(CLOSE,1),1.0989,1.110) AND C=H AND C>O;
{轨道}
CCO:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DDO:=DMA(CLOSE,CCO);
上轨:=(1+7/100)*DDO;
下轨:=(1-7/100)*DDO;
中轨:=(上轨+下轨)/2;
{箱体}
DFO:=(C-REF(C,1))/REF(C,1)*100<-5;
AAO:=BARSLAST(DFO);
突破箱体:=CROSS(C,REF(O,AAO));
V型反转3:=EXIST(DFO,3) AND 突破箱体;
VD1:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VD2:=(REF(VD1,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD3:=(REF(VD2,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VD4:=(REF(VD3,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD5:=(REF(VD4,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VD6:=(REF(VD5,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD7:=(REF(VD6,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VD8:=(REF(VD7,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD9:=(REF(VD8,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VD10:=(REF(VD9,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD11:=(REF(VD10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VD12:=(REF(VD11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD13蓝:=REF(VD1 OR VD2 OR VD3 OR VD4 OR VD5 OR VD6 OR VD7
OR VD8 OR VD9 OR VD10 OR VD11 OR VD12,1) AND 涨停;
RU9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KU1:=SMA(RU9,3,1);

DU1:=KU1-REF(KU1,1);
FD1:=IF(DU1>7 AND REF(DU1,1)<0 AND (DU1-REF(DU1,1))>9,50,0);
VD14绿:=FD1=50 OR REF("KDJ.J",1)<0 AND "KDJ.J">0 AND 涨停;
VD15红:=VD13蓝 AND VD14绿 AND 涨停;
VD13蓝过滤:=IF((VD14绿),DRAWNULL,VD13蓝);
形态1:=(VD13蓝过滤 OR VD15红) AND C>O AND C<中轨;
形态2:=(VD13蓝过滤 OR VD15红) AND C>O;
急速超跌:=(C-MA(C,34))/MA(C,34)*100<-14;
实体比例2:=ABS(C-O)/C>0.07;
实体比例3:=ABS(C-O)/C>0.06;
统一价:=DYNAINFO(7)>3 AND DYNAINFO(7)<40;{股价取3至25元}
统一盘:=CAPITAL/1000000>=0.3 AND CAPITAL/1000000<9; {流通盘取0.3亿至9亿}
V手1:=BETWEEN(SUM(HSCOL,20),12,20) OR BETWEEN(SUM(HSCOL,20),23,37) OR BETWEEN(SUM(HSCOL,20),39,49)
OR BETWEEN(SUM(HSCOL,20),51,164) OR SUM(HSCOL,20)>166;
V手2:=BETWEEN(SUM(HSCOL,20),12,16) OR BETWEEN(SUM(HSCOL,20),18,19) OR BETWEEN(SUM(HSCOL,20),21,32)
OR BETWEEN(SUM(HSCOL,20),36,48) OR BETWEEN(SUM(HSCOL,20),50,60) OR BETWEEN(SUM(HSCOL,20),62,68)
OR BETWEEN(SUM(HSCOL,20),70,74) OR BETWEEN(SUM(HSCOL,20),76,102) OR BETWEEN(SUM(HSCOL,20),104,126)
OR BETWEEN(SUM(HSCOL,20),128,164) OR BETWEEN(SUM(HSCOL,20),166,267) OR BETWEEN(SUM(HSCOL,20),269,512);
V手3:=BETWEEN(SUM(HSCOL,20),0,22) OR BETWEEN(SUM(HSCOL,20),24,30) OR BETWEEN(SUM(HSCOL,20),32,130)
OR BETWEEN(SUM(HSCOL,20),132,164) OR BETWEEN(SUM(HSCOL,20),166,267) OR SUM(HSCOL,20)>269;
V手4:=BETWEEN(SUM(HSCOL,20),12,20) OR BETWEEN(SUM(HSCOL,20),23,32) OR BETWEEN(SUM(HSCOL,20),36,48)
OR BETWEEN(SUM(HSCOL,20),52,69) OR BETWEEN(SUM(HSCOL,20),71,81) OR BETWEEN(SUM(HSCOL,20),83,89)
OR BETWEEN(SUM(HSCOL,20),91,99) OR BETWEEN(SUM(HSCOL,20),101,111) OR BETWEEN(SUM(HSCOL,20),113,164)
OR BETWEEN(SUM(HSCOL,20),166,267) OR SUM(HSCOL,20)>269;
V手5:=BETWEEN(SUM(HSCOL,20),12,20) OR SUM(HSCOL,20)>23;
V手6:=BETWEEN(SUM(HSCOL,20),0,28) OR SUM(HSCOL,20)>31;
V手7:=BETWEEN(SUM(HSCOL,20),5,17) OR BETWEEN(SUM(HSCOL,20),21,22) OR BETWEEN(SUM(HSCOL,20),24,28)
OR BETWEEN(SUM(HSCOL,20),30,32) OR BETWEEN(SUM(HSCOL,20),36,60) OR BETWEEN(SUM(HSCOL,20),62,130)
OR BETWEEN(SUM(HSCOL,20),132,164) OR BETWEEN(SUM(HSCOL,20),166,267) OR SUM(HSCOL,20)>269;
{以上为选股框架 以下为选股多指标源码}
VA1:=(C-MA(C,30))/MA(C,30)*100;
VA2:=VA1<-3;
VB2:=(H-L)/L>0.07 AND (C-O)/O>0.07 AND C/REF(C,1)>1.05;
VB3:=急速超跌 AND VB2;
VL1:="BIAS.BIAS3"<-6;
VE1:=(-100)*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3));
VE2:=CROSS(VE1,-87) AND OPEN<MA(CLOSE,5) AND CLOSE>=1.099*REF(CLOSE,1)
AND INDEXC>0.98*REF(INDEXC,1) AND CLOSE<=1.47*LLV(CLOSE,58);
VF1:=HHV(DMI.ADX,10)>65;
VF2:=IF(O<XS2.通道2 AND C>XS2.通道2 AND O<XS2.通道4 AND C>XS2.通道4 AND VF1,70,0);
V短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
V中期:=100*(C-LLV(L,8))/(HHV(C,8)-LLV(L,8));
V中期A:=100*(C-LLV(L,13))/(HHV(C,13)-LLV(L,13));
V中长期A:=100*(C-LLV(L,21))/(HHV(C,21)-LLV(L,21));
V中短:=(V短期+V中期+V中期A+V中长期A)/4;
V中长期:=100*(C-LLV(L,34))/(HHV(C,34)-LLV(L,34));
V长期:=EMA(V中长期,13);
V选股:=V长期<20 AND CROSS(V中长期,V长期);
V转1:=VE2 AND 形态1 AND 实体比例2 AND V型反转3 AND C<EMA(C,99) AND V手1 AND 统一盘 AND 统一价;
V转2:=VA2 AND 形态1 AND 实体比例3 AND V型反转3 AND V手2 AND 统一盘 AND 统一价;
V转3:=VB3 AND 形态2 AND 实体比例2 AND V手3 AND 统一盘 AND 统一价;
V转4:=VL1 AND 形态1 AND 实体比例2 AND V手4 AND 统一盘 AND 统一价;
V转5:=VF2 AND 形态2 AND 实体比例2 AND V型反转3 AND C<EMA(C,60) AND V手5 AND 统一盘 AND 统一价;
V转6:=VF2 AND 形态2 AND 实体比例2 AND REF(急速超跌,2) AND REF(急速超跌,1) AND 突破箱体 AND CROSS(C,EXPMA(C,13))
AND V手6 AND 统一盘 AND 统一价;
V转7:=V选股 AND 形态2 AND 实体比例2 AND V型反转3 AND V手7 AND 统一盘 AND 统一价;
V型反转:V转1 OR V转2 OR V转3 OR V转4 OR V转5 OR V转6 OR V转7 NODRAW};
{图标}
DRAWICON((V型反转),17,1);
{信号}
{绿色柱状}
STICKLINE(V型反转,0,8,4.5,0),COLORGREEN;
STICKLINE(V型反转,0,12,2.5,0),COLORGREEN;
STICKLINE(V型反转,0,12,2,0),COLOR006600;
STICKLINE(V型反转,0,12,1.5,0),COLOR009900;
STICKLINE(V型反转,0,12,0.1,0),COLOR00FF00;
{白色}
STICKLINE(V型反转,0,15,0.1,0),COLORWHITE;
{写字}
DRAWTEXT(V型反转,10,'---V型反转'),COLOR00FFFF;[/lycode][lycode=tdx2,true]涨停赋值:收盘价/1日前的收盘价位于1.0989和1.110之间 AND 收盘价=最高价 AND 收阳线
CCO赋值:(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均
DDO赋值:以CCO为权重收盘价的动态移动平均
上轨赋值:(1+7/100)*DDO
下轨赋值:(1-7/100)*DDO
中轨赋值:(上轨+下轨)/2
DFO赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100<-5
AAO赋值:上次DFO距今天数
突破箱体赋值:收盘价上穿AAO日前的开盘价
V型反转3赋值:最近3日存在DFO AND 突破箱体
VD1赋值:(收盘价<1日前的收盘价 AND 收盘价<2日前的收盘价)
VD2赋值:(1日前的VD1 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VD3赋值:(1日前的VD2 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VD4赋值:(1日前的VD3 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VD5赋值:(1日前的VD4 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VD6赋值:(1日前的VD5 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VD7赋值:(1日前的VD6 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VD8赋值:(1日前的VD7 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VD9赋值:(1日前的VD8 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VD10赋值:(1日前的VD9 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VD11赋值:(1日前的VD10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价)
VD12赋值:(1日前的VD11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价)
VD13蓝赋值:1日前的VD1ORVD2ORVD3ORVD4ORVD5ORVD6ORVD7ORVD8ORVD9ORVD10ORVD11ORVD12 AND 涨停
RU9赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
KU1赋值:RU9的3日[1日权重]移动平均
DU1赋值:KU1-1日前的KU1
FD1赋值:如果DU1>7ANDREF(DU1,1)<0AND(DU1-1日前的DU1)>9,返回50,否则返回0
VD14绿赋值:FD1=50 OR 1日前的"KDJ的J"<0 AND "KDJ的J">0 AND 涨停
VD15红赋值:VD13蓝 AND VD14绿 AND 涨停
VD13蓝过滤赋值:如果(VD14绿),返回无效数,否则返回VD13蓝
形态1赋值:(VD13蓝过滤 OR VD15红) AND 收阳线AND 收盘价<中轨
形态2赋值:(VD13蓝过滤 OR VD15红) AND 收阳线
急速超跌赋值:(收盘价-收盘价的34日简单移动平均)/收盘价的34日简单移动平均*100<-14
实体比例2赋值:收盘价-开盘价的绝对值/收盘价>0.07
实体比例3赋值:收盘价-开盘价的绝对值/收盘价>0.06
统一价赋值:现价>3 AND 现价<40
统一盘赋值:当前流通股本(手)/1000000>=0.3 AND 当前流通股本(手)/1000000<9
V手1赋值:换手柱的20日累和位于12和20之间 OR 换手柱的20日累和位于23和37之间 OR 换手柱的20日累和位于39和49之间OR 换手柱的20日累和位于51和164之间 OR 换手柱的20日累和>166
V手2赋值:换手柱的20日累和位于12和16之间 OR 换手柱的20日累和位于18和19之间 OR 换手柱的20日累和位于21和32之间OR 换手柱的20日累和位于36和48之间 OR 换手柱的20日累和位于50和60之间 OR 换手柱的20日累和位于62和68之间OR 换手柱的20日累和位于70和74之间 OR 换手柱的20日累和位于76和102之间 OR 换手柱的20日累和位于104和126之间OR 换手柱的20日累和位于128和164之间 OR 换手柱的20日累和位于166和267之间 OR 换手柱的20日累和位于269和512之间
V手3赋值:换手柱的20日累和位于0和22之间 OR 换手柱的20日累和位于24和30之间 OR 换手柱的20日累和位于32和130之间OR 换手柱的20日累和位于132和164之间 OR 换手柱的20日累和位于166和267之间 OR 换手柱的20日累和>269
V手4赋值:换手柱的20日累和位于12和20之间 OR 换手柱的20日累和位于23和32之间 OR 换手柱的20日累和位于36和48之间OR 换手柱的20日累和位于52和69之间 OR 换手柱的20日累和位于71和81之间 OR 换手柱的20日累和位于83和89之间OR 换手柱的20日累和位于91和99之间 OR 换手柱的20日累和位于101和111之间 OR 换手柱的20日累和位于113和164之间OR 换手柱的20日累和位于166和267之间 OR 换手柱的20日累和>269
V手5赋值:换手柱的20日累和位于12和20之间 OR 换手柱的20日累和>23
V手6赋值:换手柱的20日累和位于0和28之间 OR 换手柱的20日累和>31
V手7赋值:换手柱的20日累和位于5和17之间 OR 换手柱的20日累和位于21和22之间 OR 换手柱的20日累和位于24和28之间OR 换手柱的20日累和位于30和32之间 OR 换手柱的20日累和位于36和60之间 OR 换手柱的20日累和位于62和130之间OR 换手柱的20日累和位于132和164之间 OR 换手柱的20日累和位于166和267之间 OR 换手柱的20日累和>269
VA1赋值:(收盘价-收盘价的30日简单移动平均)/收盘价的30日简单移动平均*100
VA2赋值:VA1<-3
VB2赋值:(最高价-最低价)/最低价>0.07 AND (收盘价-开盘价)/开盘价>0.07 AND 收盘价/1日前的收盘价>1.05
VB3赋值:急速超跌 AND VB2
VL1赋值:"乖离率的BIAS3"<-6
VE1赋值:(-100)*(3日内最高价的最高值-收盘价)/(3日内最高价的最高值-3日内最低价的最低值)
VE2赋值:VE1上穿-87 AND 开盘价<收盘价的5日简单移动平均 AND 收盘价>=1.099*1日前的收盘价AND 大盘的收盘价>0.98*1日前的大盘的收盘价 AND 收盘价<=1.47*58日内收盘价的最低值
VF1赋值:10日内DMI的ADX的最高值>65
VF2赋值:如果开盘价<薛斯通道II的通道2ANDC>薛斯通道II的通道2ANDO<薛斯通道II的通道4ANDC>薛斯通道II的通道4ANDVF1,返回70,否则返回0
V短期赋值:100*(收盘价-5日内最低价的最低值)/(5日内收盘价的最高值-5日内最低价的最低值)
V中期赋值:100*(收盘价-8日内最低价的最低值)/(8日内收盘价的最高值-8日内最低价的最低值)
V中期A赋值:100*(收盘价-13日内最低价的最低值)/(13日内收盘价的最高值-13日内最低价的最低值)
V中长期A赋值:100*(收盘价-21日内最低价的最低值)/(21日内收盘价的最高值-21日内最低价的最低值)
V中短赋值:(V短期+V中期+V中期A+V中长期A)/4
V中长期赋值:100*(收盘价-34日内最低价的最低值)/(34日内收盘价的最高值-34日内最低价的最低值)
V长期赋值:V中长期的13日指数移动平均
V选股赋值:V长期<20 AND V中长期上穿V长期
V转1赋值:VE2 AND 形态1 AND 实体比例2 AND V型反转3 AND 收盘价<收盘价的99日指数移动平均 AND V手1 AND 统一盘 AND 统一价
V转2赋值:VA2 AND 形态1 AND 实体比例3 AND V型反转3 AND V手2 AND 统一盘 AND 统一价
V转3赋值:VB3 AND 形态2 AND 实体比例2 AND V手3 AND 统一盘 AND 统一价
V转4赋值:VL1 AND 形态1 AND 实体比例2 AND V手4 AND 统一盘 AND 统一价
V转5赋值:VF2 AND 形态2 AND 实体比例2 AND V型反转3 AND 收盘价<收盘价的60日指数移动平均 AND V手5 AND 统一盘 AND 统一价
V转6赋值:VF2 AND 形态2 AND 实体比例2 AND 2日前的急速超跌 AND 1日前的急速超跌 AND 突破箱体 AND 收盘价上穿收盘价的13日指数移动平均AND V手6 AND 统一盘 AND 统一价
V转7赋值:V选股 AND 形态2 AND 实体比例2 AND V型反转3 AND V手7 AND 统一盘 AND 统一价
输出V型反转:V转1 OR V转2 OR V转3 OR V转4 OR V转5 OR V转6 OR V转7 NODRAW}
当满足条件(V型反转)时,在17位置画1号图标
当满足条件V型反转时,在0和8位置之间画柱状线,宽度为4.5,0不为0则画空心柱.,画绿色
当满足条件V型反转时,在0和12位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,画绿色
当满足条件V型反转时,在0和12位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR006600
当满足条件V型反转时,在0和12位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR009900
当满足条件V型反转时,在0和12位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR00FF00
当满足条件V型反转时,在0和15位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画白色
当满足条件V型反转时,在10位置书写文字,COLOR00FFFF[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1LiUY75X1UAWWvkLAt2IhXg

看了该指标的人还看了:
抓主升浪指标    轻松买卖指标
黑马王指标    敢死队操盘指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表