请选择 进入手机版|继续访问电脑版

一笑之资金指标 通达信 副图 资金流向 无未来函数 买卖点 量能

[复制链接]

admin  管理员

发表于 7 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: 资金流向 无未来函数 买卖点 量能 
一笑之资金指标 通达信 副图 资金流向 无未来函数 买卖点 量能 炒股叉第7595张

一笑之资金指标 通达信 副图 资金流向 无未来函数 买卖点 量能 炒股叉第7596张

[lywrap=通达信副图指标公式][lycode=tdx,true]LC:=REF(CLOSE,1);
VID:=SUM(VOL,2)/((HHV(HIGH,2)-LLV(LOW,2))*100);
RC:=(CLOSE-LC)*VID;
LONG:=SUM(RC,0);
DIFF:=SMA(LONG,10,1);
DEA:=SMA(LONG,20,1);
LON:=DIFF-DEA;
LLL:=MA(LON,10);
TDXSTEP134:IF(LLL>=REF(LLL,1),LLL,DRAWNULL),COLORRED;
V2:EMA(LON,1),COLORGREEN;
V3:EMA(V2,3),COLORGREEN;
V4:EMA(V3,3),COLORGREEN;
V5:EMA(V4,3),COLORGREEN;
V6:EMA(V5,3),COLORGREEN;
TDXSTEP135:IF(V2>=REF(V2,1),V2,DRAWNULL),COLORRED;
TDXSTEP136:IF(V3>=REF(V3,1),V3,DRAWNULL),COLORRED;
TDXSTEP137:IF(V4>=REF(V4,1),V4,DRAWNULL),COLORRED;
TDXSTEP138:IF(V5>=REF(V5,1),V5,DRAWNULL),COLORRED;
TDXSTEP139:IF(V6>=REF(V6,1),V6,DRAWNULL),COLORRED;
TDXSTEP140:0,COLORWHITE;
TDXSTEP141:STICKLINE(V2>REF(V2,1),V2,REF(V2,1),3,0),COLORRED;
TDXSTEP142:STICKLINE(V2<REF(V2,1),V2,REF(V2,1),3,0),COLORGREEN;
VAR1B:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2B:=SMA(VAR1B,9,1)+100;
VAR3B:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4B:=SMA(VAR3B,3,1);
VAR5B:=SMA(VAR4B,3,1)+100;
VAR6B:=VAR5B-VAR2B;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
火焰山:=IF(VAR8Q>100,100,VAR8Q);
TDXSTEP143:STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,3.5,0),COLOR4444FF;
TDXSTEP144:STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,2.5,0),COLOR5555FF;
TDXSTEP145:STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,1.5,0),COLOR7777FF;
TDXSTEP146:STICKLINE(火焰山>0 AND 火焰山>REF(火焰山,1),0,火焰山*1.2,0.5,0),COLOR9999FF;
逃顶:=CROSS(82,RSI.RSI1);
TDXSTEP147:STICKLINE(逃顶,逃顶,10,3.5,0),COLORFF5500;
TDXSTEP148:STICKLINE(逃顶,逃顶,15,2.5,0),COLORFF8800;
TDXSTEP149:STICKLINE(逃顶,逃顶,20,1.5,0),COLORFFAA00;
TDXSTEP150:STICKLINE(逃顶,逃顶,25,0.5,0),COLORFFCC00;
TDXSTEP151:STICKLINE(逃顶,逃顶,30,0.1,0),COLORCYAN;
强弱线:50,POINTDOT,COLORGREEN;
VARR1:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
TDXSTEP152:DRAWICON(CROSS(82,VARR1),10,15);
TDXSTEP153:DRAWTEXT(CROSS(82,VARR1),35,7),COLORYELLOW;
VAR6:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR7:=SMA(ABS(VAR6-HIGH),13,1)/SMA(MAX(VAR6-HIGH,0),10,1);
VAR8:=EMA(VAR7,10);
VAR9:=HHV(HIGH,33);
VAR0:=EMA(IF(HIGH>=VAR9,VAR8,0),3);
主力出场:IF(VAR0>REF(VAR0,1),(-VAR0)+100,100),COLORGREEN;
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED;
地量:DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND KDJ.J<0),LOW*1,8),COLORYELLOW;
TDXSTEP154:STICKLINE(地量>0,0,30,2,0),COLOR008888;
TDXSTEP155:STICKLINE(地量>0,0,30,1.5,0),COLOR00AAAA;
TDXSTEP156:STICKLINE(地量>0,0,30,0.8,0),COLOR00DDDD;
TDXSTEP157:STICKLINE(地量>0,0,30,0.3,0),COLORYELLOW;
TDXSTEP158:DRAWICON(CROSS(82,VARR1),10,15);
VAR10:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR12:=VAR10<REF(VAR11,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
TDXSTEP159:DRAWTEXT(VAR12 AND COUNT(VAR12,30)=1,40,9),COLORRED;
A2:=5;
A3:=(2*CLOSE+HIGH+LOW)/4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((A3-A4)/(A5-A4)*100,13);
A7:=EMA(0.667*REF(A6,1)+0.333*A6,2);
庄家轨迹:EMA(A7,A2),COLORRED;
A8:=HHV(HIGH,9)-LLV(LOW,9);
A9:=HHV(HIGH,9)-CLOSE;
A10:=CLOSE-LLV(LOW,9);
A11:=A9/A8*100-70;
A12:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
A13:=SMA(A10/A8*100,3,1);
A14:=SMA(A13,3,1)-SMA(A11,9,1);
A15:=IF(A14>100,A14-100,0);
A16:=EMA((A3-A4)/(A5-A4)*100,8);
A17:=EMA(A16,5);
A18:=EMA(CLOSE,2);
A19:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
A20:=HHV(MA(HIGH,13),13);
A21:=LLV(MA(HIGH,13),1);
A22:=EMA(CLOSE,4);
A23:=A18>=A19 AND A21=A20 AND A18>A22 AND CLOSE>A21 AND REF(A21,1)<REF(A20,1);
A24:=BARSLAST(A23)+1;
A25:=LLV(LOW,A24)*1.3;
A26:=LLV(LOW,20)*1.418;
A27:=A18>=A19 AND A21=A20 AND CLOSE/REF(CLOSE,1)>=1.07 AND A24<=30 AND CLOSE<=A25 AND CLOSE<=A26;
A28:=A27 AND FILTER(A27,A24);
A30:=A18>=A19 AND A21=A20 AND CLOSE/REF(CLOSE,1)>=1.035 AND A24<=30 AND CLOSE<=A25 AND CLOSE<=A26;
A31:=A30 AND FILTER(A30,20);
TDXSTEP160:DRAWICON(A28 OR A31,庄家轨迹,26);
TDXSTEP161:DRAWTEXT(A28 OR A31,庄家轨迹,11),COLORRED;[/lycode][lycode=tdx2,true]LC赋值:1日前的收盘价
VID赋值:成交量(手)的2日累和/((2日内最高价的最高值-2日内最低价的最低值)*100)
RC赋值:(收盘价-LC)*VID
LONG赋值:RC的历史累和
DIFF赋值:LONG的10日[1日权重]移动平均
DEA赋值:LONG的20日[1日权重]移动平均
LON赋值:DIFF-DEA
LLL赋值:LON的10日简单移动平均
输出TDXSTEP134:如果LLL>=1日前的LLL,返回LLL,否则返回无效数,画红色
输出V2:LON的1日指数移动平均,画绿色
输出V3:V2的3日指数移动平均,画绿色
输出V4:V3的3日指数移动平均,画绿色
输出V5:V4的3日指数移动平均,画绿色
输出V6:V5的3日指数移动平均,画绿色
输出TDXSTEP135:如果V2>=1日前的V2,返回V2,否则返回无效数,画红色
输出TDXSTEP136:如果V3>=1日前的V3,返回V3,否则返回无效数,画红色
输出TDXSTEP137:如果V4>=1日前的V4,返回V4,否则返回无效数,画红色
输出TDXSTEP138:如果V5>=1日前的V5,返回V5,否则返回无效数,画红色
输出TDXSTEP139:如果V6>=1日前的V6,返回V6,否则返回无效数,画红色
输出TDXSTEP140:0,画白色
输出TDXSTEP141:当满足条件V2>1日前的V2时,在V2和1日前的V2位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
输出TDXSTEP142:当满足条件V2<1日前的V2时,在V2和1日前的V2位置之间画柱状线,宽度为3,0不为0则画空心柱.,画绿色
VAR1B赋值:(9日内最高价的最高值-收盘价)/(9日内最高价的最高值-9日内最低价的最低值)*100-70
VAR2B赋值:VAR1B的9日[1日权重]移动平均+100
VAR3B赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
VAR4B赋值:VAR3B的3日[1日权重]移动平均
VAR5B赋值:VAR4B的3日[1日权重]移动平均+100
VAR6B赋值:VAR5B-VAR2B
VAR2Q赋值:1日前的最低价
VAR3Q赋值:最低价-VAR2Q的绝对值的3日[1日权重]移动平均/最低价-VAR2Q和0的较大值的3日[1日权重]移动平均*100
VAR4Q赋值:如果收盘价*1.3,返回VAR3Q*10,否则返回VAR3Q/10的3日指数移动平均
VAR5Q赋值:30日内最低价的最低值
VAR6Q赋值:30日内VAR4Q的最高值
VAR7Q赋值:如果收盘价的58日简单移动平均,返回1,否则返回0
VAR8Q赋值:如果最低价<=VAR5Q,返回(VAR4Q+VAR6Q*2)/2,否则返回0的3日指数移动平均/999*VAR7Q
火焰山赋值:如果VAR8Q>100,返回100,否则返回VAR8Q
输出TDXSTEP143:当满足条件火焰山>0AND火焰山>1日前的火焰山时,在0和火焰山*1.2位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLOR4444FF
输出TDXSTEP144:当满足条件火焰山>0AND火焰山>1日前的火焰山时,在0和火焰山*1.2位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR5555FF
输出TDXSTEP145:当满足条件火焰山>0AND火焰山>1日前的火焰山时,在0和火焰山*1.2位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR7777FF
输出TDXSTEP146:当满足条件火焰山>0AND火焰山>1日前的火焰山时,在0和火焰山*1.2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR9999FF
逃顶赋值:82上穿RSI的RSI1
输出TDXSTEP147:当满足条件逃顶时,在逃顶和10位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLORFF5500
输出TDXSTEP148:当满足条件逃顶时,在逃顶和15位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLORFF8800
输出TDXSTEP149:当满足条件逃顶时,在逃顶和20位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORFFAA00
输出TDXSTEP150:当满足条件逃顶时,在逃顶和25位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFCC00
输出TDXSTEP151:当满足条件逃顶时,在逃顶和30位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画青色
输出强弱线:50,POINTDOT,画绿色
VARR1赋值:收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均*100
输出TDXSTEP152:当满足条件82上穿VARR1时,在10位置画15号图标
输出TDXSTEP153:当满足条件82上穿VARR1时,在35位置书写文字,画黄色
VAR6赋值:1日前的(最低价+开盘价+收盘价+最高价)/4
VAR7赋值:VAR6-最高价的绝对值的13日[1日权重]移动平均/VAR6-最高价和0的较大值的10日[1日权重]移动平均
VAR8赋值:VAR7的10日指数移动平均
VAR9赋值:33日内最高价的最高值
VAR0赋值:如果最高价>=VAR9,返回VAR8,否则返回0的3日指数移动平均
输出主力出场:如果VAR0>1日前的VAR0,返回(-VAR0)+100,否则返回100,画绿色
VAR1赋值:1日前的(最低价+开盘价+收盘价+最高价)/4
VAR2赋值:最低价-VAR1的绝对值的13日[1日权重]移动平均/最低价-VAR1和0的较大值的10日[1日权重]移动平均
VAR3赋值:VAR2的10日指数移动平均
VAR4赋值:33日内最低价的最低值
VAR5赋值:如果最低价<=VAR4,返回VAR3,否则返回0的3日指数移动平均
输出主力进场:如果VAR5>1日前的VAR5,返回VAR5,否则返回0,画红色
输出地量:当满足条件0.9上穿1/成交量(手)*1000>0.01ANDKDJ.J<0时,在最低价*1位置书写文字,画黄色
输出TDXSTEP154:当满足条件地量>0时,在0和30位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR008888
输出TDXSTEP155:当满足条件地量>0时,在0和30位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR00AAAA
输出TDXSTEP156:当满足条件地量>0时,在0和30位置之间画柱状线,宽度为0.8,0不为0则画空心柱.,COLOR00DDDD
输出TDXSTEP157:当满足条件地量>0时,在0和30位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,画黄色
输出TDXSTEP158:当满足条件82上穿VARR1时,在10位置画15号图标
VAR10赋值:100-3*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(收盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR11赋值:100-3*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均+2*(开盘价-75日内最低价的最低值)/(75日内最高价的最高值-75日内最低价的最低值)*100的20日[1日权重]移动平均的15日[1日权重]移动平均
VAR12赋值:VAR10<1日前的VAR11 AND 成交量(手)>1日前的成交量(手) AND 收盘价>1日前的收盘价
输出TDXSTEP159:当满足条件VAR12ANDCOUNT(VAR12,30)=1时,在40位置书写文字,画红色
A2赋值:5
A3赋值:(2*收盘价+最高价+最低价)/4
A4赋值:34日内最低价的最低值
A5赋值:34日内最高价的最高值
A6赋值:(A3-A4)/(A5-A4)*100的13日指数移动平均
A7赋值:0.667*1日前的A6+0.333*A6的2日指数移动平均
输出庄家轨迹:A7的A2日指数移动平均,画红色
A8赋值:9日内最高价的最高值-9日内最低价的最低值
A9赋值:9日内最高价的最高值-收盘价
A10赋值:收盘价-9日内最低价的最低值
A11赋值:A9/A8*100-70
A12赋值:(收盘价-60日内最低价的最低值)/(60日内最高价的最高值-60日内最低价的最低值)*100
A13赋值:A10/A8*100的3日[1日权重]移动平均
A14赋值:A13的3日[1日权重]移动平均-A11的9日[1日权重]移动平均
A15赋值:如果A14>100,返回A14-100,否则返回0
A16赋值:(A3-A4)/(A5-A4)*100的8日指数移动平均
A17赋值:A16的5日指数移动平均
A18赋值:收盘价的2日指数移动平均
A19赋值:收盘价的21日线性回归斜率*20+收盘价的42日指数移动平均
A20赋值:13日内最高价的13日简单移动平均的最高值
A21赋值:1日内最高价的13日简单移动平均的最低值
A22赋值:收盘价的4日指数移动平均
A23赋值:A18>=A19 AND A21=A20 AND A18>A22 AND 收盘价>A21 AND 1日前的A21<1日前的A20
A24赋值:上次A23距今天数+1
A25赋值:A24日内最低价的最低值*1.3
A26赋值:20日内最低价的最低值*1.418
A27赋值:A18>=A19 AND A21=A20 AND 收盘价/1日前的收盘价>=1.07 AND A24<=30 AND 收盘价<=A25 AND 收盘价<=A26
A28赋值:A27 AND A27的A24日过滤
A30赋值:A18>=A19 AND A21=A20 AND 收盘价/1日前的收盘价>=1.035 AND A24<=30 AND 收盘价<=A25 AND 收盘价<=A26
A31赋值:A30 AND A30的20日过滤
输出TDXSTEP160:当满足条件A28ORA31时,在庄家轨迹位置画26号图标
输出TDXSTEP161:当满足条件A28ORA31时,在庄家轨迹位置书写文字,画红色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1xfIQiLDUR10AM9EyF2bwvw

看了该指标的人还看了:
主力看盘指标    超级主力建仓指标
一招定乾坤指标    虎拓圣龙买卖指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表