请选择 进入手机版|继续访问电脑版

波段擒牛指标 通达信 主图 MACD指标 波段 短线 买卖点 抄底逃顶 操盘控盘

[复制链接]

admin  管理员

发表于 2018-6-12 09:00:55 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: MACD指标 波段 短线 买卖点 抄底逃顶 操盘控盘 
波段擒牛是收藏指标库中一个很有意思的主图,首先原作者起名很幽默,其次采用3日和5日加权平均数进行差离值对比多空力量。
最有含金量的在于采用类似MACD指标画法并叠加到主图上,很直观。
波段擒牛指标 通达信 主图 MACD指标 波段 短线 买卖点 抄底逃顶 操盘控盘 炒股叉第7589张

波段擒牛指标 通达信 主图 MACD指标 波段 短线 买卖点 抄底逃顶 操盘控盘 炒股叉第7590张

[lywrap=通达信副图指标公式][lycode=tdx,true]A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
RCC:=DYNAINFO(3);
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
STICKLINE(DK>0,RCC,RCC+DK,0,1),COLORRED;
STICKLINE(DK<0,RCC,RCC+DK,0,1),COLORCYAN;
主力成本:EMA(X,13),COLORFF00FF,LINETHICK0;
短期底部:LLV(HIGH,30),LINETHICK2,COLORFFCC00;
IF(MA(C,3),MA(C,3),DRAWNULL),COLORYELLOW,LINETHICK2;
IF(MA(C,9),MA(C,9),DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(MA(C,23.5),MA(C,23.5),DRAWNULL),COLORWHITE;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
MA5:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
FA:=BARSLAST(CROSS(MA10,MA5)) AND CROSS(MA5,MA10);
FB:=FA AND MA5>MA30 AND MA10>MA30 AND MA10>REF(MA10,1);
DRAWTEXT(FB,L-0.58,'★红牛'),COLORRED;
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,90)*1.01,10);
DRAWTEXT(CROSS(V1,V2),V1+0.05,'牛起步'),COLOR00FF00;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
DRAWTEXT((AB = 1),(LOW * 0.99),'○牛窝'),COLORYELLOW;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
老鼠仓:=BB1 AND CC1 AND DD1 AND EE1,LINETHICK0,COLOR0099FF;
DRAWTEXT(老鼠仓,L*0.99,'老鼠仓'),COLOR0099FF;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆搏 '),COLOR00FFFF;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLOR00FFFF;
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF;
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.01,'▼逃顶'),COLORYELLOW;[/lycode][lycode=tdx2,true]A赋值:(3*收盘价+最低价+开盘价+最高价)/6
X赋值:(20*A+19*1日前的A+18*2日前的A+17*3日前的A+16*4日前的A+15*5日前的A+14*6日前的A+13*7日前的A+12*8日前的A+11*9日前的A+10*10日前的A+9*11日前的A+8*12日前的A+7*13日前的A+6*14日前的A+5*15日前的A+4*16日前的A+3*17日前的A+2*18日前的A+20日前的A)/210
RCC赋值:前收盘价
S2赋值:收盘价的3日[1日权重]移动平均
S6赋值:收盘价的5日[1日权重]移动平均
DK赋值:2*(S2-S6)
当满足条件DK>0时,在RCC和RCC+DK位置之间画柱状线,宽度为0,1不为0则画空心柱.,画红色
当满足条件DK<0时,在RCC和RCC+DK位置之间画柱状线,宽度为0,1不为0则画空心柱.,画青色
输出主力成本:X的13日指数移动平均,COLORFF00FF,线宽为0
输出短期底部:30日内最高价的最低值,线宽为2,COLORFFCC00
如果收盘价的3日简单移动平均,返回收盘价的3日简单移动平均,否则返回无效数,画黄色,线宽为2
如果收盘价的9日简单移动平均,返回收盘价的9日简单移动平均,否则返回无效数,画洋红色,线宽为2
如果收盘价的23.5日简单移动平均,返回收盘价的23.5日简单移动平均,否则返回无效数,画白色
K线
MA5赋值:收盘价的5日简单移动平均
MA10赋值:收盘价的10日简单移动平均
MA30赋值:收盘价的30日简单移动平均
FA赋值:上次MA10上穿MA5距今天数 AND MA5上穿MA10
FB赋值:FA AND MA5>MA30 AND MA10>MA30 AND MA10>1日前的MA10
当满足条件FB时,在最低价-0.58位置书写文字,画红色
V1赋值:收盘价的5日指数移动平均
V2赋值:收盘价的90日指数移动平均*1.01的10日指数移动平均
当满足条件V1上穿V2时,在V1+0.05位置书写文字,COLOR00FF00
VAR1赋值:21日内最低价的最低值
VAR2赋值:21日内最高价的最高值
AK1赋值:(((收盘价-VAR1)/(VAR2-VAR1))*100)的5日指数移动平均
AK赋值:(((收盘价-VAR1)/(VAR2-VAR1))*50)的13日指数移动平均
AB赋值:AK1上穿AK
当满足条件(AB=1)时,在(最低价*0.99)位置书写文字,画黄色
AA1赋值:成交额(元)/成交量(手)
BB1赋值:最低价<AA1*0.9
CC1赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100>1.2
DD1赋值:最低价<收盘价的5日简单移动平均*0.921
EE1赋值:成交量(手)<成交量(手)的5日简单移动平均*1.5
老鼠仓赋值:BB1 AND CC1 AND DD1 AND EE1,线宽为0,COLOR0099FF
当满足条件老鼠仓时,在最低价*0.99位置书写文字,COLOR0099FF
VAR3AA赋值:如果(收盘价>1日前的收盘价),返回88,否则返回0
VAR4AA赋值:如果((收盘价)/(1日前的收盘价)>1.05)AND((最高价)/(收盘价)<1.01)AND(VAR3AA>0),返回91,否则返回0
当满足条件(VAR4AA>90)的45日过滤时,在(最低价)*(0.93)位置书写文字,COLOR00FFFF
当满足条件(VAR4AA>90)的35日过滤时,在(最低价)*(0.99000001)位置书写文字,COLOR00FFFF
A1AA赋值:9
A2AA赋值:(A1AA+1日前的收盘价<收盘价)
当满足条件(A2AA>-0.5)的84日过滤时,在(最高价)*(1.05)位置书写文字,COLORFFFFFF
VAR6赋值:1日前的收盘价
VAR7赋值:收盘价-VAR6和0的较大值的6日[1日权重]移动平均/收盘价-VAR6的绝对值的6日[1日权重]移动平均*100
当满足条件82上穿VAR7时,在最高价*1.01位置书写文字,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1ksn3BzRwlUzvCKatE_l7wQ

看了该指标的人还看了:
超赢主图指标    MACD背离吸筹指标
百万导弹指标    一招定乾坤指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表