请选择 进入手机版|继续访问电脑版

潜伏主图指标 通达信 主图 买卖点 操盘控盘 压力支撑

[复制链接]

admin  管理员

发表于 7 天前 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 买卖点 操盘控盘 压力支撑 
潜伏主图指标 通达信 主图 买卖点 操盘控盘 压力支撑 炒股叉第7585张

潜伏主图指标 通达信 主图 买卖点 操盘控盘 压力支撑 炒股叉第7586张

[lywrap=通达信主图指标公式][lycode=tdx,true]MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)
+15*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)
+10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)
+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)
+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
马线:MA(牛线,6),COLORGREEN;
VAR0:=SMA(MAX(CLOSE-REF(C,1),0),12,1)/SMA(ABS(CLOSE-REF(C,1)),15,1)*100;
DRAWTEXT(CROSS(82,VAR0),HIGH,'快卖'),COLORWHITE;
S:=C-REF(C,1);
DX:=100*EMA(EMA(S,6),6)/EMA(EMA(ABS(S),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
{DRAWTEXT(FILTER(买=1,5),LOW-0.03,'拉升'),COLORFFDE00;}
DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;
DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;
DRAWTEXT(CROSS(DA-DB,0),L*0.95,'★B'),COLORRED;
JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
DRAWTEXT(CROSS(84,JH),H*1.05,'☆S'),COLORGREEN;
YC:=REF(CLOSE,1);
止损价位:=(YC*1.0035*97+0.2)/99.65,COLORRED,LINETHICK0;
A:=HHV(HIGH,13)=HIGH AND HIGH>REF(HIGH,1);
A1:=FILTER(A,12);
B:=LLV(LOW,13)=LOW AND LOW<REF(LOW,1);
B1:=FILTER(B,12);
TS1:=BARSLAST(A1);
箱顶:=REF(HIGH,TS1) ,COLORFF00FF, LINETHICK0;
STICKLINE(1,箱顶,箱顶,7,0),COLORFF00FF;
TS2:=BARSLAST(B1);
箱底:=REF(LOW,TS2) ,COLORFFBB80, LINETHICK0;
STICKLINE(1,箱底,箱底,7,0),COLORFFBB80;
箱高:=100*(箱顶-箱底)/箱底,LINETHICK0;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*E-LOW,NODRAW;
明日支撑:=2*E-HIGH;
明日突破:=E+(HIGH-LOW);
明日反转:=E-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
DRAWTEXT_FIX(ISLASTBAR,0.6,0.1,0,'明日阻力'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.1,0,明日阻力),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.2,0,'明日支撑'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.2,0,明日支撑),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.3,0,'明日突破'),COLORRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.3,0,明日突破),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.4,0,'明日反转'),COLORRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.4,0,明日反转),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.5,0,'今日阻力'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.5,0,今日阻力),COLOR0080FF;
DRAWTEXT_FIX(ISLASTBAR,0.6,0.6,0,'今日支撑'),COLORLIRED;
DRAWNUMBER_FIX(ISLASTBAR,0.7,0.6,0,今日支撑),COLOR0080FF;

AA:=MA(牛线,6);
MA3:=MA(C,3);
角度:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.14159>45 AND DYNAINFO(8)>0 ;
RSV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
KD金:=K<30 AND D<30 ;
ZBJ:=CROSS(MACD.DIF,MACD.DEA) ;
潜伏:=角度 AND   CROSS(MA3,AA) AND KD金 OR ( ZBJ   
AND REF(CROSS(K,D),1) AND MA3>AA) OR (CROSS(MA3,AA) AND CROSS(K,D));
STICKLINE(潜伏>0,L,H,1,0),COLORYELLOW;
DRAWTEXT(潜伏,H,'↙潜伏'),COLORYELLOW;[/lycode][lycode=tdx2,true]MID赋值:(3*收盘价+最低价+开盘价+最高价)/6
输出牛线:(20*MID+19*1日前的MID+18*2日前的MID+17*3日前的MID+16*4日前的MID+15*5日前的MID+14*6日前的MID+13*7日前的MID+12*8日前的MID+11*9日前的MID+10*10日前的MID+9*11日前的MID+8*12日前的MID+7*13日前的MID+6*14日前的MID+5*15日前的MID+4*16日前的MID+3*17日前的MID+2*18日前的MID+20日前的MID)/210,画红色
输出马线:牛线的6日简单移动平均,画绿色
VAR0赋值:收盘价-1日前的收盘价和0的较大值的12日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的15日[1日权重]移动平均*100
当满足条件82上穿VAR0时,在最高价位置书写文字,画白色
S赋值:收盘价-1日前的收盘价
DX赋值:100*S的6日指数移动平均的6日指数移动平均/S的绝对值的6日指数移动平均的6日指数移动平均
买赋值:如果2日内DX的最低值=7日内DX的最低值ANDCOUNT(DX<0,2)ANDCROSS(DX,DX的2日简单移动平均),返回1,否则返回0
DA赋值:(收盘价的1日指数移动平均+收盘价的2日指数移动平均+收盘价的3日指数移动平均+收盘价的4日指数移动平均)/4
DB赋值:(收盘价的10日指数移动平均+收盘价的20日指数移动平均+收盘价的40日指数移动平均+收盘价的80日指数移动平均)/4
当满足条件DA-DB上穿0时,在最低价*0.95位置书写文字,画红色
JH赋值:收盘价-1日前的收盘价和0的较大值的5日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的5日[1日权重]移动平均*100
当满足条件84上穿JH时,在最高价*1.05位置书写文字,画绿色
YC赋值:1日前的收盘价
止损价位赋值:(YC*1.0035*97+0.2)/99.65,画红色,线宽为0
A赋值:13日内最高价的最高值=最高价 AND 最高价>1日前的最高价
A1赋值:A的12日过滤
B赋值:13日内最低价的最低值=最低价 AND 最低价<1日前的最低价
B1赋值:B的12日过滤
TS1赋值:上次A1距今天数
箱顶赋值:TS1日前的最高价 ,COLORFF00FF, 线宽为0
当满足条件1时,在箱顶和箱顶位置之间画柱状线,宽度为7,0不为0则画空心柱.,COLORFF00FF
TS2赋值:上次B1距今天数
箱底赋值:TS2日前的最低价 ,COLORFFBB80, 线宽为0
当满足条件1时,在箱底和箱底位置之间画柱状线,宽度为7,0不为0则画空心柱.,COLORFFBB80
箱高赋值:100*(箱顶-箱底)/箱底,线宽为0
E赋值:(最高价+最低价+开盘价+2*收盘价)/5
明日阻力赋值:2*E-最低价,NODRAW
明日支撑赋值:2*E-最高价
明日突破赋值:E+(最高价-最低价)
明日反转赋值:E-(最高价-最低价)
今日阻力赋值:1日前的明日阻力
今日支撑赋值:1日前的明日支撑
当满足条件是否最后一个周期时,在横轴0.6纵轴0.1位置书写文字,画淡红色
当满足条件是否最后一个周期时,在横轴0.7纵轴0.1位置书写数字,COLOR0080FF
当满足条件是否最后一个周期时,在横轴0.6纵轴0.2位置书写文字,画淡红色
当满足条件是否最后一个周期时,在横轴0.7纵轴0.2位置书写数字,COLOR0080FF
当满足条件是否最后一个周期时,在横轴0.6纵轴0.3位置书写文字,画红色
当满足条件是否最后一个周期时,在横轴0.7纵轴0.3位置书写数字,COLOR0080FF
当满足条件是否最后一个周期时,在横轴0.6纵轴0.4位置书写文字,画红色
当满足条件是否最后一个周期时,在横轴0.7纵轴0.4位置书写数字,COLOR0080FF
当满足条件是否最后一个周期时,在横轴0.6纵轴0.5位置书写文字,画淡红色
当满足条件是否最后一个周期时,在横轴0.7纵轴0.5位置书写数字,COLOR0080FF
当满足条件是否最后一个周期时,在横轴0.6纵轴0.6位置书写文字,画淡红色
当满足条件是否最后一个周期时,在横轴0.7纵轴0.6位置书写数字,COLOR0080FF
AA赋值:牛线的6日简单移动平均
MA3赋值:收盘价的3日简单移动平均
角度赋值:(MA3/1日前的MA3-1)*100的反正切*180/3.14159>45 AND 总量>0
RSV赋值:(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均
D赋值:K的3日[1日权重]移动平均
KD金赋值:K<30 AND D<30
ZBJ赋值:平滑异同平均的DIF上穿平滑异同平均的DEA
潜伏赋值:角度 AND   MA3上穿AA AND KD金 OR ( ZBJ   AND 1日前的K上穿D AND MA3>AA) OR (MA3上穿AA AND K上穿D)
当满足条件潜伏>0时,在最低价和最高价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
当满足条件潜伏时,在最高价位置书写文字,画黄色[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1ZF5UaDB5eRkxgk-W4PyvYw

看了该指标的人还看了:
CCI优化版指标    步入抄底区指标
大底十字选股指标    主力吸筹指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表