请选择 进入手机版|继续访问电脑版

擒庄入场指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 庄家主力

[复制链接]

admin  管理员

发表于 2018-6-11 09:00:04 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: 波段 无未来函数 短线 买卖点 操盘控盘 庄家主力 
庄家洗盘到底有哪些负面影响呢?庄家洗盘对股民炒股的危害可归纳为三方面:
1、改变股价原有方向:股价本该上涨,由于庄家洗盘,导致股价无法上涨,另股民无法近日高位抛售。
2、制造股市错误信号:股价本有的走势,其实可以散发出本身的信号,由于庄家洗盘,自然打乱股市本应有的走势,导致股价走势所释放的信号失真。
3、打乱股民对股价预测方式的认知:还有一个危害就是,本来学好的一系列理论,在预测股价走势中,能拥有较高的准确率,但由于庄家洗盘,导致这一期望泡汤。也导致股民质疑自己的理论体系。
如何和谐庄家洗盘?
庄家洗盘的本质,就是迷惑股民,要解决这一魔咒,一种有效的方法,就是识破庄家的诡计。所以这就必须要股民朋友懂得庄家洗盘中惯用的伎俩。
为此,我们分别总结庄家洗盘的四种主要类型

擒庄入场指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 庄家主力 炒股叉第7569张

擒庄入场指标 通达信 主图 波段 无未来函数 短线 买卖点 操盘控盘 庄家主力 炒股叉第7570张

[lywrap=通达信主图指标公式][lycode=tdx,true]N:=11;
P:=6;
P1:=8;
M:=2;
M1:=3;
{================背景 ================};
DRAWGBK(CURRBARSCOUNT=1 , RGB(0,0,0),RGB(0,0,0),0,'1',0);
{================妖股 ================};
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:(1+7/100)*DD,COLORWHITE;
DRAWTEXT(ISLASTBAR,上,' ←加速线'),COLORWHITE ;
乖离涨停2:=O>上 AND ZT;
DRAWTEXT(乖离涨停2,L,'妖股'),NODRAW ;
{================5日30日线买入 ================};
AA05:MA(C,5),COLORWHITE ,NODRAW ;
五日乖离率:=(C-AA05)/AA05*100;
AA30:MA(C,30)COLORBLUE,NODRAW ;
三拾日乖离率:=(C-AA30)/AA30*100,LINETHICK0;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);
DRAWTEXT(买入,LOW*0.95,'买入'),COLORYELLOW;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),LINETHICK0;
AA10:MA(C,10)COLORMAGENTA ,LINETHICK2,NODRAW;
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10);
DRAWTEXT(加仓,LOW*0.98,'↖加仓'),COLORRED;
飞天:MA(CLOSE,25)+MA(CLOSE,25)*20/100,COLORMAGENTA ,LINETHICK1;
DRAWTEXT(ISLASTBAR,飞天,' ←成妖线'),COLORMAGENTA;
{=================K线柱=================}
{红}
STICKLINE(C>O,C,O,1,0),COLORYELLOW ;
STICKLINE(C>O,H,L,0,0),COLORRED;
{绿}
STICKLINE(C<O,C,O,2,0),COLORCYAN;
STICKLINE(C<O,H,L,0,0),COLORCYAN;

{=================多空布林=================}
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORMAGENTA;
BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORBLACK,LINETHICK1;
UPR:BBI+P*STD(BBI,N),COLORCYAN,LINETHICK1;
DWN:BBI-P*STD(BBI,N),COLORBLUE ,NODRAW , ;
MA1:MA(CLOSE,P1),COLORRED,LINETHICK1;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
指导线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),COLORYELLOW,LINETHICK1;
界: MA(CLOSE,27),COLORMAGENTA ,LINETHICK1;
BU:=CROSS(指导线,界);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2;
ZT1:=C>=REF(C,1)*1.097 ;
起爆:=AAA>=2*REF(AAA,1) AND ZT1 AND ABS(AAA)<=1 AND C>MA(C,20) AND C<MA(C,20)*1.2 ;
DRAWTEXT(起爆,L*0.99,'↖暴涨'),COLORYELLOW,LINETHICK3;
VAR1:=EMA(EMA(EMA((CLOSE*6+LOW*2+HIGH+OPEN)/10,M),M),M);
短线:= VAR1-REF(VAR1,1)+VAR1;
中短:= MA(短线,M1);
DRAWTEXT(CROSS(短线,中短),(LOW * 0.995),'★'),COLORYELLOW,LINETHICK3;
{=================量柱=================}
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
DRAWTEXT(TJ,LOW*1.1,'量'),COLORMAGENTA ;
STICKLINE(TJ,OPEN,CLOSE,2.2,2),COLORMAGENTA ;
K1:=SUMBARS(TJ,1);
{================走强线 ================};
HM1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,20))/EMA(CLOSE,20));
HM2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),HM1);
走强线:EMA(HM2,200)*1.118 ,LINETHICK1,COLORRED;
DRAWTEXT(ISLASTBAR,走强线,' ←走强线'),COLORRED;
{=================必升=================};
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.90),'★波段开始 '),COLORMAGENTA;
DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.8),'★强势拉升'),COLOR00FFFF;
{============操作线:分水岭================}
B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);
分水岭:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORFF00FF,NODRAW;
操作线:分水岭-(EMA(C,3)-分水岭),COLORGREEN ,LINETHICK1;
DRAWTEXT(ISLASTBAR,操作线,' ←拐点线'),COLORGREEN;
{========超级主升==========}
VAR4:=(((((REF(C,1)) * (1.1)) - C) < (0.01)) AND (H = C));
E5:(EMA(C,5)),LINETHICK0 ,COLORWHITE;
R:=(20 * H + 19 * (REF(H,1)) + 18 * (REF(H,2)) + 17 * (REF(H,3)));
R1:=16*(REF(H,4)) +15*(REF(H,5))+14 * (REF(H,6)) + 13 * (REF(H,7));
R2:=12*(REF(H,8))+11*(REF(H,9))+10 * (REF(H,10)) + 9 * (REF(H,11));
R3:=8 * (REF(H,12)) + 7 * (REF(H,13)) +6*(REF(H,14))+5*(REF(H,15));
R4:=4 * (REF(H,16)) + 3 * (REF(H,17)) +2 * (REF(H,18)) + REF(H,20);
VAR5:=(R+R1+R2+R3+R4)/(210);
VAR6:=(EMA(VAR5,90));
妖股线:(VAR6 + (((C - (VAR6)) * C) - (VAR6)) / (VAR6)),LINETHICK0 ;
VAR8:=(CROSS(妖股线,E5));
DRAWTEXT((VAR8) AND (VAR4),L,'↖后市有牛'),LINETHICK3,COLORRED ;
{===================A级起暴点=====================}
DOWN:=OPEN>CLOSE;
F:=COUNT(DOWN,6)=6;
AD:=COUNT(C<REF(C,1) ,6)=6;
BB:=(C<MA(C,30)*0.9);
E:=F AND AD AND BB;
AA:="MACD.DEA"(12,26,9)<=0.6;
ZT4:=C>=REF(C,1)*1.099 AND C< MA(C,20)*1.15 AND C>MA(C,20) AND "MACD.DEA"(12,26,9)<=0.3 AND"MACD.DEA"(12,26,9)>=0;
ZT3:=C>=REF(C,1)*1.099 AND C< MA(C,20)*1.16 AND C>MA(C,20) AND AA AND C>=HHV(C,20) { AND V>REF(V,1)*1.3 } ;
DRAWTEXT(ZT4 ,L*0.84,'C级起暴点');
DRAWTEXT(ZT3,L*0.90,'A级起暴点');[/lycode][lycode=tdx2,true]N赋值:11
P赋值:6
P1赋值:8
M赋值:2
M1赋值:3

填充背景

ZT赋值:1日前的收盘价*1.1-收盘价<0.01 AND 最高价=收盘价
CC赋值:(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均
DD赋值:以CC为权重收盘价的动态移动平均
输出上:(1+7/100)*DD,画白色
当满足条件是否最后一个周期时,在上位置书写文字,画白色
乖离涨停2赋值:开盘价>上 AND ZT
当满足条件乖离涨停2时,在最低价位置书写文字,NODRAW

输出AA05:收盘价的5日简单移动平均,画白色 ,NODRAW
五日乖离率赋值:(收盘价-AA05)/AA05*100
输出AA30:收盘价的30日简单移动平均画蓝色,NODRAW
三拾日乖离率赋值:(收盘价-AA30)/AA30*100,线宽为0
MR赋值:统计3日中满足五日乖离率上穿0的天数>=1 AND 三拾日乖离率>1日前的三拾日乖离率 AND AA05>1日前的AA05 AND (收盘价/1日前的收盘价-1)*100>5 AND 1日前的收盘价<AA30
买入赋值:MR的10日过滤
当满足条件买入时,在最低价*0.95位置书写文字,画黄色
BB05赋值:(AA05/1日前的AA05-1)*100的反正切*180/3.1416
速度5赋值:(AA05-1日前的AA05)/1日前的AA05的3日指数移动平均*100的3日[1日权重]移动平均
加速度5赋值:(速度5-1日前的速度5)的3日指数移动平均,线宽为0
输出AA10:收盘价的10日简单移动平均画洋红色 ,线宽为2,NODRAW
加仓赋值:统计5日中满足BB05上穿30的天数>=1ANDAA05>1日前的AA05AND三拾日乖离率>1日前的三拾日乖离率ANDAA10>1日前的AA10AND加速度5>1日前的加速度5AND速度5>1日前的速度5的10日过滤
当满足条件加仓时,在最低价*0.98位置书写文字,画红色
输出飞天:收盘价的25日简单移动平均+收盘价的25日简单移动平均*20/100,画洋红色 ,线宽为1
当满足条件是否最后一个周期时,在飞天位置书写文字,画洋红色
当满足条件收阳线时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
当满足条件收阳线时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画红色
当满足条件收阴线时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画青色
当满足条件收阴线时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画青色
C2赋值:1日前的收盘价
涨停赋值:如果(收盘价-C2)*100/C2>=(10-0.01*100/C2),返回1,否则返回0
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
当满足条件涨停时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画洋红色
输出多空均线:(收盘价的3日简单移动平均+收盘价的6日简单移动平均+收盘价的12日简单移动平均+收盘价的24日简单移动平均)/4,画黑色,线宽为1
输出UPR:BBI+P*BBI的N日估算标准差,画青色,线宽为1
输出DWN:BBI-P*BBI的N日估算标准差,画蓝色 ,NODRAW ,
输出MA1:收盘价的P1日简单移动平均,画红色,线宽为1
买线赋值:收盘价的2日指数移动平均
卖线赋值:收盘价的21日线性回归斜率*20+收盘价的42日指数移动平均
输出指导线: (收盘价的4日指数移动平均+收盘价的6日指数移动平均+收盘价的12日指数移动平均+收盘价的24日指数移动平均)/4的2日指数移动平均,画黄色,线宽为1
输出界: 收盘价的27日简单移动平均,画洋红色 ,线宽为1
BU赋值:指导线上穿界
DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
AAA赋值:(DIF-DEA)*2
ZT1赋值:收盘价>=1日前的收盘价*1.097
起爆赋值:AAA>=2*1日前的AAA AND ZT1 AND AAA的绝对值<=1 AND 收盘价>收盘价的20日简单移动平均 AND 收盘价<收盘价的20日简单移动平均*1.2
当满足条件起爆时,在最低价*0.99位置书写文字,画黄色,线宽为3
VAR1赋值:(收盘价*6+最低价*2+最高价+开盘价)/10的M日指数移动平均的M日指数移动平均的M日指数移动平均
短线赋值: VAR1-1日前的VAR1+VAR1
中短赋值: 短线的M1日简单移动平均
当满足条件短线上穿中短时,在(最低价*0.995)位置书写文字,画黄色,线宽为3
TJ赋值:成交量(手)>=1日前的成交量(手)*1.91 AND 收盘价>1日前的收盘价*1.01
当满足条件TJ时,在最低价*1.1位置书写文字,画洋红色
当满足条件TJ时,在开盘价和收盘价位置之间画柱状线,宽度为2.2,2不为0则画空心柱.,画洋红色
K1赋值:TJ累加至1的天数

HM1赋值:((3.48*收盘价+最高价+最低价)/4-收盘价的20日指数移动平均)/收盘价的20日指数移动平均的绝对值
HM2赋值:以HM1为权重((2.15*收盘价+最低价+最高价)/4)的动态移动平均
输出走强线:HM2的200日指数移动平均*1.118 ,线宽为1,画红色
当满足条件是否最后一个周期时,在走强线位置书写文字,画红色

VAR3AA赋值:如果(收盘价>1日前的收盘价),返回88,否则返回0
VAR4AA赋值:如果((收盘价)/(1日前的收盘价)>1.05)AND((最高价)/(收盘价)<1.01)AND(VAR3AA>0),返回91,否则返回0
当满足条件(VAR4AA>90)的45日过滤时,在(最低价)*(0.90)位置书写文字,画洋红色
当满足条件(VAR4AA>90)的35日过滤时,在(最低价)*(0.8)位置书写文字,COLOR00FFFF
B赋值:收盘价的17日简单移动平均+收盘价的17日简单移动平均-1日前的收盘价的17日简单移动平均
输出分水岭:如果收盘价的17日简单移动平均<B,返回B,否则返回收盘价的17日简单移动平均,COLORFF00FF,NODRAW
输出操作线:分水岭-(收盘价的3日指数移动平均-分水岭),画绿色 ,线宽为1
当满足条件是否最后一个周期时,在操作线位置书写文字,画绿色
VAR4赋值:(((((1日前的收盘价) * (1.1)) - 收盘价) < (0.01)) AND (最高价 = 收盘价))
输出E5:(收盘价的5日指数移动平均),线宽为0 ,画白色
R赋值:(20 * 最高价 + 19 * (1日前的最高价) + 18 * (2日前的最高价) + 17 * (3日前的最高价))
R1赋值:16*(4日前的最高价) +15*(5日前的最高价)+14 * (6日前的最高价) + 13 * (7日前的最高价)
R2赋值:12*(8日前的最高价)+11*(9日前的最高价)+10 * (10日前的最高价) + 9 * (11日前的最高价)
R3赋值:8 * (12日前的最高价) + 7 * (13日前的最高价) +6*(14日前的最高价)+5*(15日前的最高价)
R4赋值:4 * (16日前的最高价) + 3 * (17日前的最高价) +2 * (18日前的最高价) + 20日前的最高价
VAR5赋值:(R+R1+R2+R3+R4)/(210)
VAR6赋值:(VAR5的90日指数移动平均)
输出妖股线:(VAR6 + (((收盘价 - (VAR6)) * 收盘价) - (VAR6)) / (VAR6)),线宽为0
VAR8赋值:(妖股线上穿E5)
当满足条件(VAR8)AND(VAR4)时,在最低价位置书写文字,线宽为3,画红色
DOWN赋值:收阴线
F赋值:统计6日中满足DOWN的天数=6
AD赋值:统计6日中满足收盘价<1日前的收盘价的天数=6
BB赋值:(收盘价<收盘价的30日简单移动平均*0.9)
E赋值:F AND AD AND BB
AA赋值:"平滑异同平均的DEA"(12,26,9)<=0.6
ZT4赋值:收盘价>=1日前的收盘价*1.099 AND 收盘价< 收盘价的20日简单移动平均*1.15 AND 收盘价>收盘价的20日简单移动平均 AND "平滑异同平均的DEA"(12,26,9)<=0.3 AND"平滑异同平均的DEA"(12,26,9)>=0
ZT3赋值:收盘价>=1日前的收盘价*1.099 AND 收盘价< 收盘价的20日简单移动平均*1.16 AND 收盘价>收盘价的20日简单移动平均 AND AA AND 收盘价>=20日内收盘价的最高值  
当满足条件ZT4时,在最低价*0.84位置书写文字
当满足条件ZT3时,在最低价*0.90位置书写文字[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1POAsIWRxL45-0ua4aayKNg

看了该指标的人还看了:
波段抄底指标    高抛低吸指标
趋势通道指标    超级短线指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表