请选择 进入手机版|继续访问电脑版

MACD庄家抬轿指标 通达信 副图 MACD指标 买卖点 操盘控盘 背离 金叉

[复制链接]

admin  管理员

发表于 2018-6-10 09:00:34 | 查看全部

指标公式
软件: 通达信 
公式类型: 副图 
二级分类: MACD指标 买卖点 操盘控盘 背离 金叉 
MACD庄家抬轿指标 通达信 副图 MACD指标 买卖点 操盘控盘 背离 金叉 炒股叉第7559张

MACD庄家抬轿指标 通达信 副图 MACD指标 买卖点 操盘控盘 背离 金叉 炒股叉第7560张

[lywrap=通达信副图指标公式][lycode=tdx,true]JH:=VOL*CLOSE;
JHO:=SUM(JH,2)/SUM(VOL,2);
JH0:=EMA(JHO,10);
AAA:=(JHO-JH0)*20/JHO;
超:=STICKLINE(AAA>0 AND AAA>=REF(AAA,1),0,AAA,3,0),COLORLIRED;
级:=STICKLINE(AAA>0 AND AAA<REF(AAA,1),0,AAA,3,1),COLORLIRED;
好:=STICKLINE(AAA<0 AND AAA>=REF(AAA,1),0,AAA,3,1),COLORGREEN;
的:=STICKLINE(AAA<0 AND AAA<REF(AAA,1),0,AAA,3,0),COLORGREEN;
公:=EMA(IF(AAA>0 AND AAA<REF(AAA,1),0,AAA),3);
式:=CROSS(REF(公,1),公) AND 公>0;
谢:=EMA(IF(AAA<0 AND AAA<REF(AAA,1),0,AAA),3);
了:=CROSS(REF(谢,1),谢) AND 谢<0;
必买:=CROSS(C,DRAWLINE(HIGH>=HHV(HIGH,30),HIGH,LOW<=LLV(LOW,10),HHV(HIGH,6),1));
WY1001:=(2*CLOSE+HIGH+LOW)/4;
WY1002:=EMA(WY1001,4);
WY1003:=EMA(WY1002,4);
WY1004:=EMA(WY1003,4);
X:=(WY1004-REF(WY1004,1))/REF(WY1004,1)*2000;
X1:=IF(X<REF(X,1),X,DRAWNULL),COLORWHITE,LINETHICK2;
XO:=MA(X,2),COLOR9932CD;
SI:=REF(X,1);
STICKLINE(X>SI,X,SI,2.3,0),COLOR0000FF;
STICKLINE(X>SI,X,SI,0.3,0),COLORCC66FF;
STICKLINE(X<SI,X,SI,2.3,0),COLOR00BB00;
STICKLINE(X<SI,X,SI,0.3,0),COLOR00FF00;
STICKLINE(式,X,SI,2.15,0),COLOR545454;
STICKLINE(了,X,SI,2.15,0),COLORDB7093;
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,3,0),COLORWHITE;
AA1:=CROSS(控盘,0);
无庄控盘:IF(控盘<0,控盘,0),COLORWHITE,NODRAW;
轻度控盘:STICKLINE(控盘<0 AND 0.9*控盘>REF(控盘,1),控盘,0,3,0),COLORYELLOW;
轻度出货:STICKLINE(控盘<0 AND 1.1*控盘<REF(控盘,1),控盘,0,3,0),COLORFFFF79;
开始控盘:=IF(AA1,5,0),LINETHICK1,COLORYELLOW;
有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,3,0),COLORRED;
VAR2:=100*WINNER(CLOSE*0.95);
高度控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,3,0),COLORFF00FF;
主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;
STICKLINE(控盘<1.2*REF(控盘,1) AND 控盘>0,控盘,0,3,0),COLOR00FF00;
DIF1:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA1:=EMA(DIF1,9);
{柱状线}
MACD1:=(DIF1-DEA1)*2*60;
MACD上:IF(MACD1>REF(MACD1,1),MACD1,DRAWNULL),
STICK,COLORRED,LINETHICK1;
MACD下:IF(MACD1<REF(MACD1,1),MACD1,DRAWNULL),
STICK,COLORFF9900,LINETHICK1;
{买点提示}
A1:=BARSLAST(REF(CROSS(DIF1,DEA1),1));
BL:=REF(CLOSE,A1+1)>CLOSE AND DIF1>REF(DIF1,A1+1) AND CROSS(DIF1,DEA1);
{STICKLINE(BL,0,1,2,0),COLOR00FF00;}
买点:DRAWICON(BL,DEA1,23);
A2:=BARSLAST(REF(CROSS(DEA1,DIF1),1));
DBL:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF1,A2+1)>DIF1 AND CROSS(DEA1,DIF1);
买点1:DRAWICON(DBL,DEA1,12);
低位金叉:=CROSS(DIF1,DEA1) AND DIF1<-0.1;
DRAWTEXT(低位金叉,-0.36,' 低位金叉');
JCCOUNT:=COUNT(CROSS(DIF1,DEA1),BARSLAST(DEA1>=0));
二次金叉:=CROSS(DIF1,DEA1) AND DEA1<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二次金叉,DEA1*1.04,13) ;
DRAWTEXT(二次金叉,-0.22,' 二次金叉'),COLORFF00FF;
A10:=BARSLAST(REF(CROSS(DIF1,DEA1),1));
底背离:=REF(CLOSE,A10+1)>CLOSE AND DIF1>REF(DIF1,A10+1) AND CROSS(DIF1,DEA1);
DRAWLINE(A10=0,DEA1,底背离,DEA1,0),COLORRED,LINETHICK2;
DRAWTEXT(底背离,-0.50,' 底背离'),COLOR00FF00;
A20:=BARSLAST(REF(CROSS(DEA1,DIF1),1));
顶背离:=REF(CLOSE,A20+1)<CLOSE AND REF(DIF1,A20+1)>DIF1 AND CROSS(DEA1,DIF1);
DRAWLINE(A20=0,DEA1,顶背离,DEA1,0),COLORWHITE,LINETHICK2;
{STICKLINE(底背离,X,SI,1,0),COLORYELLOW;}
STICKLINE(低位金叉,X,SI,1,0),COLORWHITE;
STICKLINE(必买,X,(X+SI)/2,2.3,0),COLORFF9900;
STICKLINE(必买,X,(X+SI)/2,0.1,0),COLORWHITE;
STICKLINE(低位金叉 AND 底背离,X,(X+SI)/2,2.3,0),COLORYELLOW;
STICKLINE(低位金叉 AND 底背离,X,(X+SI)/2,0.1,0),COLORCC66FF;
STICKLINE(二次金叉,X,SI,2.0,0),COLORYELLOW;
{主力进场}
VAR12:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR13:=SMA(ABS(LOW-VAR12),13,1)/SMA(MAX(LOW-VAR12,0),10,1);
VAR14:=EMA(VAR13,10);
VAR15:=LLV(LOW,33);
VAR16:=EMA(IF(LOW<=VAR15,VAR14,0),3);
主力进场:=IF(VAR16>REF(VAR16,1),VAR16,0),COLORRED,NODRAW;
STICKLINE(主力进场,X,SI,0.1,0),COLORRED;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
X3:=LLV(J,2)=LLV(J,8);
A:=250;
JH1:=HHV(MAX(K,MAX(D,J)),A);
DH:=HHV(MAX(DIF1,DEA1),A);
SH:=INTPART(JH1/DH)/2;
DIFF50:=SH*DIF1+50,COLORFFFF00;
DEA50:=SH*DEA1+50,COLORBLUE;
诱空:=IF(1.5*(DIFF50-DEA50)>0 AND REF(1.5*(DIFF50-DEA50),1)< REF(1.5*(DIFF50-DEA50),2) AND 1.5*(DIFF50-DEA50)>REF(1.5*(DIFF50-DEA50),1),1,0);
低位:=CROSS(J,REF(J+0.01,1)) AND X3 AND J<19;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
值:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(诱空,3) AND 诱空,X,'洗盘'),COLOR00FF00;[/lycode][lycode=tdx2,true]JH赋值:成交量(手)*收盘价
JHO赋值:JH的2日累和/成交量(手)的2日累和
JH0赋值:JHO的10日指数移动平均
AAA赋值:(JHO-JH0)*20/JHO
超赋值:当满足条件AAA>0ANDAAA>=1日前的AAA时,在0和AAA位置之间画柱状线,宽度为3,0不为0则画空心柱.,画淡红色
级赋值:当满足条件AAA>0ANDAAA<1日前的AAA时,在0和AAA位置之间画柱状线,宽度为3,1不为0则画空心柱.,画淡红色
好赋值:当满足条件AAA<0ANDAAA>=1日前的AAA时,在0和AAA位置之间画柱状线,宽度为3,1不为0则画空心柱.,画绿色
的赋值:当满足条件AAA<0ANDAAA<1日前的AAA时,在0和AAA位置之间画柱状线,宽度为3,0不为0则画空心柱.,画绿色
公赋值:如果AAA>0ANDAAA<1日前的AAA,返回0,否则返回AAA的3日指数移动平均
式赋值:1日前的公上穿公 AND 公>0
谢赋值:如果AAA<0ANDAAA<1日前的AAA,返回0,否则返回AAA的3日指数移动平均
了赋值:1日前的谢上穿谢 AND 谢<0
必买赋值:收盘价上穿当满足条件最高价>=30日内最高价的最高值时,在最高价位置画直线起点,当满足条件最低价<=10日内最低价的最低值时,在6日内最高价的最高值位置画直线终点,1表示是否延长.
WY1001赋值:(2*收盘价+最高价+最低价)/4
WY1002赋值:WY1001的4日指数移动平均
WY1003赋值:WY1002的4日指数移动平均
WY1004赋值:WY1003的4日指数移动平均
X赋值:(WY1004-1日前的WY1004)/1日前的WY1004*2000
X1赋值:如果X<1日前的X,返回X,否则返回无效数,画白色,线宽为2
XO赋值:X的2日简单移动平均,COLOR9932CD
SI赋值:1日前的X
当满足条件X>SI时,在X和SI位置之间画柱状线,宽度为2.3,0不为0则画空心柱.,COLOR0000FF
当满足条件X>SI时,在X和SI位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLORCC66FF
当满足条件X<SI时,在X和SI位置之间画柱状线,宽度为2.3,0不为0则画空心柱.,COLOR00BB00
当满足条件X<SI时,在X和SI位置之间画柱状线,宽度为0.3,0不为0则画空心柱.,COLOR00FF00
当满足条件式时,在X和SI位置之间画柱状线,宽度为2.15,0不为0则画空心柱.,COLOR545454
当满足条件了时,在X和SI位置之间画柱状线,宽度为2.15,0不为0则画空心柱.,COLORDB7093
VAR1赋值:收盘价的9日指数移动平均的9日指数移动平均
控盘赋值:(VAR1-1日前的VAR1)/1日前的VAR1*1000
当满足条件控盘<0时,在控盘和0位置之间画柱状线,宽度为3,0不为0则画空心柱.,画白色
AA1赋值:控盘上穿0
输出无庄控盘:如果控盘<0,返回控盘,否则返回0,画白色,NODRAW
输出轻度控盘:当满足条件控盘<0AND0.9*控盘>1日前的控盘时,在控盘和0位置之间画柱状线,宽度为3,0不为0则画空心柱.,画黄色
输出轻度出货:当满足条件控盘<0AND1.1*控盘<1日前的控盘时,在控盘和0位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFFFF79
开始控盘赋值:如果AA1,返回5,否则返回0,线宽为1,画黄色
输出有庄控盘:如果控盘>1日前的控盘AND控盘>0,返回控盘,否则返回0,画红色,NODRAW
当满足条件控盘>1日前的控盘AND控盘>0时,在控盘和0位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
VAR2赋值:100*以收盘价*0.95计算的获利盘比例
输出高度控盘:如果VAR2>50ANDCOST(85)<CLOSEAND控盘>0,返回控盘,否则返回0,COLORFF00FF,NODRAW
当满足条件VAR2>50ANDCOST(85)<CLOSEAND控盘>0时,在控盘和0位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF00FF
输出主力出货:如果控盘<1日前的控盘AND控盘>0,返回控盘,否则返回0,COLOR00FF00,NODRAW
当满足条件控盘<1.2*1日前的控盘AND控盘>0时,在控盘和0位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR00FF00
DIF1赋值:不定周期收盘价的12日指数移动平均-不定周期收盘价的26日指数移动平均
DEA1赋值:DIF1的9日指数移动平均
MACD1赋值:(DIF1-DEA1)*2*60
输出MACD上:如果MACD1>1日前的MACD1,返回MACD1,否则返回无效数,STICK,画红色,线宽为1
输出MACD下:如果MACD1<1日前的MACD1,返回MACD1,否则返回无效数,STICK,COLORFF9900,线宽为1
A1赋值:上次1日前的DIF1上穿DEA1距今天数
BL赋值:A1+1日前的收盘价>收盘价 AND DIF1>A1+1日前的DIF1 AND DIF1上穿DEA1
输出买点:当满足条件BL时,在DEA1位置画23号图标
A2赋值:上次1日前的DEA1上穿DIF1距今天数
DBL赋值:A2+1日前的收盘价<收盘价 AND A2+1日前的DIF1>DIF1 AND DEA1上穿DIF1
输出买点1:当满足条件DBL时,在DEA1位置画12号图标
低位金叉赋值:DIF1上穿DEA1 AND DIF1<-0.1
当满足条件低位金叉时,在-0.36位置书写文字
JCCOUNT赋值:统计上次DEA1>=0距今天数日中满足DIF1上穿DEA1的天数
二次金叉赋值:DIF1上穿DEA1 AND DEA1<0 AND 统计21日中满足JCCOUNT=2的天数=1
当满足条件二次金叉时,在DEA1*1.04位置画13号图标
当满足条件二次金叉时,在-0.22位置书写文字,COLORFF00FF
A10赋值:上次1日前的DIF1上穿DEA1距今天数
底背离赋值:A10+1日前的收盘价>收盘价 AND DIF1>A10+1日前的DIF1 AND DIF1上穿DEA1
当满足条件A10=0时,在DEA1位置画直线起点,当满足条件底背离时,在DEA1位置画直线终点,0表示是否延长.,画红色,线宽为2
当满足条件底背离时,在-0.50位置书写文字,COLOR00FF00
A20赋值:上次1日前的DEA1上穿DIF1距今天数
顶背离赋值:A20+1日前的收盘价<收盘价 AND A20+1日前的DIF1>DIF1 AND DEA1上穿DIF1
当满足条件A20=0时,在DEA1位置画直线起点,当满足条件顶背离时,在DEA1位置画直线终点,0表示是否延长.,画白色,线宽为2
当满足条件低位金叉时,在X和SI位置之间画柱状线,宽度为1,0不为0则画空心柱.,画白色
当满足条件必买时,在X和(X+SI)/2位置之间画柱状线,宽度为2.3,0不为0则画空心柱.,COLORFF9900
当满足条件必买时,在X和(X+SI)/2位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画白色
当满足条件低位金叉AND底背离时,在X和(X+SI)/2位置之间画柱状线,宽度为2.3,0不为0则画空心柱.,画黄色
当满足条件低位金叉AND底背离时,在X和(X+SI)/2位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLORCC66FF
当满足条件二次金叉时,在X和SI位置之间画柱状线,宽度为2.0,0不为0则画空心柱.,画黄色
VAR12赋值:1日前的(最低价+开盘价+收盘价+最高价)/4
VAR13赋值:最低价-VAR12的绝对值的13日[1日权重]移动平均/最低价-VAR12和0的较大值的10日[1日权重]移动平均
VAR14赋值:VAR13的10日指数移动平均
VAR15赋值:33日内最低价的最低值
VAR16赋值:如果最低价<=VAR15,返回VAR14,否则返回0的3日指数移动平均
主力进场赋值:如果VAR16>1日前的VAR16,返回VAR16,否则返回0,画红色,NODRAW
当满足条件主力进场时,在X和SI位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画红色
RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
K赋值:RSV的3日[1日权重]移动平均,画白色
D赋值:K的3日[1日权重]移动平均,画黄色
J赋值:3*K-2*D,COLORFF00FF
X3赋值:2日内J的最低值=8日内J的最低值
A赋值:250
JH1赋值:A日内K和D和J的较大值的较大值的最高值
DH赋值:A日内DIF1和DEA1的较大值的最高值
SH赋值:JH1/DH的整数部分/2
DIFF50赋值:SH*DIF1+50,COLORFFFF00
DEA50赋值:SH*DEA1+50,画蓝色
诱空赋值:如果1.5*(DIFF50-DEA50)>0ANDREF(1.5*(DIFF50-DEA50),1)<2日前的1.5*(DIFF50-DEA50)AND1.5*(DIFF50-DEA50)>1日前的1.5*(DIFF50-DEA50),返回1,否则返回0
低位赋值:J上穿1日前的J+0.01 AND X3 AND J<19
MTM赋值:收盘价-1日前的收盘价
DX赋值:100*MTM的6日指数移动平均的6日指数移动平均/MTM的绝对值的6日指数移动平均的6日指数移动平均
值赋值:2日内DX的最低值=7日内DX的最低值 AND 统计2日中满足DX<0的天数 AND DX上穿DX的2日简单移动平均
当满足条件诱空的3日过滤AND诱空时,在X位置书写文字,COLOR00FF00[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1nMa2Ifx7XkBsHFnfQepNbg

看了该指标的人还看了:
立柱量指标    金博士资金指标
指标王指标    云端短线王指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表