请选择 进入手机版|继续访问电脑版

KDJ+MACD+抢反弹指标 通达信 主图 KDJ指标 MACD指标 波段 无未来函数 短线 买卖点 操盘控盘

[复制链接]

admin  管理员

发表于 2018-6-4 09:00:07 | 查看全部

指标公式
软件: 通达信 
公式类型: 主图 
二级分类: KDJ指标 MACD指标 波段 无未来函数 短线 买卖点 操盘控盘 
此指标不含未来函数,可放心使用!
1,指标的构成:在主图中相对叠加了抢反弹、KDJ、MACD等指标,通过适当运用此组合指标来确定较准确的买入、卖出时机,提高操盘的合理性。
2,简易使用方法:其中日K线图中,已将抢反弹指标叠加到日K线上,并用红绿箭头表示买卖点位。其余的KDJ辅助图中用K.D.彩带及J线的走势提供相应的买卖时机。另一辅助图斯运用MACD指标中的MACD的柱状体来表示买卖时机。
3,注意事项:指标不是万能的,人的因素是第一位的。一定要根据自己对技术指标的理解再配合行情的走势,适当组合三部分指标提供的买点和卖点进行操盘,相对胜算的几率会大大提高。

KDJ+MACD+抢反弹指标 通达信 主图 KDJ指标 MACD指标 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第7430张

KDJ+MACD+抢反弹指标 通达信 主图 KDJ指标 MACD指标 波段 无未来函数 短线 买卖点 操盘控盘 炒股叉第7431张

[lywrap=通达信主图指标公式][lycode=tdx,true]EMA5:MA(C,5),COLORFF00FF,LINETHICK2;
EMA10:MA(C,10),COLOR00FFFF,LINETHICK2;
EMA21:MA(C,21),COLORC0FF7F,LINETHICK1;
EMA55:MA(C,55),COLORFFFFFF,LINETHICK1;
VAR1:=1;
VAR2:=((((2*CLOSE)+HIGH)+LOW) / 4);
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
C1:=(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4)*VAR1),COLORRED,LINETHICK2;
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR1),COLORFFFFFF,LINETHICK2;
AA:=C1>=C2 ;
BB:=C2>C1 ;
买入:DRAWICON(CROSS(AA,BB),L-0.1,1);
卖出:DRAWICON(CROSS(BB,AA),H+0.1,2);
STICKLINE(AA,C,O,3,0),COLOR000099;
STICKLINE(AA,H,L,0.5,0),COLOR000099;
STICKLINE(BB,C,O,3,0),COLORFF0099;
STICKLINE(BB,H,L,0.5,0),COLOR660099;
STICKLINE(AA,CLOSE,OPEN,3.0,0),COLOR9900CC;
STICKLINE(AA,CLOSE,OPEN,2.5,0),COLORFF00CC;
STICKLINE(AA,CLOSE,OPEN,1.9,0),COLORFF00FF;
STICKLINE(AA,CLOSE,OPEN,1.0,0),COLORFF33FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORFF66FF;
STICKLINE(AA,CLOSE,OPEN,0.2,0),COLORFF99FF;
STICKLINE(BB,CLOSE,OPEN,3,0),COLOR006633;
STICKLINE(BB,CLOSE,OPEN,2.5,0),COLOR339933;
STICKLINE(BB,CLOSE,OPEN,1.9,0),COLOR669933;
STICKLINE(BB,CLOSE,OPEN,1.5,0),COLOR33CC33;
STICKLINE(BB,CLOSE,OPEN,1.0,0),COLOR66CC33;
STICKLINE(BB,CLOSE,OPEN,0.2,0),COLORCCFF33;
STICKLINE(买入,O,(C-O)/2+O,3,0),COLOR335555;
STICKLINE(买入,O,(C-O)/2+O,2.2,0),COLOR338888;
STICKLINE(买入,O,(C-O)/2+O,1.5,0),COLOR33AAAA;
STICKLINE(买入,O,(C-O)/2+O,1,0),COLOR33CCCC;
STICKLINE(买入,O,(C-O)/2+O,0,0),COLOR33EEEE;
STICKLINE(卖出,O,(C-O)/2+O,3,0),COLOR550055;
STICKLINE(卖出,O,(C-O)/2+O,2.2,0),COLOR880088;
STICKLINE(卖出,O,(C-O)/2+O,1.5,0),COLORAA00AA;
STICKLINE(卖出,O,(C-O)/2+O,1,0),COLORCC00CC;
STICKLINE(卖出,O,(C-O)/2+O,0.5,0),COLOREE00EE;
HH0:=CONST(HHV(H,75));
LL0:=CONST(LLV(L,75));
MM0:=CONST((HH0+LL0)/2);
HL0:=CONST(IF(CONST(C)>=MM0,LL0-(HH0-LL0)*0.2,HH0+(HH0-LL0)*0.2));
HH1:=IF(CONST(C)<MM0,HH0*1.01,HL0);
LL1:=IF(CONST(C)>=MM0,LL0*0.99,HL0);
HL1:=(HH1+LL1)/2,COLORFFFFFF;
STICKLINE("MACD.MACD">0,"MACD.MACD"+HL1,HL1,2,1),COLOR00FFFF;
STICKLINE("MACD.MACD">0 AND "MACD.MACD">REF("MACD.MACD",1),
"MACD.MACD"+HL1,HL1,2,0),COLORFF00FF;
STICKLINE("MACD.MACD"<0,"MACD.MACD"+HL1,HL1,2,0),COLOR00FFFF;
STICKLINE("MACD.MACD"<0 AND "MACD.MACD">REF("MACD.MACD",1),
"MACD.MACD"+HL1,HL1,2,1),COLORFF00FF;
RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));
RSVK:=SMA(RSV1,3,1);
RSVD:=SMA(RSVK,3,1);
RSVJ:=RSVK*3-RSVD*2;
K:RSVK*3+HL1,COLORWHITE;
D:RSVD*3+HL1,COLORYELLOW;
J:RSVJ*3+HL1,COLORRED,LINETHICK2;
DRAWBAND(K,RGB(150,0,150),D,RGB(150,150,150));[/lycode][lycode=tdx2,true]输出EMA5:收盘价的5日简单移动平均,COLORFF00FF,线宽为2
输出EMA10:收盘价的10日简单移动平均,COLOR00FFFF,线宽为2
输出EMA21:收盘价的21日简单移动平均,COLORC0FF7F,线宽为1
输出EMA55:收盘价的55日简单移动平均,COLORFFFFFF,线宽为1
VAR1赋值:1
VAR2赋值:((((2*收盘价)+最高价)+最低价) / 4)
VAR4赋值:5日内最低价的最低值
VAR5赋值:4日内最高价的最高值
C1赋值:((((VAR2-VAR4)/(VAR5-VAR4))*100)的4日指数移动平均*VAR1),画红色,线宽为2
C2赋值:(((0.667*1日前的C1)+(0.333*C1))的2日指数移动平均*VAR1),COLORFFFFFF,线宽为2
AA赋值:C1>=C2
BB赋值:C2>C1
输出买入:当满足条件AA上穿BB时,在最低价-0.1位置画1号图标
输出卖出:当满足条件BB上穿AA时,在最高价+0.1位置画2号图标
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR000099
当满足条件AA时,在最高价和最低价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR000099
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFF0099
当满足条件BB时,在最高价和最低价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR660099
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为3.0,0不为0则画空心柱.,COLOR9900CC
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLORFF00CC
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为1.9,0不为0则画空心柱.,COLORFF00FF
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为1.0,0不为0则画空心柱.,COLORFF33FF
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFF66FF
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLORFF99FF
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR006633
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR339933
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为1.9,0不为0则画空心柱.,COLOR669933
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR33CC33
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为1.0,0不为0则画空心柱.,COLOR66CC33
当满足条件BB时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLORCCFF33
当满足条件买入时,在开盘价和(收盘价-开盘价)/2+开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR335555
当满足条件买入时,在开盘价和(收盘价-开盘价)/2+开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR338888
当满足条件买入时,在开盘价和(收盘价-开盘价)/2+开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLOR33AAAA
当满足条件买入时,在开盘价和(收盘价-开盘价)/2+开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR33CCCC
当满足条件买入时,在开盘价和(收盘价-开盘价)/2+开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR33EEEE
当满足条件卖出时,在开盘价和(收盘价-开盘价)/2+开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR550055
当满足条件卖出时,在开盘价和(收盘价-开盘价)/2+开盘价位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLOR880088
当满足条件卖出时,在开盘价和(收盘价-开盘价)/2+开盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,COLORAA00AA
当满足条件卖出时,在开盘价和(收盘价-开盘价)/2+开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLORCC00CC
当满足条件卖出时,在开盘价和(收盘价-开盘价)/2+开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOREE00EE
HH0赋值:75日内最高价的最高值的最后一日取值设为常数
LL0赋值:75日内最低价的最低值的最后一日取值设为常数
MM0赋值:(HH0+LL0)/2的最后一日取值设为常数
HL0赋值:如果收盘价的最后一日取值设为常数>=MM0,返回LL0-(HH0-LL0)*0.2,否则返回HH0+(HH0-LL0)*0.2的最后一日取值设为常数
HH1赋值:如果收盘价的最后一日取值设为常数<MM0,返回HH0*1.01,否则返回HL0
LL1赋值:如果收盘价的最后一日取值设为常数>=MM0,返回LL0*0.99,否则返回HL0
HL1赋值:(HH1+LL1)/2,COLORFFFFFF
当满足条件"平滑异同平均的MACD">0时,在"平滑异同平均的MACD"+HL1和HL1位置之间画柱状线,宽度为2,1不为0则画空心柱.,COLOR00FFFF
当满足条件"平滑异同平均的MACD">0AND"平滑异同平均的MACD">1日前的"平滑异同平均的MACD"时,在"平滑异同平均的MACD"+HL1和HL1位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFF00FF
当满足条件"平滑异同平均的MACD"<0时,在"平滑异同平均的MACD"+HL1和HL1位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00FFFF
当满足条件"平滑异同平均的MACD"<0AND"平滑异同平均的MACD">1日前的"平滑异同平均的MACD"时,在"平滑异同平均的MACD"+HL1和HL1位置之间画柱状线,宽度为2,1不为0则画空心柱.,COLORFF00FF
RSV1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)
RSVK赋值:RSV1的3日[1日权重]移动平均
RSVD赋值:RSVK的3日[1日权重]移动平均
RSVJ赋值:RSVK*3-RSVD*2
输出K:RSVK*3+HL1,画白色
输出D:RSVD*3+HL1,画黄色
输出J:RSVJ*3+HL1,画红色,线宽为2
画带状线[/lycode][/lywrap]
下载地址:https://pan.baidu.com/s/1oRh93huqttilb6XnJL1ICQ

看了该指标的人还看了:
熊百组合极品指标    600万指标 每一波赚钱
逃顶抄底指标    牛起步指标

举报 使用道具

回复

*滑动验证:
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

股票公式

炒股叉客服QQ:156669939

手机版|小黑屋| Powered by Discuz! X3.4

© 2017-2018 炒股叉 版权所有 Version v4.7 / 工信部备案:京ICP备16025792号-1

快速回复 返回顶部 返回列表