指标公式
软件: 通达信 
公式类型: 主图 副图 选股 
二级分类: 波段 无未来函数 短线 买卖点 抄底逃顶 起爆点 
TIM截图20180517101109.png

TIM截图20180517101129.png

[lywrap=通达信主图指标公式][lycode=tdx,true]MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3),COLORMAGENTA;
MA4:MA(CLOSE,M4),COLORGREEN;
N:=10;M:=9;
VAB0:=531;VAB1:=1510000;
VAB2:=VAB0 + VAB1;
AB:=SMA(L,4,3) ;
VAB3:=IF(DATE > VAB2,0,1);
涨停:=IF(REF(C,1)*1.1*VAB3-C<0.01 ,1,0);
HH:=COUNT(涨停,13)>=1;
HD:=COUNT(涨停,21)>=1;
STICKLINE(涨停,OPEN,CLOSE,3.3,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
STICKLINE(涨停,H,L,0.5,0),COLORRED;
STICKLINE(涨停,O,C,3.8,0),LINETHICK2,COLOR000055;
STICKLINE(涨停,O,C,3.2,0),LINETHICK2,COLOR000077;
STICKLINE(涨停,O,C,3,0),LINETHICK2,COLOR000099;
STICKLINE(涨停,O,C,2.5,0),LINETHICK2,COLOR0000BB;
STICKLINE(涨停,O,C,1.5,0),LINETHICK2,COLOR0000DD;
STICKLINE(涨停,O,C,0.5,0),LINETHICK2,COLOR0000FF;
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
AAF:=VAR8>REF(VAR8,1);
DR:=100;ZRQ:=3;
DJ:=REF(LLV(L,100),3);
ZD:=REFDATE(DJ,DATE);
XG:=L=ZD;
XGA:=AAF AND XG,COLORRED,LINETHICK2;
XG1:=XGA>REF(XGA,1);
AA:=XG1>REF(XG1,1)COLORRED,LINETHICK2;
STICKLINE(AA,H,L,0,0),COLOR44FFFF;
STICKLINE(AA,C,O,6.1,0),COLOR003333;
STICKLINE(AA,C,O,5,0),COLOR003333;
STICKLINE(AA,C,O,4,0),COLOR116666;
STICKLINE(AA,C,O,3,0),COLOR116666;
STICKLINE(AA,C,O,2,0),COLOR229999;
STICKLINE(AA,C,O,1,0),COLOR229999;
STICKLINE(AA,C,O,0.5,0),COLOR33CCCC;
STICKLINE(AA,C,O,0.2,0),COLOR33CCCC;
STICKLINE(AA,C,O,0,0),COLOR44FFFF;
STICKLINE(AA,H,L,0,0),COLOR44FFFF;
DRAWICON(AA,L-0.15,13);
DRAWTEXT(AA,L*0.96, ' ↖ 牛股起爆点A')COLORYELLOW;


日:=150;
昨前:=3;
高1:=REF(HHV(H,日),昨前),COLORGREEN,LINETHICK2;
顶:=REFDATE(高1,DATE),COLORGREEN,LINETHICK2;
绝顶:=REFDATE(顶,DATE),NODRAW;
跑:=绝顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O)),COLORGREEN,LINETHICK2;
STICKLINE(跑,C,O,3.5,0),COLOR155500;
STICKLINE(跑,C,O,3.2,0),COLOR155500;
STICKLINE(跑,C,O,3,0),COLOR155500;
STICKLINE(跑,C,O,2.8,0),COLOR155500;
STICKLINE(跑,C,O,2.5,0),COLOR208000;
STICKLINE(跑,C,O,2.1,0),COLOR208000;
STICKLINE(跑,C,O,2,0),COLOR2BAA00;
STICKLINE(跑,C,O,1.8,0),COLOR2BAA00;
STICKLINE(跑,C,O,1.6,0),COLOR35D500;
STICKLINE(跑,C,O,1.2,0),COLOR35D500;
STICKLINE(跑,C,O,1,0),COLOR40FF00;
STICKLINE(跑,C,O,0.8,0),COLOR40FF00;
STICKLINE(跑,C,O,0.5,0),COLOR40FF00;
STICKLINE(跑,C,O,0.2,0),COLOR40FF00;
STICKLINE(跑,C,O,0.1,0),COLOR00DD00;
STICKLINE(跑,C,O,0,0),COLOR00BB00;
STICKLINE(跑,L,H,0,0),COLOR00CC00;
DRAWTEXT(跑,C*1.03,'↖绝顶')COLORYELLOW;[/lycode][lycode=tdx2,true]输出MA1:收盘价的M1日简单移动平均
输出均线:收盘价的M2日简单移动平均
输出MA3:收盘价的M3日简单移动平均,画洋红色
输出MA4:收盘价的M4日简单移动平均,画绿色
N赋值:10
M赋值:9
VAB0赋值:531
VAB1赋值:1510000
VAB2赋值:VAB0 + VAB1
AB赋值:最低价的4日[3日权重]移动平均
VAB3赋值:如果日期>VAB2,返回0,否则返回1
涨停赋值:如果1日前的收盘价*1.1*VAB3-收盘价<0.01,返回1,否则返回0
HH赋值:统计13日中满足涨停的天数>=1
HD赋值:统计21日中满足涨停的天数>=1
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为3.3,0不为0则画空心柱.,画红色
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
当满足条件涨停时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画黄色
当满足条件涨停时,在最高价和最低价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画红色
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为3.8,0不为0则画空心柱.,线宽为2,COLOR000055
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,线宽为2,COLOR000077
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,线宽为2,COLOR000099
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,线宽为2,COLOR0000BB
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为1.5,0不为0则画空心柱.,线宽为2,COLOR0000DD
当满足条件涨停时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,线宽为2,COLOR0000FF
VAR2赋值:1日前的最低价
VAR3赋值:最低价-VAR2的绝对值的13日[1日权重]移动平均/最低价-VAR2和0的较大值的13日[1日权重]移动平均*100
VAR4赋值:如果收盘价*1.2,返回VAR3*13,否则返回VAR3/13的13日指数移动平均
VAR5赋值:34日内最低价的最低值
VAR6赋值:34日内VAR4的最高值
VAR7赋值:如果56日内最低价的最低值,返回1,否则返回0
VAR8赋值:如果最低价<=VAR5,返回(VAR4+VAR6*2)/2,否则返回0的3日指数移动平均/618*VAR7
AAF赋值:VAR8>1日前的VAR8
DR赋值:100
ZRQ赋值:3
DJ赋值:3日前的100日内最低价的最低值
ZD赋值:日期日DJ
XG赋值:最低价=ZD
XGA赋值:AAF AND XG,画红色,线宽为2
XG1赋值:XGA>1日前的XGA
AA赋值:XG1>1日前的XG1画红色,线宽为2
当满足条件AA时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR44FFFF
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为6.1,0不为0则画空心柱.,COLOR003333
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR003333
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLOR116666
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR116666
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR229999
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR229999
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR33CCCC
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR33CCCC
当满足条件AA时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR44FFFF
当满足条件AA时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR44FFFF
当满足条件AA时,在最低价-0.15位置画13号图标
当满足条件AA时,在最低价*0.96位置书写文字画黄色
日赋值:150
昨前赋值:3
高1赋值:昨前日前的日日内最高价的最高值,画绿色,线宽为2
顶赋值:日期日高1,画绿色,线宽为2
绝顶赋值:日期日顶,NODRAW
跑赋值:绝顶=最高价 AND ((收盘价-最低价)<(开盘价-收盘价) OR (开盘价-最低价)<(收盘价-开盘价)),画绿色,线宽为2
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为3.5,0不为0则画空心柱.,COLOR155500
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为3.2,0不为0则画空心柱.,COLOR155500
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLOR155500
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为2.8,0不为0则画空心柱.,COLOR155500
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为2.5,0不为0则画空心柱.,COLOR208000
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为2.1,0不为0则画空心柱.,COLOR208000
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR2BAA00
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为1.8,0不为0则画空心柱.,COLOR2BAA00
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为1.6,0不为0则画空心柱.,COLOR35D500
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为1.2,0不为0则画空心柱.,COLOR35D500
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR40FF00
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为0.8,0不为0则画空心柱.,COLOR40FF00
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR40FF00
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为0.2,0不为0则画空心柱.,COLOR40FF00
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,COLOR00DD00
当满足条件跑时,在收盘价和开盘价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00BB00
当满足条件跑时,在最低价和最高价位置之间画柱状线,宽度为0,0不为0则画空心柱.,COLOR00CC00
当满足条件跑时,在收盘价*1.03位置书写文字画黄色[/lycode][/lywrap]


[lywrap=通达信副图指标公式][lycode=tdx,true]VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
AA:=VAR8>REF(VAR8,1);
DR:=100;ZRQ:=3;
DJ:=REF(LLV(L,100),3);
ZD:=REFDATE(DJ,DATE);
XG:=L=ZD;
XGA:AA AND XG,COLORRED,LINETHICK2;
XG1:=XGA>REF(XGA,1);
牛股起爆点:=XG1>REF(XG1,1)COLORRED,LINETHICK2;
STICKLINE(FILTER(牛股起爆点>=1,5),45,0,4,0),COLORRED;
DRAWTEXT(FILTER(牛股起爆点=1,5),36,'---牛股起爆点A'),COLORRED;
STICKLINE(牛股起爆点,40,25,1,0),COLORYELLOW;
STICKLINE(牛股起爆点,25,10,2,0),COLOR00FF00;
STICKLINE(牛股起爆点,10,0,2,0),COLORBLUE;
STICKLINE(牛股起爆点,25,15,0.5,0),COLORRED;
STICKLINE(牛股起爆点,15,6,1,0),COLOR00FF00;
STICKLINE(牛股起爆点,6,0,2,0),COLORBLUE;

VARA3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VARA3,3)-10;
VARB7:=LLV(LOW,30);
VARA11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*20;
VARA12:=HHV(VARA11,30)*20;
火焰山:=EMA(IF(LOW<=VARB7 AND 趋势<40,(VARA11+VARA12),0),3)/618,COLORRED,LINETHICK2;
火焰:=STICKLINE(火焰山>0,0,火焰山,3,1);
今量:=火焰山;
STICKLINE(火焰山>0,0,今量*1.2,2,0),COLORLIRED;[/lycode][lycode=tdx2,true]VAR2赋值:1日前的最低价
VAR3赋值:最低价-VAR2的绝对值的13日[1日权重]移动平均/最低价-VAR2和0的较大值的13日[1日权重]移动平均*100
VAR4赋值:如果收盘价*1.2,返回VAR3*13,否则返回VAR3/13的13日指数移动平均
VAR5赋值:34日内最低价的最低值
VAR6赋值:34日内VAR4的最高值
VAR7赋值:如果56日内最低价的最低值,返回1,否则返回0
VAR8赋值:如果最低价<=VAR5,返回(VAR4+VAR6*2)/2,否则返回0的3日指数移动平均/618*VAR7
AA赋值:VAR8>1日前的VAR8
DR赋值:100
ZRQ赋值:3
DJ赋值:3日前的100日内最低价的最低值
ZD赋值:日期日DJ
XG赋值:最低价=ZD
输出XGA:AA AND XG,画红色,线宽为2
XG1赋值:XGA>1日前的XGA
牛股起爆点赋值:XG1>1日前的XG1画红色,线宽为2
当满足条件牛股起爆点>=1的5日过滤时,在45和0位置之间画柱状线,宽度为4,0不为0则画空心柱.,画红色
当满足条件牛股起爆点=1的5日过滤时,在36位置书写文字,画红色
当满足条件牛股起爆点时,在40和25位置之间画柱状线,宽度为1,0不为0则画空心柱.,画黄色
当满足条件牛股起爆点时,在25和10位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00FF00
当满足条件牛股起爆点时,在10和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
当满足条件牛股起爆点时,在25和15位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画红色
当满足条件牛股起爆点时,在15和6位置之间画柱状线,宽度为1,0不为0则画空心柱.,COLOR00FF00
当满足条件牛股起爆点时,在6和0位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
VARA3赋值:3*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均-2*(收盘价-55日内最低价的最低值)/(55日内最高价的最高值-55日内最低价的最低值)*100的5日[1日权重]移动平均的3日[1日权重]移动平均
趋势赋值:VARA3的3日指数移动平均-10
VARB7赋值:30日内最低价的最低值
VARA11赋值:最低价-1日前的最低价的绝对值的3日[1日权重]移动平均/最低价-1日前的最低价和0的较大值的3日[1日权重]移动平均*20
VARA12赋值:30日内VARA11的最高值*20
火焰山赋值:如果最低价<=VARB7AND趋势<40,返回(VARA11+VARA12),否则返回0的3日指数移动平均/618,画红色,线宽为2
火焰赋值:当满足条件火焰山>0时,在0和火焰山位置之间画柱状线,宽度为3,1不为0则画空心柱.
今量赋值:火焰山
当满足条件火焰山>0时,在0和今量*1.2位置之间画柱状线,宽度为2,0不为0则画空心柱.,画淡红色[/lycode][/lywrap]

[lywrap=通达信选股公式指标][lycode=tdx,true]VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
AA:=VAR8>REF(VAR8,1);
DR:=100;ZRQ:=3;
DJ:=REF(LLV(L,100),3);
ZD:=REFDATE(DJ,DATE);
XG:=L=ZD;
XGA:=AA AND XG;
XG1:=XGA>REF(XGA,1);
L0:=XG1>REF(XG1,1);
COUNT(L0,2)>0;[/lycode][lycode=tdx2,true]VAR2赋值:1日前的最低价
VAR3赋值:最低价-VAR2的绝对值的13日[1日权重]移动平均/最低价-VAR2和0的较大值的13日[1日权重]移动平均*100
VAR4赋值:如果收盘价*1.2,返回VAR3*13,否则返回VAR3/13的13日指数移动平均
VAR5赋值:34日内最低价的最低值
VAR6赋值:34日内VAR4的最高值
VAR7赋值:如果56日内最低价的最低值,返回1,否则返回0
VAR8赋值:如果最低价<=VAR5,返回(VAR4+VAR6*2)/2,否则返回0的3日指数移动平均/618*VAR7
AA赋值:VAR8>1日前的VAR8
DR赋值:100
ZRQ赋值:3
DJ赋值:3日前的100日内最低价的最低值
ZD赋值:日期日DJ
XG赋值:最低价=ZD
XGA赋值:AA AND XG
XG1赋值:XGA>1日前的XGA
L0赋值:XG1>1日前的XG1
统计2日中满足L0的天数>0[/lycode][/lywrap]

下载地址:https://pan.baidu.com/s/1okCc885hH6ukK6Y04q-B6w

看了该指标的人还看了:
高抛低吸指标    主力吸筹指标    校长抓黑马指标
短线操盘指标    趋势买卖控盘指标    牛起步指标

使用道具 举报

回复